[SEC/FUN] Factions 2.0.0 - Guilds, War and user-controlled antigrief [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by MassiveCraft, May 29, 2011.

  1. Offline


    I actually editted it with the in-game commands as recommended. Anyway, I set up an entire new Bukkit server to fix the problem. I simply not added DimensionDoor and it worked. Removing DimensionDoor on the old server, however, did not fix anything.
  2. Offline


    I saw in the source code, thanks.
    I also noticed the /f chatspy command does not work with CAPI faction / ally chat
  3. Offline


    Hmm, apparently so. I'll try to fix that for the next release.
  4. Offline


    Hello, i need to know how is possible to set "griefint" during war between factions.
  5. suddenly my faction homes gone.

    when i try do /f home it says "your faction does not have a home. You should:
    /f sethome [faction tag=mine]

    when im doing /f sethome it says the faction home is set but does not work.
    when im doing /f home after it is set for my faction it says
    "your faction home has been un-set since it is no longer in your territory.

    i found it that it has unclaimed the land, thats why the faction home is gone.
  6. Offline


    How can I make factions griefables by other faction that is in war with it?
  7. Offline


    A few suggestions.
    • Use cuboids to set owners, like in Worldguard.
    • Set the owner to [For Sale: <price>] to allow anyone to buy the cuboid (money is given to the faction).
    • Wolves, Snowgolems, and (in 1.2) Irongolems attack enemy factions, based on the land they are in.
    • Officers can't build in land owned by other officers or the leader.
  8. Offline


    @Olof Larsson

    New idea for new snapshot, if possible.

    Iron Golems - Make them attack neutral/enemy faction members to the player's faction they were created for.

    It'd be awesome! Thanks. :>
  9. Hello, I have Essentials Chat and I installed the faction plugin and placed the {FACTION} message in the correct format in the essentials config.yml and read throughout all the user guides and FAQ's, but every time someone speaks on the server it just has {FACTION} instead of the faction tag name. Ex: (Messed up chat:
    {FACTION} [Admin] Ian0611: Hi) Instead of (Correct chat:
    **TnTCaNNoN [Admin] Ian0611: Hi)
    Here is my essentials group format:

    Owner: '{FACTION} &0= &f[&7-&5Owner&7-&f] {DISPLAYNAME}&7:&4 {MESSAGE}'
    Co-Owner: '{FACTION} &0= &f[&7-&4C&1o &2O&3w&6n&4e&er&7-&f] {DISPLAYNAME}&7:&4 {MESSAGE}'
    Guest: '{FACTION} &0= &f[&7-&8Guest&7-&f] {DISPLAYNAME}&7:&f {MESSAGE}'
    Member: '{FACTION} &0= &f[&7-&2Member&7-&f] {DISPLAYNAME}&7:&f {MESSAGE}'
    Moderator: '{FACTION} &0= &f[&7-&bModerator&7-&f] {DISPLAYNAME}&7:&f {MESSAGE}'
    Admin: '{FACTION} &0= &f[&7-&4Admin&7-&f] {DISPLAYNAME}&7:&f {MESSAGE}'
    Head-Admin: '{FACTION}n&0= &f[&2$&f][&7-&4Head Admin&7-&f] {DISPLAYNAME}&7:&f {MESSAGE}'

    If you need any other information I will be happy to help. Thank you for taking them time to read this and help me out.
  10. MassiveCraft I use AuthMe, and a player unlogged can use Factions commands!
  11. Offline


    I have a little problem, with Factions v1.6.5c.

    When i start my server, it's show me a error:

    2012-02-26 17:08:10 [INFO] [Factions] Loading Factions v1.6.5c.
    2012-02-26 17:08:10 [INFO] [Factions v1.6.5c] === ENABLE START ===
    2012-02-26 17:08:10 [INFO] [Factions v1.6.5c] Loading board from disk
    2012-02-26 17:08:10 [INFO] [Factions v1.6.5c] Found and will integrate chat with EssentialsChat v2.8.2
    2012-02-26 17:08:10 [INFO] [Factions v1.6.5c] Economy integration through Vault plugin successful.
    2012-02-26 17:08:10 [INFO] [Factions v1.6.5c] === ENABLE DONE (Took 265ms) ===
    2012-02-26 17:08:10 [WARNING] Server permissions file permissions.yml is not valid YAML.
    java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Map
    at org.bukkit.craftbukkit.CraftServer.loadCustomPermissions(CraftServer.java:491)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:188)
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:357)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:344)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:175)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:408)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

    What is the problem?

    Thanks for reading this. ;)
  12. Offline


    There should be something logged to that effect. Look for either the text "unclaimed" in your server log in case somebody unclaimed the land, or for an error from Factions one of the times you started the server up.

    "territoryEnemyDenyBuild" and the other settings which start with "territoryEnemy".

    1. Not likely. Though, with the upcoming change from Minecraft handling chunks as the entire vertical area to instead be 16x16x16 areas, there's a possibility that at some point we'll change our territories in the same way. No promises though.
    2. Also not very likely; definitely not soon, but possibly if someone wants it enough to donate for it in future (or if Olof decides to do it).
    3. Hmm. For that I think we'd have to write up an extra AI routine to occasionally check for faction enemies in a radius near all tamed creatures and make them target them. Not a bad idea, might happen at some point; I'm not 100% sure how feasible it would be (as being possible, or as being non-stressful to the server). Probably acceptable.
    4. At the least you can set ownedAreasModeratorsCanSet and ownedAreaModeratorsBypass to false so that only faction admins can set or bypass ownership.

    Sounds like you're running an older version of Essentials and/or an older version of Factions.

    Not Factions. Based on the error, you've messed up your permissions.yml file.
    NazzyDragon likes this.
  13. Thank you for your suggestion, but sadly it did not work. I updated both essentials and factions, but now instead of {FACTION} it is [FACTION] Dx. The group format is still the same as my post above. Thanks for your help. :)
  14. Offline


    Hmm. I haven't had any problems like that with EssentialsChat, but then I've only ever used the standard "format" value, never the group-specific formatting. I guess I should test that out and look into it.

    Version 1.6.6

    • Damage protection is now extended to being set on fire (by flaming arrows, for instance) and receiving harmful splash potion effects. Beneficial splash potions are unaffected, and prevention of harmful splash potion effects is handled on a player-by-player basis, so you can still harm yourself if you're not careful where you throw them.
    • New setting "homesTeleportCommandEssentialsIntegration" (default true) which, if enabled, will integrate /f home teleports with the Essentials plugin's teleport handler if Essentials is on the server. This provides teleport cooldown and/or delay to /f home based on your Essentials configuration. (Olof)
    • Added possibility to specify a player in the /f join command (/f join <faction> [player=you]), to make a player other than yourself join the specified faction. The new permission factions.join.others (added to factions.kit.mod permission kit and above) is required to be able to specify a different player. Note that the player cannot currently already be in another faction; if they are, you'll need to /f kick them first. Also note that if the faction isn't open (with no invitation required), the player isn't invited, and you don't have the factions.join.any permission or have admin bypass mode on, the attempt will also fail.
    • New setting "factionMemberLimit" (default 0, no limit), which will prevent players from joining any faction that has reached this membership limit.
    • Added command logging for commands used by players. (Olof)
    • "autoLeaveAfterDaysOfInactivity" routine now runs only once every few minutes instead of running every time a player logs in. New setting "autoLeaveRoutineRunsEveryXMinutes" (default 5 minutes) to determine just how often the routine is run. The routine is also slightly more careful now about how it calculates how long a player has been offline.
    • Updated various things for compatibility with upcoming CB 1.1-R5 and above while still being compatible with 1.1-R4. Also updated Spout integration to handle deprecated stuff.
    • Updated default GSON jar version to 2.1. For existing users, you can either delete the lib/gson.jar file on your server so Factions can download the newer version, or just download and replace it yourself: https://github.com/downloads/MassiveCraft/Factions/gson.jar (note: old version still works fine, new version just works slightly better)
    • Other plugins which prevent commands should be more likely to work: our PlayerCommandPreprocessEvent handler is now at Low priority instead of Lowest priority. (Olof)
    • "worldsIgnorePvP" setting no longer ignores PvP damage in SafeZones and PvP damage done by players who just logged in, no matter the world it happens in.
    • Fix for command prevention routine (used by territoryEnemyDenyCommands and such) not properly covering commands with uppercase letters in them.
    • Fix for potential rare NPE triggered in LWC integration where the location world returns null for whatever reason.
    • Fix for error when disbanding faction from server console with economy enabled.
    • Hopeful fix for rare errors where location world changes partway through trying to show a smoke effect for /f home.
    • Updated CAPI integration. (Olof)
    • Hopeful fix for chatspy not working with CAPI chat integration.
    New conf.json settings:
    "homesTeleportCommandEssentialsIntegration": true, - whether to hook /f home into the Essentials plugin's teleport handling (for delay and cooldown) if it's available
    "factionMemberLimit": 0, - if set to anything higher than 0, players will be prevented from joining any faction which reaches this limit
    "autoLeaveRoutineRunsEveryXMinutes": 5.0, - "autoLeaveAfterDaysOfInactivity" routine runs this often; for example, the default value makes it run once every 5 minutes

    New permission:
    factions.join.others - allows you to specify another player in the /f join command. Included in factions.kit.mod permission kit and above.

    Updated command:
    /f join <faction> [player=you] - join a faction. To specify a player other than yourself, you must have the factions.join.others permission.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  15. Offline


    I have problems with mods and Factions.
    I want to activate bypass for the mod "user" ( [RedPower] ) . I already OP it, so they should have the permission to initiate bypass.
    Now I can't enter the server as that user and I can't activate it from the console.
    Is the bypass state saved in a file? Does it stay after relog/reload?
    If it is saved, where exactly.
  16. Offline


    Hello, I've searched around the net I can't seem to find an answer to this problem.

    I was updating the Faction plugin (and a few others) on my server and now nobody has any claimed land.
    Everyone's faction is still there, with the correct people in them and everything else is right just with nothing claimed.

    I was wondering where Factions stores this information and the best course for restoring it.
    Thank you.
  17. Brettflan I use AuthMe. A player not logged can use Factions Commands. How to fix it? I closed my server for this bug!
  18. Offline


    Brettflan after updating my factions to the version mentiond above I am unable to use any factions command with a / i am being forced to use it with out a / and i have the config setting set to not allow the / less command.

    Iv tinkered with the settings and cant fix it the formatting is fine.

    Ontop of this you failed to mention a new config setting in the summery but you mentioned it in the notes.


    Unless ofc it was already in the config but unused in that case my bad.

    Still at this point in time not being able to use the / for factions commands is causing mass confusion on my server :eek:
  19. Okay thanks! Greatly appreciate it!

    I updated the to your latest factions update and it fixed whatever issue I was having. Everything is back to normal! Thanks for your help!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  20. Offline


    OP suggested wolves & iron golems attack enemy factions.

    Please. For the love of Jeb_, do this.
  21. Offline


    Admin bypass mode does not persist between server restarts; it is not saved anywhere. The person in question will need to use the /f bypass command to enable/disable it. As for your problems logging in as a user, that has nothing to do with this plugin.

    A couple of other people have reported having a similar problem. Please see here:

    Are you sure you're using Factions 1.6.6? It makes our command handler run at "Low" priority so that other plugins can get first shot by monitoring events at "Lowest" priority. You should also make sure slashless commands are disabled (/f config allowNoSlashCommand false), as other plugins probably wouldn't prevent those. If the problem persists, you might need to take it up with the other plugin author.

    1. Strange. Maybe because we changed our command handler priority as above? If so, it would be another plugin presumably interfering, so you could try temporarily removing other plugins to see if that changes anything.
    2. It is mentioned in the main changelog list, but I see that I indeed missed adding it to the "New conf.json settings" section of the changelog as well. Thanks for pointing that out.
  22. Offline


    Another plugin Interfering with /f is not likely at all. I'm not running any thing that most servers would not be running. The real Bit that Points the fault back to factions is the fact that I have the setting saying not to allow the commands with out a / and Yet it still allows it with out the / Infact its forcing me to use it that way.

    Removing plugins one by one is not some thing i can really do as i dont have a Dev environment (used to but it runs so crap on my lappy now I cant join it to test any thing) and taking the live server down while I do it all will piss many players off.

    Bukkit Version:

    This server is running CraftBukkit version git-Bukkit-1.1-R4-b1938jnks (MC: 1.1) (Implementing API version 1.1-R4)

    Here is a full list of the plugins I am using.:

    BorderGuard,SilkSpawners,Minequery,WorldEdit,WorldInventories,CFBanner,PermissionsEx,Modifyworld,XcraftGate,NoCheat,WorldGuard,Essentials,ChatManager,Permissions,LogBlock,HomeSpawnPlus , Factions, OtherDrops

    Current Config:
    Any Help With the issue would be awesome Cheers.


    The Setting in the config is working but only after a restart and the / command still wont work it is not saying its an invalid command and its not doing any thing. For the record i was editing the config and using f lock on / off and f reload before and the changes were not being applied only after a resart did i find my self in a commandless situation had to allow the / less for now as nothing else works...

    Attached Files:

  23. Offline



    I have recently added the faction plugin to my server, and I have gone to update it and when I do It breaks it after I upload it to my server.

    I have deleted the original plugin and the gson.jar as well but still get the same result

    I am currently using Factions1.6.5_c did i miss something that I needed to do in the new version?
  24. Offline

    The Boss43

    Hey guys I need help with this faction plugin when i turn on my server it says on the faction [SEVERE] Error occurred while enabling Factions v1.6.5c (Is it up to date?): java/util/concurrent/ConcurrentSkipListMap
    please help guys.:'(
  25. Offline


    What do you mean by "it breaks"? Details. Does it give an error message or what?

    I don't know based on that part of the error. Please paste the full error message. By the way, 1.6.6 is released so you might want to use it instead of 1.6.5c.
  26. Offline


    Hey, I just downloaded factions (and it works fine) but IE refuses to open the page with the user guide; something about IE has stopped working, even though sometimes I can see the page in the background, loaded just fine. It closes and fails at reopening the page.

    So if someone in charge could either look into that problem for IE9 on 64 bit Windows 7 or send me the user guide in a word doc or text file, that would be great.

    Thanks, and congrats on recieving my very first forum post! (not that its a big deal or anything *cough* huge deal *cough*)
  27. Offline


    Thank you for your answer. Well that's rather problematic then. The problem is that mod functions that interact with the world (like breaking a block or placing one) don't work on claimed faction territory. In the wild everything works fine. (As an example the RedPower Blockbreaker and Deployer don't work on faction land).
    Maybe there's a way around it.
  28. Offline


    I just tested it in IE9 on Win7 64-bit and had no problems. Besides, if your browser crashes it's not a problem with the webpage, it's a problem on your end. You could always try another browser anyway.

    So... I've never used those plugins, but based on how Factions handles block placement/destruction events and what you've said, it sounds like those plugins triggger BlockPlaceEvent and/or BlockBreakEvent and indicate some specific user as the one taking action? And it's configurable which user you want it to implicate? Is there some standard name that they use by default, or do they require you to provide a player name?
  29. Offline

    Nick Hooper

    Can it be possible to customize the alliance chat format? It seems that the Faction tag and the player name is all one variable... But it's not with the faction only chat?
  30. Offline


    You may have missed it or I forgot to mentioned it clearly enough ... those aren't plugins those are mods. There is a Communiy at http://www.mcportcentral.co.za/ which port mods to bukkit. That's how I got them by the way.
    Now to the problem. How the ported mods handle those effects/functions is by creating a fake "Player". In case of RedPower (Wich is also a mod) this fake player is called "[RedPower]". Now this player wants to add or remove a block in faction area and is, of course, denied permission.
    So you guessed correctly. And yes it is configurable to some extend in the config files of those mods (or some of them).

Share This Page