Inactive [SEC] EpicZones v0.37 - Polygon Based Area Protection - Now with Economy Support! [1.3.1-R2.0]

Discussion in 'Inactive/Unsupported Plugins' started by jblaske, Feb 2, 2011.

  1. Offline


    • Polygonal and Circular area creation. (Not just cuboids!)
    • In-game zone creation.
    • Provide a Circular border to your map.
    • Hierarchical Permissions with Child and Parent Zones.
    • Display Entering and Exiting messages in chat.
    • Enhanced /who
    • Advanced control of zone based regeneration
    • Many zone specific controls for things like Fire, Explosions and Mob spawning control
  2. Offline


    Alright. Thanks.

    This is what my config.yml says:
    enableSpout: true
    enableHeroChat: false
    enableRadius: true
    globalZoneDefaultAllow: true
    zoneTool: 280
    language: EN_US

    Any suggestions?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  3. Offline


    So, this is a zoning tool for admins only? Or, are there permissions that I can give to standard users to allow them to create their own protections?
  4. Offline


    Creating Zones You need the epiczones.admin Permissions node to create a Zone - Note: With this node, players can edit and create any zones

    Permissions The only 'player permissions' available are those - Build, Destroy and Entry

    Issue 38 Player create and Admin/Mod confirm will be in a future release, if jblaske still wants to put that feature in :)

    If you want to read the suggestions, and make your own:
    jblaske likes this.
  5. Offline


    Thanks for the informed reply!

    I do want to add on to what microskies said, by telling you that if you make any player an owner of a already created zone, they will be able to modify anything that doesn't change the size of the zone. (like who can enter, modify, etc.)
  6. Offline


    when it loads it say
    [EpicZones]error starting: null; mapping values are not allowed here disabling plugin
    can you please help?

    Also, can you show me the permissions nodes

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  7. Offline



    Please review the wiki for the basics of setting up EpicZones. If you need further assistance, create an issue ticket with all of the required documentation.
  8. Offline


    It happens when i set pvp fire and all that stuff on true in the world zone file
  9. Offline


    I get this error whenever someone attempts to move. It started happening after I added MultiInv to my server. (

    CraftBukkit Build #1240
    Epic Zones v.027

    Thank you for your time.
  10. Offline


  11. Offline



    If you would like me to seriously consider your issues, you need to follow the guidelines in the first post.
  12. Offline


    Having the same error. Got any fix?
  13. Offline


    Version 0.28
    • Updated for support of latest RB of CraftBukkit
    • Fixed error "Unable to sent PLAYER_MOVE to EpicZones"
  14. Offline


    I can confirm the above error is still occuring in version .28 on RB#1240. Have had to revert to the last working version which is .26 and everything is fine.
  15. Offline


    Is it really working? Because I need it with Graveyard...
  16. Offline


    Is this the same error that was posted above?

    Can you please provide a copy of your servers startup sequence and the error that is spamming. I want to fix this issue today.
  17. Offline


    Hi everyone, maybe someone can help me...
    I just cant get Epic Zones 0.2.6 to work (@moment 0.28 ends up in server crash),
    Default Permission players still can destroy and build stuff with no restrictions.
    Here my World.yml
    ceiling: 128
    - mainframe
    entertext: ''
    exittext: ''
      creeper: true
      ghast: true
      tnt: true
      ignite: true
      spread: true
    fireburnsmobs: true
    floor: 0
    - ALL
    name: world
    owners: []
    permissions: {}
    points: 0:0
    pvp: true
    radius: 1000
      amount: 0
      bedbonus: 0
      delay: 0
      interval: 500
      maxregen: 20
      mindegen: 0
      restdelay: 0
    sanctuary: false
    type: GLOBAL
    world: world
    and here my Zone. There should be no building or destroying allowed from default! Build and Destroy should be just allowed for a certain group)
    ceiling: 128
    childzones: []
    entertext: Welcome
    exittext: ''
      creeper: false
      ghast: false
      tnt: false
      ignite: false
      spread: false
    fireburnsmobs: true
    floor: 0
    - ALL
    name: mainframe
    owners: []
        destroy: deny
        entry: allow
        build: deny
    points: '-84:107 -231:106 -234:211 -210:223 -178:234 -161:249 -135:263 -83:266 '
    pvp: true
    radius: 0
      amount: 0
      bedbonus: 0
      delay: 0
      interval: 500
      maxregen: 20
      mindegen: 0
      restdelay: 0
    sanctuary: false
    type: POLY
    world: world
    If i log my self in as default i still can build and destroy stuff in mainframe zone...
    Please help...
  18. Offline



    What permissions system are you using? Can you post a copy of your server startup log? What do you mean that 0.28 results in "server crash"?

    Version 0.28.1 is now out.
    • A bug fix for how global zones were being stored.
    • If you are experianceing trouble, you need to issue the command "\ezzone debug" and attach your debug.txt file to any posts. This command can be issued form the console as well.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    Hello there, here my startup server.log
    2011-10-12 17:55:55 [INFO] Starting minecraft server version Beta 1.8.1
    2011-10-12 17:55:55 [INFO] Loading properties
    2011-10-12 17:55:55 [INFO] Starting Minecraft server on
    2011-10-12 17:55:55 [INFO] This server is running Craftbukkit version git-Bukki$
    2011-10-12 17:55:55 [INFO] [SuperpermBridge] Superperm/Permissions bridge initi$
    2011-10-12 17:55:56 [INFO] Preparing level "world"
    2011-10-12 17:55:56 [INFO] Default game type: 0
    2011-10-12 17:55:56 [INFO] Preparing start region for level 0 (Seed: 8056118340$
    2011-10-12 17:55:57 [INFO] Preparing start region for level 1 (Seed: -377790549$
    2011-10-12 17:55:57 [INFO] Preparing spawn area: 0%
    2011-10-12 17:55:58 [INFO] Lockette version 1.4.4 is being enabled!  Yay!  (Cor$
    2011-10-12 17:55:58 [INFO] Lockette: Detected craftbukkit build [1317] ok.
    2011-10-12 17:55:58 [INFO] Lockette: Linked to PermissionsBukkit plugin version$
    2011-10-12 17:55:58 [INFO] [SuperpermBridge] Superperm/Permissions bridge enabl$
    2011-10-12 17:55:58 [INFO] Lockette: Linked to Permissions plugin version 2.7.7
    2011-10-12 17:55:58 [INFO] Lockette: Using ops file for admin permissions.
    2011-10-12 17:55:58 [INFO] Lockette: Ready to protect your containers.
    2011-10-12 17:55:58 [INFO] PermissionsBukkit v1.1 is now enabled
    2011-10-12 17:55:58 [INFO] [EpicZones] Using 'Permissions' plugin for permissio$
    2011-10-12 17:55:58 [INFO] [EpicZones] Language File Loaded [EN_US.txt].
    2011-10-12 17:55:58 [INFO] [EpicZones] Loaded GLOBAL Zone [world]
    2011-10-12 17:55:58 [INFO] [EpicZones] Loaded POLY Zone [mainframe]
    2011-10-12 17:55:58 [INFO] [EpicZones] Loaded GLOBAL Zone [world_nether]
    2011-10-12 17:55:58 [INFO] [EpicZones] version 0.26 is enabled.
    2011-10-12 17:55:58 [INFO] [iConomy - Celty] Enabled (62 ms)
    2011-10-12 17:55:59 [INFO] [Citizens] NPC types loaded: quester, healer, trader$
    2011-10-12 17:56:00 [INFO] [Citizens] Permissions system found (PermissionsBukk$
    2011-10-12 17:56:00 [INFO] [Citizens] version [devBuild-250] loaded.
    2011-10-12 17:56:00 [INFO] [Citizens] Economy plugin found (iConomy v6)
    2011-10-12 17:56:01 [INFO] [ChestShop] Permissions version 2.7.7 loaded.
    2011-10-12 17:56:01 [INFO] [ChestShop] Lockette version 1.4.4 loaded.
    2011-10-12 17:56:01 [INFO] [ChestShop] version 3.24 initialized!
    2011-10-12 17:56:01 [INFO] [ChestShop] iConomy 6 loaded.
    2011-10-12 17:56:01 [INFO] [MobArena] Payment method found (iConomy version: 6)
    2011-10-12 17:56:01 [INFO] [MobArena] v0.94.3.17 enabled.
    2011-10-12 17:56:01 [INFO] Server permissions file permissions.yml is empty, ig$
    2011-10-12 17:56:02 [INFO] Done (0.584s)! For help, type "help" or "?"
    2011-10-12 17:56:02 [INFO] [Citizens] Loaded 7 NPCs.
    2011-10-12 17:56:02 [INFO] [Citizens] Loaded 0 quests.
    2011-10-12 17:56:02 [INFO] New max size: 484
    2011-10-12 17:56:02 [INFO] New max size: 784
    and here my permissions.yml (PermissionsBukkit 1.1 + Superperms)
            - admin
      *: true
                lockette.user.create.*: true
                mobarena.arenas.default: true
                mobarena.classes.*: true
                mobarena.use.join: true
                mobarena.use.leave: true
                mobarena.use.spectate: true
                citizens.wizard.use.interact: true
                citizens.wizard.use.locations: true
                citizens.wizard.modify.mode: true
                citizens.wizard.use.status: true
                citizens.trader.use.trad: true
                citizens.trader.use.list: true
                citizens.quester.use.quests: true
                citizens.quester.use.quests.status: true
                citizens.quester.use.quests.abort: true
                citizens.healer.use.heal: true
                citizens.blacksmith.use.status: true
                permissions.*: true
                superpermbridge.*: true
                citizens.*: true
                iConomy.*: true
                mobarena.*: true
                lockette.*: true
                ChestShop.*: true
            - default
                coolplugin.item: true
            - default
        build: '&cYou do not have permission to build here.'
    debug: false
    EpicZone 0.28 conflicts with my citizens plugin and crashes it...
    Will post debug later...
    Update: is running no crash anymore... :)
    But still can build as Default... its the " true" in permissions.yml overwriting epiczones settings... what to do?
  20. Offline



    The true should not be overriding what EZ is saying. EZ cancels the build/break event if the permission fails. One thing to test, if you are in the Ops.txt file that *might* be overriding the permissions check, i'm not sure right now, but its something to test.

    if worse comes to worse, you might have to zip up your environment (minus world folders) and send it to me to try on my test box, to see if i can re-create the issue.

    since 0.28.1 doesn't crash on you, please do any future testing in that version.
  21. Offline


    pleas make him also for premissions 3.0X
  22. Offline


    Yup, I still get this
    2011-10-12 21:26:25 [SEVERE] Could not pass event PLAYER_MOVE to EpicZones
    java.lang.NoClassDefFoundError: org/getspout/spoutapi/gui/Widget
    at com.epicsagaonline.bukkit.EpicZones.listeners.PlayerEvents.onPlayerMove(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.ClassNotFoundException: org.getspout.spoutapi.gui.Widget
    at Method)
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    ... 12 more
  23. Offline


    Version 0.28.2
    * More fixes for the Player_move error
    * Now properly supports when other plugins generate worlds.
    * some /zone commands can now be used from the console.
  24. Offline


    Can someone make a youtube movie about this plugin?
    I want to see it in action with spout :)
  25. Offline


    i need to now where the grouopmamger nodes are pleas
  26. Offline


    ummmm well when i use it on my mac server people can break blocks in a protected zone, do you know what is wrong but other wise i would love to use it
  27. Offline


    Is there any functionality that blocks Endermen from picking up/setting down blocks in a zone? They're tearing up my spawn town and it annoys me.

    Also, I've been having trouble protecting against any player editing a zone. Is there a wildcard functionality? Or should my use of PEX hierarchy cover it and I'm just being a dumbass? :p
  28. Offline


    oh nvm sorry didnt see that 0 . O

    how do i delete zones? and why cant i build and destroy things anymore? no matter where i am i cant destroy or build things uggh x(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  29. Offline


    What brought me here was, "polygon", hope it's true! XD


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  30. Offline


    So, i'm using PEX, does "/zone perm default build deny" deny users in the default group from building? I saw a ticket on the google code page, where you said it doesn;t work with default permissions, so i am assuming that i am not affected by this problem?

Share This Page