Inactive [SEC/ADMN] OwnBlocksPlus v1.7.1 - Protect blocks, adminstick and chest protection. [MySQL][1.2.5-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Thypthon, Mar 7, 2012.

  1. Offline


    Any reason or anyway to convert a OwnBlocks DB over to this new plugin? Does not seem to find my protected blocks from the old OwnBlocks. This would be great as our public server has been running about 6 months with the old OwnBlocksX
  2. Offline


    Could we have an option to disable the Chest Protection? I tried using Exclude in the config to exclude chests, but that didn't work either. =( (Though I know it's marked as indev)
  3. Offline


    Blocks are not protected from the movement of the piston.
    Do not have a way to be protected?
    I mean, can continue to be protected at move the blocks.
    I apologize for my English skill. ;)
  4. Offline


    Same here. it says "This chest is not owned by you." whenever the member places chest.
    Can you just remove the chest protection? cause i just want to use the protection. or I want you to have
    a nodes that disable chest protection. Thank you
  5. Offline


    I use the same table as OwnBlocksX, so if tou used OwnBlocks please rename your mysql table to "OwnBlocksX".
    Its a bug or not added, but its anyway added to the "to-do list".
    Its now added to the plugin. (1.7.1)
  6. Offline


    When i was installing 1.7.1 of your plugin, I was installing Vault, Jobs, and i removed Vault and Jobs to test... OwnBlocks+ doesnt work with Vault and Jobs instaled D:

    Man, i am using GroupManager, later I update to 1.7.1 of your plugin, It loads before GM, here is the error:

    2012-04-09 14:57:32 [INFO] Preparing start region for level 1 (Seed: 2280660989301280515)
    2012-04-09 14:57:32 [INFO] [OwnBlocksPlus] Enabling OwnBlocksPlus v1.7
    2012-04-09 14:57:32 [SEVERE] Error occurred while enabling OwnBlocksPlus v1.7 (Is it up to date?)
    at org.anjocaido.groupmanager.GroupManager.getPermissionHandler(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.t(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    2012-04-09 14:57:32 [INFO] [GroupManager] Enabling GroupManager v1.9 (2.9.1) (Phoenix)

    (I attached a file, its a print)

    Attached Files:

    • obp.JPG
      File size:
      124 KB
  7. Offline


    All the popular plugins take ages to get approved as they keep getting bumped up the page, approved.
  8. Offline


    Is there a way you can make it not require Mysql. hate that thing, never could get it set up, never knew how to use it.
  9. Offline


  10. Offline


    Can anyone help me please?
    I think it is a problem with the MySQL, anyone please.


    I will open a worldwide server and I need this plugin. :(
  11. Offline


    Hi there,
    Been using the old OwnBlocks (not X) for long time now but its borken :( anywho when installing this one and setting mysql up it still does not want to connect...

    atm Im running mysql '5.1.46-log SUSE MySQL RPM' with the official jdbc drivers on a OpenSUSE 11.3..
    I have set a normal db up with full access for the user that OwnBlocksPlus is using and still getting this error :( permissions are flushed and whatnot and given to localhost connections only (conf is for localhost)

    was some time ago i worked with mysql but this should not be a mysql error :) i can login to mysql using the same credentials manually
  12. Offline


    Can you fix compatibility with
    - Lockette;
    I REALLY need this plugin, or similar that isnt broken! Anyone have a similar?
    (or this plugin will update with this bug?)

    Can you make a Source?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  13. Offline


    can someone upload a the Sqlcode in a pastebin needed for the sql server

    can you upload a the Sqlcode in a pastebin needed for the sql server. plzzzzzzz
    please help

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  14. Offline


    I have a problem if i protect blocks and than close my sever console and restart it . than all blocks that i protect where unprotect und player can destroy them. :/( sry für my english :D )
  15. Offline


    will create a db for user ownblocks with password abc123
  16. Offline


    TheMaa likes this.
  17. Offline


    Thank you so much! :)
    God bless you!!
  18. Offline


    if i set some block with worldedit OwnBlocks will protect or no?
    Because on bananaprotect plugin when you set block with world edit he don't protect these blocks.
  19. Offline


    it said is out of date when i got OwnblockPlus.beta 1.7 whats the problem?
  20. Offline


    I can't seem to get ownblocks to work, I run a multiplay server with these addons installed:
    Essentials, MySQL, Nocheatplus, Orebfuscator, Permissionsex,Worldedit, Worldguard. OwnblocksX.

    I also had Lockette installed but someone said above that its not compatible. Either way then I type /plugins it doesn't show up on the list. How do I get it to work? I put the permissions in already.
  21. Offline


    what can i do to prevent my users from choosingto protect or unprotect blocks ?
    i just want all their blocks to be saved..
  22. Offline


    it said in the console "is it up to date" can u update it?
  23. Offline


    Is there anyway you can let players own blocks together?
  24. Offline


    Ok, So I got Ownblocksplus to work but now I've got a different problem. For a few minutes after the server has been started the blocks people place become 'owned' but after a while it stops working? It says 'block not owned' when blocks are placed. Also when people try to add blocks with the add tool it doesn't work even though they have these permission nodes:

    - OwnBlocksPlus.add
    - OwnBlocksPlus.use

    However I can add blocks myself using the tool, However any blocks I place after a while aren't protected either. Is there a reason this is happening?
  25. Offline


    Could you make a video tutorial
  26. Offline


    Im getting:

    "2012-04-24 20:31:31 [INFO] Permission system not detected, defaulting to OP"

    Even when i have permissionsbukkit installed and everything looks good in the permissions file.

    Im trying to restrict access to one group but it just enables for everyone by default. Even when i add this to the permissions config:

    OwnBlocksPlus.use: false false
    OwnBlocksPlus.add: false


    the root of the problem is because OBP is loading BEFORE permissionsbukkit, therefore not detecting it:

    2012-04-24 21:23:31 [INFO] Preparing start region for level 1 (Seed: 478636172434224601)
    2012-04-24 21:23:32 [INFO] Preparing spawn area: 77%
    2012-04-24 21:23:32 [INFO] Preparing start region for level 2 (Seed: 3244468754365583413)
    2012-04-24 21:23:33 [INFO] [OwnBlocksPlus] Enabling OwnBlocksPlus v1.7
    2012-04-24 21:23:33 [INFO] Permission system not detected, defaulting to OP
    2012-04-24 21:23:33 [INFO] [OwnBlocksPlus] version 1.7 initialized with MySQL
    2012-04-24 21:23:33 [INFO] [WorldEdit] Enabling WorldEdit v5.3
    2012-04-24 21:23:33 [INFO] WEPIF: Using the Bukkit Permissions API.
    2012-04-24 21:23:34 [INFO] [PermissionsBukkit] Enabling PermissionsBukkit v1.6
    2012-04-24 21:23:34 [INFO] [PermissionsBukkit] Enabled successfully, 0 players registered
    2012-04-24 21:23:34 [INFO] [WorldGuard] Enabling WorldGuard v5.5.2
    2012-04-24 21:23:34 [INFO] [WorldGuard] (world) TNT ignition is PERMITTED.
    2012-04-24 21:23:34 [INFO] [WorldGuard] (world) Lighters are blocked.

    cant figure this one out!!! argh!!
  27. Offline


    Is it possible to protect blocks that have already been placed?
  28. Offline


    Use the right bukkit-file.
    Its works best with groupmanager. PermissionBukkit is not tested or added.
    Maybe some day.
    Post error's from console?
    See the config, I think its there.

    No, its closed source until I release the source.
    I dont have the skills to make something like that.
    Check that your mysql server is installed correctly.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  29. Offline


    how do i get ignore ownership to work??? its not working for me and i'm using group manager
    FOcraft :D
  30. Offline


    Why isnt OwnBlocksPlus.ingoreOwnership working? I need this!

Share This Page