[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    I just installed this plugin today and it doesn't seem to work. I'm not seeing any messages in the startup log about mcmmo at all. The .jar file is in the plugins folder along with my other plugins. Any reason this isn't loading up for me? I'm running the newest released version of bukkit (for 1.4). Edit: The plugin is creating the mcmmo folder as its supposed to. Still no in-game commands work. Not even /mcmmo.
  3. Offline


    hey maybe you can change the /stats command to /skills ? because i like the stats & achievement plugin but with mcmmo cant use the /stats command for stats <.<
  4. Offline


    Could we have something like an XP loss if you die? I'd like to make it so that players lose like...a level, or 200xp or something everytime they die so they quit putting beds on high pillars and repeatedly jumping off to train their acrobatics.
  5. Offline


    Would it be possible to make skills such as excavation, mining, herbalism and woodcutting only give experience when the block is broken server side? It would seem that my users are digging or herbing in protected areas and still getting exp when the block doesn't actually break (and not damaging their tools either). I use epiczones for protection if that makes any difference.
    P.S. My users are also suiciding to get acrobatics experience!
  6. Offline


    When you update your plugin, please remember to update your plugin.yml. over and over I'm seeing old version #s on new releases after the thread says it's been updated.. Kind of hard to tell if I actually have the updated version or not if you don't properly increment your Version #s in your plugin.
  7. Offline


    Update: tracked down the error i'm getting.

    [SEVERE] PLAYER_BED_ENTER loading mcMMO v0.9.21 (Is it up to date?)
    .NoSuchFieldError: PLAYER_BED_ENTER
    t com.gmail.nossr50.mcMM:confused:nEnable(mcMMO.java:70)
    t org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    t org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoa
    t org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginMan
    t org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:94)
    t org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:72
    t net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
    t net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
    t net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
    t net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
    t net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  8. Offline


    Just updated, Downloaded 0.9.22 from link. It installed fine and is running on CB670, but wanted to say the MOTD is saying it is 0.9.21

    Not a big deal, just figured I would report it. Or it could just be me screwed up somehow.
  9. Offline


    I'm getting spammed with this error in console. I've seen this before - last time CB changed the API on you. Something about the NPC plugin and you not recognizing that interaction?

    mcmmo Version: v0.9.22
    CB 670

    Bigbrother, elevators, essentials, essentialschat, essentialsspawn, griefalertr, help, heroicdeath, iconomy, lwc, magiccarpet, mcmmo, monsterhunt, multiverse, npcx, permissions, portabletorch, preciousstones, runecraft, towny, uquest, vanish, worldedit, worldholextreme.
  10. Offline


    Your plugin.yml file still says 0.9.21 by the way, or you forgot to upload the 0.9.22 version :p
  11. I get these errors while attacking a NPC (plugin: http://forums.bukkit.org/threads/fu...paths-aggro-loot-guard-shops-quest-chat.9186/)

    Show Spoiler
    2011-04-11 02:29:48 [SEVERE] Could not pass event ENTITY_DAMAGE to AuthMe
    at com.bukkit.fabe.AuthMe.PlayerCache.PlayerCache.getLastAlert(PlayerCache.java:68)
    at com.bukkit.fabe.AuthMe.PlayerCache.PlayerCache.isAlertNeeded(PlayerCache.java:76)
    at com.bukkit.fabe.AuthMe.AuthMe.checkAuth(AuthMe.java:611)
    at com.bukkit.fabe.AuthMe.Listener.AuthMeEntityListener.onEntityDamage(AuthMeEntityListener.java:30)
    at org.bukkit.plugin.java.JavaPluginLoader$41.execute(JavaPluginLoader.java:452)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
    at net.minecraft.server.EntityHuman.d(EntityHuman.java:504)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:722)
    at net.minecraft.server.Packet7UseEntity.a(SourceFile:33)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)

  12. Offline


    digi, npc or npcx plugin?
  13. NPCX, I posted the link.
  14. Offline


    the link for me is still giving me 9.21, at least according to the error messages i keep getting
    [SEVERE] PLAYER_BED_ENTER loading mcMMO v0.9.21 (Is it up to date?)
  15. Offline

    Netto Hikari

    Does it allow the customisation of the messages?
  16. Offline


    Simple question which the almighty Google couldn't answer for me and I haven't seen brought up in the parts of the thread I've read:

    Is there any way to disable mcMMO entirely on certain worlds for a MultiVerse-equipped server? I currently have a survival RP-type game going on with a surface and nether, but I'd like to add a creative world to the mix. I just want to make sure that nothing which occurs in the creative world would have any impact on the player's stats as far as mcMMO is concerned.
  17. Offline


    I just have one simple request. Is there any way for the /whois command to let me see the stats of people who aren't online? It is pretty difficult for me to use the mcmmo.users file to calculate the power level of the person I am looking for. Alternatively, could in a future update one of the values in every user's mcmmo.users file be their power level? Thanks in advance for any help, and thanks again for this great mod! :)
  18. Offline


    Whoops, sorry about forgetting to update the version number last build!

    Version 0.9.23
    • Chimaera Wing now takes the world into account
    • Abilities now make announcements within a short distance to nearby players
    • Acrobatics won't give XP on death, and will fail if you would've died after the damage reduction
    • Added yet another check to see if a Player is not in the Users system for NPC mod compatibility

    @wolrah Permissions is world based so have one world setup with no mcMMO permissions and viola!

    @TheDeejay I could make this command, I'll put it on my todo list

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    is there anyway to disable chimera wing? id like to use the fly ridge fly plugin but the chimera wing spams me @_@
  20. Offline


    Any idea on why im getting:
    23:26:30 [SEVERE] Could not pass event BLOCK_DAMAGE to mcMMO
    at com.gmail.nossr50.mcm.damageTool(mcm.java:56)
    at com.gmail.nossr50.mcBlockListener.onBlockDamage(mcBlockListener.java:
    at org.bukkit.plugin.java.JavaPluginLoader$25.execute(JavaPluginLoader.j
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockDamageEvent(C
    at net.minecraft.server.ItemInWorldManager.a(ItemInWorldManager.java:87)

    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:356)
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  21. Offline

    Justin Hawtree

    Is there anyway to disable adminchat or to change the command of admin chat?
  22. Offline


    I have the plugin running fine, but when I try to issue any commands for abilities it says it does not have sufficient permissions. I have added permissions for the abilities globally and individually, but no dice, help.
  23. Offline


    Wondering if it was possible to add a config for xp lost on death percentage.
  24. Offline


    sorry nvm i found an answer to my question by just jumping in the deep end ;)
  25. Offline


    Rite, thanks for this. But still the same problem with beds exists.
    If you right click the bed during day or with feather in hand, home is set to the bed, but myspawn is not, so after dying the player returns to the bed, but after using the chimaera wing (Shouldn't it be called chimera btw?), the player returns to the spawnpoint of the map.

    IMO MySpawn and Home should be the exact same place.
  26. Offline


    Hey so I was wondering, if a player doesn't have access to the mcmmo.skills.* permission, but has already gained levels in some of the skills, will they keep the benefits?
    If they do, but can't level up them more, than that's exactly what I want!
  27. Offline


    hmm, repair doesn't seem to work with 9.23. I don't get any xp for repairing iron items :(

    edit: ah, sorry. you just had to place a new anvil or replace the old one

    edit2: hmm, have to take back edit1, now it doesn't work again (with iron armor) after I reconnected. Also after placing a new anvil

    edit3: Ok, I think the error lies in the "armor-repair mechanism", because repairing tool works, but repairing armor does not. I have no armor plugins installed
  28. Offline


    Well a bug we have on our server Minesville.net is that we cant use the pick axe ability.
    Another bug is that you can train you acrobatics on slimes.
  29. Offline


    Ok, so we're having a bit of a freak accident over on my server.
    After downloading the new version of mcMMO and overwriting the old .jar, mcMMO simply does not work anymore. None of the commands are recognized, even to OPs. The console doesnt even output errors for it because its as if it doesnt even exist. The strangest part, is that the config files are still generated by the .jar

    I recently installed MultiInv, which may/may not be the cause of these issues...
    Also, running the current recommened CraftBukkit, and java is up to date.

    I'm not exactly sure what happened, so if you have ANY insight, please let me know! :x
  30. Offline

    Nathan Kamenar

    Ok so I am looking at installing this on my server but I noticed a lot of bold print saying it requires craftbukkit 670 but I am running 617. Will this really not work with any version but 670? Or do you just say this to make troubleshooting problems easier? I would just upgrade my craftbukkit but it takes a day to have my serverhost do it and I am concerned that upgrading to 670 will make some of my current pluggins stop working. Anyone have this working on 617? Thanks.
  31. Offline


    @DrBoweNur Not sure if I know whats happened, does it say its loaded in the console?

    @Nathan_Kamenar Yes you really need 670 for the newest, but heres an old version that will work with 617

    @omen964 Are you sure you have the permission setup correctly?

    @Shanev Are you sure its not a plugin interfering? Seems to work fine on my server, tell me if it happens with only mcMMO running.

    @TehJammers they need the skill permission to receive the benefits as well

    @Sopsys you actually need to sleep in the bed to set your MySpawn

    @Shnowmon Could you post your permissions file to pastebin.com so I could look it over?

    @silentdojo not a bad idea, I could put it on my todo list
Thread Status:
Not open for further replies.

Share This Page