[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


  3. Offline


    "Giga Drill Breaker" Ability, "Super Breaker" Ability, "Serrated Strikes" Ability, "Skull Splitter" Ability, "Tree Feller" Ability, how to disable?

  4. Offline

    Daniel Few

    Is there a list of your hooks other plugin authors can use?
  5. Offline


    uhm to me the tree feller doesn't need to refresh i can use it as much as i want no delay is this me or the mod???
  6. Offline


    Version 0.9.20
    • Fixed Tree Feller not checking if its cooldown was refreshed and always activating
    • /stats and /whois will now show the powerlevel based on permissions
    • Shovels will no longer say you've lowered your axe
    • /myspawn will no longer say your inventory has been cleared if the server settings disable this feature
  7. Offline


  8. Offline


    Is there an easy way to disable Power Level Based Regeneration for everyone? I know by not giving the node to other users I can block it, but how do I disable it for admins without having to type out all the permissions (rather than using '*') ?

    Power Level Based Regeneration
  9. Offline


    Did you do something to fix the "not being able to do a /reload" bug? or maybe it was an issue with bukkit?
    I was just doing some testing, and decided to rebuild a test server from scratch;
    I got Grpmanager up and running with CB670, then installed MCMMO and was messing around and tried a /reload, forgettting about the issue, but i got no console errors at all!

    Gah, its not letting me post on a reply to shadow85! -.-
    use "-mcmmo.regeneration"
    this is an exception node, and is outlined in the permissions thread

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  10. Offline


    Been using this on my server for some time now, Love it!
    However, after the latest update /setmyspawn wont work! Neither for me/other OP's/ or default players.
    ty for help in advance!
  11. Offline


    Version 0.9.21
    • /mcrefresh fixed to work properly with the new ability monitoring system
    • Ability lengths are now based on your skill level directly rather than a tiered system
    • Chimaera Wings won't trigger on things they shouldn't (Doors, Chests, ETC)
    • Chimaera Wings will properly tell you how long you have to wait to use it if you've been recently hurt
    Another hotfix [cake]

    Abilities start with 2 second minimum duration and go up for every 50 skill you have in their respective skills.

    @diegokilla It should be fixed

    @Rekorderlig That was removed a few versions back, you set your spawn by entering beds now just like in Vanilla MC.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  12. Offline


    Thank you. I will admit I'm trying to learn how to work with the formatting and the more I read about it and the YAML files I get more confused lol. Thank you again, and for being patient <3
  13. Offline

    Daniel Few

    In your mcmmo.users properties file, can you give me a description of the values.
    Also, what is gather? eg wgather archerygather, axesgather?

    EDIT: Does 'gather' mean experience?
  14. Offline


    Gather variables are what holds the XP, gather is for mining as when I first made the mod it was named that and haven't gotten around to changing it, wgather is for woodcutting, these are the only skills with weird gather names. I should probably rename them all to miningxp etc now that I think about it.
  15. Offline


    Of course my friend, It's no problem. I will give you a piece of advice tho, Go read permissions OP again, then when your done with that, read it again, then just to be on the safe side, read it again tomorrow to make sure you retained it. It seriously took me about 5 readthroughs to fully understand it -.-
  16. Offline


    yeah i'm sure. Tried it again with the new version (21). Excavation and mining. both length are shorter than displayed.
    And yes, i tried it multiple times. Excavation should be 9 sec. and it ends after 4,5 - 5 sec... mining, should be 7 sec, ends after ~4,5.
    the other users on my server reported similar results.
    maybe a count problem, conflict with another plugin?

    I'm only using permissions, essentials, minecartmania, creaturebox, multivers, multiinv and your great mcmmo plugin.
  17. Offline

    Daniel Few

    Thank you :)
  18. Offline


    @pSyCeNeTiC Hmm, not observing any oddities with it on my own server. Could you PM me connection info so I could check it out?
  19. Offline


    i Know i need to compile it ,i try with eclipse, but it compile to normal class files not binary, maybe i can send you translated lava files and u can compile it too me please ? :)
  20. Offline


    Thank u so much! <3
  21. Offline


    oh wow i feel dumb. thanks guy lol.
  22. Offline


    @Czarnuch Class files are the expected result when compiling Java files

    Version 0.9.22
    • Fixed bug where Chimaera Wing was unusable after being for eternity

    Rewrite one major part of your plugin, and you break a dozen things ;_;
  23. Offline


    Any idea when we'll see the addition of fishing as a skill? I appreciate the frequent updates, but I'd like to give the denizens of my server more of a reason to fish, as currently they have little motivation and that just seems weird for an RPG-like server.
  24. Offline


    Still getting this when /reloading

    2011-04-10 21:58:50 [SEVERE] Exception in thread "Timer-5687" <-- number is random
    2011-04-10 21:58:50 [SEVERE] java.util.ConcurrentModificationException
    2011-04-10 21:58:50 [SEVERE] at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
    2011-04-10 21:58:50 [SEVERE] at java.util.AbstractList$Itr.next(AbstractList.java:343)
    2011-04-10 21:58:50 [SEVERE] at com.gmail.nossr50.PlayerList.findProfile(mcUsers.java:147)
    2011-04-10 21:58:50 [SEVERE] at com.gmail.nossr50.mcUsers.getProfile(mcUsers.java:91)
    2011-04-10 21:58:50 [SEVERE] at com.gmail.nossr50.mcSkills.watchCooldowns(mcSkills.java:70)
    2011-04-10 21:58:50 [SEVERE] at com.gmail.nossr50.mcTimer.run(mcTimer.java:31)
    2011-04-10 21:58:50 [SEVERE] at java.util.TimerThread.mainLoop(Timer.java:512)
    2011-04-10 21:58:50 [SEVERE] at java.util.TimerThread.run(Timer.java:462)
    2011-04-10 21:58:50 [INFO] [mcMMO] Permissions enabled.
    2011-04-10 21:58:50 [INFO] mcMMO version 0.9.21 is enabled!
  25. Offline


    Aww, no more spiral energy? = (
  26. Offline


    I really want quests or something of the sort but you never get back to me lol.
  27. Offline


    Yeah, one of my players says he used to have super break at 7~seconds, now it's around 4. I personally haven't tried, though.
  28. Offline


    Maybe this :...
    1.I Make a new project in Eclipse
    2.I put all the surce files there
    3.I edit java files
    4.I export it as a mcMMO.jar

    So what is wrong ? :(
    (i think class files are still not binary :( and i dont know how to make them binary)
  29. Offline


    Thanks for this great plugin.
    Unfortunately, my users can't use /party because of insufficient permissions although they have the permission.
    Any ideas on that?

  30. Offline


    More to report, <text removed>...

    EDIT: Did more research and seems like the home bed is set only when the user really goes laying in the bed, that's when the "Myspawn set to your current location." -text comes, and after that the chimaera wing works fine. Maybe that could be fixed so that it works in conjunction with the "Your home is now set to this bed." -text.

    Also, using Chimaera Wing does not take world into account, so teleporting from nether to home set in normal world does not work.
  31. Offline


    @nossr50 So is there a way to fix the npc problem? I can give you the full error if you want it.
Thread Status:
Not open for further replies.

Share This Page