[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    This is great. Thank you so much ! Going to test it.
  3. Offline


    download link is down
  4. Offline


    Well I saw that myspawn was set automatically when I clicked on a bed (i was testing the ability messages)

    I like an idiot typed /myspawn and it cleared my entire fucking inventory from mining all night.

    Goodbye iron, diamonds, and coal. Other than that its a great plugin - but the inventory thing seems pretty unnecessary and it doesn't look like I can undo it so I guess I'm just fucked.

    A confirmation message would have been nice stating that it was about to clear my entire inventory for teleporting me 2 blocks back to my bed I just woke up from, but oh well.
  5. Offline


    download url is broken

    Error (404)

    We can't find the page you're looking for. Check out our FAQ or forums for help. Or maybe you should try heading home.
  6. Offline



    Error (404)

    We can't find the page you're looking for. Check out our FAQ or forums for help. Or maybe you should try heading home.
  7. Offline


    Join my server and i would hapily give you that back.. is a lovely SMP multiworld/multiinv server with lots of goodies

  8. Offline


    Ugh can I disable this myspawn nonsense...

    If it was named "suicide" instead i wouldn't have typed it -.-

    Edit: and yes the link is down
  9. Offline


    Can anyone please help me with the following error :) After installing the new mcmmo, on both my home test server and a external rented server; only my home test server is working fine and the rented server is producing the below problem.

    McMMO 0.9.18
    Craftbukkit 670

    [SEVERE] PLAYER_BED_ENTER loading mcMMO v0.9.18 (Is it up to date?)
    java.lang.NoSuchFieldError: PLAYER_BED_ENTER
    at com.gmail.nossr50.mcMM:confused:nEnable(mcMMO.java:70)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:514)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:216)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:94)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:72)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  10. Offline


    Stop the server entirely. Restart.
  11. Offline


    Download link have broken =/ ?
  12. Offline


    Links up B}

    (im done raging about suiciding now)
  13. Offline


    It was down because Iwas updating it, heres a quick hotfix for a big mistake of mine

    Version 0.9.19
    • Fixed Anti-Exploit XP stuff not working
  14. Offline



    Just updated to v0.9.18 using CB 670
    Permissions 2.6
    I have mcmmo.* permission

    The repair skill doesn't seem to to be increasing when I am repairing my diamond armor. Tested another skill (excavation) and it increases but repair doesn't.
    Haven't tested others yet.
  15. Offline


    @SeeD419 It is toggle-able in the config file, should be named something like "myspawnClearsInventory=True"

    @vizorsx You need a newer CB

    @Arjan I would just ignore that message
  16. Offline


    His post does say 670 :/ and yes I'll have to disable that I suppose. R.I.P. items ;(
  17. Offline


    @SeeD419 Oh derp, no idea what would cause an error with it then.
  18. Offline

    Daniel Few

    Hello, i'm setting up an RPG Server (still making it, not open yet) and i love this!! While i was setting up i had LevelCraft installed, which was very good as well.

    I love your plugin as it includes a much wider range of skills! However, something i would LOVE to see if level restrictions like on LevelCraft.

    For example, when you reach level 10 you can use a stone pick, however if you try and mine with one before that the block re spawns and you get no drop. I would love to see this as it brings in another reason to level up and gives players another challenge, they MUST level up to use higher tools.

    Please can you consider adding this :) Overall however an EXCELLENT plugin that gives so many features.

    PS. If possible it would be great to make this customizable. E.g in config, what level you need to use what tools. :)
  19. Offline


    Thanks for the advice but im still having no luck :(

    I've suspected that the server is using a slightly altered .exe to start the server because i copied the whole mc server file over to my pc and ran the server file here and produced the same error. Whilst my own server file is still working fine without a problem.
  20. Offline


    That error is coming from a prior build than 670.

    I did a reset when updating from 617 > 670 and got the same error.

    After stopping, and then starting up again - the error was gone and hasn't returned. Make sure you're seeing build 670 on server startup.
  21. Offline


    @nossr50 Please help me :(
    I translate your plugin to PL but i dont know hot to recompilate it again to binary class :(
  22. Offline


    Hate to drop a mild bug on you after 2 good updates, but when you disable Inventory clearing of /myspawn in the config file, you still get a message everytime saying "Inventory cleared" even though it hasn't been :/
  23. Offline


    @SeeD419 Alright, will be fixed in the next update.
  24. Offline

    Daniel Few

    Did you see my post on previous page about limits?
    :) Just wondering if you can implement this?
  25. Offline


    I'm not going to, however the mod is open source so feel free to do so yourself.
  26. Offline


    Well in the config you posted I didnt see any global settings group, perhaps it just didnt get copy pasted? If not then those "class" groups inherit nothing... You may want to browse through it again...
  27. Offline


    I stopped the time and the Ability Length aren't right. CB#470 mcmmo 0-9-18

    my SuperBreaker should be 10sek. But effektiv it ends after ~5 sek.
    Is it the plugin or another known problem?
    The cooldown time works fine.
  28. Offline


    Just wanted to say that this plugin is doing so great! 0.9.18 Really fixed so much :D And I also love to see that you are adding in hooks for other authors, God I wish I could program >.< Kudos good sir!
  29. Offline


    WHY YOU IGNORE ME ???? :(
  30. Offline


    @Czarnuch you need to compile the Java files with something like eclipse or netbeans, you'll also need to use the permissions plugin and craftbukkit as libraries in addition to bukkit.

    @diegokilla You could always start learning :)

    @pSyCeNeTiC Are you sure about this? I'll look into it.
  31. Offline


    I have tried, unforunately, I dont think it's going to be something I could teach myself :(
Thread Status:
Not open for further replies.

Share This Page