[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. I said what it printed, there's no usual error, just disconnect reason which was outofstream but the client printed something else... anyway, it's been fixed in client version it seems, so nvm :p
  3. Offline


    Im not sure about the doubble drops but i know for a fact if you place a flower down and pick it again you wont get exp for it im sure there are many other quick looping tactics blocked. i would like to think that the exp for the ores would be 1 of them. i remember seeing an update where he said some thing about them i think he may of fixed it then. but your right about the doubble drops i hope that is blocked
  4. Offline


    It is, there's an anti-xray plugin or something that doesn't retain the byte data of player places ores when it swaps them out, and thus I am getting reports like this lately.
  5. Offline


    anyone getting block lag with the latest versions?
  6. Offline


    This is the error I get:
    07:55:47 [SEVERE] Could not pass event ENTITY_DAMAGE to mcMMO
    java.lang.NoSuchFieldError: PROJECTILE
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    > at com.gmail.nossr50.Combat.combatChecks(Combat.java:220)
    at com.gmail.nossr50.listeners.mcEntityListener.onEntityDamage(mcEntity
    at org.bukkit.plugin.java.JavaPluginLoader$58.execute(JavaPluginLoader.
    7:56:17 [INFO] Unknown console command. Type "help" for help.isteredListen
    7:56:17 [INFO] Unknown console command. Type "help" for help.isteredListener
    > at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.j
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    > at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.j
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    07:56:17 [INFO] Unknown console command. Type "help" for help.
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.
    at net.minecraft.server.EntityHuman.d(EntityHuman.java:550)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:858)
    at net.minecraft.server.Packet7UseEntity.a(SourceFile:33)
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    7:56:17 [INFO] Unknown console command. Type "help" for help.er
    7:56:17 [INFO] Unknown console command. Type "help" for help.er.j
    7:56:17 [INFO] Unknown console command. Type "help" for help.ger.java
    7:56:17 [INFO] Unknown console command. Type "help" for help.er.java:2
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    7:56:17 [INFO] Unknown console command. Type "help" for help.
    7:56:17 [INFO] Unknown console command. Type "help" for help.Sourc
    7:56:17 [INFO] Unknown console command. Type "help" for help.SourceFi
    7:56:17 [INFO] Unknown console command. Type "help" for help.ourceFile
    7:56:17 [INFO] Unknown console command. Type "help" for help.ourceFile:4
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    7:56:17 [INFO] Unknown console command. Type "help" for help.
  7. Offline


    Either your CB or mcMMO isn't up to date

    None on my server

    Version 1.1.05
    • Maps dropped from excavation are created correctly, and represent the area they are found in
    • Fixed an exploit with clay and excavation
    • Fixed a NPE with locking xp bars
    • Fixed the !AdeptDiamond! localization error when repairing diamond with a skill below 50

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  8. Offline


    So the exp bar isn't showing up.. It's enabled and all that jazz, just refuses to show up at all. What do?

    mcMMO v1.1.04
    CB 1060
    Spout 1.02
  9. Offline


    Are you using a version earlier than 1.1.04?
  10. Offline


    Hello. I'm admin for a small server and a decent programmer. My server is a small group of friends who are fairly casual. I've been attempting to alter this mod to better suit my particular server. I'm also using this as an excuse to learn Bukkit better - if I start with this, you've already done all the hard parts.

    Changes I'm making, if you're curious:
    Flat 100 XP to level. Some XP gains nerfed. Max level of 1000.
    Weapons skills level per hit rather than by damage.
    Excavating clay no longer can reward maps, and webs and slime can come from soil.
    Mining provides a small chance to give iron and gold bars from smooth stone.
    Mining provides a small chance to give diamond from coal.
    Axes get a small damage bonus at 250 that doesn't stack with the one at 500.
    Taming skills up from wolves dealing damage.
    Taming causes wolves to be healed more from pork chops.
    Taming causes wolves to be healed when you eat.
    Will attempt to resolve the bug where eating while focusing on a block fails to reward herbalism bonus. (haven't quite figured this one out yet)

    I've figured out how to effectively make the changes in the code that I want, but I'm having a lot of trouble getting dependencies resolved. The biggest headache I've had is with the Permissions plugin. Could you recommend versions of Spout, Bukkit, and Permissions for importing? Especially Permissions, which seems to be under some sort of version and ownership mess.
  11. Offline


    Using 1.1.04 but I upgraded from earlier versions. I've never wiped the entire setup and re-installed it (not even since before 1.0), should I try that?
  12. Offline


    yes i was using the spoutcraft client, i found my issue... i use a ramdisk for INSANELY fast i/o performance and i neglected to update the image my ramdisk loads/backups to and so when the ramdisk saved its current state and loaded the mirror, the old spout plugin overwrote the newly updated one.

    I'm just glad it was an easy fix, now im having strange chunk loading issues i have narrowed down to the spoutcraft client loading the chunks in a strange fashion... time to post over there andsee if im alone on that one ;-P
  13. Offline


    • Permissions
    • PermissionsEx
    • SpoutAPI
    • Bukkit
    • CraftBukkit

    You shouldn't need to, just restart the server and make sure you are running the SpoutCraft client latest version.
  14. Offline


    That's it. PermissionsEx was what I was looking for. Thanks! Love this mod!
  15. Offline


    I was having this problem on my server. If you are admin, update the spout server side program, if you are not an admin, ask them to do so, it may help. Spout is having a few issues with updates right now. Either they released a new update to fix it ;) Or the current version got updated with the older version.

    Either way, or what ever the cause, downloading the latest version of Spout for the server and installing it fixed my issue.
  16. Offline



    love the new bars but they just eat up too much they make my players disconnect from memory errors since v1.0 :( even without the textures
  17. Offline


    I updated mcmmo to It still didn't help
    and my CB is 1000
  18. Offline


    Have your players click 'use the dev version' when starting up their spoutcraft launcher, there is a memory leak fixed in 149 of Spout that will affect your players.

    You need to do the following

    1. Install CB 1060
    2. Celebrate
  19. Offline


    just thought of perhaps another idea for this lovely mod @nossr50 perhaps a "Construction" skill to level up with? leveling up increases your chance for giving you a free placement of a block? ie: you have 20 cobblestone, you place 1 down and have 19 but the proc triggers and you gain 1x cobblestone back, so its like a free block placement? I COULD see an issue with this, ie: placing down rare blocks, mining them & repeat to dupe... unsure what a good way to prevent exploiting this skill/ability, if it is implimented, would be... keep in a log/memory of placed blocks and after a x long period of time passes it removes it from memory/log? *shrug* or perhaps a special ability for the Contruction skill to fly for x ammount of time for easier building of hard to reach areas and when it's about to expire slowly drop the player back down to ground level? anyways great job with the updates! my players are enjoying this plugin quite a bit!
  20. Offline


    This sounds like exploits waiting to happen with not much benefit to start with.

    Also, nossr, it's not on the list so I figure I should ask, there should be no issues using PermissionsBukkit for my permissions correct?

    EDIT: Editing fails.
  21. Offline


    v1-1-05 gets this in spoutcraft console

    Bar never shows up, no errors in bukkit, just spoutcraft.
  22. Offline


    Hi nossr,

    The XP bars are cool... but I noticed (and players noticed) how it effects the frame rate a lot... Is there some way to toggle the bars on and off as a player preference.. or command... Or is there something else I'm missing.

    I know I can disable them in the config... but they are too neato to not at least offer them as an option.



    Ps. Another user was asking about them blinking on each update.. is that because it loads a whole new image each time?
  23. Offline


    Player side customization is coming, the blinking is from it switching images before the new image is fully downloaded. This will be corrected when Spout has precaching.
  24. Offline


    2011-08-16 19:01:59 [SEVERE] Could not pass event ENTITY_DAMAGE to mcMMO
    java.lang.NoSuchFieldError: PROJECTILE
        at com.gmail.nossr50.Combat.combatChecks(Combat.java:220)
        at com.gmail.nossr50.listeners.mcEntityListener.onEntityDamage(mcEntityListener.java:133)
        at org.bukkit.plugin.java.JavaPluginLoader$58.execute(JavaPluginLoader.java:649)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
        at net.minecraft.server.EntityArrow.m_(EntityArrow.java:183)
        at net.minecraft.server.World.entityJoinedWorld(World.java:1198)
        at net.minecraft.server.WorldServer.entityJoinedWorld(WorldServer.java:48)
        at net.minecraft.server.World.playerJoinedWorld(World.java:1180)
        at net.minecraft.server.World.cleanUp(World.java:1104)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:447)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Since the upgrade from 1.0.5 to 1.1.0, I get the following issue when arrows are fired -- at least, so far that is the only place this type of error happens. I was wondering if anyone knew why this is happening? Perhaps something is setup incorrectly? I'm currently using mcMMO with a mySQL database.. but this doesn't look related.

    Bukkit 1060 (same error happened on version 1000)
  25. Offline


    That should not be happening with 1060, PROJECTILE was introduced before it.
  26. Offline


    I do not get this error, at all, with version 1.0.5 -- it works perfectly with arrows. It's just something about this update. Any ideas as to where it's coming from?

    Other plugins: iConomy, LocalShops, Residence, PermissionsBukkit (1.1) (w/SuperPermsBridge 1.2)
  27. Offline


    don't use the dev-build of Spoutcraft and it'll work =)
  28. Offline


    Thanks for great plugin!!

    Can I change commands? (/stats, /whois)
    These conflicts with other plugins (Stats and achievements, Essentials)
           Name: stats
           Enabled: true
           Name: whois
           Enabled: true
    What these configuration does???
  29. Offline


    Are you triple positive you are running CB1060?
  30. Offline


    Hi there.
    I'm updating my mcmmo.users file, because it went blank on me.
    I've found this http://mcmmo.wikia.com/wiki/Mcmmo.users_file

    but I still dont know what are the last 10 fields for.
    Relevant? Or just leave as it is?
  31. Offline


    done both already lol it maybe because of permissions though im using the latest one.
  32. Offline


    Thats cool.. I tried disabling it for the time being by setting everything to false.. but the party xp bars won't go away... It dropped my frame rate down to 16fps.. and I actually have a really good video card. Can't imagine what its doing to players.
Thread Status:
Not open for further replies.

Share This Page