[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Version 1.0.15
    • Removed leftover code that spammed SQL errors
    Hotfix for reported MySQL spam, just an fyi I had to ninja into my dads at 1:30 AM and use the internet to publish this. (Still in a no internet situation lol)

  3. Hah I know the feeling, but that was fast work, ty!
  4. Offline


    Hey :) Nice Plug-in !!!
    But can you make a file where i can make a german language.yml
    Sky from Germany
  5. Offline


    Hm, I'm using 1.0.15 and when a chat command comes up, that should be "YOU READY YOUR AXE", I get a chat message that's something like this: "!Skills.ReadyAxe". Can someone help me? I may have installed it wrong or something but I'm going nuts here, been trying for some hours, installed permissions and Bukkit.
    But I still can't get it to work! =/

    EDIT: I'm using CB 818 too
  6. Offline


    @Gredenvall many bug reports are coming in very similar to yours, I think it has something to do with the localization files failing to load properly. I'll be working on it soon.
  7. Offline


    *Feature Request*
    When /stats is used, hide the stats the user doesn't have permission for
  8. Offline


    @nossr50 Okay, thanks mate. Keep up your good work, it's not unappreciated!
  9. Offline


    Supported Languages
    English - en_US : Finnish - fi : German - (Coming Soon!) : Dutch - (Coming Soon!)​
    (Setup the locale= in mcmmo.properties to use other languages)
    ou thats nice :)
  10. Offline


    Alright guys, I've narrowed down the cause of the bug where localization files weren't being loaded correctly for some users. There's 2 solutions I've found on google, and this is one of them.

    This is a WIP build of mcMMO, tell me if it fixes the problem. If not I have a backup plan.
    http://dl.dropbox.com/u/18212134/mcMMO test builds/mcMMO.jar
  11. Offline


    I deleted essentials plugin from my server, now McMMO and several other plugins I have work... so that solves THAT problem lol
  12. Offline


    Version of mcMMO:1.0.15 Version of CB:818 Plugins used on your server:CB uptodate,heroic death, ichat, lightvote, LWC, Permissions, PLG coldlightning,
    PLG essentials_op, PLGsetspawn_op, Quick Strasse, RaveBlox, Vanishnopickup, McMMO

    Using Flat File System or MySQL: No clue, how do i check Instructions on how to replicate reported bug: type any command to do with mcmmo How frequently the bug happens: everytime. Does this effect all users or only a few: im pretty sure everyone List any custom server software besides bukkit N/A

    Dont know how to upload a pic, but I get an error when typing any command (in the minecraft textbox)
    When a player joins:
    When a player types /stats:
    And other ones, but im too lazy to type them >.<
  13. Offline


    ZeroWing, a post or two above I provide a WIP of mcMMO, try that version out and report back.
  14. Offline


    hi nossr
    is the myrespawn thing multiworld compatible?

    if I right-click a bed in world1, die, I respawn at the bed
    if I do the same in world2, when I respawn I respawn at world2's default respawn point
  15. Offline


    I can confirm that this is working without a problem (atleast for me).
    I had the !mcListener etc bug before, but with that build it works perfectly ;)
  16. Offline


    Same here. One question, How do I edit Message of the day?
  17. Offline


    Works now thank you ;D Doesn't come up with message when log in or when upgrade skill!
  18. Offline


    Alright good to hear the WIP worked, I'll be putting out 1.0.16 soon

    Version 1.0.16
    • Fixed bug where localization file failed to load
    • Changed en_US to lowercase
    • mcMMO now requires locale files to be in lowercase
    • Fixed a few strings missing from the localization file
    This has a few more fixes than the WIP, anyone having problems with mcMMO text not displaying should grab this version ASAP.

    Let me know if there are any issues still.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    so, i have to put ANOTHER plugin to fix this ones problem!? im not trying to be rude but, why?
  20. Offline


    I am using the permission
            default: false
                prefix: '&6'
                suffix: '&e'
                build: true
                 - 'mcmmo.skills.taming'
                 - 'mcmmo.skills.archery'
    however, I'm still able to train Acrobatics.
  21. Offline


    i still had performance issues with mcmmo, and a server hosted at the biggest german minecraft hoster nitrado.net
    hope more performance updates will come
    my users and i love this plugin
  22. Offline


    Sorry if this has already been in the thread, but can I change the drops people receive from excavation? For example, I want to add fire to the drop table for gravel so people can make chainmail. Anyone want to show me how to do this?
  23. Offline


    I can understand what you said before about them being annoying and all that but I personally don't think it is a problem that you can't kill your pets. If you were able to, you might accidentally kill them while trying to train your taming and need to find another wolf.
  24. Offline


    yeees, but is also annoying to try to punish them and not being able to touch them :) jajajajaja its like if peta's there all the time
  25. Offline


    You can make them sit in a corner and just forget about them. :)
  26. Offline


    I'm not sure what I'm doing wrong but I can't seem to get it to work properly. When I try to use an ability it still wants to use pickaxe even though I try to use other tools. I am trying to upgrade from 1.0.9 and never had problems.

    EDIT: Nevermind the problem was with new version of logblock that messed it up.
  27. Offline


    Ok, I deleted my old post because I thought I figured it out, but something weird is still happening with the /myspawn command.

    After some time being unable to use the myspawn command, I tried re-setting my spawn point by using one of my beds again. A few minutes later, I was able to /myspawn back to it. I instructed one of my users to do the same and it worked. Thinking that I had solved the problem, I deleted my original post.

    Well, looks like I was wrong. Apparently I am able to use myspawn once before it sends me the console error again.

    I'm using a flat file.

    Edit: Nobody else is having this problem? Myspawn worked perfectly for me up to one of the recent versions and suddenly broke. I can't be the only one. I haven't changed anything in permissions or anything else.
  28. Offline


    I'll make it so you can hurt your wolves next update.
  29. Offline


    Our stats keep resetting, like every time we log out.
  30. Offline


    Edit: Fixed
  31. How do i change the max skill limit? Its 20,000 at the moment; how do i set it to 1,000?
Thread Status:
Not open for further replies.

Share This Page