Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    is the restart option in the plugin, and not the .jar?
    i would prefer to keep using craftbukkit++, as it gives me much performance upgrades, but would also like the server to auto-restart.
  3. It seems like the RTKPlugin is not working with the latest Development Build of CB.
    This is what i do get :/
    20:09:50 [INFO] [RemoteToolkitPlugin] Enabling RemoteToolkitPlugin v0.61
    20:09:50 [INFO] Memory max: 1556938752 bytes
    20:09:50 [INFO] Memory total: 1037959168 bytes
    20:09:50 [INFO] Remote Toolkit Plugin V0.61 enabled!
    First attempt at checking for presence of Bukkit RTK plugin...
    Second attempt at checking for presence of Bukkit RTK plugin.
    Third attempt at checking for presence of Bukkit RTK plugin...
    RTK plugin for Bukkit was not detected. Disabling heartbeat until next restart.
    Server version:
    20:00:58 [INFO] This server is running CraftBukkit version git-Bukkit-1.3.2-R0.1
    -4-gd08e620-b2359jnks (MC: 1.3.2) (Implementing API version 1.3.2-R0.2-SNAPSHOT)
  4. Offline


    This is somewhat broken since the 1.3.2 r0.1 update beta build, can't issue any commands, the RTK plugin cant be detected, long wait times on restarts and shutdowns. Gonna try the jline thing.

    Also, this does not work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  5. Offline



    If I don't have your plugin installed, this wipe does NOT occur.

  6. Offline


    Whoops, use this:
    Liger_XT5 Hartorn Lathanael Clackw3rk See above.

    Pythros I will look into it more carefully ASAP.
  7. drdanick
    What do you mean by "see above" ? Is it the thing with nojline ?
  8. Hmm seems i forgot another - in --nojline.

    Now it is working ;)
  9. Offline


  10. Ok, it works fine with this line.
  11. Offline


    I've been using your wrapper for a while, and now I'm getting some issues. Whenever the server automatically restarts, some of the chunks but not all of them are getting rolled back. I tried disabling all of my plugins except this and this seems to be the cause. I have scheduled restarts every 13 hours, and I run a quite big server, the world size is quite massive. It takes usually about 3-4 secs to do a /save-all command. I think there might be a problem with the time it allows the server to save the chunks after that the plugins sends a /stop command. Here's a log with for the shutdown period:

    I run tekkit 3.1.2 which runs a custom version of bukkit 1.2.5-R4. I would need help as soon as possible, thanks.
  12. Offline


    Hey there, I've been using this for a long time, but suddenly I have some issues.

    First I was getting "RTPING>RTPONG++", so I put -nojline as a server argument (and the fact that I wasn't able to see what I was typing until after I hit Enter). But now, all the colors in the console have disappeared (and I really need these).

    I'm on 1.3.1R2.0. Thanks!
  13. Offline


    I read the thread and the wiki page, but I still have a this plugin making it so the servers using it are hosted online, or is the "almost perfect server uptime" from the fact that you can feel safe using and viewing the console from anywhere you go?
  14. Offline


    Thanks people so much. --nojline Worked! Awesomee!
  15. Offline


    drdanick likes this.
  16. Offline


    The command fixed the issue, and as stated previous posts, we see no color when viewing the console.
    I have my server hosted, so I have to use SSH to see the console. I've had issues reading chat when there is at least 5 people or more talking at once.
  17. Offline


    Everything working good here, using craftbukkit 2363. Well, except the console colors, but those never worked for me, since a year ago when I started using this.

  18. Offline


    When i start my server it runs fine with Remote Toolkit, but it gives an error every 5 secconds
    starting udp listen server on port *****
    There was an issue inding the UDP server to port ***** cannot assign requested address: cannot bind
    Attempting to refresh UDP server in 5 secconds...
    How do i get this to stop spamming my concole?
    Also, Every 8th time it replaces 5 secconds with 1 minute... Thanks
  19. Offline


    Hey guys,
    I was using this plugin in 1.2.5 and it worked fine.
    I updated the plugin to 1.3.1. and so did I update the Survival Games plugin to 1.3.1. The server starts up and than it gives errors saying: Rtoolkit not found send impulse 1. etc.
    When I remove the survivalgames.jar rtoolkit works fine. It's just when I put the survivalgames.jar back in, it starts giving these errors again and players can't connect to the server when this happens.
    I updated this plugin just by copy & paste the new survivalgames.jar into my plugin folder. (Using mysql for storage).
    Can someone tell me how it fix this? And why are these plugins interrupting?
  20. Offline


    What are the permissions for restarting ingame and stuff
  21. Received this error today:

    Exception in thread "stderr" java.lang.OutOfMemoryError: Java heap space
            at com.drdanick.McRKit.Wrapper$
    Is this known at all? Couldn't find much looking around, but caused a random crash.
  22. Offline


    Hello, I was wondering how to install and configure the plugin when i use a Hostcompany (beastnode) and use filezilla?
    Please help i really need this plugin? PS. i got it to work on my testserver with hamachi.
  23. Offline


    Hey,I am running a tekkit server with java 7 but this isn't the default java on the server.So i want rtoolkit to run the jar with this java:/usr/local/openjdk7/bin/java
    How i can do that?
    Thanks for all responses
  24. Offline


    I am only getting one issue with this. It won't let me edit these lines in


    I would like to make these configuration lines to be:


    But whenever I change these (with the toolkit off first), then when I turn the server on it just rolls back!
    What am I doing wrong here?
  25. Offline


    Bukkit\rtoolkit\ I use
    overridden-process-arguments=../jre7/bin/java -Xms1500M -Xmx3500M -Djline.terminal\=jline.UnsupportedTerminal -jar craftbukkit.jar
  26. Offline


    I'm still getting the issue where after a while, the console looses half of its contents and is replaced with
    " RTPONG++"

  27. Offline


    Tried this but when I start it it says failed to bind port or its used.
  28. Offline


    That means you forgot to turn your server off.

    just rename craftbukkit++ to craftbukkit.jar or change the minecraft-server-jar option

    @drdanik I've been getting the log clearing issue for awhile too, also happens on my test server that only has pex, worldedit, worldguard, and commandhelper. It only happens on ssh screen, but happens regardless of whether screen is attached. To my memory it has not happened over telnet.
  29. Offline


    Im sorry im not that noob i did turned off and it wont work...
  30. Offline


    i know THAT, it uses a seperate jar.
    im not that noobish ;)
  31. Offline


    Has anyone found the fix for the console colors? It is extremely difficult and annoying to read chat without colors. I will probably be removing this if I can't find an answer soon.

Thread Status:
Not open for further replies.

Share This Page