Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    I tried to send the string "unhold:testserver:testserver\r" via UDP to the toolkit.

    Jul 15, 2012 4:02:09 PM makeConnection
    INFO: connection #1 made.
    Unexpected error in shell! Broken pipe
            at Method)
            at Source)
            at Source)
            at Source)
            at Source)
            at Source)
    Jul 15, 2012 4:02:09 PM cleanupClosed
    INFO: cleanupClosed():: Removing closed connection Thread[Connection1,5,]
    Does someone have a (working) PHP-Script to control the wrapper?
  3. Offline


    You're sending it as a TCP packet.
    minifisch likes this.
  4. Offline


    im on Ubuntu and running
    Nearly everything's fine but
    1. No color support (not that bad, but would be nice)
    2. No äöüß[...] support in eg. "say " (not that bad, too)
    3. i cant use BACKSPACE, DEL, ARROWs or any other "function" key (yeah this is BAD! :( i cant correct a typo and have to retype everything)
    I would be glad if this could be fixed :)
    Especially 3. ;)

    Seems he got the same problem:
  5. Offline


    can u get this to work on bukkitgui? the bukkitguiproject! please reply great plugin btw
  6. I have a problem, i use this on my tekkit server & normal minecraft server

    When ever the plugin restarts the server, it leaves JAVA running in the background..
    I had like 3 java's running for 1 server. They take 70 500 kt from my memory for NOTHING . Wtf? if i shut down 1 of the javas, it will shut down the server. So basicly it leaves the server running multiple times or something.
    Is this normal? coz i think it wastes my memory usage for nothing there..
  7. Offline


    Has this been rolled out? I still get this happening occasionally with the current build (10a13).

    Sometimes restarting the game server fixes it (hold+unhold), appears to be random. If it happens once it'll always happen until the game server stops.
  8. Offline


    What happend with colors?
  9. Offline


    but i've got a problem :
    if i want to connect with my iphone he tell me that :

    Jul 21, 2012 2:36:39 PM makeConnection
    INFO: connection #1 made.
    Jul 21, 2012 2:36:40 PM cleanupClosed
    INFO: cleanupClosed():: Removing closed connection Thread[Connection1,5,]
    Jul 21, 2012 2:36:40 PM makeConnection
    INFO: connection #1 made.
    Jul 21, 2012 2:36:41 PM cleanupClosed
    INFO: cleanupClosed():: Removing closed connection Thread[Connection2,5,]

    what should I do
    plz help me

    (sorry for my bad english)
  10. Offline


    Backspace does actually work fine, even if the console does not reflect exactly what you have typed (this issue is present since I do not format console output. I am working on introducing this soon).

    Yes, you should be able to have the toolkit launch bukkitgui in place of craftbukkit or viceversa. This should be as easy as setting minecraft-server-jar in to the bukkitgui executable, or even telling bukkitgui to launch the toolkit, if that's possible.

    The toolkit only ever spawns one other java process (which would mean that you should see two active java processes pertaining to your server). What operating system are you using?

    What exactly is the problem you are having? You quoted a very old issue which was due to a quirk in bukkit.

    A recent bukkit update has had the console colours stripped out when jline is disabled. I am exploring alternatives, but this doesn't seem like a particularly easy thing to fix, unfortunately.

    What application are you using to connect to the server?
  11. Offline


    Error Report here, This error report has forced me to make a bukkit account since I've been using plugins for my server from bukkit for 2 years, and I've always figured out my errors on my own, but this one I just can't seem to break. I've looked through at least 10 pages with no answer to my question at all. so I'll explain it from here. So, I get your plugin and install it like anyone else would, and I run it from the toolkit and everything, server works fine, yay, I installed it. so I try to connect to it via telnet and it doesn't work, and It puzzles me because I set up everything right and I'm totally new to telnet. I figure out that Silly me, I need to portforward so that telnet can work. I port forward and as soon as I do, everything goes wrong. I start up the toolkit interface and It just pops up with a looping error. Though, I can connect to telnet with my phone, And after I enter the prompted login I get to see the error thats looping
    Wrapper is running on: Windows 7 6.1 amd64
    Starting wrapper...
    Jul 23, 2012 3:50:25 PM run
    INFO: Listening to Port 25, 561 with a connectivity queue size of 5.
    Starting UDP listen server on port 25561
    Error: Unable to access jarfile C:\Users\John\Desktop\Minecraft Stuff\My Server\Minecraft Server\craftbukkit
    Error: Unable to access jarfile C:\Users\John\Desktop\Minecraft Stuff\My Server\Minecraft server\craftbukkit
    and the error and restart loops because you programmed it to restart upon severe exceptions of which I haven't changed/messed with. The log itself should tell you my OS I have suspicion It has something to do with port forwarding. but the error itself drives me away from that suspicion, Unable to access jarfile, Initially I thought It said It couldn't find it and it ticked me off lol. but I took a closer look and figured out It couldn't access it, Why? well, I don't know. I was hoping you could tell me that. I'll answer any questions you have.

    EDIT: I've done my research at It appears to be a problem with bukkit and not with your plugin itself, but the idea of port forwarding telnet and the server Immediately not being able to run anymore makes it a bit suspicious. and that the server was working PERFECTLY FINE before, so It can't be bukkit can it? The problem still resides though since I haven't taken action since I'm afraid I'm going to screw things up even more. Also, since Windows likes to be weird, my craftbukkit, is named: "craftbukkit" (without quotes) under the file type of Executable jar file but If I saved a file as .txt or .bat or .jar in this case, It would save it under the name but leave the .jar suffix out. The server worked before under the name "craftbukkit" as minecraft-server-jar=craftbukkit in the wrapper properties, but If I put a .jar at the end would It make a difference?
  12. Offline


    Alkhemyst You do need the .jar suffix in I actually recommend setting explorer to not hide file extensions (google) just to avoid confusion in the future. Also, port forwarding would not have anything to do with this not working. You may have inadvertently used the default settings for before you forwarded the port, which does include the .jar suffix.
  13. Offline


    I am having trouble to download the plugin, it always says that is unable to connect it, could you please send me a better link or a mirror? Thanks.
  14. Offline


    Thank you :)
  15. Offline


    Wow, Just because I left out the .jar suffix. Heh. thanks. The port forwarding only completed the toolkits installation, which is why It worked before since technically toolkit wasn't necessarily forwarding a telnet. which must be why my server was working before because It was just as if I never installed toolkit. But now It's taking forever on my phone now! It did when the error was popping up now It doesn't.

    ConectBot (Using External IP)
    Connecting to (IP):25561 via telnet
    5 Generations later

    So I'm going to look into my properties and see whats wrong.
    Nothing in the properties...
    HERP DERP, I'm using my server IP to connect, external IP, when from my phone I should be using my Internal IP? probably cause I'm connected to my router with Wi-Fi, If I leave it It's probably going to lose connection.

    (Using Internal IP)
    Minecraft Remoteshell v0.46
    username password
    and it connects perfectly fine. Though, I AM connected to the router via Wi-fi while I already have internet on my phone without the need for Wi-Fi, Thing is, What If I left the area for Wi-Fi? Wouldn't it disconnect? weird. I'm not too good with networking when it comes to distance or port forwarding, I'm used to security like Sniffing and Packets and things like that. So none of this makes sense to me. but General common sense for me says that If I leave the area for Wi-Fi I'm going to lose connection to the server since I'm connecting using my routers Internal IP. and the external IP just takes a million years to connect.

    Not THAT much of a problem for me since I'm always in the house but a potential problem and worry for me If I left my server on and traveled somewhere other than my house.

    The connection is only UDP since thats what was described only needed in the original post, If it needs to be TCP too I didn't catch that.
  16. Offline


    Alkhemyst You will need to forward port 25561 over both TCP and UDP if you want to make use of the Telnet RCon and the UDP API outside your home network (telnet works over TCP). Also, you will need to use your server's local address if you're trying to connect to it from within the same network. If you are connecting from an external network, you will need to use the external ip address.
  17. Offline


    I have installed remotetoolkit and it worked perfectly but now when I try to enter my admin:pass in any of the commands it says it's wrong. I checked the server start command but it keeps saying that it's the wrong password, any ideas?
  18. Offline


    You can start the RemoteToolKit with the GUI. See the GUI bukkitDev page for information about this.
    You can also remotely connect to your server. Set the server type to JSONAPI and enter the credentials as set for JSONAPI/RTK
    For more information, visit the BukkitGUI page on bukkitdev.
  19. Offline


    Hi i just got the remotetoolkit plugin and because i am renting it i cant run the bat is there a way you can have a modified craftbukkit.jar so the bat file is not required
  20. I had my survival server running same time thats why there was 3 javas, with only Semicraft up -> 2 javas
    So this is normal?

    I use windows 7 64bit with java 7
  21. Offline


    I am excited and worried about the 1.3 upgrade. I own a big server and the server depends on remote toolkit. Would you be able to release the 1.3 version in time?
  22. Offline


    Is there a auto backup plugin that works with RTK or even runs as a module? .. I tried searching but have not found anything that works
  23. Offline


  24. Offline



    When i do .stopwrapper it saves all.
    After 1-2 minutes it stops the server.
    Can i change the time between save and stop of the server?
  25. Offline


    Unfortunately, no. The toolkit needs to run as an external process to bukkit.

    If you're running another server, then this is normal. The toolkit runs in its own process, which accounts for the extra running java process that you have noticed.

    The current version of the toolkit should work with 1.3 without any problem.

    Not yet. Spacebukkit does have provisions for scheduling backups, so I suggest you have a look at it.

    It looks to me like you're supplying the toolkit port in your adminium client, as opposed to the JSONAPI port.

    This is not normal behaviour. Could you provide a pastebin of your console output from the time you enter the command up until the server shuts down?
  26. Offline


    //Update: i have reinstalled the toolkit now it works fine
  27. Offline


    I know this isnt possible, however is there ANY way on EARTH, RemoteToolkit can work properly with Multicraft (I am trying to get SpaceBukkit to work with it) I expect a big fat no, however it is worth a shot.

  28. Offline


    I have installed remotetoolkit and it worked perfectly but now when I try to enter my admin as in any of the commands it says it's wrong. I checked the server start command but it keeps saying that it's the wrong password, I am entering the EXACT pass and user that I have configured in the server stater executable but it does not work.

    Please help.
  29. Offline


    Hey, when I try to connect from your webpage or the udp client I get authentication error even with the password and username are 100% correct.
  30. Offline


    Sometimes the toolkit will print messages and perform actions to the game server twice, for example on the timed saves.

    It'll show the message that it's about to save twice, then the Minecraft vanilla "Forcing save..." appears twice, then the finished saving message twice. The same if I use ".hold" or ".restart" or anything like that.

    I'll try updating to CraftBukkit 1.2.5-R5.0 and see if its' any different. I'm already running Toolkit release 10a13.

    Edit: Tested after closed down the toolkit and started it up with CraftBukkit updated. If I go to Telnet and put in "save-all" the Minecraft vanilla saving messages appear twice in game, implying the operation is being performed twice. It only appears in the Telnet session once though.
  31. Offline


    Hey - I'm just wondering, is there a way to run a function before the reset? I want to extract a map from a zip before minecraft loads the map - where do I add it?
Thread Status:
Not open for further replies.

Share This Page