Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    Hello, when I start the RTK controller, enter in everything, it says " socket closed" I need help!
  3. Offline


    Everything when well till i launched
    Unable to access jarfile /PATH TO MY craftbukkit.jat restarting

    over and over till i kill it.
    yes i chmod the .sh
    on linux hosted vps
    please help this is a really kool tool:)
  4. Offline


    I'm so so so sorry to ask for help...
    From the instruction, I need to open the MinecraftRestartController.jar, the WinRAR, I can only see some .class files. and I can't open it with java se binary..
    Could you please tell me the way to use this program in simple words?(Cause I'm Chinese and my English is really bad)
    And, should I use the Telnet from windows, or I should just use the Programs in your .zip?
  5. Offline


    I'm so confused with this... does it matter if i have a hosting plan or host this server off a computer at home? I'm hosted with beastnode, and i already purchased a $9.99 app for this whole remote administration thing, but i cant get this to work, thats keeping me from being able to get on this....
  6. Offline


    Help! I have me server hosted. The program the server is using is Multicraft. The website is . So how would I set up the wrapper for this? Please respond @drdanick.
  7. Offline


    Heyho drdanick

    With RTK, I have no Colored Console since the last 2 or 3 RBs, and umlauts doesn't work (umlauts never worked for me, since first rls of rtk. /say äöü).
    If I start the Server normally with my .sh file, it works.

    I think it's a problem of the "Djline.terminal\=jline"?!

    I'm on Ubuntu Linux.
    Help would be nice. Thanks.
  8. Offline


    DL link isnt working for me
  9. Offline


    Yeah its not working for me either.

    These guys never make mirror dl's lol!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  10. Offline


    skiracerdude ElementalRogue The links should be working again.

    @everyone I apologize for my absence from this thread for the last few months. I've been under a lot of pressure at University for the exam period, and could not dedicate any time for toolkit support, save for the IRC channel. I'm currently working on pushing R11 out over the next few weeks.
    Until then, I highly suggest that those seeking support visit the IRC channel linked to in the first post. Although i'm not always on, there is often someone there that can help. Just remember to stay for a while if no one answers. It's hard to help when you give up after 2 minutes of waiting!
  11. Offline


    I use a program called Multicraft at . I have to use this program because my server is hosted. How do I install instal the wrapper with multicraft? drdanick
  12. Offline


    You will need to contact your hosting providers about this one. Either you will have to have to toolkit launch the multicraft wrapper, or you will have to have the multicraft wrapper launch the toolkit in leu of bukkit. I cannot strongly advise having a server operate behind two wrappers that offer conflicting functionality, though.
    I will explore the possibility of adding better support for this situation - but it may not be viable.
  13. Offline


    Error: socket closed

  14. Offline


  15. Offline


    As I have mentioned many times, that "error" is normal. Feel free to ignore it.

    Try launching it without the .sh:

    java -Xmx30M -jar Minecraft_RKit.jar user:pass
  16. Offline


    I get this error with it when i launch without sh:
  17. Offline


    I get that the Java socket error as well. If it's normal, why isn't the command working? I'm telling the RTK controller to restart my server, but I get that error, and the server doesn't restart.
  18. Offline


    Updated java to 1.6 on a CentOS 6.0 Machine.

    Seems 1.5 wasn't compatible.
  19. Offline


    I'm unable to see colors in the console. I've tried adding "log-strip-color=true" to server-arguments and various other places but it doesn't work.

    "log-strip-color=true" works fine if I don't use the wrapper.
  20. Offline


    Is the controller producing the error, or is the toolkit console?

    This is because bukkit now strips colours from the console when jline is disabled. As far as I know, there is no way around this as at the moment.
  21. Offline


    Will this work with FML or other mods? SimpleServer Wrapper didn't, and I want to use this with a Tekkit server. (I AM NOT ASKING ABOUT TEKKIT, I AM ASKING ABOUT FORGE AND OTHER MODS)
  22. Offline


    But if I use something like:

    java -Xincgc -Xmx6G -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui log-strip-color=true

    I can see colours again, but that doesn't work with the wrapper.
  23. Offline


    Quick question - How do I disable automatic restarts in the restart-delay option, not the restarts if it crashes, I've tried setting the value to 0, 0h and false but they revert to the default 5h everytime i start the server?
  24. Offline


    i am also getting the error when starting rtoolkit.bat
    unable to access jar file
    can anyone help me??
  25. Offline


    When I run toolkit.bat I can't get in the server except for local host. But when I run with the old .bat I'm able to log in. Does the plugin change the ip or port?
  26. Offline


    Download Link does not work....
  27. Offline

    Admiral AnimE

    Does this plugin conflict with any other? Because i have a few installed and RemoteToolkit is not shutting down the server and is not sending messages for the time remaining to shut down. It is however saying the correct remaining time in cmd with the command .shutdowntime, and also the restarts are working fine.
    I got Dynmap, Worldguard, Worldedit, PermissionsEx, Nolagg, Minebackup, Loginmessage, Essentials, Authme, Anticreeper.
  28. Offline


    Annoying question:
    When I try to stop my server (typing stop or /stop), it just unloads everything and does a complete restart. I would like to change this, as I do not keep my server up 24/7. I can still stop it while it's saying "restarting..." but I would rather not cut it off but instead do a proper server stop.
  29. Offline


    I have a huge problem

    i have two server with the rtk one server shutdown at 4h59 the second one at 5h. Because i have a cron task to shutdown the server at 5h15

    I check the log file and i don't see anything about the shutdown i have the feeling this functionnality is broken or other...

    So my server restart (cron task) but the rtk don't stop the server before, and some plugin don't stop correctly ... i use a bank system and this plugin don't stop correctly i loose his data.
    And i don't see the server broadcast at 15/10/5/1 mn before the shutdown...

    I use the last recommended build

    Do i need to change anything in my config file???

  30. Offline


    Use the command .hold, to stop the server and not have it auto start. Then start it with .unhold.

    Is this project still active?

    As some may know, the base bukkit in windows launch window now supports color. This makes watching the command console much much easier, is there any way to add this functionality to this wrapper?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  31. Offline


    Thanks so much.
Thread Status:
Not open for further replies.

Share This Page