Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    Does anyone have some good optimizations (server/extra runtime arguments) for my specs?
    4x Quad Core 32 GB Ram 2T HDD
  3. Offline



    CB 2037, R10 A12. Half the time the .restart and .stopwrapper commands do not work. They force a save and kick all players but no restart or shutdown occurs.
  4. Offline


    That means that the server is not responding to the 'stop' console command. Does it still work if you enter it manually?

    Do be aware that you are running a development build of bukkit - and more often than not, the problem lies with bukkit, not the toolkit. As a general rule, make sure the problem exists on beta or recommended builds before reporting it in this thread.

    Also, is the toolkit still reporting that it cannot find the plugin, or was that resolved?
  5. Offline


    No, entering it manually does not work. Ive been experiencing this problem from build 2034 (Beta) to 2040.

    That was resolved, it finds the plugin now.
  6. Offline


    Does it work with the version 1.2.3?
  7. PLEASE update!!
  8. Offline


    i have an error. Whenever i open the wrapper and dont type .stopwrapper i cant fully open the server again it says"FAILED TO BIND PORT" after that it says"The exception BindException: Address already in use: JVM_Bind". can please try and make it so if i close the wrapper without typing .stopwrapper it will be able to re-open again.Also when i try using the udp client or putty,it won't work.For the udp client it says " socket closed" and for putty i cant login, i open putty fill in the area that are needed and i get a black window and if i try to type in my username and password it doesnt work. Please try and fix there errors it would be much appreciated

  9. Offline


    at Kaosvf it seems to be working just fine on 1.2.3 i'm redoing my server and it was the first plugin to install and seems to be functioning fine
  10. Offline


    Very nice would help a lot on my server has my server runs 24/7 and has memory leaks so its great that this plugin can restart it self without me doing it
  11. Offline


    thx for the info
  12. Offline


    i start the server with this batch:

    @Echo off
    "C:\Program Files\Java\jre6\bin\java.exe" -server -Xmx7G -Xms7G -XX:ParallelGCThreads=4 -Xincgc -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts -XX:+CMSParallelRemarkEnabled -XX:+DisableExplicitGC -XX:MaxGCPauseMillis=500 -XX:SurvivorRatio=16 -XX:TargetSurvivorRatio=90 -XX:+UseAdaptiveGCBoundary -XX:-UseGCOverheadLimit -Xnoclassgc -XX:UseSSE=3 -XX:PermSize=128m -XX:LargePageSizeInBytes=4m -jar craftbukkit-1.2.3-R0.1.jar
    for bypass any type of lag... how can I integrate it with your plugin?
  13. Offline


    Why is that when I run to run the server with screen sh, it makes me get spacebukkit? I dont want to use Spacebukkit and its features.
  14. Offline


    Try using this in
    overridden-process-arguments=C:\Progra~1\Java\jre6\bin\java.exe -Djline.terminal\=jline.UnsupportedTerminal -server -Xmx7G -Xms7G -XX:ParallelGCThreads=4 -Xincgc -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts -XX:+CMSParallelRemarkEnabled -XX:+DisableExplicitGC -XX:MaxGCPauseMillis=500 -XX:SurvivorRatio=16 -XX:TargetSurvivorRatio=90 -XX:+UseAdaptiveGCBoundary -XX:-UseGCOverheadLimit -Xnoclassgc -XX:UseSSE=3 -XX:PermSize=128m -XX:LargePageSizeInBytes=4m -jar craftbukkit-1.2.3-R0.1.jar
    I do not include spacebukkit with the toolkit; It sounds to me like you've tried to install it in the past.
    Try clearing the toolkit/modules folder.
  15. Offline


    Does this work with the current #2020 Beta build. I don't want to bother my players installing something that might not currently work. Looks exciting.
  16. Offline


    Yep, it should work fine ;)
  17. Offline


    but the plugin isnt working, is it?
  18. Offline


    Does it work with CraftBukkit 1.2.3-R0.2?
  19. Offline


    It is :)

  20. Offline


    Sweet, I will start installing now ;)
  21. Offline


    Thanks for the info drdanick :)
  22. Offline

    Mr Washington

    How can I set a custom message for each time I restart. Like if I type the command in-game to restart instantly, how can I make it so that the kick message is custom each time I type it?
  23. Offline


    You can't right now, but that is a good idea. I'll work it into a future update.
  24. Offline


    I dont know why but this crshes my entire server :S not only minecraft but my entire Virual Machine!!!! I run the server of a remote server; i dont have phisical acces to it.

    How is that happening im running it with enough ram... but i dont know what im supposed to enter for initial ram??

    Please help!

    are there any known compability prolems with ubuntu?
  25. Offline

    Mr Washington

    Thanks! I have seen this before where they can change the name...Just wondering, developer to developer. How did you get the exit message to work as it does? Been looking into that myself for private reasons and cant work it out!
  26. Offline


    Help please! I need to reset the world every time when server restarts. I mean, on restart I want to delete the "world" folder and replace it with "world_initial" folder. When i were restarting the server manually, I used the following .bat file:
    taskkill /IM java.exe /t /f
    cd "..\"
    rmdir world /s /q
    robocopy "world_initial" "world" /E
    start /MIN java -Xmx1024M -Xms1024M -jar minecraft_server.jar nogui
    Now I want to insert this operation in toolkit's restart process. How can I do that?

    Forgive me for my poor english.
  27. Offline


    Can will be added command like ".command" for giving commands from web or java api .... ??
  28. Offline


    Hi, I'm sorry is my question sounds totally stupid but i'm a real noob with linux

    my server is runnin on Debian and i'd like to know if there is a way to run automatically this wrapper when the server is rebooting.

    thanks for any help
  29. Offline


    I use a custom .bat file to start my server is there any way to use it with the rootkit ?
    like instead of linking to the craftbukkit.jar in the to link it to the .bat i normally use.
  30. Offline



    Release 10 Alpha 13
    -UDP API protocol updated to accept hashed passwords and usernames.
    -Usernames and passwords are now salted (Salt is configurable in
    -UDP socket exception is now completely suppressed in most cases.
    -Windows .bat launcher now uses correct Windows line endings.
    -Minor bug fixes.

    UDP Client fixes:
    -Now supports the new, more secure UDP protocol.

    NOTE: If you have added users in the past, you will need to delete users.txt and re-add them manually! Sorry about that!
    godgodgodgo likes this.
  31. Offline


    just what i was looking for, now to see how it runs :)


    running fine but missing a way to run custom script on startup ( shutdown?) ie rotate logs on startup, which i had the launcher script do before this ?
Thread Status:
Not open for further replies.

Share This Page