Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    the only reason why i want this plugin is because of SpaceBukkit
  3. Offline


    Then remove .DS_Store from modules folder.
  4. Offline


    i'm on Mac... it auto-adds that... i wouldn't know how to stop it...
  5. Offline


    Delete it.
  6. Offline


    Any update on "my" problem? :)

  7. Offline


    Hello drdanick,

    your Plugin works on my Server perfectly.

    THX for your nice Work. :)
    Rytis likes this.
  8. Offline


    I run a few Minecraft servers, all which use RTK. I don't like the CMD interface as it is, but if I switched to another wrapper, would I still have the benefits of crash detection? Also, when I am using this wrapper that comes with RTK(CMD), if I am typing something into the console, and someone talks on the server or something, the line resets, the text is still there, but I can't see it as I'm typing it, which normally has issues with command syntax.
  9. Offline


    OK, i used to use this on my old computer, i had it running perfectly. I got a new gateway desktop and set up exactly how it says, i go to run the wrapper and i get
    "java" not recognized as an internal command
    or something like that, closes out of the cmd to quickly for me too read, i am not sure what is causing this problem, im on CB-1.1-R4 . Please Help
  10. The java binaries aren't in your Path. Google the error and you'll get a host of answers on how to fix it.
  11. Offline


    got it! thank you!
  12. Offline


    Do you use this plugin and have an Android? Search for "RTK Controller (for Minecraft)" by SRC Development in the Android Market! Also I will be posting the next release of my RTK Controller for Windows soon!
  13. Offline


    I was looking at introducing RTK support in Minecraft Mobile Admin and found an issue in UDP API REV 6.

    RTKInterface::executeCommand has a typo in the packet string for FORCE_STOP.
    It's sending "forcerestop" instead of "forcestop".

    public void executeCommand(CommandType type, String commandParameter)throws IOException, RTKInterfaceException{
        String packet = null;
        String suffix = ":"+user+":"+password;
        else if(type==CommandType.FORCE_STOP)
            packet = "forcerestop"+suffix;
        throw new RTKInterfaceException("Illegal command type specified");
    Once corrected, it works fine.
    However, it would be nice if it responded with an error instead of RTK_TIMEOUT.

    Also, while sniffing the packets, I noticed that the username and password are sent raw and unprotected.
    I hate to sound like a jerk, but I take the security of my users and their servers very seriously with Mobile Admin.
    Therefore I am a bit concerned about supporting this wrapper because of that.
    A simple salt/hash before sending the packet and comparing that to the users once received would make me (and I'm sure many others) feel much more comfortable.
    Any chance of adding some level of encryption to the credentials?

    Thanks and keep up the good work!
    - Mike
  14. Offline


    Hello, last week (I think it was..) I made a reply here explaining my situation regarding this wonderful plugin. While I have gotten some helpful tips and tricks, nothing have had any impact thus far.

    So I'm going to quote my original post in hopes of getting more thoughts and feedback from all of you guys!

    Thanks in advance,

    Original post in spoiler below:
    Show Spoiler
  15. Based on some preliminary testing there may be an issue with the shutdown timer being somewhat forgotten when the server has been restarted by an automatic timer.
  16. Offline


    Hello Toolkit users!

    Considering the sheer number of support requests in the last few weeks, and the fact that many of them have already been answered by the community - I will address the unresolved issues on only the immediate page. If you did not have your issue addressed, please visit the IRC channel referenced in the main thread post, it is easier for me to provide faster support there :)
    Also, if you would rather not use IRC, you are always more than welcome to ask your question here.

    This is standard behavior in any unformatted CLI program that simultaneously reads and writes to the input/output streams. I plan on adding a formatting module to R11. Also, crash detection will not work without the wrapper component of the Toolkit.

    Thank you for your utilities :) I will evaluate them as soon as I can, and perhaps add them to the wiki page.

    Oh dear. I have had that typo pointed out to me on numerous occasions, but I haven't published my corrections. I'll get that sorted ASAP, along with providing a more informative error on a timeout.

    As far as encryption goes, I do completely agree with you. The reason for the packets, or at least the authentication string being sent in plaintext is to provide legacy support for the few users that send raw packets with the iOS UDP tool referenced in the wiki. I was already building encryption in to R11, but I would be more than happy to add it to R10. The authentication portion of the packet will simply be sent hashed with an optional salt. It's not perfect, but it should be adequate. I'll let you know when it's ready.

    I assume you are using a script to have the toolkit run on startup. Can you check that .restarttime actually gives a correct value after a system restart? I suspect that your working directory may not be correct when launching the wrapper on startup.
  17. Offline


    I'd suggest at least returning RTK_INVALID_CMD or similar in the typo scenario instead of just not responding and letting it time out.
    Also, glad to hear you plan to implement some form of encryption.
    With that said, I look forward to integrating RTK into Minecraft Mobile Admin.
  18. Offline


    As far as I know there is no script, I've always thought that this is a intended feature of RTK. What happens is that the server software basically starts itself after a hardware restart. If it's not intended, can it be that RTK sees the restart as a crash somehow? Could this mess things up?

    I'm having a lot of things on my plate now so it's going to take some time for me to recreate these scenarios on my own private server. I'll give you guys an update as soon as I have one.
  19. Offline


    drdanick, Are you going to add any new features any time soon?
  20. Offline


    Minor update: Right now the AutoShutdown is inactivated, but I'm still doing the daily hardware restart. Instead of AutoShutdown I'm having a temporary solution by using a regular restart at that time. It's definitely not perfect, but the server restarts automatically without having any major rollbacks at least. (Since the restart forces a save, and we've also installed a WorldSaver plugin that saves a lot more frequent than earlier.)

    Right after the hardware restart I checked the values of .restarttime and the command gives correct values. The restarts has never caused any issues, it's the shutdown that doesn't function properly.
  21. Offline



    Thank you, I will look into this thoroughly.
  22. Offline


    I have a problem.
    With automatic restart the server a lot of players losing their inventory.
    The server is going nowhere dig up all the players, and now restarts.
    This is my setup:
    #Minecraft Remote Toolkit Properties File
    #Sat Mar 03 21:45:55 CET 2012
    Can anyone help me?
  23. Offline


    Please update!
    I don't know if this will keep happening because I just recently downloaded craftbukkit-1.2-R0.1.jar and it tried three times on the first startup to find the Bukkit RTK Plugin (which I have installed and this has always worked before) and then it said it couldn't find it and it disabled heartbeats until the next restart?
  24. Offline


    I have the same issue that the server just restarts (mostly after 5 min) and the players are loosing the inventory and the world isn't saved
  25. Offline


    Koksons xGhOsTkiLLeRx It sounds to me like another plugin is causing the server to crash. If the toolkit restarts the server itself, it will mention it ("Restarting..." is printed after the server has shut down, so that does not indicate that the toolkit has forced a restart).
    Can you pastebin your console output from when the toolkit starts up until the first time the toolkit checks for the plugin?
  26. Offline


    The server shuts down before throws all players. Previously, you could see how each player's individual dig (kick).
  27. Offline


    The toolkit is mentioning the "Restarting..."
    That's why I know it's the toolkit.

    Log and console output:
  28. Offline


    I'll double check that the plugin component is actually kicking users correctly. Even so, the save-all and stop commands that the toolkit issues should not cause players to lose their inventories. If that happens, Bukkit is at fault.

    Read my reply again. I said that the toolkit prints "Restarting..." after the server is shut down, not before. It only indicates that the server was stopped (for whatever reason) and is due to be restarted.
  29. Offline



    Sorry, I'm a bit tired, you are right. Does the toolkit or any of the toolkit files need a chmod +x?
    I'm running a linux server, so a not exactly configured access to a file could be the cause
  30. Offline


    You only need to give execute permission to the script, if you wanted to use that to start the toolkit. The issue you are having is more than likely to be that your server is crashing on its own.
  31. Offline



    Third attempt at checking for presence of bukkit RTK plugin
    RTK plugin for bukkit was not detected. Disabling heartbeat until next restart.
    Running R10, A12. CB 2037
Thread Status:
Not open for further replies.

Share This Page