Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    WTF i'm trying to restart the server and it's talking back at me saying things like "Make me!"
    I AM using the correct password
  3. Offline


    how can i start the toolkit.bat using 64bit java. i want to add more ram
  4. Offline


    How do I disable automatic restart? I tried setting it to blank and I tried setting it to 0h but it just reverts to 5h when I start RTK. Edit: I meant scheduled restarts in case I confused anyone, but I found the solution in an earlier post :) (server-restart-delay=0)
  5. Offline


    In that case, use this configuration for
    Then, change the execution command to (this is assuming craftbukkit-0.0.1-SNAPSHOT.jar and Minecraft_RKit.jar are in the same directory):
    -Xmx30M -Xms30M -XX:MaxPermSize=40M -jar C:\UserFiles\scarnick7400\GameServers\TC71136882042602124415865\minecraft\Minecraft_RKit.jar
    Do you happen to know what shell you're using? If it's bash, I can't see why it would have trouble interpreting that.
    Try putting user:pass in single quotes, for example:

    java -Xmx30M -Xms30M -XX:MaxPermSize=40M -jar Minecraft_RKit.jar 'USER123:PASS321'
    @Ruprect Can I see a copy of your configuration files?
    It sounds to me like the wrapper isn't swapping the output stream from the old server instance to the new server instance, and a lot of the time this seems to be due to the Java process library itself. That's not to say I can't fix this, but it's not exactly easy and will require some careful workarounds. I'm actively working on getting Release 11 functional, and I will be sure to send you an early release as soon as possible to see if we can get this sorted.
    As for the ramdisk, I have not tested the toolkit on a ramdisk, and so it is possible that it is not going to function correctly. I hope to have ramdisk support in release 11.

    What operating system are you using?
    It looks like the java Process library isn't recognizing that the child process has died, and thus isn't forcing a restart. I will definitely have some sort of workaround in place for Release 11.

    Do you have any way of configuring how your server is started with your host? You need to execute Minecraft_RKit.jar, rather than craftbukkit.jar.

    Possibly with Release 11.

    Can I see your configuration? Map saves are forced on a restart, so that shouldn't happen.

    Who is your provider? You will need to be able to change the command that is used to start the minecraft server if you want to use the toolkit.

    .unhold works on both my test servers, which are running Ubuntu. Try removing all the .jars from toolkit/modules/ and try again. (Note that this will stop milkadmin from running while the server is held)

    I'm looking into this. The algorithm that reads and writes to the server streams needs to be optimized. This should not heavily affect the performance of your server, though.

    What operating system are you using, and how are you launching the toolkit?
    "Standard input stream has closed externally and cannot be recovered!" means that the operating system has closed the input stream to the toolkit.

    Oh dear, that looks like an error on my part. What version of java are you using?
    Try putting a file (for example, an empty .txt file) into toolkit/modules/

    Is this the first time you have had problems with this? Has it worked in the past?

    Edit the .bat and replace "java" with the full path to whichever java.exe you want. Generally, Java is located in C:\Program Files\Java\<java version>\bin\java.exe (you may need to put the entire path in double quotes)
  6. Offline


    In wiki is a mistake.

    but if i write time to command serwer reply "Usage: /stopwrapper username:password
  7. Offline


    Ah, the mistake is in the plugin. The correct usage is in the wiki (i.e. the username is optional, the password is not).
  8. Offline


    How do i change my craftbucket to a .jar? what do i open?
  9. Offline


    Yes, it's been perfectly fine until yesterday. I have made no changes to the server at all. I just updated the plugin and all the configs and it still gives me the messages.
  10. Offline


    Can this plugin let me run an external batch file within the console somehow, or is that planned for future updates?

    I'm looking for a way to periodically backup my world directories and generate corresponding maps with PixelMap, the only way I can do this now is to do a /save-off, launch the batch file (manually) and /save-on again. Otherwise I have to stop the server I think?

  11. Offline


    It will still restart if I kill the servers own process in Webmin.

    And I am using CentOS 5

    Dedicated server, how about the bad file descriptor thing?
  12. Offline


    It is already a .jar. What are you trying to do?

    Does work?

    There will be functionality like this possible with release 11.

    In this context, the FileDescriptor refers to the toolkit process. Again, if it has closed like that, something external to the toolkit closed it. I will look into the possibility of recovering the stream, but this may not be possible.
  13. Offline


    It wont work when i run the .bat but my craftbukkit name is craftbukkit-0.0.1-SNAPSHOT
    it says unable to acsess jar file, and on ure wiki it says:
    If your craftbukkit .jar is not named craftbukkit.jar, then you will need to open (which is inside the toolkit folder) with your favorite text editor, and set minecraft-server-jar=to the name of your bukkit server jar file.
    So i did:
    But it doesnt work? when i run the .bat and i dont know what to do next.
  14. You need to append '.jar' to the name (thats what is working here):

  15. Offline


    What would close it? Need a list of my processes?
  16. Offline


    Sure thing - I'm currently not running on RAM Disk, it crashed and I lost 1½ days of world updates, simple save was configured wrongly, so I reverted to plain old harddisk world.

    But here is my config files:

    Show Spoiler
    #Minecraft Remote Toolkit Properties File
    #Fri Jul 29 16:41:54 CEST 2011
    messages.txt (Translated to danish)
    restart-kick-message:Serveren genstarter! Kom tilbage om 1 minut :)
    toolkit-shutdown-kick-message:Serveren lukker ned! Kom tilbage om 5-10 minutter :)
    hold-kick-message:Serveren lukker ned!
    restart-time-warning:**SERVER GENSTART OM %t**
    restart-warning:**SERVEREN GENSTARTER**
    toolkit-shutdown-time-warning:**SERVEREN LUKKER NED OM %t**
    toolkit-shutdown-warning:**SERVEREN LUKKER NED**
    hold-warning:**SERVEREN LUKKER NED**
    auto-save-start:**SERVEREN GEMMER KORTET**
    auto-save-complete:**FÆRDIG MED AT GEMME**
    restart-time-left:Tid til næste genstart: %t
    RemoteToolkit.bat (The file used to start the server):
    @echo off
    "%ProgramFiles%\Java\jre6\bin\java.exe" -Xmx30M -Xms30M -XX:MaxPermSize=40M -jar Minecraft_RKit.jar mysecretname:mysecretpassword

    Let me know if you need any other information.
  17. Offline


    Nope still didn't work. If it helps, for some reason players can break the spawn area now :/
  18. Offline


    I am using Debian 6 (64bit)

    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
  19. Offline


    Ok. Try connecting to the console via telnet. If it connects but you can't authenticate, then you probably need to set a new remote user up in the console.

    Since it's an issue with Java's process library, I reccomend trying out JRE 1.7, which may or may not offer a fix for this.
  20. Offline


    I had installed this plugin but I won't let to stop the server .. every time I stoped it, it restarted automaticly
    (maybe bad conf.?) stopped using this 5 days ago :(
  21. Offline



    i have a problem with my toolikt. i get following exception with the udp client: socket closed only worked once and since than doesnt work at all.
    putty doesnt work either.
    just now i had this exception in the :
    generic UDP Socket exception: socket closed
    the toolkit started the UDP listen Server again and after that i could use one command with the UDP client. and now it doesnt work again.

    my ports are forwarded and i didnt change any properties.

    hope u can help me
  22. Offline


    Where do i view my backups?
  23. Offline


    The console doesn't recognize .useradd and .userremove as console commands. Should I just send you all my files or you can tell me what the format of the users.txt is? Because I don't see my name in that file.
  24. Offline


    Also, when i run the toolkit, it says failed to bind to port? what do i do and which do i run it from?
  25. Offline


    Use .stopwrapper. This and all the other toolkit commands are documented in the wiki.

    I will look into this. What operating system are you using? Is anything printed in the console when you try to use the web panel at

    Does .help or .version work? It sounds to me like the toolkit wrapper isn't running, which would explain all of the problems you are experiencing.

    Can I see an exact copy of this error?
  26. Offline


    i am using windows 7 and i didnt get any massage using the web panel. i tried the server with the sam configuration at my brothers computer with win xp. your web panel and udp client worked just fine. but in putty and a linux terminal it just worked with the local ip address. and we didnt get anything printed in the console.

    greetings weeti
  27. Offline


    I apologize if this is a stupid mistake, but I finally(!) got around to updating from Toolkit V1.0_b18_3 ALPHA / Plugin V0.31b to R10 Alpha 10.32 / Plugin V0.45b, and I'm seeing the same error loop as a few others:
    This only happens when I start the server from a basic shell script that does some log file cleanup, then runs:
    ...but not if I start the server with the basic, or if I start it with nohup from the command line. Am I missing something obvious?
  28. Offline


    Ah, I think I see what's happened - You're forking the process to the background, which (I am guesing) leaves the process without any standard input stream. Exactly the same thing happened in all older versions, but it was only recently that I had it actually print an error. Does it still print the error if you remove the '&' ?

    I'll work on getting something out to you that will help debug this issue.
  29. Offline


    It doesn't show any errors, but without the &, the command still sits in the foreground, so I would need to manually break out and send it to the background.

    I tried redirecting /dev/null into standard input like so:
    ...but it still complains about the console connection closing.
  30. Offline


    Nope neither of them worked either.
  31. Offline


    Well... i deleted it so i make a new server but it was like
Thread Status:
Not open for further replies.

Share This Page