Read Timed Out

Discussion in 'Bukkit Help' started by Thug319, Apr 27, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    So I've been using Bukkit for quite a long time now on a server hosted by hostalititude running on CentOS on 4GB ram. Every few hours or so, I get:
    Read Timed Out
    Read Timed Out
    Read Timed Out

    Constantly spammed onto my console.

    It makes the server stop responding to stop commands and makes everyone lose their inventory because it hadn't saved.

    I currently use this script to start my sever :

    screen -dmS minecraft java -server -Xmx3500M -Xms3500M -jar craftbukkit.jar nogui
    screen -r

    Any Idea how to stop this error?

    Guys, My server has gone down 2 times in the last 2 hours... any help?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  2. Offline


    i have this problem too... no one can help us ((( in 1.3v all was fine
  3. Offline


    Actually I also have the same problem with 733.... only when I rage about all the snow covering the world and then I use worldedit to do the command //thaw 10000. Other than that, it's fine
  4. Offline


    is that thaw command a radius? that would probably crash a server, most amount of blocks Worldedit can usually handle on a good server is 20,000 total, radius would be much more than that :p

    @Thug319 - it went down again overnight, same error. Just trying to get it back up now..
    I think its something to do with Bukkit, probably the current recommended build. I guess we just gotta wait it out and get the next one when it comes...

    a temporary fix for those who haven't got it, just to get back online ASAP (it will roll back level.dat to last save, but that will happen whatever you do.)
    Open up PuTTY or whatever SSH client you have, and kill your current minecraft screen (screen -X -S #####.minecraft kill)
    Try your startup command now, if it workes your already sorted and good to go, if not you need to end the java process.
    type "ps x" to list all current processes, and find the one for java. then, type "kill -9" followed by the number of the java process and it should kill it. Now again try starting your server. Now, it should start.

    sorry if there is any nooby phrases in there, Thug and I both admin a server together but he does most of this stuff, I only know the things I need to know (such as this) :p
  5. Offline


    Can't do this... PuTTY says fatal error connection refused
  6. Offline


    I still get de error ;(
  7. Offline


    its only temporary, its how to start your server after you get the error. When the error comes up you lose your stop command, this is just a long way around of stopping it properly and then getting it back up again

    Do you run your own server or is it from a hosting company (one of the ones that set it up and then give it to you)
    if its the latter, you will need to talk to them about it because you might not have the right access for it, I know Thug had to talk our hosts into even giving us any SSH access..
  8. Offline


    ViZiT, can you normally connect to the server?

    If so ( This is what sometimes happens to us ), is we have to wait a while for the server to stop using up loads of resources and actually parse us logging in. Its a pain.
  9. Offline


    First! server on my own...But im use DunDNS here is my system: my ip(from provider)->**** host)->mygamemy****.ru(web site and server addres)

    im use DunDNS here is my system: my ip(from provider)->**** host)->mygamemy****.ru(web site and server addres) Is it my problem with read time out
    For game Yes i'm!(mygame****.ru:25565) SSH (mygame******.ru:22 (SSH Port))

    Thug do u have 1.4 build(buggs FREE) without plugins and world? Give it to me for TEst

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  10. Offline


    No I don't, sorry.
  11. Offline


    I'm using mcmyadmin ;-/
  12. Offline


    same issue here, seems to happen at least once a day on 733, never happened before 1.5, though my stop command still works after it happens, just nobody can join and everyone who was on has the server freeze up on them.
  13. Offline


    Could any gurus help?
  14. Offline


    any help?
  15. Offline

    Mot Wakorb

    I'm seeing these Read Errors as well. Relevant information:

    1. OS: CentOS 5.5
    2. 64-bit
    java version "1.6.0_24"
    Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
    Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02, mixed mode)
    4. Are you running any wrappers? NO.
    5. What build of CraftBukkit are you running? 733
    6. What command are you using to run your CraftBukkit server?

    java -Xmx1536M -Xms1536M -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalPacing -XX:parallelGCThreads=$CPU_COUNT -XX:+AggressiveOpts -jar craftbukkit.jar nogui

    7. What plugins are you running? NONE - issue continues after all plugins disabled.

    8. What error are you getting (post your server.log file if possible)?

    2011-04-28 17:06:29 [INFO] Dodongo45 [/] logged in with entity id 40
    2011-04-28 17:06:38 [SEVERE] Connection reset
    2011-04-28 17:06:38 [SEVERE] at Source)
    2011-04-28 17:06:38 [SEVERE] at Source)
    2011-04-28 17:06:38 [SEVERE] at Source)
    2011-04-28 17:06:38 [INFO] Connection reset
    2011-04-28 17:06:38 [SEVERE] at net.minecraft.server.Packet33RelEntityMoveLook.a(SourceFile:32)
    2011-04-28 17:06:38 [SEVERE] at net.minecraft.server.Packet.a(
    2011-04-28 17:06:38 [SEVERE] at net.minecraft.server.NetworkManager.e(
    2011-04-28 17:06:38 [SEVERE] at net.minecraft.server.NetworkManager.d(
    2011-04-28 17:06:38 [SEVERE] at
    2011-04-28 17:06:38 [INFO] Dodongo45 lost connection: disconnect.endOfStream

    2011-04-28 17:09:57 [INFO] Dodongo45 [/] logged in with entity id 1601
    2011-04-28 17:10:27 [INFO] Read timed out
    2011-04-28 17:10:27 [INFO] Dodongo45 lost connection: disconnect.endOfStream
    2011-04-28 17:10:47 [INFO] Dodongo45 [/] logged in with entity id 1988
    2011-04-28 17:11:16 [INFO] Read timed out
    2011-04-28 17:11:16 [INFO] Dodongo45 lost connection: disconnect.endOfStream

    9. What have you tried already?

    Standard Minecraft does NOT have this issue. Only seeing it in Bukkit. Bukkit restarts sometimes clear this issue.

    10. Have you tried any of the things below?

    Yes, as stated in #9, standard MC 1.5_02 doesn't have this problem, Bukkit w/o plugins does.
  16. make sure you have no client mods. also, check updating to the newest build.
  17. Offline


    Done both, although its definatly server side so client mods shouldn't affect it really..
  18. Offline


    Out of date client mods have been causing a lot of the problems here lately along with texture packs.
  19. Offline


    I'm having the same problem! It's with 733, and I actually know the cause, but no idea on how to fix it.

    Mine crashes when certain chunks are loaded. These chunks have the ground layer snow blocks suspended in midair, from when a moderator tried to use worldedit to fix patchy snow by replacing air blocks with the groundcover snow blocks. In previous versions, it would only spawn those snow blocks on the ground, ignoring the rest, but now they're in the air, and the physics bit crashes, rendering my console a mess of spam, and after that, "Read Timed Out" errors.


    EDIT: This happens no matter who loads the chunks, and I've crashed it by going to those chunks myself. No client mod, no texture pack, nothing.
  20. google chunckster
  21. Offline


    Chunkster Use

    1. download the zip file: Chunkster
    2. unzip it
    3. copy Chunkster.jar (in dist) to the same folder that your craftbukkit.jar file is in
    4. from a command prompt (in the folder you just copied chunkster to) enter "java -jar Chunkster.jar <world directory>"
    ex: java -jar Chunkster.jar iceworld​

  22. Offline


    Can someone see if thatll work?
  23. Offline


    Chunkster doesn't fix the snow, that was the first thing I tried. It'll fix corrupted chunks and the like, but these aren't corrupted, so it has no effect.
  24. Offline


    mcedit can probably fix this
    unfortunately, i don't know how to use it
  25. if you need help with McEdit, look here :D
    anyway, i could see mcedit being VERY tedious if the snow is not all in one spot..
  26. Offline


    Worldedit, then /thaw 100. Move, repeat.
    (I think powertool is part of worldedit too. if so, just get an item like coal or something and type /powertool thaw 100 and you can just click with the coal isntead of typing. simples!)

    Guys, done more research, no doubt it is BUKKIT and not a plugin. People have tried creating entire new servers, its fine until bukkit comes on...
  27. Offline


    Update: I fixed this a while ago, or someone on server did. I went there to thaw it out rapid-fire before it crashed, and the whole area had been filled with lava, which worked too. :p If you're having this problem, just eliminate the snow by whatever means necessary. Also, be ready for the server to crash a few times in the process, because it'll happen.
  28. Offline


    Bump. Still getting this for over 2 Months.
Thread Status:
Not open for further replies.

Share This Page