Read Timed Out - Ubuntu 11.04 + OpenVZ

Discussion in 'Bukkit Help' started by mjhasbach, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    1. What OS are you using (Brand and version - Ex. Windows XP SP3)?
    2. What architecture is the OS you are running (x64 or x86)?
    3. What version and architecture is your java install? (Type: java -version in command prompt.)
    4. Are you running any wrappers? McMyAdmin, mcadmin, Hamachi, etc?
    5. What build of CraftBukkit are you running?
    6. What command are you using to run your CraftBukkit server?
    7. What plugins are you running?
    8. What error are you getting (post your server.log file if possible)?

    After the server has finished starting, I attempt to connect to the server. IF I am able to connect, I am able to walk around briefly until I am disconnected due to "Read timed out." In certain situations, I am not able to connect at all, and "Read timed out" appears in the terminal. After both scenarios, there is no terminal output and no one can connect again until the server is rebooted.

    Terminal output when starting the server via "java -Xms32M -Xmx2500M -jar craftbukkit.jar"
    146 recipes
    16 achievements
    23:22:08 [INFO] Starting minecraft server version Beta 1.5_02
    23:22:08 [INFO] Loading properties
    23:22:09 [INFO] Starting Minecraft server on *:25565
    23:22:10 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-729-g5ee3f0f-b766jnks (MC: 1.5_02)
    23:22:11 [INFO] Preparing level "world"
    23:22:12 [INFO] Preparing start region
    23:22:13 [INFO] Preparing spawn area: 12%
    23:22:15 [INFO] Preparing spawn area: 28%
    23:22:16 [INFO] Preparing spawn area: 44%
    23:22:17 [INFO] Preparing spawn area: 77%
    23:22:19 [INFO] Preparing spawn area: 81%
    23:22:22 [INFO] Preparing spawn area: 81%
    23:22:23 [INFO] Done (1.185s)! For help, type "help" or "?"
    ***I tried to connect around here, unsuccessfully***
    23:23:07 [INFO] Read timed out
    Terminal output when starting the server via "java -Xms32M -Xmx2500M -jar minecraft_server.jar nogui"
    146 recipes
    16 achievements
    2011-05-24 23:34:10 [INFO] Starting minecraft server version Beta 1.5_02
    2011-05-24 23:34:10 [INFO] Loading properties
    2011-05-24 23:34:10 [INFO] Starting Minecraft server on *:25565
    2011-05-24 23:34:11 [INFO] Preparing level "world"
    2011-05-24 23:34:11 [INFO] Preparing start region
    2011-05-24 23:34:12 [INFO] Preparing spawn area: 20%
    2011-05-24 23:34:13 [INFO] Preparing spawn area: 28%
    2011-05-24 23:34:14 [INFO] Preparing spawn area: 32%
    2011-05-24 23:34:16 [INFO] Preparing spawn area: 40%
    2011-05-24 23:34:17 [INFO] Preparing spawn area: 85%
    2011-05-24 23:34:17 [INFO] Done (6487751855ns)! For help, type "help" or "?"
    2011-05-24 23:34:50 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-05-24 23:34:53 [INFO] mjhasbach [/<omitted>:49454] logged in with entity id 164 at (926.5, 76.62000000476837, -262.5)
    2011-05-24 23:35:00 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-05-24 23:35:02 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    ***I was booted due to Read timed out around here***
    2011-05-24 23:35:14 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-05-24 23:35:41 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    9. What have you tried already?

    Other Relevant Server specs:
    OpenVZ VPS @ VolumeDrive
    2 Dedicated Cores from Xeon X3450 @ 2.67GHz
    4096MB Guaranteed Ram. Although via cat /proc/meminfo "MemTotal: 8146648 kB"

    Ok, so here's the deal. I'm in the process of transferring all of my services from a XenServer with 1024MB of RAM to this current server (see above). When I was first configuring this server, I had CentOS 5.6 installed. I transfered all needed Minecraft files via scp and briefly tested the server...all was working well. Due to serious issues with configuring ISPConfig in CentOS 5.6, I decided to scrap the whole installation and install Ubuntu 10.10 (my server OS of choice, anyway). This process was automated and painless via "vePortal," which VolumeDrive provides. I immediately upgraded to Ubuntu 11.04.

    Configuration of ISPConfig on Ubuntu went smoothly. I then made sure I had the latest mono and java packages from the repositories. I then transferred all of the Minecraft files from the old server via scp. Since then, I have been trying a variety of configuration scenarios, yet the problem persists. The server is completely unusable, as this "Read timed out" error is murdering the MC server soon after it prepares the spawn area.

    I know that OpenVZ isn't exactly the ideal environment for Minecraft, but the fact that the server was running smoothly with CentOS+OpenVZ (pre Ubuntu+OpenVZ) seems to eliminate OpenVZ as the problem.

    The problem must lie with my Ubuntu configuration or with the configuration of the services associated with ISPConfig. I tried disabling my iptables to no avail.

    Being that this issue still occurs while running vanilla MC, it is outside the scope of Bukkit help; however, I'm sure there are seasoned Linux admins on this forum, so I decided to ask here.

    Suggestions are greatly appreciated.
  2. Offline


    I have an Ubuntu 10.10 VPS from VolumeDrive as well. AND I get the error as well. I really don't know what it is that would make it do this. I would consider my self a pretty knowledgable Linux Admin, but it may be a problem with Ubuntu on VolumeDrive's VPS's. It would be quite funny if we were on the same server node... :p. I would also like to know why this is... I think it is a general problem with MC 1.5 as I never got it before. But I could be wrong.
  3. Offline


    Ha! Wow. If you ever get the inkling to wipe your install and replace it with another Linux OS (and test MC on it afterwards), share your results here please ;).

    I may end up going back to CentOS and diagnosing the ISPConfig issues/switch server control panels if CentOS would fix the Minecraft issue.

    Have you attempted contacting VolumeDrive about your server performance with Minecraft? If so, what were the results?

    Someone in #MineCraftHelp over at is trying to help me diagnose the issue right now. At one point in performing a HDD I/O test, the HDD wrote 1GB of data at like 3.4MB/s...that's pretty horrible. He suspects that when I signed up, I was placed on a new node, and now it's starting to fill up (that would explain why the MC server worked on CentOS). I hope that's not the case, though...

    The Minecraft 1.6 update apparently addresses some I/O issues, so we'll see if that helps.

    Alternate suggestions still appreciated :D
  4. Offline


    Hmm... strange enough I get a less severe version of this on Win 7. I have been searching for the cause without success :'(

    With mine I can run the server for hours without this happening and other times it doesn't happen at all.
  5. Offline


    On my old VPS, with only 1024MB RAM, I would get "Read Timed Out" when the system memory maxed out and had to swap (either from the Minecraft server leaking or from starting the MCServer with too much RAM).

    Have you watched your memory usage Walker?

    Also, if your server is running on your Desktop PC that you use for everyday stuff, HDD I/O rape can cause "Read Timed Out" (e.g. unraring a bunch of stuff at the same time).

    I'm sure you know all of this...plugin devs are usually intelligent :p

    I think I'm going to contact VolumeDrive support and experiment with putting the MC server on a ramdisk...
  6. Offline


    I' going to try and switch to Debian for my VPS and see what that does. When I tested the drive I/O, I got 24.4 MB/s. I'm on the 2GB Ram plan from VolumeDrive and I only allocate 1.5 GB's to MC. We'll have to see if this is an issue with Ubuntu and/or MC 1.5. Hopefully it is one of those and not VolumeDrive itself. I would rather not pay a lot for a VPS.

    Oh, and please share your results of contacting VolumeDrive and putting MC on a Ramdisk. I would hope to get this resolved before I put my new amazing server public.
  7. Offline


    Debian huh? That will be interesting, considering Ubuntu is based on Debian. I wonder if that will lead to any performance increase.

    Also, what method(s) are you using to test your HDD I/O? For some reason hdparm doesn't seem to get along well with my current configuration. It always outputs "XXXXX failed: Inappropriate ioctl for device" (XXXXX = what it is testing, e.g. BLKFLSBUF).

    I'm in the same boat. I don't want to pay a lot for hosting. Most VPS prices (especially reputable Xen providers) are real expensive. The prices of dedicated "Minecraft Hosts" are usually pretty high as well.

    I haven't contacted VD yet, because I'm trying to collect enough data to quantify my argument. I'm setting up the ramdisk as we speak.

    Tylerjd, by default, on the OpenVZ templates that VolumeDrive provides, it appears that /dev/shm/ is not enabled in fstab (confirmed on Ubuntu and CentOS). To enable the ramdisk:

    vi /etc/fstab

    Then add this line:
    Then reboot the VPS.

    An easy way to test if it's configured correctly is to make a new file inside /dev/shm/ and reboot the VPS again. If the file is gone after reboot, it's configured correctly.

    I then followed the instructions here to configure Minecraft on a ramdisk.

    There was no performance improvement ("read time out" after the spawn area is prepared). This indicates to me that the ramdisk is swapping. I'm going to contact VolumeDrive now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  8. Offline


    Thanks for the instructions, mjhasbach.

    The way I tested my HDD I/O was running the commands

    dd if=/dev/zero of=/tmp/output.img bs=8k count=256k
    rm /tmp/output.img

    Which gave me the 24.4 MB/s reading
    Apparently, does relatively cheap XEN or VMWare ESXi (Like Xen) hosting using their Virtual Dedicated Servers. They don't have as much RAM, but it is using XEN/ESXi.

    They are resellers of VolumeDrive's VPS's.

    As of the time of this posting (10:20 EDT) I can't ven access my server through its control panel or SSH. It is like it disappeared off the interwebz. I first got a Read Timed Out in MC, then everything started getting VERY SLOW. I tired halting the VPS (running "halt" in SSH) and it still hasn't signaled that it has shut down. I don't know what is happening to it, but I may just write to them as well.I hope everything gets sorted out as well...

    And yes, Debian, as Ubuntu and Debian are what I am most comfortable with...

    I could learn CentOS or the like, but I would rather not.
  9. Offline


    Tylerjd, thanks for the info. A few hours ago, I ended up using dd to generate a 1GB file and copying it with rsync to produce a disk I/O benchmark. Here's an excerpt from an email to VolumeDrive, if you're interested:

    "Josh" is the person who responded to my emails, and so far he has been helpful. The response time was good. He is apparently currently in the process of moving me to a new node. --Completed while typing this. Yikes, he didn't move the data over; there goes a few hours. He moved next billing date to today though, which was cool-- Although, I'm not sure what exactly that is going to accomplish. If it's a relatively empty node, I should expect good performance only for a few days until it begins to fill up, unless they plan on forcefully allocating the proper (what I paid for) amount of resources to me...

    We'll see how it goes.

    Also, I strongly recommend against buying services from IPAP. They were my previous host before VolumeDrive. As a matter of fact, my server is still running on their VDS until this VolumeDriver server situation gets straitened out :oops:.

    I'll spare you most of the details, but this is from my server thread on the Minecraft Forums:

    I'm currently have 2 PayPal claims with them. The first, trying to get the upgrade fee back, because they *still* haven't delivered the upgrade. The second, trying to get a prorated refund back on my monthly bill, because I requested IMMEDIATE cancellation of my services. My services still haven't been deactivated...

    There were a few other issues, like being allocated 524MB of RAM when I first signed up, instead of the 1024MB that I paid for. Also, for whatever reason, fsck runs every time the server is it takes like 15-20 minutes to reboot. I didn't care enough to learn how to disable that, but it's still a pain in the ass when I have to reboot.
  10. Offline


    Thanks, and sorry for the Code FAIL that had happened on my last post :oops:.

    TIME TO BACKUP MY WORLD SAVES! The ones my friends and I have taken a few days to do...

    I'm going to switch over to using Debian and see what that does to the Read Timed Out Error, and upgrade to the 4GB plan next month so I can do a RAM disk.

    And Thanks for the info on IPAP, I'm glad I didn't go with them to start.

    I knew these services were too good to be true for what we want at the price we have them at... :mad:
  11. Offline


    For Tylerjd and any others interested...I just wanted to let you know that after they moved me to the new node, the Disk I/O does seem better. Like I said above, when they moved me, all the data was wiped (not a huge deal) and I was given a fresh installation of CentOS. Like last time I was on CentOS @VolumeDrive, Minecraft worked fine (it doesn't time out after preparing the spawn area).

    However, because of the ISPConfig problems in CentOS 5.6, I installed Ubuntu 11.04 again. To my surprise, I still get the "Read Timed Out" error. This makes me believe that the problem isn't necessarily associated with VolumeDrive's resource allocation, but rather with the way VolumeDrive's Ubuntu template is configured by default. Note that I said "VolumeDrive's Ubuntu template" rather than just Ubuntu. I know that Minecraft servers run just fine on Ubuntu, because that's what my home server is running.

    I've scrapped the Ubuntu installation and installed Debain (my fifth OS install since my service was activated less than a week ago :confused:). I'm currently in the process of upgrading Debian and testing Minecraft...I'll share the results when I'm finished.

    Update: Debian also produces the "Read Time Out" error after preparing the spawn area.

    Next OS install will be openSUSE, and if that fails, I will try Fedora...

    Edit: VolumeDrive only has an openSUSE x86 I'll try Fedora next. I imagine the results will be similar to CentOS, since they're both based on Red Hat.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  12. Offline


    I had this on my server and after a few days of doing trial and error, I believe I have a fix. Add me on msn - [email protected] or send me a message on these forums
  13. Offline


    I've added you on MSN, however, it may be best if you share your proposed fix with the community. If you prefer PM or MSN, that's fine. I'll just share my results on here after we've talked :rolleyes:
  14. Offline


    can you just post it here? clearly more than one person is having this issue
  15. Offline


    Please to share the results. I will learn CentOS/Fedora if I need to, but I would like to stay on a Debian based distro.

    If you do have a fix, I will make sure this ( [cake] ) isn't a lie. :)
  16. Offline


    Sorry, everyone, for the lack of correspondence lately. Here's a quick update:

    Josh @ VolumeDrive, as per my request, uploaded a x64 template for Fedora 14. Both Minecraft and ISPConfig were working on Fedora...I though I had found the perfect solution. However, a networking issue (with the template, Josh claims) developed and I was forced to switch back to CentOS.

    As I cannot get ISPConfig working on CentOS 5.6, I ending up switching to Webmin/Virtualmin (a fine replacement, as I've come to discover). The Minecraft server is working fine on CentOS.

    Lets do a quick recap of my OS installations since I've been with VolumeDrive:

    -CentOS 5.6: Minecraft works; Couldn't get ISPConfig to work
    -Ubuntu 11.04: Minecraft doesn't work; ISPConfig works
    -CentOS 5.6: Minecraft works; Couldn't get ISPConfig to work
    -Ubuntu 11.04: Minecraft doesn't Work; ISPConfig works
    -Debain 6: Minecraft doesn't work; ISPConfig works
    -Fedora 14: Minecraft work; ISPConfig works; critical template issues
    -CentOS 5.6: Minecraft works; Webmin and Virtualmin work

    To summarize, if you are using VolumeDrive as your hosting provider for Minecraft, I would recommend using only the CentOS 5.4 template (and then upgrade to CentOS 5.6). All the other templates that I have tried (with the exception of Fedora 14) have problems running the Minecraft server. The general vibe that I got from Josh (I'm putting words in his mouth) was that CentOS is the only distro that VolumeDrive officially supports.

    Hope this helps.
Thread Status:
Not open for further replies.

Share This Page