Plugins that have "Add __ to the plugins= line in" aren't working

Discussion in 'Bukkit Help' started by xephaeon, Mar 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I've recently started hosting my own server and have been adding plugins to it that look awesome. So far I have 5 working just fine and 3 that I believe are having a related issue.

    The three plugins that aren't working are MoveCraft, PushBlocks, and UpdatrFront. All three have installation instructions such as "Add __ to the plugins= line in" All three have the same error, see the attachment, and adding the plugins= line to the doesn't seem to make a difference.

    I am using Windows 7 and running (x86)

    java version "1.6.0_24"
    Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
    Java HotSpot(TM) Client VM (build 19.1-b02, mixed mode, sharing)

    Are you running any wrappers? None.
    This server is running Craftbukkit version git-Bukkit-0.0.0-544-g6c6c30a-b556jnks (MC: 1.3)

    6. What command are you using to run your CraftBukkit server?
    - I'm going to assume this is the RUN.bat file, in which case the code is as follows:
    SET BINDIR=%~dp0
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar "%BINDIR%\craftbukkit-0.0.1-snapshot.jar"

    Working plugins:

    Non-working plugins:

    9. What have you tried already? I've googled around for information relating to what I believe to be the problem and haven't really found anything.

    10. Have you tried any of the things below?
    If I just run CraftBukkit the server loads fine. If I run it with the first 5 plugins it works fine. If I add any of the last 3 the server still loads but those three plugins do not.

    This could be an issue of the plugins being outdated but I suspect it is a simple issue that is related to the required modification of the server properties and my not doing something right. If the former then I simply need to wait for the three to update, if the later then I hope this is easily resolved.

    Thanks for the read/help guys :D

    Attached Files:

  2. Offline


    Make sure you're using the Bukkit version of the plugin (not hMod). hMod plugins do not work with Bukkit. Try redownloading the jar (it could have been a bad download).
  3. Offline


    Are you trying to run hMod plugins on Bukkit?

    Which version of MoveCraft are you running? This one?
  4. Offline


    I can rule out the "plugins=" line in - that's a relic from hMod and not actually used in Bukkit, so adding that line won't do much.

    My guess is that is the core problem for all the plugins shown there - are you using the ones meant for hMod, or the ones meant for Bukkit, as they're built differently? The very tail end of each of the 3 plugin fails has this:

    Caused by: Jar does not contain plugin.yml
    If possible recheck the jar files and see if there's an updated one that's meant for Bukkit - in the case of Movecraft for instance, use the Dropbox link under Download - that one has a plugin.yml like bukkit wants. If you follow the link at the top of the movecraft topic, you end up on the Hey0/hMod forums which does have a download, but that's the one for hMod instead.

    Granted, making sure it's the Bukkit plugin might not fix it, but it -should- produce a different error if it doesn't fix it outright :)

    Edit: Oh wow like 3 replies at once, gotta love active communities :)
  5. Offline


    Nin-ja'd bitches. :p
  6. Offline


    Aww... You win... Shouldn't have gone off looking for the MoveCraft thread, left me distracted...
  7. Offline


    Feel the wrath of chrome. Select plugin name, google. All 3 showed up with first hit being for it's respective hMod page.

    *Strokes beard* Hmmmmmm...
  8. Offline


    I downloaded that second link for MoveCraft and it loads fine now, but I can't find any other links for the other two. I guess they were never updated from hMod to Bukkit. I found PushBlocks via the MoveCraft thread and Updatr from that and neither are on the Bukkit list now that I've gone and checked. MoveCraft was the one I really wanted of the three, Updatr was just gonna be a convenience and PushBlocks I'll just have to live without until someone makes a bukkit version.

    Thanks again for the help ^^
  9. Offline


    Plugin= isnt needed in bukkit btw.
Thread Status:
Not open for further replies.

Share This Page