Plugin not loading

Discussion in 'Plugin Help/Development/Requests' started by __Sour, Apr 26, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, I've made a plugin. And install it , but it won't load. There is no error in console, and the plugin is in the plugins folder, but won't load. I also tried to install another plugin, and that one worked, any reason why mine won't? If you need anything just ask :)
  2. Offline


    Can you post the code from your main class @__Sour
  3. Offline


    Also look carefully for errors! Errors arre some times handled and so only their message gets to the console that is lost between all the enable lines :3
  4. Offline


    Did you compile your plugin using the same version of Java as your server?
    Have you checked latest.log and searched for any errors?
  5. Offline


    Make sure you have onEnable() and compiled java version is lower/same as your server java version. If you compile plugin to 1.7 java and the server is 1.8 java, it will work, but if the plugin is compiled with java 1.8 and the server uses java 1.7, it will not work.
  6. Offline

    timtower Administrator Administrator Moderator

  7. Nvm, didn't read correctly, show us your code indeed
  8. Offline


    @megamichiel @timtower @robertforyou @Creeper674 @mine-care @ChromeHD__ here is the main class's code
    package srmc.core;
    import org.bukkit.Bukkit;
    import srmc.core.commands.user.Money;
    import srmc.core.commands.user.Pay;
    import srmc.core.economy.Economy;
    import srmc.core.listeners.PlayerListener;
    import srmc.core.listeners.SignListener;
    import srmc.core.user.Userdata;
    public class SRMC extends JavaPlugin {
        public void onEnable() {
        public void list() {
            Bukkit.getServer().getPluginManager().registerEvents(new PlayerListener(this), this);
            Bukkit.getServer().getPluginManager().registerEvents(new SignListener(), this);
        public void command() {
            getCommand("money").setExecutor(new Money(this));
            getCommand("pay").setExecutor(new Pay(this));
        public Userdata data;
        public Economy economy;
        public Chat chat;
        public void setup() {
            data = new Userdata(this);
            economy = new Economy(this);
            chat = new Chat(this);
        public Userdata getUserdata() {
            return data;
        public Economy getEconomy() {
            return economy;
        public Chat getChat() {
            return chat;
    EDIT: I checked the latest log, and saw that my spigot jar is more of a recent update, and It didn't say that in console, I'll downgrade it and let you guys no if it works.
    Last edited: Apr 27, 2015
  9. Offline



    Do you have a plugin.yml being exported with the plugin?
  10. Offline


    @mythbusterma yes I do, this is the error in console.
    [23:33:27] [Server thread/ERROR]: Could not load 'plugins\SRMC.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: srmc/core/SRMC : Unsupported major.minor version 52.0
        at ~[spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin( ~[spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins( [spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins( [spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at net.minecraft.server.v1_8_R1.DedicatedServer.init( [spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at [spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at Source) [?:1.7.0_75]
    Caused by: java.lang.UnsupportedClassVersionError: srmc/core/SRMC : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_75]
        at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_75]
        at Source) ~[?:1.7.0_75]
        at Source) ~[?:1.7.0_75]
        at$100(Unknown Source) ~[?:1.7.0_75]
        at$ Source) ~[?:1.7.0_75]
        at$ Source) ~[?:1.7.0_75]
        at Method) ~[?:1.7.0_75]
        at Source) ~[?:1.7.0_75]
        at ~[spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at ~[spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_75]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_75]
        at java.lang.Class.forName0(Native Method) ~[?:1.7.0_75]
        at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_75]
        at<init>( ~[spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        at ~[spigot-1.8-R0.2.jar:git-Spigot-29dbaa7-262c777]
        ... 6 more
  11. Offline


  12. Offline


    @mythbusterma Okay, so i deleted and recompiled with with java 7, and I still get the same error, any suggestions?
  13. Offline


    @__Sour You didn't compile with Java 7 then.
  14. Offline


    I would suggest compiling with java 6 because the majority of servers use 6 or greater. Also, if you are using maven you have to edit the pom.xml for proper version compilation.
  15. Offline


    Moved to Alternatives Section.
Thread Status:
Not open for further replies.

Share This Page