Plugin Errors With Mac G5 Series

Discussion in 'Bukkit Help' started by Darkvoltage3, Apr 7, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I've made a server recently and the server works just fine Craftbukkit is out to date and all plugins are to everything is at 1.2.5+ except permissions but Permissions surprisingly is the only plugin that seems to work and its still on 1.1 R6s so I get this:

    [1.2.5 Plugin sample]

    16:05:59 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R1.0-b2149jnks (MC: 1.2.5) (Implementing API version 1.2.5-R1.0)
    16:05:59 [SEVERE] Could not load 'plugins/SimpleGold.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(
    at Method)
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClassInternal(
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(
    ... 8 more
    [Permissions 1.1 R6]
    16:10:50 [INFO] [PermissionsBukkit] Enabling PermissionsBukkit v1.6
    16:10:50 [INFO] [PermissionsBukkit] Enabled successfully, 0 players registered
    16:10:50 [INFO] Server permissions file permissions.yml is empty, ignoring it
    16:10:50 [INFO] Done (2.715s)! For help, type "help" or "?"
    HELP PLEASE! :eek:
  2. Offline


    Its because you run Java 6 and the plugin only works for Java 7. So you need to contact the plugin developer about it.
  3. Offline


    Can u explain that a little more clearer what that is "JRE6" and ive tried 20 different plugins could it be my java version? or something went wrong with my mac permissions?
  4. Offline


    JRE 6/JRE7 are just different types of Java, 7 is an update of 6, and like most updates, things are always changed. In this case of the plugin, it was compiled(made) in a different version of Java that it is trying to be run in, so it doesn't work properly.

    It is your Java, or the Devs Java (the way he made it)
  5. Offline


    could I by chance change the java version I have from 6 to 7?
  6. Offline


  7. Offline


    Thank You but which one should I go with cause im running Java J2SE 5.0 32-bit version 1.5.0_30b03?
  8. Offline


    Can i ask why you are running a J2SE version, and not a SE?

    Also, i was under the impression you were running Java6, not Java5... Try downloading Java 6 then from here, and select your OS and the bit your OS is(32/64)
  9. Offline


    I have Mac G5 32 Bit I dont see mac anywhere on here unless this is compatible with linux? btw thank you again :) if we ever solve this problem I will make a video on the issue to correct others.
  10. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

    You just need to update to java 6. Nearly all plugins are compatible with java 6. :)
  11. Offline


    yes I know that but I dont see it for mac 10.5.8 g5?
  12. Offline


  13. Offline


    I used to have this problem, Dark. I actually don't think that Java is updated for older Mac OSes since it is updated via Apple Software Update.

    I know that when I was running 10.5, I couldn't use the latest version of Java. Once I updated to 10.6 (I'm now on 10.7) my Java updated and my server plugins worked again.

    However, since the G5 is a PPC machine, it won't update to 10.6 or further. Since you said that you're running 10.5, and I don't believe that Java can be updated for 10.5 easily now, the next step is up to you.
  14. Offline


    Says It wont appear up for 32 bit users...

    Well theres got to be some kind of other java platform that these plugins are compatible with or custom java fireware or somthing?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  15. Offline


    The real question is why are you running a server on an ancient machine?
  16. Offline


    its the only one ive got with 10 GB ram besides my pc with has 3GB and its my brothers...
Thread Status:
Not open for further replies.

Share This Page