Players unable to connect to server stuck at 'downloading terrain'

Discussion in 'Bukkit Help' started by ghost15, Nov 22, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    My server's hard drive crashed and I replaced it, so I have a fresh install and since 1.0 is coming up at 'some point' I tried to setup the unrecommended build (keep reading!), however when my friend tries to connect now, they get stuck at "downloading terrain" and then eventually "connection Lost, timed out".

    Figuring it was bukkit not being a RB, I swapped out the .jar to vanilla minecraft server for 1.0. My friend is still having the same exact issue as well. I'm able to connect over LAN but not over the internet either. I checked the port with (canyouseeme) as well as disabling the firewall completely temporarily. In both cases nothing changed from the player or server log perspective.

    I've tried re-generating the world with the vanilla install, as well as deleting the player files, but nothing has seemed to work so far. This is a fresh map (twice now) so it shouldn't be any kind of protection issue etc.
    I've also tried using Java 7 x64 and Java 6 x86 (I used direct path to Java to make sure I launched the different flavors)

    Bat command:
    "C:\Program Files\Java\jre7\bin\java.exe" -Xmx2048M -Xms2048M -jar minecraft_server.jar nogui
    Server Log:
    2011-11-22 10:38:37 [INFO] Starting minecraft server version 1.0.0
    2011-11-22 10:38:37 [INFO] Loading properties
    2011-11-22 10:38:37 [INFO] Starting Minecraft server on *:25565
    2011-11-22 10:38:37 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-11-22 10:38:37 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-11-22 10:38:37 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-11-22 10:38:37 [INFO] Preparing level "Talie"
    2011-11-22 10:38:37 [INFO] Default game type: 0
    2011-11-22 10:38:37 [INFO] Preparing start region for level 0
    2011-11-22 10:38:38 [INFO] Preparing spawn area: 8%
    2011-11-22 10:38:39 [INFO] Preparing spawn area: 20%
    2011-11-22 10:38:40 [INFO] Preparing spawn area: 36%
    2011-11-22 10:38:41 [INFO] Preparing spawn area: 52%
    2011-11-22 10:38:42 [INFO] Preparing spawn area: 69%
    2011-11-22 10:38:43 [INFO] Preparing spawn area: 85%
    2011-11-22 10:38:44 [INFO] Done (7133341906ns)! For help, type "help" or "?"
    2011-11-22 10:39:03 [INFO] Test123 [/*********:2576] logged in with entity id 8605 at (12.5, 72.62000000476837, 91.5)
    2011-11-22 10:39:50 [INFO] Test123 lost connection: disconnect.endOfStream
    2011-11-22 10:41:35 [INFO] Test123 [/*********:2582] logged in with entity id 9541 at (12.5, 72.59375, 91.5)
    2011-11-22 10:41:48 [INFO] Test123 lost connection: disconnect.genericReason
    Any ideas, suggestions, etc would be welcome. I'd like to get whatever this is fixed by the time the RB for 1.0 is out.
  2. Offline


    You said that is was possible to connect within your LAN? It looks like either their connection or your connection is faulty in some way or another. Is it just your friend that cannot connect to the server or is it everyone that tries to connect outside your LAN?
  3. Offline


    Thanks for the reply, Yes, I can connect on the LAN ok, but when I tried from work it failed for me as well (same issue). I've only had the one other person try because we are just getting it ready for the eventual 1.0 release of bukkit.
    the server is at: if anyone else wants to see if they can connect
  4. Offline


    Yeah, same problem... Plz help soeone!
  5. Offline


    I recently started using bukkit and also got stuck at downloading terrain. I removed all my plugins and now it works :eek: I still cant run the trade addon i want, if i add a plugin it gets stuck again
  6. Offline


    Have you made your IP 'static' instead of 'dynamic'? If not, PM me and I will set it up for you :)
  7. Offline


    i had the same problem and i solved it. maybe it works for you, i removed the pip plugin and i could join that plugin was the error for me.
Thread Status:
Not open for further replies.

Share This Page