Solved PEX Integration

Discussion in 'Plugin Development' started by Rufus5, Jul 7, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Ok. So I'm developing a small plugin for my server and I've made all my permissions. When I run the commands, they all pass because I have put myself in a group with all perms. I still get the message saying I don't have the perms. Can I import PEX and check groups? If so, how?

                    player.sendMessage(ChatColor.RED + "You don't have permission!");
    That's one command. It teleports me to the spawn, but I still get the perms message.
  2. Offline


    1. are you really in the group in de pex config files
    2. does that group really have all permissions? (you can see that in the pex config, it has to have a * by permissions)
    3. is the pex plugin loaded and working? (check with /pl ingame)
    4. try giving only yourself all permissions, in stead of only the group
    5. give that group or yourself as a player only the permission chraft.basic
    Rufus5 likes this.
Thread Status:
Not open for further replies.

Share This Page