Plugin Help PEX+EssentialsXChat+EssentialsX

Discussion in 'Plugin Help/Development/Requests' started by LimitedM0dz, Oct 13, 2018.

Thread Status:
Not open for further replies.
  1. Offline



    so I configured my own (lokal) server and got it to work, only the prefix isn't showing up right.

    My Pex permissions .yml
    Code (open)

          default: true
          prefix: New
        permissions: []
          prefix: '&6[&aMember&6]&6'
        - essentials.msg
        - essentials.mail
        - essentials.mail.send
        - essentials.list
        - essentials.motd
        - essentials.suicide
        - essentials.tpa
        - essentials.tpacancel
        - essentials.tpaccept
        - essentials.tpahere
        - essentials.tpdeny
        - essentials.warp
        - essentials.warp.list
        - essentials.spawn
        - timber.use
    schema-version: 1
          name: LimitedModz
        - Member

    As you can see, the first group is "default" and the prefix is set as "New"

    ingame it shows

    [default]<MyName>: Message

    I already tried to change the group name from "default" to "New". That didn't worked.

    I have no clue how to get this to work properly

    Ok so i got this problem fixed by adding "Vault" to my plugins, but i have now two prefixes.

    As example:

    [Member] [Member] <MyName>: Message

    The first "Member" is i would guess from Vault and the second is from pex because it has the colors i set

    Is there a way to remove the first group prefix?

    I fixed it myself by reading hundreds of threads an here is my solution:

    It was the essentials.yml

    I had to set it up like this:
    Code (open)

    # Chat formatting can be done in two ways, you can either define a standard format for all chat.
    # Or you can give a group specific chat format, to give some extra variation.
    # For more information of chat formatting, check out the wiki:
    # For EssentialsX changes, take a look at the EssentialsX wiki:

    format: '{DISPLAYNAME}: &7{MESSAGE}'

    It's around line 666

    Attached Files:

    Last edited by a moderator: Oct 13, 2018
Thread Status:
Not open for further replies.

Share This Page