Solved PEX and Multicraft Auto-Saves

Discussion in 'General Help' started by ExUprising, Jul 9, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Hello all! On my server we're using the IslandWorld plugin and it's gonna mainly be a skyblock server and my friends island was going to serve as the spawn, but he accidentally deleted his island and we were wondering if and how the auto-saves from multicraft could be accessed and rolled back to so that we could atleast have it back to copy and paste it somewhere else in the world so that our hours of work on spawn haven't gone to waste! And also, I have turned the server off since it happened so that there was no more auto saves. Thanks for any help! And also I don't know what's wrong with my PEX it shows up red in /pl and I can't tell why but from looking it up for a little I think it has something to do with my .yml file but I can't seem to find the error. I tried to use YAML parser but I didn't know what it meant cause I'm dumb also :3 sorry! But thanks for any help! And if it's in the wrong forum also sorry! I'm new to bukkit and server creation.
    Permissions.yml file (open)

    default: true
    build: true
    prefix: '&7[Member]&f'
    - islandworld.create.normal
    - modifyworld.*
    - essentials.home
    - essentials.sethome
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.spawnislandworld.island.create
    - islandworld.island.delete
    - islandworld.island.spawn
    - islandworld.island.home
    - islandworld.island.sethome
    - islandworld.island.delhome
    - islandworld.island.fixhome
    - islandworld.island.expell
    - islandworld.island.add
    - islandworld.island.remove
    - islandworld.island.leave
    - islandworld.island.visit
    - islandworld.island.join
    - islandworld.island.accept
    - islandworld.island.deny
    - islandworld.island.calc
    - islandworld.island.rank
    - islandworld.island.lock
    - islandworld.island.unlock
    - islandworld.island.biomelist
    - islandworld.island.biomeshow
    - islandworld.island.biomeset
    - islandworld.island.biomechunkset
    build: true
    - Default
    prefix: '&6[Donator]&f'
    build: true
    - Default
    prefix: '&b[Moderator]&7'
    suffix: '&7'
    - essentials.kick
    - essentials.mute
    - essentials.tjail
    - essentials.jail
    - essentials.vanish
    build: true
    - Moderator
    prefix: '&4[&cAdmin&4]&e'
    suffix: '&7'
    - essentials.gamemode
    - essentials.ban
    - essentials.unban
    - essentials.ipban
    - essentials.unipban
    - essentials.pardon
    - Admin
    prefix: '&4[Owner]'
    suffix: '&b'
    - '*'

    Thanks again!
  2. Offline


    Post permissions.yml on and link it here. You've posted your permissions file here without any format, so it doesn't preserve the spacing which is crucial.
  3. Offline


  4. Offline


    Well the parser didn't throw any errors, so that's why you probably couldn't figure out how to use it ;)

    Provided you know how to use FTP to access your server files, the backed up world should be in a zip file in the root directory (where your worlds/ are located). You should be able to download that zip file, open it up, and the world folder should be in there, you can replace the current world with that one.

    You should also install a plugin called CoreProtect. This logs placed/removed blocks and chest transactions, etc. and check them in-game. It also allows you to roll back areas, so if someone griefed your spawn, you could rollback all the blocks that that player modified in the past x seconds/minutes/hours/days/months.

    Your PEx shows up as red because you may have the incorrect plugin version for your server version. Please let me know which version server jar you have and which version PermissionsEx you have. Note -- "The latest version" isn't a valid answer.
  5. Offline


    He replied with his pastebin not mine which mine is different and has an error :3. Here's my pastebin @oceantheskatr

    I will get core protect as soon as I get the server back up and running. Thanks! I'll see if this fix works in a few minutes. Although I think the reason it's red is an error in the YAML. Thanks so much!

    P.S. I'm using Craftbukkit 1.8 and PEX is 1.23.3
  6. Moved to Bukkit Alternates.
  7. Offline



    You were missing a few colons, and the spacing on Owner: was incorrect. Otherwise, your permissions.yml file was fine. Try to be a bit more careful when editing the file next time :)
  8. Offline


    Alright thank you so much!
  9. Offline


    You're welcome :)
Thread Status:
Not open for further replies.

Share This Page