Permissions Bukkit not being recognised.

Discussion in 'Bukkit Help' started by barrbossa, Dec 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hey there,

    I have a peculiar problem in that my Plugins don't seem to recognize Permissions Bukkit. For instance when I start up they will say "No Permissions detected" or something similar and proceed to use the default OP file instead for who should be allowed to control it.

    The only reason this was not a problem before is because I could still just make myself OP and Admin of Permissions and it would all work fine - until I got the area control Plugin Regios. Now I can't seem to get it to work without a proper Permissions file since I can't deny groups of users entry or if they are allowed to build in that area without it.

    Is there anything which can be done, or will I have to get a new permissions plugin?
    Yes, all plugins are up to date by the way with the latest bukkit .jar file.

    I have highlighted all related parts to it in the log:

    Many thanks for any help.
    ~ Your... sort of newbie, to servers.

    Wow, I did not notice that threads here get buried so fast. My apologies for adding to the wave, though its still something I have not found an answer to after searching. =/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  2. Offline


    It might not work but try rename permissionsbukkit to somthing like AAAApermissionsbukkit so that it will force it load first. I had to do this before with some plugins like multiverse to make sure it loaded correctly. I had a problem with factions not working with permissions before. i installed the permissions bridge and it picked up the old version permissions and worked fine. I still to this day dont know why it doesnt work without the bridge.
    barrbossa likes this.
  3. Offline


    I am afraid I know that trick does not work, renaming the file, I first tried that when I first laid eyes on Bukkit.
    I'll look into this "Bridge" you speak of, if it helps me bring back the old TheYeti permissions and make it usable with all my plugins then I'll happily take it!
  4. Offline


    Do you realy want to use PEX? there are other, easier permission plugins wich I wrote a guide about, check the link in my sig if you're interested =)
  5. Offline


    Your guide zipron, as helpful as it may be, was not helpful to me.
    That is for complete beginners, who knew nothing of Permissions or how it worked, while I do however know this.

    Please read my problem next time, I mentioned nothing about PEX and I only wanted something which either fixes Permissions Bukkit so it works with all plugins or something else to try out instead. For example this permissions bridge which TheMadMan697 kindly suggested.

    And hoorah!
    My many thanks to him. I looked over on the Permissions Bukkit website more thorougly and saw a Superperms Bridge when I was on the Dev pages, turns out this is all I need!

  6. Offline


    Soory, think I posted that to the wrong person xP I read all posts but sometimes I forget things because of many topics. =) sorry

Thread Status:
Not open for further replies.

Share This Page