Discussion in 'Inactive/Unsupported Plugins' started by Crash, Mar 13, 2011.

  1. Offline


    Attached Files:

    Flipp, Phaedrus, Loart and 4 others like this.
  2. Offline


    how weird...can't wait to see what you come up with!
  3. Offline


    I have zero problem with the rolling problem and getting the length error. Currently using Craftbukkit version 716. My rolls file has no problems at all. Most I have is the disappearing third slot roll.
  4. This broke my Server on build #689 !
    If anyone tries to connect, they get insta-kicked and it says "Received string length longer tha maximum allowed"
    This has to to with the changes of minecraft, so if there are more characters on the sign than allowed, it will start to kick everyone if the sign is loaded on the server :'(
    I think I must delete the sign with an editor or something ...:mad:

    EDIT: Fixed it by deleting the slots.jar, restarting the server and removing the sign.
    However, I can't use it now, because everyone gets kicked then :-/
  5. Offline


    Little, update to the newest build, the newer bukkit builds fix that string error. Also if it still for some reason happens, also try to check to see the length of the names for your rolls. I know Double Bar gave me problems for awhile.

    Build 712 fixed that problem.
  6. Offline


    Yeah I get no crash with 714 but the third slot symbol doesn't show up on signs.

    Moved up to CB 733 ...still no third symbol.. maybe because it's on old signs? testing...nooo s till fails.
  7. Works again ;) Very cool plugin. The players on my server play slots all the time now :D

    Edit: Third symbol doesn't work for me either :-/
  8. Offline


    I can't wait to see this updated!
  9. Offline


    The third symbol is already reported to be missing. It has to do with the new sign lengths. Or at least that's what I'm assuming. Probably with the colors, and spaces, it's just too long to actually get to fit on the sign, so it cuts it off. Because with colors, even using just one color code, At the end it gets to 15 characters. before the last letter
  10. Offline


    Is it possible for this plugin to take from their player's inventory of a designated item, like Gold Ingots, instead of working with iConomy? iConomy is kinda not suiting my server style...
  11. Offline


    Is it 733 ready?
  12. Offline


    it works.. just doesn't show third roll on the sign...waiting patiently for 0.8
  13. Offline


    Thanks for waiting guys, v0.8 is released.

    Changes :
    Update to CB 740 and MC 1.5
    Changed slot machine spacing to make it fit
    Added optional announcing of winnings
     Added optional lever rolling only, right click only, or allow both to roll a slot machine
     Added on option of making 3 in a row rolls not be multiplied
    Post any bugs you find, as I wasn't able to thoroughly test all of this.
  14. Offline


    Works great but i cant edit the value of winning. All the time i /reload it sets it back. Could you fix it?
  15. Offline


    How are you setting the value ?
  16. Offline


    Loving the update. Works great, and really good to see pretty much all the ideas I had added. +1 for that. Only other things I'd like to see possible if you're up to it is ability to use a button or a lever instead of just a lever. That and possibility of item winnings. Maybe code it to have to go
    Where the workbench is a dispenser, and the wood is a block with the sign on it? Or if they don't want a block behind the sign, they can just do the dispenser on top of the sign. And do it where the item winning can be random, so if someone does get it, they won't always get the item.
  17. Offline


    most of the time it keeps saying "there was no roll to match the random value" and on the occasion it does get two, it gives an error and then kicks u from the game and glitches the slot machine hardcore and it constantly says its rolling.... have any idea whats going on
  18. Offline


    "no roll to match the random value" just means the chances= lines of rolls.txt don't add up to 100.
  19. Offline


    Yeah, what Aaron said is correct. Make sure in your rolls.txt file all your chances add up to 100%. Otherwise you get that error. Though the slot machine glitching is a new one for version 0.8. I used to get those multiple times in a row and it didn't affect the slots.

    Edit: I also found something really odd. No matter what I do to try and make my three of a kinds announce on win, it always turns false. This is with saving it before server start up, and saving it during start up and /loading.

    Also when you reload the server, it converts the combos.txt so all the combos are on one line. Then when you start up again, only the first combo is there. This is with saving it before server start. saving it during server up and /slots load. Both as soon as server restarts or reloads it first converts it o all one line, then erases all the combos but the first.
  20. Offline


    I'm using Essentials plugin, but it seems, that it has its own currency system, and it overwrites iconomy? Don't have the slightest idea how to check baallance, while using iconomy (don't have any other plugin that requires it, so dunno), any tips?
  21. Offline



    I'm getting some issue using your plugin. I tried to add a new symbol to rolls.txt but I can't get any slot machine to work ;(. I got "There was no roll to match the random value".... but all chances add up to 1 :(.

    Using CB#740 & Slots v0.8

    I tried to delete all config files , the .jar but when i installed Slots again the previous rolls.txt was loaded...but it's not on the disk! WTF!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  22. Offline


    Sorry about that I changed fractions to percents so remove all the /100 parts for your chances.

    I just fixed both of those in the v0.8.1 bugfix.

    I don't understand, what do you mean it overwrites iConomy ? Do you mean Essentials or my plugin overwrites it?
    You only need iConomy or Essentials to run this not both.

    v0.8.1 bugfix is released.
    Changes :
    Fixed all combos on one line
    Fixed announce-wins in rolls.txt file resetting to false.
  23. Offline


    Just installed v0.8.1 after not seeing any announce wins.

    Here is a piece of my roll.txt file

    For some reason its not announcing wins for the rolls. It does announce for the combos tho.

    Any idea?

    Also here is my slots.txt file
    "Super Low Roll"=0,-157,55,-100,1.0,4,,0.0
    "LOW ROLLER"=0,-160,55,-100,10.0,17,,0.0
    "LOW ROLLER"=0,-163,55,-100,10.0,2,,0.0
    "HIGH ROLLER"=0,-166,55,-105,25.0,44,,0.0
    "HIGH ROLLER"=0,-166,55,-108,25.0,81,,0.0
    "HIGH ROLLER"=0,-166,55,-111,25.0,5,,0.0
    "HIGH ROLLER"=0,-166,55,-114,25.0,10,,0.0
    "HIGH ROLLER"=0,-165,55,-120,25.0,41,,0.0
    "HIGH ROLLER"=0,-162,55,-120,25.0,74,,0.0
  24. Offline


    Hmm I'm not sure.. it should be announced when you roll a D | D | D or an S | S | S ...
    Did you edit the rolls.txt file before starting the server or after ? If you edited them after use /slots load
    I'll take a look at it.
  25. Offline


    I just installed the plugin yesterday (is a huge hit on the server) and things were working before I went to sleep. Next day I believe the server had crashed (especially after seeing all the new lines in the combos.txt file had gone), which is why I updated to latest version of slots. I will note that my rolls.txt file was in tact and didn't have any changes to it. (no announce-win flags were flipped).

    Here is what I have tried to do.
    1) removed all slots and typed /slots load (after verifying the rolls.txt had announce-win=true for all rolls), then readded them
    2) Restarted the server (noticed combos.txt did not get messed up)

    I'll keep fiddling ...


    AHA! Found the file that shows announce-win = false.

    Not sure why it was using a strange version... must be something wrong with FileZilla. Sorry about the confusion
  26. Offline


    Alright glad to see it worked out :)
    Remember to post any other bugs you find !
  27. Offline


    Hey I'm having some problems linking it to iConomy. So I would create a sign using "/slots create <username>" and left click the sign in the slot format, but whenever its used no money is deducted for users iConomy accounts.
  28. Offline


    Just started trying the same thing.

    Instead what i'm doing is create a slot that is unowned. Then wanting the user to buy it... As a test I have all permissions, and try to use /slots buy, but i dont get any messages. I left click the sign and nothing happens.

    Also I try to use /slots withdraw and /slots deposit, and nothing is showing up.

    Here is my config file
    tick-delay: 5
    op-only: false
    require-ownership: false
    multiply-combo-payout: true
    combo-order-matters: false
    connect-to-accounts: true
    backup-slots: false
    save-on-shutdown: true
    roll-type: any
    use-combo-names: true
    multiply-3-in-a-rows: true
  29. Offline


    Can you make the lever work like this:

    2011-05-02_16.49.13.jpg 2011-05-02_16.52.08.jpg
  30. Offline


    Connect-to-accounts is true, make it false I put up the wrong thing in the instructions.

    Make sure that connect-to-accounts is false.
  31. Offline


    Is it possible for a standalone version? I really don't want to use iConomy or any other economy systems.

    Maybe Right Click the sign with the required item, then it pays out by dropping items in front of the player?

Share This Page