No permission message

Discussion in 'Bukkit Help' started by Weetch, May 13, 2014.

Thread Status:
Not open for further replies.
  1. Offline



    My question is how can I change the default no permission message?
    So I want to change this message: 'I'm sorry, but you do not have permission to perform
    this command. Please contact server administrators if you believe that this is in error.'
    To: 'You do not have permission to use that command!'

    I checked the bukkit.yml but there isn't any option to change that message.
    If there are any plugins that are able to change this please link.:D

    Thanks for help
  2. Offline


    It be possible to extract the languages file and make the changes there. Craftbukkit.jar -> assets/minecraft/lang/en_US.lang

    However, the text inside that file is as you mentioned already. Might be another plugin showing that message, of which you'll need to edit that plugins language file.

    If you use NoCheatPlus, there is an override message for that.

  3. Offline


    I checked the langauge file but it wasn't there.
    May there is a plugin which can change that message?
  4. Offline


    Did you even read my post beyond the 1st sentence?
  5. Offline


    PeX and GM have different messages pretty sure its plugin side.
  6. Offline


    And I said as much in lines 2 and 3 of my 1st reply :) The 1st line was just to show where the original message is pulled from if there are NO plugins installed.
  7. Offline


    That message is showed when players try to use bukkit commands.
    For example when they try to use /plugins they get that message.

    Maybe it's hard coded in the jar?
  8. Offline


    Remove all plugins and see if you get the message in the bukkit file I mentioned. If so, then that is pulling from the bukkit language file. Now, if you add your permission plugin back in and your try the command again, does it change the error message? If so, you now know which plugin is spitting out that particular message. If not, continue to add the other plugins 1 at a time until you find it.

  9. Offline


    I tried without plugins and I get that message again, so it supposed to be
    in the langauge file as you said.
    But I cant find it in that file :(
  10. Offline


    Ok then, I shall try to replicate it.

    What version/build of CraftBukkit are you running and what commands are you trying?


    I extracted craftbukkit.jar (from CB 1.7.2) to a sub-folder and used X-Find to search the contents of every file in this folder and found the following file that contained that message:

    So it does in fact seem to be hard-coded.

    You'll have to use other plugins that can override that behavior such as NoCheatPlus

  11. Offline


    And do you know any plugins that are able to change this message
    and it's up to date?
    I couldn't find any... :(
  12. Offline


    I have not personally gone searching for any. I just know that NoCheatPlus has an option to override the default permission errors because I use that to make it look like the command does not even exist on the server if the player doesn't have the right to use it. It helps me hide certain plugins I want to remain hidden. ;)
  13. Offline


    I'm still looking for that plugin.
    I found some but they are out-dated or they not support colors.

    If somebody knows plugin like that I'm looking for please link:cool:

    Thanks for help
  14. Offline


    Yes, the no permission message is hard-coded in to the Bukkit jar.
Thread Status:
Not open for further replies.

Share This Page