Need Help on a PermissoinBukkit Problem

Discussion in 'Bukkit Help' started by Starfie, Aug 31, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Hey everyone of the Bukkit community!

    Recently I decided to found a sever for me and a couple of my friends, everything went smoothly until I found out after some testing that I couldn't break/place blocks! Yes I have tried many of the methods mentioned in similar posts but have worked. I am set to op and have the permissions node set to true for building, and I have no spawn protection set. I did a little bit more testing and found out that Perms was the problem, the source of all the stress. I don't know exactly what causes this but if I remove the plugin I can break blocks no problem, but with it the problem stands. So how can I fix this problem? I just have one plugin installed and that's PermissionsBukkit. Also I tried to fix the problem and came up with some other relative problems. How can I fix these problems? Thanks for all the support!

    Reference and here's the YML txt:

    permissions: true
    - admin
    permissions: true
    bukkit.command.version: false
    bukkit.command.plugins: false
    bukkit.command.plugins: false
    bukkit.command.timings: false
    bukkit.command.tell: false
    bukkit.command.kill: false true false
    bukkit.command.kick: false
    bukkit.command.ban.player: false
    bukkit.command.ban.list: false
    bukkit.command.unban.player: false
    bukkit.command.ban.ip: false
    bukkit.command.unban.ip: false
    bukkit.command.op.give: false
    bukkit.command.op.take: false
    bukkit.command.teleport: false
    bukkit.command.give: false
    bukkit.command.stop: false false false false
    bukkit.command.list: true
    bukkit.command.say: true
    bukkit.command.whitelist.enable: false
    bukkit.command.whitelist.disable: false
    bukkit.command.whitelist.add: false
    bukkit.command.whitelist.remove: false
    bukkit.command.whitelist.list: false
    bukkit.command.whitelist.reload: false
    bukkit.command.time.add: false
    bukkit.command.time.set: false
    bukkit.command.gamemode: false
    bukkit.command.xp: false
    bukkit.command.toggledownfall: false
    bukkit.command.defaultgamemode: false
    bukkit.command.seed: true
    bukkit.command.enchant: false false
    bukkit.command.clear: false
    bukkit.command.difficulty: false
    bukkit.command.spawnpoint: false
    bukkit.command.gamerule: false
    bukkit.command.effect: false
    bukkit.command.ban: false
    bukkit.command.unban: false
    bukkit.command.op: false
    bukkit.command.time: false false
    bukkit.command.broadcast: false
    bukkit.command.broadcast.admin: false
    bukkit.command.broadcast.user: false
    permissions.*: true true
    bukkit.command.*: true

    And here's the error code whence the server is started.
    16:21:49 [SEVERE] Permission node 'groups' in permissions.yml is invalid
    java.lang.IllegalArgumentException: 'default' key contained unknown value
    at org.bukkit.permissions.Permission.loadPermission(
    at org.bukkit.permissions.Permission.loadPermissions(
    at org.bukkit.craftbukkit.v1_6_R2.CraftServer.loadCustomPermissions(
    at org.bukkit.craftbukkit.v1_6_R2.CraftServer.enablePlugins(
    at net.minecraft.server.v1_6_R2.MinecraftServer.l(
    at net.minecraft.server.v1_6_R2.MinecraftServer.f(
    at net.minecraft.server.v1_6_R2.MinecraftServer.a(
    at net.minecraft.server.v1_6_R2.DedicatedServer.init(

    Attached Files:

  2. Offline


    1. Switch to a different Permissions plugin and try that. 2. You didn't even post your permissions.yml.
  3. Offline


    First off, USE PASTEBIN! I recommend PermissionsEx, then just give them the necessary modify world permissions. Also please paste a plugin list.
Thread Status:
Not open for further replies.

Share This Page