Problem/Bug Name Manager Error: Cannot pass event PlayerJoinEvent to NameManager

Discussion in 'Bukkit Help' started by Willmaster04, May 13, 2016.

Thread Status:
Not open for further replies.
  1. Hello I have an error with a plugin and I was wondering If anyone could help me. It's a common error and I hope some of you can help me it's not just this plugin so if you've fixed something like this please tell me. The error is cannot pass event PlayerJoinEvent to NameManager. It happens when people disconnect and connect to my server.
    Last edited by a moderator: May 13, 2016
  2. Offline

    I Al Istannen

    You would need to post your whole sever log from the console or the latest.log in the "logs" folder. The error is described in more detail there.
  3. ok
    HI Here is a recent log

    21:33:11 [INFO] SnowyTurtle7 lost connection: Disconnected
    21:33:11 [ERROR] Could not pass event PlayerQuitEvent to NameManager v2.1.4
    21:33:11 org.bukkit.event.EventException
    21:33:11 at$1.execute( ~[craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at org.bukkit.plugin.RegisteredListener.callEvent( ~[craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at org.bukkit.plugin.SimplePluginManager.fireEvent( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at org.bukkit.plugin.SimplePluginManager.callEvent( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at net.minecraft.server.v1_8_R1.PlayerList.disconnect( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at net.minecraft.server.v1_8_R1.PlayerConnection.a( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at net.minecraft.server.v1_8_R1.NetworkManager.l( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at net.minecraft.server.v1_8_R1.ServerConnection.c(SourceFile:148) [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:11 at net.minecraft.server.v1_8_R1.MinecraftServer.z( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:12 at net.minecraft.server.v1_8_R1.DedicatedServer.z( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:12 at net.minecraft.server.v1_8_R1.MinecraftServer.y( [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:12 at [craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:12 at Source) [?:1.8.0_77]
    21:33:12 Caused by: java.lang.NoSuchMethodError: org.bukkit.scoreboard.Scoreboard.getEntryTeam(Ljava/lang/String;)Lorg/bukkit/scoreboard/Team;
    21:33:12 at net.agentlv.namemanager.api.NameManagerAPI.getNametag( ~[?:?]
    21:33:12 at net.agentlv.namemanager.listener.PlayerQuitListener.onPlayerQuit( ~[?:?]
    21:33:12 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_77]
    21:33:12 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_77]
    21:33:12 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_77]
    21:33:12 at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_77]
    21:33:12 at$1.execute( ~[craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-"24557bc"]
    21:33:12 ... 12 more
    21:33:12 [INFO] SnowyTurtle7 left the game.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  4. Offline

    timtower Administrator Administrator Moderator

    @Willmaster04 Are you running the last version? Did you notify the developer about this already?
  5. Yes I am running a latest 1.8 unofficial craftbukkit version

    I tried a few fixes with the plugin that the dev said some worked but I still get this

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
Thread Status:
Not open for further replies.

Share This Page