Problem/Bug Mob Arena Problems

Discussion in 'Plugin Help/Development/Requests' started by DarudeDaDude, Jan 3, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    So just the other day (in my timezone) I came up with a problem when I tried to edit some of the classes in mob arena and I don't know what's wrong. Given I tried to get rid of the rewards just so my inventory didn't get all clogged up I tried to delete the reward section. I have no idea what to do here.

    Here is the pastebin to the mob arena safe file.

    Could someone please edit this so I don't get an error and tell me what happened?
  2. Offline

    OTF Catastrophe

    The pastebin no longer works and you never stated what the error was. For instance, what happens when you use that specific file?
  3. Offline


    Sorry, kinda updated the file. Here, lemme give it to you.

    04.01 15:36:28 [Server] INFO There is an error in your config-file! Handle it!
    04.01 15:36:28 [Server] INFO Here is what snakeyaml says:
    04.01 15:36:28 [Server] INFO mapping values are not allowed here
    04.01 15:36:28 [Server] INFO in 'string', line 111, column 18:
    04.01 15:36:28 [Server] INFO spawnpoints:

    I think this might be the problem I'm having with this config file.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 4, 2017
  4. Offline


    Indentation is important! Currently "coords" is it own path that has nothing to do with "rewards.waves", and because of this, the spawnpoints, containers, p1, and p2 also have nothing to do with rewards.waves (which is why you are getting the error)
  5. Offline


    Alright, so how do I change this to make mob arena work again?
  6. Offline


    Add 6 spaces before coords. Also, that line should come after you create the p1 and p2 instances.
  7. Offline


    Alright. I'll try that.

    EDIT: Okay, I'm really confused here. Could you straighten that out for me? I'm not very good with this.
  8. Offline


    It is literally adding 6 spaces in front of the "coords" line.
    1. open up the file in a text editor.
    2. Go down to coords.
    3. Left-Click right behind the "C" for coords.
    4. Press space 6 times.
  9. Offline


    Okay, so I'm having a different problem this time. I fixed what you said.

    04.01 18:27:54 [Server] INFO while parsing a block mapping
    04.01 18:27:54 [Server] INFO in 'string', line 103, column 5:
    04.01 18:27:54 [Server] INFO waves:
  10. Offline


    There was an issue loading "waves". Post the updated file.
  11. Offline


  12. Offline

    OTF Catastrophe
    Heres a fixed version of your file. Please put any YAML related files into an Online YAML Parser such as this one. It's much easier than making a post on here. Saves everyone a lot of time
    Zombie_Striker likes this.
Thread Status:
Not open for further replies.

Share This Page