[MISC] MarcoPolo v0.2 - Explore the map [953]

Discussion in 'Inactive/Unsupported Plugins' started by MrAdam, Jun 13, 2011.

  1. Offline


    MarcoPolo - Explore that map!
    Version: v0.1

    Annoyed by all the black spots on your map?
    Don't wanna go explore all of it by yourself?
    Well.. this plugin will help you!
    It loads and unloads all chunks in a square area from spawn, up to the radius specified.
    (The radius is specified in chunks, not blocks)
    It does not generate trees or snow! (Will still appear when exploring manually)

    /explore [world] [radius in chunks]

    • Explores the map by loading and unloading chunks in a specific radius.
    • Multiworld support.
    • Op's only. Terminal only.

    • 0.1 | First release.
    • 0.2 | Terminal only, speed improvements, progress message.
    • Permissions support.
    MatthewDMerrill and STALKER000 like this.
  2. Offline

    Brian Eilber

    Gotta Say this is great but one question... Can you stop it once it runs? or Pause? I think having that ability would make this even better!

    This have been very useful for me![diamond][diamond][diamond]
  3. Offline


    This probably doesnt have much to do with your mod in particular, but do you happen to know if the world stops spawning at the edges of the "full world render" for dynmaps? Or can the world keep being generate out further?
  4. Offline


    Due to the amount of stress it puts on the server, I don't think its feasible.

    The "/dynmap fullrender world" only generates the terrain that has been explored.
    I made this plugin to explore the map in a square (looks nice) and to prevent black holes all over.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  5. Offline


    So eeh.. My map is 5000x5000. How do I let it explore everything, but not make it bigger? (I don't know how to go from blocks -> chunks :p)
  6. Offline


    Sorry to ask, but how did you become a plugin developer not knowing that a chunk is 16*16?
    flames likes this.
  7. Offline


    I think i know how to posibly make the trees generate. You can add a second command to use after the one now, that teleports you around the map in set patterns going around and out towards what the first command did, so that you stay for a few seconds to generate, then you tp to the next set area to generate that, please say you understand, cause i can't think of a better way to explain, execpt it tps you in a spiral going out from the center to the edges generating the chunks because you are there?
  8. Offline


  9. Offline


    i explored in a 200radius..... im scared O_O
    MrAdam likes this.
  10. Offline


    Basically because I don't ever use chunks :p
  11. Offline


    Most people on my server (even a 70 year old lady), knows that a chunk is 16x16 xD
    But yeah, just divide by 16. then you have the diameter. Then cut in half, you have the radius.
  12. Offline


    Just... thank you. !
  13. Offline


    An odd omission to be sure :D
  14. Offline


    This looks like LoadChunks which is a bukkit plugin.. not sure what they do thats different.. as soon as PTM is updated, ill give it a shot.
  15. Offline


    Heh, couldn't find the command :p
  16. Offline


    Tryed 188 and its getting better then I was thinking it would. On a i7 with a poor 2gb Ram and a 99% dead harddrive

    10min to do 78%
  17. Offline


    I can't find a single thread about that plugin..
    Got a link?
  18. Offline


  19. Offline


    Encouragement for permissions.


  20. Offline


    I dont see why permissions is needed, as this is usually a one-time use plugin.
  21. Offline


    usually, yes. I suppose its not a big deal to plug it in when needed.

    What are the chances of circle radius rather than square?
  22. Offline


    Anyway to add a set spawn function?
  23. Offline


    You could use a different plugin for that like Essentials. It does a lot of other stuff besides set spawn too.
  24. Offline


    I would use this but as I am hosting, I can't get to the terminal :(
    Any chance to have Op/Terminal option in a cofig?
  25. Offline


    If you are hosting, you should be able to access the terminal from ssh
  26. Offline


  27. Offline


    hehe, i've tried to programm exactly the same but with asyncrepeatingtask and i'm still getting randomly errors that freeze the server. your way is one (unusual) way to avoid such errors: occupy all ressources for your thread :D
    i've also tried to find a way to populate the chunks but i ended up in sending a player via teleporting across the map to generate and populate the map :confused:


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  28. Offline



    well I try to explore 500 chunks and it gets to approx 4.1% then i get this

    Show Spoiler
    174 recipes
    27 achievements
    00:28:19 [INFO] Starting minecraft server version 1.0.1
    00:28:19 [INFO] Loading properties
    00:28:19 [INFO] Starting Minecraft server on *:25565
    00:28:19 [INFO] This server is running Craftbukkit version git-Bukkit-1.8.1-R4-9
    3-ged6232b-b1565jnks (MC: 1.0.1) (Implementing API version 1.0.0-R1-SNAPSHOT)
    00:28:19 [INFO] [Spout] Spout 611 has been initialized
    00:28:19 [INFO] Preparing level "world"
    00:28:19 [INFO] Default game type: 1
    00:28:20 [INFO] Unable to find spawn biome
    00:28:20 [INFO] Placed stronghold in INVALID biome at (-27, 33)
    00:28:20 [INFO] Placed stronghold in INVALID biome at (-18, -48)
    00:28:20 [INFO] Placed stronghold in INVALID biome at (59, 10)
    00:28:27 [INFO] Preparing start region for level 0 (Seed: 87633)
    00:28:28 [INFO] Preparing spawn area: 12%
    00:28:29 [INFO] Preparing spawn area: 24%
    00:28:30 [INFO] Preparing spawn area: 36%
    00:28:31 [INFO] Preparing spawn area: 44%
    00:28:32 [INFO] Preparing spawn area: 56%
    00:28:33 [INFO] Preparing spawn area: 69%
    00:28:34 [INFO] Preparing spawn area: 77%
    00:28:35 [INFO] Preparing spawn area: 89%
    00:28:36 [INFO] Preparing spawn area: 97%
    00:28:36 [INFO] Preparing start region for level 1 (Seed: 349331869211057536)
    00:28:37 [INFO] Preparing start region for level 2 (Seed: 349331869211057536)
    00:28:37 [INFO] Preparing spawn area: 40%
    00:28:37 [INFO] AutoCraft Enabled
    00:28:37 [INFO] Permission system not detected, defaulting to OP
    00:28:38 [INFO] Bukkit version format changed. Version not checked.
    00:28:38 [INFO] Loaded Essentials build 2.6.4 by: Zenexer, ementalo, Aelux, Bret
    tflan, KimKandor, snowleo, ceulemans, Xeology, KHobbits
    00:28:38 [INFO] Essentials: Using config based permissions. Enable superperms in
    00:28:38 [INFO] Loaded EssentialsChat build 2.6.4 by: essentials team
    00:28:38 [INFO] Loaded EssentialsSpawn build 2.6.4 by: essentials team
    00:28:38 [INFO] MarcoPolo version 0.2 enabled!
    00:28:38 [INFO] WorldEdit 4.7 enabled.
    00:28:38 [SEVERE] WorldEdit: Unable to read default configuration: config.yml
    00:28:38 [INFO] WorldEdit: Using the Bukkit Permissions API.
    00:28:38 [INFO] [dynmap] Using Bukkit Permissions (superperms) for access contro
    00:28:38 [INFO] [dynmap] Loaded 12 shaders.
    00:28:38 [INFO] [dynmap] Loaded 82 perspectives.
    00:28:38 [INFO] [dynmap] Loaded 7 lightings.
    00:28:38 [INFO] [dynmap] Loaded 3 maps of world 'world'.
    00:28:38 [INFO] [dynmap] Loaded 2 maps of world 'world_nether'.
    00:28:38 [INFO] [dynmap] Loaded 2 maps of world 'world_the_end'.
    00:28:38 [INFO] [dynmap] Dynmap WebServer started on null:8123
    00:28:38 [INFO] [dynmap] version 0.25.1-624 is enabled
    00:28:38 [SEVERE] Error occurred while enabling Speedwalk v1.55 (Is it up to dat
    e?): null; mapping values are not allowed here
    mapping values are not allowed here
    in "<reader>", line 43, column 34:
    multiXZ: 10 multiY: 10

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:73
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:17
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:161)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:146)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:106)

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:480)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:423)
    at org.bukkit.util.config.Configuration.load(Configuration.java:89)
    at de.p3king.speedwalk.helper.p3WorldSettings.load(p3WorldSettings.java:
    at de.p3king.speedwalk.helper.p3WorldSettings.<init>(p3WorldSettings.jav
    at de.p3king.speedwalk.Speedwalk.onEnable(Speedwalk.java:54)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:186)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:169
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:342)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:329)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:165)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:393)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    00:28:38 [WARNING] Server permissions file permissions.yml is not valid YAML: wh
    ile scanning a simple key
    in "<reader>", line 98, column 9:
    could not found expected ':'
    in "<reader>", line 99, column 5:

    00:28:38 [INFO] Done (1.877s)! For help, type "help" or "?"
    >explore map 500
    00:29:14 [INFO] Could not find the specified world.
    >explore world 500
    00:29:22 [INFO] Exploring 1000000 chunks.
    00:29:22 [INFO] Exploring: 0.0%
    00:29:37 [INFO] Exploring: 0.1%
    00:29:48 [INFO] Exploring: 0.2%
    00:29:58 [INFO] Exploring: 0.3%
    00:30:08 [INFO] Exploring: 0.4%
    00:30:18 [INFO] Exploring: 0.5%
    00:30:28 [INFO] Exploring: 0.6%
    00:30:38 [INFO] Exploring: 0.70000005%
    00:30:48 [INFO] Exploring: 0.8%
    00:30:58 [INFO] Exploring: 0.9%
    00:31:08 [INFO] Exploring: 1.0%
    00:31:18 [INFO] Exploring: 1.1%
    00:31:28 [INFO] Exploring: 1.2%
    00:31:38 [INFO] Exploring: 1.3000001%
    00:31:48 [INFO] Exploring: 1.4000001%
    00:31:59 [INFO] Exploring: 1.5%
    00:32:09 [INFO] Exploring: 1.6%
    00:32:19 [INFO] Exploring: 1.7%
    00:32:29 [INFO] Exploring: 1.8%
    00:32:39 [INFO] Exploring: 1.9%
    00:32:50 [INFO] Exploring: 2.0%
    00:33:05 [INFO] Exploring: 2.1%
    00:33:18 [INFO] Exploring: 2.2%
    00:33:29 [INFO] Exploring: 2.3%
    00:33:39 [INFO] Exploring: 2.4%
    00:33:50 [INFO] Exploring: 2.5%
    00:34:01 [INFO] Exploring: 2.6000001%
    00:34:12 [INFO] Exploring: 2.7%
    00:34:23 [INFO] Exploring: 2.8000002%
    00:34:33 [INFO] Exploring: 2.8999999%
    00:34:44 [INFO] Exploring: 3.0%
    00:34:54 [INFO] Exploring: 3.1%
    00:35:04 [INFO] Exploring: 3.2%
    00:35:15 [INFO] Exploring: 3.3%
    00:35:25 [INFO] Exploring: 3.4%
    00:35:35 [INFO] Exploring: 3.5%
    00:35:46 [INFO] Exploring: 3.6%
    00:35:56 [INFO] Exploring: 3.7%
    00:36:06 [INFO] Exploring: 3.8%
    00:36:17 [INFO] Exploring: 3.9%
    00:36:27 [INFO] Exploring: 4.0%
    00:36:46 [INFO] Exploring: 4.1%
    00:37:38 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'expl
    ore' in plugin MarcoPolo v0.2
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:42)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:16
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3
    at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:558)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:535)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:419)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    Caused by: java.lang.OutOfMemoryError: Java heap space
    at net.minecraft.server.NibbleArray.<init>(SourceFile:9)
    at net.minecraft.server.Chunk.<init>(Chunk.java:77)
    at net.minecraft.server.ChunkProviderGenerate.getOrCreateChunk(SourceFil
    at org.bukkit.craftbukkit.generator.NormalChunkGenerator.getOrCreateChun
    at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServ
    at org.bukkit.craftbukkit.CraftWorld.loadChunk(CraftWorld.java:239)
    at org.bukkit.craftbukkit.CraftWorld.loadChunk(CraftWorld.java:125)
    at dk.neweden.MarcoPolo.explore(MarcoPolo.java:30)
    at dk.neweden.ExploreCommand.onCommand(ExploreCommand.java:46)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
    ... 7 more
    00:37:42 [WARNING] Can't keep up! Did the system time change, or is the server o

    whats my issue?
  29. Offline


    the download link is broken. I get a 404 error when I try to download this plugin.

Share This Page