Minecraft Server Crashing - Read Time out - HELP

Discussion in 'Bukkit Help' started by Ben1002, May 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Same thing has been happening to me since I updated to 1000 I've turned off all plugins. It has to be bukkit.
  2. Offline


  3. Offline

    The Zephyr Kid

    same this exaclty!
  4. Offline


    This is what we are using
    CraftBukkit Build 1000

    Kind Regards
  5. Offline


    Psst, dont use McMMO with anything but permissions 3.1.5 if you use 3.1.6 you will max out your CPU after some time and get the symptoms listed. They have lots of people posting this issue just got read up on it.

    Now this might not be all your guys issues but I am sure its some of them. I myself have moved on to heros instead of mcmmo
  6. Offline


    I'm having the same problem here :/

    I got bukkit 1000 like a couple days ago, and it was working fine. I have iConomy, WorldEdit, HeroicDeaths, and Anti-Creeper.

    But last night, my internet went out by accident. So I went and reset my internet, and after a couple minutes or so it was back online. But when everyone tried to get on, it kept saying 'Failed to connect to server, Operation Timed Out'

    I don't know why :/ nothing changed. My internet went out, but it should be fine now. I'm so confuzzled.

    Oh, and I can still get on using localhost, so it must be the internet or something, I just can't figure out what.


  7. Offline


    Read timeouts are usually when someone crashes out the game, (Internet issues), I noticed this when looking through my server logs today :|

    All fucking 2gb of them
  8. Offline


    @Ben1002: I had the tickgettick error on my server too, usually happens when blocks are changing too fast. In my case it was the Midibanks plugin and later the Raveblox one.

    Anyway I'm also suffering (Massively) from the read timed out error, nothing else, no errors, just read timed out and server dies. Frustrating to no end, and all suggestions I've tried haven't helped. And yeah I do wish the RTK would detect it, hence a forced restart is all that can restart it. Rollbacks included.

    By now I have pretty much disabled all plugins in order to find if it's caused by such, but again no avail.
    As in the last thread about this problem (And the thread before) I hope we can eventually get a devs answer on this issue, seeing it's not getting better at all and viable solution has yet to be found.
  9. Offline


    Maybe our pc cant handle hosting a server
  10. Offline


    say that to my servers face

    24GB Ram
    Dual Quad Intel Xeon (16 Cores with H/T)
    1GBit Uplink,

    It would kick your arse so hard you would never say maybe again.
  11. Offline


    Same crap happens to me
    I watched cpu usage and it goes to 0% for a long period of time then times out everyone (some people).

    I'm on a vps with 8gb ram, 4 cores.

    I think its related to bukkit running on a single core.

    Its as if it stops using the cpu, pauses, then the lag begins.

    Has anyone found the problem?
    I have been researching this problem forever and found nothing.

    If you still get the problem watch your cpu usage during the lag/disconnects it brings and see if your cpu drops to 0% for some reason

    I get the problem running bukkit w/o plugins. But it does seem to be rarer (much). Possibably in the form of "lag" as if it doesn't last long enough (the cpu drop) it wont d/c everyone just make lag (chat lag, block regen, blablalba)

    If any of you have dynmap. Attempt to type using dynmap and watch it appear in game chat, while nothing else does (not even your own text, saves, console messages). This might be because dynmap uses a different thread than bukkit?

    Using WorldEdits /debug clock
    CONSOLE: Timing clock test for 5 IN-GAME seconds...
    CONSOLE: Warning: Bukkit scheduler inaccurate; expected 100, got 101
    CONSOLE: Clock test result: EXCELLENT
    CONSOLE: Expected time elapsed: 5000.0ms
    CONSOLE: Time elapsed: 4970ms
    CONSOLE: Actual clock rate: 20.321931589537225 ticks/sec
    CONSOLE: Expected clock rate: 20 ticks/sec"
    ^^ some times it says clock ahead. If done during teh "lag" it will have 1 tick/sec

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  12. Offline


    See if your running MCMMO with Permissions 3.1.6, that will cause the issues shown.

    Also bukkitcontrib can do this
  13. My server's been getting this constantly as well. It happens randomly, usually around every two hours or so but it quickly fixes itself and runs as normal after around 10-15 seconds. Sometimes it lasts longer and other times it's instant. I've tried to disable my plugins and removed some that could've been causing the problem, but it still happens. I've run Chunkster to see if my map was corrupted: nothing. I've reset my map entirely: nothing. Like someone above said, my CPU usage drops to 0% when it happens.

    I've gotten rid of Permissions and McMMO entirely, but the problem still persists. Haven't tried bukkitcontrib yet, but I'll let you know how that goes. Honestly, the server was running fine with everything with the past build, but ever since the recent one, this has been happening. Maybe it's a host problem? I don't know.
  14. Offline


    I do not have mcmmo.
    I dont have bukkitcontrib. I have mcmyadmin though, anyone else?
    Btw, thnx for the help.

    Are you also using mcmyadmin or bukkitcontrib?
  15. Offline


    I can say it again lol

    still is possible though minecraft servers are buggy
  16. Yeah, I'm using McMyAdmin and BukkitContrib.
  17. Offline


    Seems like we might have something here.

    Are you also using mcmyadmin and/or bukkitcontrib?
  18. Offline


    I had this Read Timed Out problem a few weeks ago. It was dnymap. New version is fixed. Just make sure that if you have dynmap that you are using latest version.
  19. Offline


    Yea i am having the same issues i am using McMyAdmin all my plugins are up to date and i got rid of McMMo for now but the problem is still there. can anyone help?
  20. Offline


    Here is a list of my plugins
    I use MCMA
    Plugins: WorldBorder, MobBounty, BukkitCompat, xAuth, HeroChat, BananaChunk, BigBrother, iConomy, FirstLastSeen, KiwiAdmin, ChestShop, CheckPoints, WorldEdit, IPGet, OKB3, VanishNoPickup, MultiHome, EasyBan, xWarp, CommandBook, Permissions, DonationMeter, WorldGuard, dynmap, LWC, PermissionsSql, NoCheat
  21. Offline


    I dont think its MCMA, I have been working with it for 5 months with no issues, but bukkitcontrib caused me lots of issues when installed.
  22. Offline


    I dont use bukkitcontrib and I have the problem. Do any of your plugins match mine?
  23. Offline


    I use these plugins:

    AutoMessage, BigBrother, BorderGuard, CraftBook, Essentials, EssentialsSpawn, FoundDiamonds, Fruitful, HeroicDeath, iChat-p3, iConomy, iConomyChestShop, Jail, Jobs, Lockette, MinecraftViewer, MultiHome_m, mxAntiPVPCheat, MyWarp, NaturalGiants, NoCheat, nSpleef, Permissions, PermissionsPlus, rawcritics_ore_obfuscation_plugin, SignColours, UQuest, WorldEdit, WorldGuard

    it must be one of them that is causing the problem or maybe its McMyAdmin?
  24. Offline


    Here. I'm going to disable MCMA. Ill post results when I wake up. =)
    If you can run with out bigbrother you should try that and post results

    Watching your cpu usage on mcma does it randomly drop to 0% with out you getting read timed out?

    Mine does it a lot and it doesn't time us out every time, but it makes lag.

    So my server is still doing ti with out MCMA
    So here's what we should do. Starting with matching plugins we disable them one at a time until we find the culprit.
    If no luck there we then more to second hand matching plugins. Sound good?

    Plugins that match both servers:

    Second hand connection: (plugins that do the same thing but arnt the same plugin)






    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  25. Offline


    I've had a little chat with a Bukkit dev about this issue, or rather sympton of an issue.
    It seems it's neither a bukkit or plugin problem, but rather related to Java, or more precisely, Garbage collection.
    You might wanna start looking there for a solution. I have changed my startup arguments a bit (Trimmed them heavily) and may be able to do a report on the results soon.
  26. Offline


    BTW, im testing worldedit and Worldguard atm
    still the cpu issues.

    Thanx for the info. Please do post the results when you're done.

    Found this thread http://forums.bukkit.org/threads/problem-cpu-loaded.18807/

    I used that line adn it seems to fix it a bit. Still a bit of random lag with cpu drops tho.
  27. Offline


    I've tested them already and the server read timed out anyway. Same for Bigbrother.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  28. Offline


    Yea I tried disabling one plugin at a time but but still no luck.
    i only started experiencing these problems after i update McMyAdmin. before i updated it everything was working fine hmm.
  29. Offline


    The plugins I have that match yours are

    WorldBorder, HeroChat,BigBrother, iConomy, WorldEdit, CommandBook, Permissions,WorldGuard, dynmap, LWC,NoCheat
  30. Offline


    i have the following plugins:BedRespawn, ChairCraft, CraftBookCommon, CraftBookCircuits, CraftBookMechanisms, CraftProxyLiter, Essentials, EssentialsGeoIP, EssentialsSpawn, FirstJoin, HeroChat, HeroicDeath, iConomy, IPGet, LightVote, Lockette, LockIP, mcMMO, nSpleef, Permissions, PvP Control, pvparena, Residence, RocketBoots, SimpleRestart, SimpleSave, SimpleTips, WorldEdit, WorldGuard, MobArena
    30 plugins in total

    i run on a Windows XP SP3 machine with 2 GB RAM DDR3, 2.2 GHZ AMD processor and 5 Mb/s Upload speed

    i get the error Read time out even if there are like 4 players on the server but strangely, when i am on the server I don't get that error and even with 16+me players i didn't get that error for lik 4 hour but when I exited , like in 1 hour the server crashed saying Read Time Out!

    all plugins are up to date (I think)I really need help I can't be at the PC every minute to see if the server crashes and restart it!HELP!
Thread Status:
Not open for further replies.

Share This Page