/mem command and some weird error

Discussion in 'Bukkit Help' started by FunCraft, Apr 17, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    So I just moved to a new host that I thought will be better then the last one because it has more CPU power.It turns out I was wrong.

    On my old host I had 4GB of RAM and when I did the /mem command (from the plugin Essentials)it displayed the maximum memory at 4025 MB, the same as the allocated memory.

    On my new host I have also 4GB of RAM but when I do the /mem command it displays the maximum memory at 1508 MB and the allocated memory at the same amount.I asked my host and it said that he allocated 4 GB of RAM to my server and that the command will still say the same amount.Is my host fooling me?

    Let me tell you my story...I ran the current server with 5/64 players online and the server crashed with Java Out Of memory errors.The odd thing was that MultiCraft said that the memory usage was only at 56%.

    I run the almost the same plugin like on my old host(i had LogBlock there and I don't have it here and now I have MultiVerse running 5 worlds including nether and end and only 2 worlds have the spawn left in memory).I could run the server with 40+ players on my old host and there was little lag but now even with 5 players there were HUGE lag spikes of 10-15 seconds sometimes.

    And this was the error that spammed my console when the server crashed:
    2012-04-17 17:08:48 [SEVERE] java.net.SocketException: Software caused connection abort: socket write error
    2012-04-17 17:08:48 [SEVERE]    at java.net.SocketOutputStream.socketWrite0(Native Method)
    2012-04-17 17:08:48 [SEVERE]    at java.net.SocketOutputStream.socketWrite(Unknown Source)
    2012-04-17 17:08:48 [SEVERE]    at java.net.SocketOutputStream.write(Unknown Source)
    2012-04-17 17:08:48 [SEVERE]    at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
    2012-04-17 17:08:48 [SEVERE]    at java.io.BufferedOutputStream.flush(Unknown Source)
    2012-04-17 17:08:48 [SEVERE]    at java.io.DataOutputStream.flush(Unknown Source)
    2012-04-17 17:08:48 [SEVERE]    at net.minecraft.server.NetworkWriterThread.run(SourceFile:103)
    So should I blame my host for not allocating me 4GB of RAM or is MultiVerse that memory intensive to crash my server with 5 players online out of which 4 were in a world and 1 in another world?I got to mention that one of the worlds is the same as the one on my hold host(where only one player was at that moment).
  2. Offline


    Whatever is allocated that's what it should say. Try /debug info if you have CommandBook.

    Your server should not crash with that little players even if you only have 2GB of RAM.

    I would make sure that all of your plugins are 100% up-to date before looking at anything else.

    Also, the CPU and memory usage meters in Multicraft panel are kind of useless imo, they always seem to be wrong, especially the CPU usage one.
  3. Offline


    I still haven't got my question answered.Please help me if you can.
  4. Offline


    leave that host and go with another. /mem command is accurate.

    once ive been fooled like this too.

    also, can you post your plugin list ?
  5. Offline


    My plugins are:
    bPermissions, NoCheatPlus, WorldEdit, SimpleTips, CreativeNoItemDrop, Vault, Multiverse-Core, Rakamak, WorldGuard,
    bChatManager, WordUp, dynmap, Dynmap-WorldGuard,
    IPLog, DisguiseCraft, DynamicEffectWhitelist,
    Lockette, MobEggs, Essentials, Residence,
    WorldBorder, EssentialsSpawn, Multiverse-Portals,
    EssentialsGeoIP, Multiverse-NetherPortals, VanishNoPacket
  6. Offline


    The error you have provided is not Bukkit related; since it relates to IO - ask your host about it (submit a support ticket/email?)

    Don't let your host BS you - if they're not meeting their 'end of the deal', they are in violation of contract laws and you have a legal right to cancel your service with them - without any cancellation fee.
Thread Status:
Not open for further replies.

Share This Page