[MECH] WorldBorder v1.7.2 - feature-rich world size limiting plugin [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Brettflan, Apr 4, 2011.

  1. Offline


  2. Offline


    Sounds like you're using an older version of WorldBorder and need to update it.
  3. Offline


    Ah DERP!
    So I am!


    Updating now.

    All working :D
  4. Offline


    Released v1.5.4
    • Added integration with DynMap to display borders. It's enabled by default if you have DynMap installed, but note that you'll need DynMap v0.36 or newer for it to work. Borders will be displayed correctly as round or square and should be very accurate, based on a Y height of 64 on isometric maps. Any changes you make to your borders should almost immediately be reflected in DynMap (border radius or shape change, removal, new border set, etc.). Thanks to mikeprimm for adding a couple of requested features to DynMap which made this feature possible.
    • Fix for error on border crossing if player is riding on something which is not classifiable as a Vehicle. This only occurs when using another plugin which does something like making wolves or dragons ride-able and similar.
    • Also, a slight improvement to how boolean values are determined from command input; it accepts "y", "yes", "true" instead of just "on".
    New commands:
    /wb dynmap <on/off> - turn DynMap border display on or off.
    /wb dynmapmsg <text> - DynMap border labels will show this.

    New permissions:
    worldborder.dynmap (Op): Can enable/disable DynMap border display integration
    worldborder.dynmapmsg (Op): Can set the label text for borders shown in DynMap
  5. Offline


    Is there a way to change the color or width of the Dynmap border? It's just a tad wide/bright. Similar request here.
  6. Offline


    I'll consider it when I have time.
  7. Offline


    Thanks for your continues support for this plugin. I've been using this for a long long time, and I appreciate its stability.
  8. Offline


    I have some problems with worldborder - can't trim unneeded world part.

    >wb mrnikel3 trim
    21:58:14 [INFO] World trimming task is ready for world "mrnikel3", trimming the map past 208 blocks beyond the border (default 208), and the task will try to process up to 5000 chunks per second (default 5000) and blah-blah.
    >wb trim confirm
    21:58:17 [INFO] WorldBorder map trimming task started.
    21:58:22 [INFO] [WorldBorder] [Trim] 0 entire region(s) and 8997 individual chunk(s) trimmed so far (100,0% done)
    21:58:22 [INFO] [WorldBorder] [Trim] task successfully completed!
    >wb mrnikel3 trim
    21:58:14 [INFO] World trimming task is ready for world "mrnikel3", trimming the map past 208 blocks beyond the border (default 208), and the task will try to process up to 5000 chunks per second (default 5000) and blah-blah.
    >wb trim confirm
    21:58:17 [INFO] WorldBorder map trimming task started.
    21:58:22 [INFO] [WorldBorder] [Trim] 0 entire region(s) and 8997 individual chunk(s) trimmed so far (100,0% done)
    21:58:22 [INFO] [WorldBorder] [Trim] task successfully completed!
    WHY it shows "8997 individual chunk(s)" in second time instead of 0 ?!
    It should delete these chunks after first trim command, doesn't it?

    After that, I deleted all Dynmap files, copied new "dynmap" folder without any data and run
    dynmap mrnikel3 fullrender
    and get this:
  9. Offline


    1. It's indicating all of the chunks in existing regions as being trimmed whether they existed or not, because it doesn't actually check first. I should probably make it check first so that the indicated number would be absolutely correct, though that will slow the process down a little bit.
    2. I'll quote the relevant part of the first post:
    There's otherwise no way I know of to get dynmap to detect that all of the chunks are gone. I even tried adding in code to make dynmap re-render those specific areas but it did no good.
  10. Offline


    But these chunks really exist? Of course I've done all the things: stopped server (not just 'reload' command), wiped dynmap folder, re-rendered all map. I ever tried like that:

    wb mrnikel3 set 1500 100 100
    wb mrnikel trim
    wb trim confirm
    wb mrnikel3 set 1400 100 100
    wb mrnikel trim
    wb trim confirm
    wb mrnikel3 set 400 100 100
    wb mrnikel trim
    wb trim confirm

    this isn't working either (

    I want to say that when I started "fill" command - new terrain appeared only on those black regions on map i posted up here. This means that those chunks were not deleted, it's not dynmap problem.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  11. Offline


    I've tested it pretty extensively so I know it works.
    After trimming, fully stop your server and then start it back up again. Then run a fullrender, i.e. dynmap fullrender world.
    EDIT: be sure you actually stop your server, though. Otherwise dynmap will not detect the trimmed chunks as being gone. A reload won't do.
  12. Offline


    What I do, step by step:
    1. server console: wb mrnikel3 set 400 310 -80 (instead of radius=1500 as were before)
    2. server console: wb mrnikel trim
    3. server console: wb mrnikel confirm
    It says it does all the work.

    4. system console: /etc/rc.d/minecraft stop
    It propertly saves world and shutting down server

    5. system console: cd /home/srv1/plugins/ && rm -rf ./dynmap
    wipe all dynmap data (I don't have standalone web serv like apache, using dynmap internal web serv)

    6. system console: cp -R /home/user/Desktop/minesrv1.2.x/dynmap ./
    copy new&fresh dynmap installation files, downloaded from the web (there's NO any world data)

    7. system console: /etc/rc.d/minecraft start
    starting server, it goes all right

    8. open localhost:8123 in firefox: there's NO map, only red circle of world border.

    9. server console: dynmap mrnikel3 fullrender
    And now it statrs...

    10. open firefox with map tab and see, how one after one appears old map pieces

    Yes, all this steps I did once more time. And now my map looks like this:


    when I run client, connect to server and go to one of black areas - new landscape generating. And in old areas there's already old one - with bad looking connections between new and old.

    Man, I just trying to save all buildings made by players, and to generate new landscape with new jungle biome and cats)
  13. Offline


    I'm not sure what's happening to cause your problem, then; by all appearances dynmap is not clearing out old data. Dynmap appears to be incorrectly showing regions which have been deleted where it's properly showing the deleted chunks (as opposed to regions) as gone.
    A way you can confirm that those regions you're seeing do not actually exist: go to your world's region folder and see how many MCA files are in there. Judging by your map above, there should be 10 of them if the trimmed regions are indeed removed (unless you've since expanded the map by venturing into the previously trimmed areas). If dynmap is correct, however, there should be substantially more. If I'm counting correctly, something like 36 of them.

    EDIT: actually, another thought: perhaps your browser is caching the old map image files? You might also try clearing your browser cache.
  14. Offline


    There's old world data actually ingame! When you go to the edge of black area - there is new generated (as long as i move) world contacting with old, can't make screenshot now, i'm not at home now.
  15. Offline


    I've just told you how to check by looking at the region files.
  16. Offline


    Looks like much more then 10. As i can remember there's ~30 of them, visually
  17. Offline


    That being the case, the trim process should be reporting errors when trying to delete some of the region files. You haven't mentioned any errors; you should double-check for them.
  18. Offline


    If there were any errors... I can doublecheck and all needed things when i come home, ~1 hour left. I can upload my world files on filehosting, or anything else.

    After that, in /mrnikel3/region folder i have 215 files total, 57 of them have size not 8 kb )) 46 of them have size ~1 Mb and more. I can take screenshot from the game, where new landscape meets with "deleted" one.
    NOPE. Suddently, this time it works. dynmap fullrender shows that allright, without restart (I've ran fullrender just in case)
    trying to set wb radius to 1500 again and make "fill" command, running
    Success. I'll try to reproduce bug with old map backup. In case of success, will upload map to filehosting and post link here.
    http://joysamara.dlinkddns.com/ - my map online, check this out )))

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  19. Offline



    i use your world border plugin(which is awesome btw) but now i have the bukkit 1.2.4 version it doesnt seem to work, everytime i put a command in for the plugin it just brings up the list of commands like it doesnt recognise what i have typed. i have tried th /wb /worldborder and /wborder and they all do the same.

    i also use world edit, world guard, essentials, mcmmo and some other plugins

  20. Offline


    narical All the possibilities have pretty much been covered.

    MatyBoyIV Is it specific commands? If so, can you give an example of a command that's not working for you?
    You also might try temporarily removing WorldEdit+WorldGuard to see if that makes a difference, as someone reported a similar problem with Factions which went away when WorldEdit was removed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  21. Offline


    ok i tried it without world edit and world guard and it does the same thing for example if i type '/wb set 2000' all it does is bring up the list of wb commands, and if i type any other command it does the same thing and brings up the entire list without actually performing the command asked.

  22. Offline


    Please tell me you're not running that command from the server console. If so, that's why; read Note #2 in the first post.
  23. Offline


    i type the command in game as OP Admin
  24. Offline


    Then I have no ideas why it wouldn't be working. If run as an in-game player, that should work perfectly. Hmm. Not using all caps or something? That's the last thing I could think of.
  25. Offline


    ok man thanks for trying anyway, maybe its something to do with my server provider as i use clanforge and i have to use there control panel and stuff.
  26. Offline


    Either way you should still be able to use the commands with the world specified, I suppose, and in the case of the "set" command the X and Z values would be needed as well.
  27. Offline


    I keep getting this,

    Attached Files:

  28. Offline


    Hey, just thought I'd post something weird that's going on for me. If this has nothing to do with World Border, just let me know.

    I keep getting tiny little chunks loading miles away from nowhere outside of the border with no players ever entering them. The trim tool for World Border sometimes gets rid of them but mostly just shouts "The chunk which is outside the border could not be deleted!"

    Here's what my FTP looks like:


    Makes it impossible to generate a map of my server with all these little extra chunks throwing the actual size of the map off.
  29. Offline


    WorldBorder wouldn't be generating those chunks. Is it possible that you had players who logged out in locations beyond where you have your border currently set? If so, when they log back in, the Minecraft server would likely preload that chunk before WorldBorder is able to move them back inside the border.
    Whatever the reason though, it's not WorldBorder loading those chunks.

    If a region outside the border can't be deleted, it's because the region file is locked by your OS. Deleting the indicated file manually or restarting your server and running the Trim command again should take care of it.
  30. good moring sir!
    when i first time used your plugin.. it was fantastic, worked w/o problems, just as it was meanĀ“d to be...
    we are running a small local server, and thus we set the border to just like 500 radius...
    but... as the time passed... we wanted to expand the border... so we did set it to 1000 radius...
    when at once... our pretty map had a SQUARE CHUNK REGION MESS ERROR IN THE MIDDLE
    first off... we thought it was caused by BSOD what the server owner got while he was running the server...
    however... few days back... when no BSOD nor anything strange happened... we noticed an another SQUARE CHUNK REGION MESS ERROR outside the existing border...

    ...no wonder... your plugins trim command deleted all the chunks behind the border, and when the border expands the chunks generate fully new... which i think you know already...

    but we did not...

    ... now our map is fuc!@#$ed up with weeks of effort gone in nothing but timewaste...

    once... there was an plugin... called borderguard (iirc) and it has the ability to not just remove the chunks or whatever behind the set border... but also to RESTORE THEM AS THEY WHERE before the "trim"... though this applies if I understood it correctly only to those blocks which was replaced by the physical border (i dont know if it would be possible to use that method/code in a greater scale, so that once the border gets expanded it wont mess up the biomes/chunks...) or somehow simply to avoid the chunk/biome mess-up after trimming by expanding the border.

    it would be really nice from you to implement such feature into this addon, as because the mentioned borderguard is no longer updated... which is IMHO fatal loss... /sad

    also a notice,... better told a Warning... would be nice to find in the main post of this topic/plugin... that this plugin is one use only... in means that it will mess up the map/chunks/regions/biomes after triming when planing to expand the border in future...

    i registered just to report that crap...
    have a nice day

    some screenshots for visual eye-bleeding...
    Show Spoiler

    yay! the borderguard is still alive!
  31. Offline


    1. Of course the trim command deletes the chunks, that should be clear. However, the chunks will be regenerated (by using the fill command or by walking around) just like they were before anyone did anything to them, unless your world is rather messed up or you've run into a CraftBukkit bug or something.
    2. After using the trim command, you'll need to restart your server and run a fullrender in DynMap to get it to update the map. It otherwise doesn't know the chunks are removed. After using the fill command, it can potentially take a while for DynMap to re-render everything. Your browser might also have old map image files cached.
    3. As I've explained many many times at this point, WorldBorder uses CraftBukkit's built-in chunk generation methods for the fill command. Any problems with the generated chunks (other than some lighting issues) are therefore problems with CraftBukkit, not this plugin.
    4. Borderguard is less efficient than WorldBorder and has only a fraction of the features. For instance, it does not have and never had the ability to trim or fill worlds. I'm not sure where you got that from.

Share This Page