Inactive [MECH] TreeAssist - Auto-Replant and Auto-Chop Trees [1.4.2-RB0.1]

Discussion in 'Inactive/Unsupported Plugins' started by itsatacoshop247, Apr 25, 2011.

  1. Offline


    TreeAssist - Auto Replants
    Version: v5.0

    This plugin will replant trees when they are cut down (or burnt down), and will keep it the same tree type. Also has a custom leaf decay planter and tree removal.

    Checkout the BukkitDev page!

    Most Recent Video

    Here is a video of the 3.0 Tree Removal Feature (slightly outdated):

    Here is a video of the normal functions

    • Replants trees when the bottom log is cut down, or burnt down.
    • Break a birch tree? Replants a birch sapling. Same for all type of trees
    • '/TreeAssist Toggle' - lets a player turn TreeAssist features on or off.
    • '/TreeAssist Global' - Toggles TreeAssist for everyone
    • '/TreeAssist Reload' - Reload the plugin's config file
    • treeassist.autoremove - Should the player be allowed to break the bottom block and the whole tree comes down?
    • treeassist.replant - When the player chops down a tree, should a sapling replant itself?
    • treeassist.toggle - Gives player access to the '/TreeAssist Toggle' command to turn TreeAssist on or off
    • - Gives player access to the '/TreeAssist global' command to turn TreeAssist on or off for everyone
    • treeassist.reload - access to '/treeassist reload'

    Source Code

    See the full change-log here!

    • Suggest things!
    • Custom Leaf Drops
    Like the plugin? Help me keep my programming hobby alive! Please consider donating!
  2. Offline


    When will the 1.1?
  3. Offline


    Make it so they need an Axe for the tree to come down, instead of anything.
  4. Offline


    i've decompiled your version and i don't see any changes, what is that
  5. Offline


    Look in In config files, having spaces set in your code will output as a "/ " slash space. That's why his original config would break every time it was reloaded even if you fixed the bug while the plugin was running. I fixed that by placing an underscore there rather than a space, and I compiled it against 1.1-R3 and realized that his events did not match up to the new event system in the updated craftbukkit.

    How about you decompile his, then try to build it with 1.1-R3 or 1.1-R4 and you'll see what I'm talking about.

    In the download I'm linking at the bottom, it requires a stone axe to make it auto-chop the tree. It will not replace a tree sapling if the bottom block is broken by anything but a stone axe.
    Looks like the plugin author sorta dropped this one. I'm unofficially taking it over I guess until he returns. This download is working with 1.1-R4.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  6. Offline


    yeah, but warnings are still there
  7. Offline


    There's only 1 warning, and that's for an unused import. If you know anything about compiling Jar's, then you know that you can successfully compile even with warnings. And if you take the time to read what the warnings are, you'd realize that its for an unused import.

    If you're getting anything other than an unused import, then you're missing some jar's in your build path. And that's not my fault.
  8. Offline


    nope, deprecated event warnings
  9. Offline


    Those warnings won't affect the plugin right now. Once Bukkit finally gets rid of the old version of events, I'll update to the new one.

    But for now, just tell eclipse to suppress them.
  10. Offline


    This Plugin is not compatible with newest update
    CB 1943 ( is the last version it works with plugin
    please update

    Show Spoiler

    Could not load 'plugins\TreeAssist v3.0.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: org/bukkit/event/block/BlockListener
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.<init>(
        at net.minecraft.server.ServerConfigurationManager.<init>(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.NoClassDefFoundError: org/bukkit/event/block/BlockListener
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(Unknown Source)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at Source)
        at Source)
        at$000(Unknown Source)
        at$ Source)
        at Method)
        at Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at me.itsatacoshop247.TreeAssist.TreeAssist.<init>(
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        ... 8 more
    Caused by: java.lang.ClassNotFoundException: org.bukkit.event.block.BlockListener
        at$ Source)
        at Method)
        at Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 27 more
  11. Offline


    Hey look, I'm not dead! And I have two more semesters of coding under my belt now!
    That said, there's a lot of work for me to become reacquainted with Bukkit coding, but if I fail miserably at it this weekend I'll turn all code and rights over to Jombi, whom you should all give internets to for updating it while I was busy playing Skyrim... ;)
  12. Offline


    This definitely works with the recommended build of craftbukkit. However, you're using the craftbukkit dev builds, which are totally different.

    I'll look into getting a 1.1-R5 version up soon.

    Look at the BukkitDev posting for this plugin (my updated parts...). R5 completely rids craftbukkit of the old event system. You must have downloaded one of my earlier edits which still contained parts of the old event system.
  13. Offline


    Alright guys, I updated to 3.2. MC 1.1, 1.1-R4, new events system, fixed some issues, and most importantly - redid the entire TreeRemoval system, and it works SO much better. Download the new version and figure out what I messed up, eh? :D

    My next plans are to cleanup the config file and make it easier to use/read, then I'll just add a butt-ton of options, like turning each thing on or off, using tools, etc. Please suggest anything else, and help me get my 'To-Do' list up to date!

    Edit: Also note that permissions are all lowercase now!
  14. Offline


    Hello i simply love this plugin, I'm really sorry about the nickname i got LOL, i couldn't put any other one.
    Please i would love if you can update your plugin so i can use it the new craftbukkit R5, THANK YOU A LOT :)
  15. Offline


    As far as I know both the latest Bukkit and CraftBukkit builds are R4 and I do not see ANY other plugins updated to 1.1-R5, but if you link me the R5 I will get it working with that ASAP.
  16. Offline


    ur plugin overwrites old config
    plz add a check if a correct config exist
    if exist dont overwrite

  17. Offline


    Fixed for new version, ETA this Friday. Also adding more to the config file for then.
    DaEgo likes this.
  18. Offline


    Hi, that's what i get when i crop a tree then the game crashes, after that i entry again in the server and the tree has been choped.
    What's wrong?
  19. Offline


    1. Do you have 1.1-R4?
    2. Try removing tree assist and seeing if it continues, then enable tree assist and remove other plugins.

    Your error reports don't mention any tree assist problems, so it may not be it. From what I just spent 2 minutes Google-ing, it could be a Permissions error, and error in the config file (Like you wrote 'ture' instead of 'true'. Also, try removing your playername.dat from the server (back it up) and running the server again and see if that helps.
  20. Offline


    I don't understand everything in the config. Can I set up your plugin, so that every cut down tree spawns exactly one sapling at the place where the log was? Additional saplings should just fall to the ground but not be planted.
  21. Offline


    Yes i have 1.1-R4 and i have tried without any plugin that i use(LWC, ExtendDay, Backup and essentials (I have erased it) Just with your plugin and it still the same, i have remove the playername.dat of the server and it doesn't work, I just get out of the server, but the server works perfectly it seems i dunno what happens
  22. Can you please update to 1.2 R0.2 ?
    and jungle trees not falling down.
  23. Offline


    Yeah, you have to turn Custom Leaf Decay off in the config for that to happen. It will be more clear in the new version.
    I am unable to recreate the problem, and I really don't know. Try posting in the help section on the forums, maybe someone else will understand the problem.
    Working on it! :D

    I've updated to the dev builds for 1.2.3! I did as much as I could, I'll be back in about 24 hours to work on it more! Jungle trees should work now, though some really large ones are being mean, and I have no idea why.

    Download Version 3.3
    Make sure to delete old config file!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  24. Offline


    Amazing work! The jungle trees work well, and so far they have not caused any lag. It may be hard to reach the bottom block for some jungle trees, but it's working fine. Great job.
  25. Offline


    Awesome, thanks! My test server just runs on a very old processor and can't handle it very well :p
  26. Offline


    Could you make some region protection? So that when you enter a region that's protected, you can't remove the trees.
  27. Offline


    That's on the to-do list once bukkit has a stable 1.2 build and all other features are working on that. I do believe there are multiple region protection plugins, but besides world guard, does anyone actually use any different ones?
  28. Offline


    Is the problem with removing user-placed tree blocks fixed now? Will this only bring down tees that were made made by saplings/worldgen?
  29. Offline


    If you mean user's houses and buildings not being brought down, then yes that is fixed. I added more system checks that check if the blocks appear to form a wall/corner or something, so that only trees will be destroyed.
  30. Offline


    Well I also thought that the same system used to tell endermen if a block is user-placed would be useful for TreeAssist so it only affects non-user-blocks.
  31. Offline


    To do that with a plugin I would have to log EVERY SINGLE BLOCK placed by users. And when they break it I'd have to run it against EVERY SINGLE BLOCK that was logged. It's good in theory, but doesn't actually work. As of now, there's no easier way to check if a block is user placed or not.

    But the system I came up with and implemented in the plugin works very well now, or I assume so since noone has complained about it since I released it :p

Share This Page