Inactive [MECH] SignClock v1.8.2 - View the in game time on Signs [1060]

Discussion in 'Inactive/Unsupported Plugins' started by V10lator, Jul 7, 2011.

  1. SignClock - View the in game time on Signs.

    Moved to
    GPLv3 or later (Sources includes in the jar)

    Version 1.8.2
    • Updated for lib24time 0.7.
    Version 1.8.1
    Version 1.8
    • Updated for lib24time 0.6.
    • Removed a useless log message (Bug report from: Navigateur).
    • Hopefully fixed a few bugs in the marquee code.
    Version 1.7.2
    • Fixed a bug which prevents users not having the permissions to destroy SignClocks to destoy any blocks.
    Version 1.7.1
    • Fixed the lib24time detection to the right version.
    Version 1.7
    • Added better daytime scrolling (still not pefect!)
    • Added PermissionsBukkit support (not tested).
    Version 1.6
    • Removed MagicSign.
    • Added /SignClock as MagicSign replacement.
    • Removed daytime clock.
    • Added daytime theme tag.
    • Cleaned up code.
    • Changed save file fomat but save files since 1.3 should get converted to the new format.
    Version 1.5
    • Added daytime clock (you have to update lib24time, too! ) (request from Marcos Cosmos).
    • Reworked save file handling (you know it from some of my other plugins: reduced diskwites).
    • Added MagicSign.
    • Cleaned up code.
    • Rewoked code parts here and there.
    • Hopefully fixed the bug reported by chickenmove.
    • Made everything you write on the sign (exception: theme names) case insensitive.
    • Changed save file fomat but save files since 1.3 should get converted to the new format magically. ;)
    • Changed block power detection.
    Version 1.4.2
    • Updated plugin for lib24time 0.2
    • Changed craftbukkit includes/functions with bukkit ones (craftbukkit is no longer a building dependency).
    Version 1.4.1
    • Fixed a bug (self-triggered clocks won't reset after server reload).
    Version 1.4
    • Fixed a memory leak.
    • Changed display update timings (for self triggered clocks).
    • Added left-click support.
    • Cleaned up code.
    Version 1.3
    • Exported the themes to customizable theme files.
    • Added an option to use the Clock without redstone.
    Version 1.2
    • Splitted out lib24time
    Version 1.1
    • Fixed a Bug (the display won't update always)
    Version 1.0
    • First public release
    Older downloads:
    Download v1.8.1
    Download v1.8
    Download v1.7.2
    Download v1.7.1
    Download v1.7
    Download v1.6
    Download v1.5
    Download v1.4.2
    Download v1.4.1
    Download v1.4
    Download v1.3
    Download v1.2
    Download v1.1
    Download v1.0
    jon674, nandinho and Marcos Cosmos like this.
  2. Thanks, done. :)

    @Marcos Cosmos: Please have a look at the newest version. It still has the same amount of API-Calls but that shouldn't really matter. The scrolling code seems to be a real bottleneck but I changed it in 1.7 (only one scroll-updater for all clocks, also I changed some display/task timings to fix some other bottlenecks).
  3. Offline

    Marcos Cosmos

    I had a look at it briefly, been lazying around the house most of the afternoon. (finally friday xD) but the scrolling looked much better! :3, also I've been meaning to take a look at other servers, (well, ones that use bukkit contrib, but at least private since I don't personally have an account <.<..>.>) not sure what server to join though because I haven't see servers mentioned on my fav plugin topics etc.... do you run one? o.o
  4. Offline

    Marcos Cosmos

    Heh. np I'm just trying to look around for now :3
    Edit: I've only got 2.9gb ram for everything and 2.10ghz dual core, your server > mine xD
    Edit2: I can't get in, just keep falling @.@
  5. Maybe the server was overloaded? Right now I'm standing at the spawn position so the chunks should be loaded.
  6. Offline

    Marcos Cosmos

    Whats the bugfix? o.o
  7. I added permissions in 1.7... But I didn't test it because I don't use permissions for myself.
    Yesterday I reviewed the code again because I wanted to copy&paste permissions functions to another plugin. While I was doing that I noticed that a code block was placed wrong. The code first checked if a player braks a block, then it checked if he has permissions and than he checked if it's a SignClock. Do you see my mistake? Now it checks if a player breaks a block, the it checks if it's a SignClock and then it checks if you have permissions to destroy and if not it cancelles the event. So 1.7 and 1.7.1 should cancel every block break event from players not having the permissions to destroy SignClocks. :D
    //EDIT: Thats's why I marked it as important bugfix release. It could compromise a whole servers "marketing" if the players can't destroy blocks anymore.
  8. Im sorry if this is a stupid post.
    When I put the jar into my Plugin folder it says: Can't load Theme Folder
  9. Code:
    [SignClock] error: can't create theme folder.
    [SignClokc] Can't sace (-1)
    What is not right ?
  10. You're the third one reporting this.
    Please create the folder plugins/V10lator/themes and restart the server. The folder should be created and currently I have no idea why it isn't. I will add a better error message in the next release (and hopefully fix it soon).
  11. Offline


    Awesome, but it's generating too much overload! :(
  12. Network, CPU or RAM overhead?
    Can you give me the output of /networks when it's overloaded?
  13. Offline


    Uppdate to 1.7.3 !!
  14. Then tell me what you want in 1.7.3. ;)
  15. & an icecream <3

    I'll think for the 1.7.3 the better way, it's make an Permission 3.x Support, it will be great.
    With the same nodes of PermissionsBukkit.


    Ps: When nobody is on the server the plugin SignClock spam my server.log :/, any idea from this? :

    2011-08-05 06:18:56 [INFO] [SignClock] No new save data..
    2011-08-05 06:21:19 [INFO] / lost connection
    2011-08-05 06:26:13 [INFO] / lost connection
    2011-08-05 06:26:26 [INFO] [SignClock] No new save data..
    2011-08-05 06:31:20 [INFO] / lost connection
    2011-08-05 06:33:56 [INFO] [SignClock] No new save data..
    2011-08-05 10:01:19 [INFO] / lost connection
    2011-08-05 10:03:56 [INFO] [SignClock] No new save data..
    2011-08-05 10:05:50 [INFO] / lost connection
    2011-08-05 10:06:23 [INFO] / lost connection
    2011-08-05 10:11:19 [INFO] / lost connection
    2011-08-05 10:11:26 [INFO] [SignClock] No new save data..
    2011-08-05 10:16:40 [INFO] / lost connection
    2011-08-05 10:18:56 [INFO] [SignClock] No new save data..
  16. Free icecream for everyone
    I wouldn't hope for it. Before PB support this had no permissions support at all and I think PB will be the default permissions system in a foreseeable future. So why should I implement a dieing feature?

    This is more a debugging output than a usefull information, true. Will remove that message completely in the next version. :)
  17. Offline


    It's not working for me ? very much errors -_- :(
  18. Please give the errors to me, I can't interpret and fix them if I don't know them. :)

    Also note that you have to install lib24time too or this plugin won't work.
  19. @V10lator

    I download the lasted version ^^ (I'll wait until the end of the day to see if errors log occur).

    Otherwise, in the server.log, the plugin version mentioned is not the correct version.
    2011-08-09 11:14:44 [INFO] [SignClock] 5 Themes loaded.
    2011-08-09 11:14:44 [INFO] [SignClock] 8 SignClocks resetted.
    2011-08-09 11:14:44 [INFO] [SignClock] v1.8 enabled.
    Just put on the post that this is the signclock v.1.8, since you have made ​​an update to lib24time (v.0.6) :)

  20. Sorry for that and thanks for the nice idea. ;)
  21. Offline


    I have a problem.. I started this plugin, made a few clocks. Everything worked fine until I bought the game, changed the client and my skin. When I tried to move a clock I made it said it had been destroyed but it's still there. And I can't remove it. Tried to delete the plugin also, it's still there.. Also other clocks stopped... Help?
  22. Ehm... any errors in the log? The clocks don't check if you bought the game or not or what's you're skin (why should they?)
    If you delete the plugin it's impossible that it can prevent you from destroying the clocks... but that the clocks stop when there is no plugin contolling them i no error, it's the ony thing that can happen.

    Are you sure you didn't change anything else (like worldGuard preventing block destroyment...)
  23. Offline


    Ok, i get this error when i right-click a sign after creating a [SignClock]
    2011-08-11 02:08:24 [SEVERE] Could not pass event PLAYER_INTERACT to SignClock
    java.lang.ArrayIndexOutOfBoundsException: -1
    at java.util.ArrayList.get(Unknown Source)
    at com.V10lator.SignClock.SignClockPlayerListener.onPlayerInteract(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(
    at net.minecraft.server.ItemInWorldManager.dig(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(
  24. You have to have at leat one theme in the themes folder! Normally the plugin ensures that but there's still a bug... Please create the folder
    reload your server and try it again. :)
  25. Offline


    I believe that your plugin and Spout have some form of conflict, the error log is below. A short recap of what occured: I installed SignClock last night with no problems at all (Awesome plugin by the way), and when I installed Spout a few minutes ago and booted up my server, I got the error shown below, removed Spout and the error was gone.
    [WARNING] Task of 'SignClock' generated an exception
    at net.minecraft.server.MinecraftServer.h(
  26. Shivanous: That sounds strange, sure that it was a conflict (is it reproduceable)?
    Anyway, I will have a look into this. :)

    //EDIT Could it be that you're using a self made SignClock theme?
  27. Offline


    I thought it was strange too, reasonably sure it was (Did it about five times to be sure, including after checking your post, popped right up.)
    I don't even know how to make custom themes...Not that I need to, I like one of the premades, lol. They are set to Self Triggering by the way, not sure if that's important or not, but worth mensioning I guess.
  28. I've just downloaded the latest versions of SignClock (1.8) and lib24time (0.6).
    But I still get the following error whenever I restart my server.
    21:13:28 [WARNUNG] Task of 'SignClock' generated an exception
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
            at net.minecraft.server.MinecraftServer.h(
    Like Shivanous I use Spout.

    There might be an additional hint to get this bug squashed:
    If I remove every SignClock in my world (I'm glad it's just one at the moment X-D ) everything is fine when the server starts. But if one or more signs with the SignClock tag on it are present in the world, the above error occurs during server startup.
  29. Okay, so this does only happen with spout installed, too. That's very strange because spout shouldn't interference with this... I will have a look at spout now. :)

    //EDIT: I can't logon my server with spout enabled! But I don't see any SignClock errors in the logs. So I have a few more questions:
    - Which Version of bukkit are you using?
    - Which version of spout are you using?

    //EDIT²: Okay, I got it to work but...
    Bukkit: 1000
    SignClock 1.8
    Spout: 1.0.1
    Is working just fine here (except for a few bugs in spout which are freezing the server or do other funny things...) :/

    Bukkit: 1000
    SignClock: 1.8
    works, too. So maybe there's a third plugin involved? Could you try it with only spout and SignClock installed and then, plugin by plugin, enable the other plugins again?
    P.S. I realized that a /reload is bad for spout. Please use /stop and restart your server by hand after that instead. ;)
  30. I use
    BUKKIT 1000
    lib24time 0.6
    SignClock 1.8
    Spout 1.0.1 (where can I get

    And I always use /stop to stop my server.

    The mentioned error occurs when I use a self triggered SignClock:

    Show Spoiler

    If I create a redstone triggered SignClock the first start does not show the error.
    Show Spoiler

    But after serverstart the SignClock is not working anymore.
    If I rebuild the sign it works fine again.

    Btw: I trigger my clock by this restone-cirquit.
    Show Spoiler

    So, if I now restart my server no error occurs, but the SignClock ceased working again.
    If I now do NOT rebuild the sign and /stop and start the server again, still everything
    is fine, except the broken clock.

    Ok, now I set up a new SignClock, /stop and start my server, the error occurs again.

    When I just took a look at the config file "SignClock.sav" it contains the following:
    the world of Kepas Beleglorn,-181,73,-135,1,0
    the world of Kepas Beleglorn,-181,73,-135,1,1

    I guess the last number identyfies if te sign is seftriggered (1) or triggered by redstone (0).

    Now I've tried some editing of the file.

    This will not lead to the error:
    the world of Kepas Beleglorn,-181,73,-135,1,0
    And this will bring up the error on server start:
    the world of Kepas Beleglorn,-181,73,-135,1,1
    There seems to be a problem with selftriggered SignClocks.

    Now I played around a bit. I deleted all but the first line in "SignClock.sav".
    After server start I created a redstone triggered SignClock.
    I took another look into the fresh created "SignClock.sav"... and found this:
    the world of Kepas Beleglorn,-181,73,-135,1,1
    the world of Kepas Beleglorn,-181,73,-135,1,0
    Now I first deleted the line with the "1" at the end, stopped and startet my server.
    1. No error on startup.
    2. Clock not working... (I hoped it might work after editing the config before serverstart...)

    Ok... I'm a software developer and so I know about the hell if a user reports a bug which
    you can't reproduce on purpose. But I'll do what I can to help you to solve the problem.

Share This Page