[MECH] Quantum Connectors v1.0.2 - Remote Control Redstone Made Easy [MOVED]

Discussion in 'Inactive/Unsupported Plugins' started by feildmaster, Jun 30, 2011.

  1. Offline


    Quantum Connectors

    Has found a new home:

    For those of you wishing to get "pistons" compatible with this plugin, I will add compatibility for pistons when 1.7 is patched. I "might" also wait for bukkit to update, I haven't decided.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
    Tim/Hoopi2, master_10 and sinkir like this.
  2. Offline


    @zachcheatham : Oh right, I completely forgot this plugin used permissions.
  3. Offline


    Your plugin is my new best plugin :D
    Thank you :D
  4. Offline


    @sinkir : You're welcome.

    Here's a sneak peak of the change log for v0.4:
    + Added chunk persistence​
    + Wireless TnT support!​
    * Cleaned Code​
    * Fixed accidental breaking of "existing circuits"​

    Planned Updates:
    + Multiple Receivers​
    + New Circuits​

    (This update may take a while. If it takes too long I'll release the current updates and make the circuitry changes a later update)
  5. Offline


    Sad to see that pistons won't be added :(

    Maybe 1 day it will be possible? :)

    Can you make it possible for a sender to be able to send to more then 1 thing?
    This would make life way easier!
  6. Offline


    @Zeeky : Someday, hopefully. :)

    As an answer to your "also" : read the post above yours.
  7. Offline


    oh god multiple receivers, i love you.
  8. Offline


    @feildmaster is this made to work with multiple worlds? I seem to get "Could not pass PLAYER_INTERACT" Spammed in my console now. This never happened with a single world.

    EDIT: Just tested on latest build and heres what happened.

    I installed it properly, restarted the server and it made my config file. I made a test quantum circuit and it worked fine. Then, I restarted my server and it made a circuits.yml as it was stopping.

    I went back on my server after the restart and noticed this was spammed over and over in the console:

    2011-07-20 23:31:42 [SEVERE] Could not pass event REDSTONE_CHANGE to Quantum Connectors
        at Ne0nx3r0.QuantumConnectors.QuantumConnectorsBlockListener.onBlockRedstoneChange(QuantumConnectorsBlockListener.java:26)
        at org.bukkit.plugin.java.JavaPluginLoader$34.execute(JavaPluginLoader.java:476)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
        at net.minecraft.server.BlockButton.interact(BlockButton.java:142)
        at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:219)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:553)
        at net.minecraft.server.Packet15Place.a(SourceFile:57)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    I noticed you mentioned you will "Fix Circuits Breaking" in the next update, is this related to the problem I just posted?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  9. Offline


    @Pand3micc : Can you post the error for PLAYER_INTERACT as well?

    And what plugin are you using for multiworlds. (Though this should already support multiworlds...)

    And no, circuit breaking was not the error you are talking about. I'll see if I can reword it better.
  10. Offline


    I don't mean to offend you in any way, but how about taking a look at the source of the WirlessRedstone-Plugin if you are having issues with adding multiple receivers?
    I am just suggesting this because I would like this plugin to improve even more.

    Have a nice day.
    Regards, Duginox
  11. Offline


    @Duginox : No offense taken, I'm more having trouble with lack of time/hatred for having to change the circuits.yml from it's... unique way, to the PROPER way it should go, AND not break the circuits.

    Multiple receivers wont be a problem... once I get the yml fixed.
  12. Offline


    it's looking nice thanks i'ill try
  13. Offline


    The one post I didn't read XD

    os Pistons not being able to be a reviser be related to minecraft it self or bukit?

    If its bukit, I am sure they can help make it work for you in the next update for it :)
  14. Offline


    @Zeeky : It's bukkit, and I'm not too worried about it. It's already been stated that they will expand more on the pistons so I'll wait till they expand more, and see what they have planned.
  15. Offline


    Can't wait till then :3
  16. Offline


    Hi, got an idea for a new circuit type, don't know if it can be done, but it would be handy..

    How about a pulse circuit? The sender would be either a lever or pressure plate and the receiver would be a button. When the sender is on, it would activate the button every x seconds. The command could be something along the lines of "/qc pulse ##" where ## is the seconds between the pluse.

    What ya think?

  17. Offline


    Like a repeater/clock yes?

    I have that planned... But not coding it in (yet)

  18. Offline


    Great, can't wait.....
  19. Offline


    ok, im having trouble using this with a latch. could be me and the friend testing this are just missing something. but then i press a button to actiavate a lever, the lever gets stuck on, even after the button's charge ends. is there any way around this? temp on circuits are vital to the way my circuits run, and with wireless redstone on the fritz, the quest we've been develpoing has come to a sudden halt.
    thanks for the help
  20. Offline


    @Matsuro : Are you using "qc quantum" to turn the lever on/off?

    I think there are some bugs with buttons. I'll have to take a look later.
  21. Offline


    i was using quantum yes. i figured it out though. when you flick the receive lever with redstone it changes states. you have to manually click it again to change it back or the circuit breaks.
    thanks for the great plugin, with luck i can still get the quest done by the date i promissed my players. just a few more circuits to convert from wireless redstone!
  22. Offline


    That (click) bug will be fixed with the next version. :)
  23. Offline


    @feildmaster I can't get the PLAYER_INTERACT one to occur in build 1000, only the one i posted about REDSTONE_CHANGE occurs.

    I use this plugin for multi-world, its the only one I could find that doesn't force me to make gates, as i wish to use BlueTelePads for teleportation between worlds (and it works great). If that one is conflicting with the plugin could you suggest one that I could use to manage worlds without creating gates?

  24. Offline


    @Pand3micc : ah no. I haven't ever tested the multi-world, so I was looking to see how it worked. and was going to use yours and how ever many others as a test.
  25. Offline


    ill try using a more-known multi-world manager
  26. Offline


    @Pand3micc : speaking of multi-world, was the circuit crossing over multiple-worlds, or was the circuit in the same world you were currently in?
  27. Offline


    Okay, here is the problem:

    I made a 5-clock , and i wanted to connect the output (/qc quantum) to an redstone torch. (but sadly:(, this doesnt work because a redstone torch is not an output! (!new feature maybe!))

    so i attached a lever to the block, and connected the output to the lever. (! it works! the lever is switching continous!) but the redstone torch attached to it doesnt switch..... :( sad..

    So here is the brief message :)p):
    1st: Add redstone torch as possible output.
    2nd: Why doesnt this work with a 5-clock?

    And yea, i must say: i love the plugin :D
  28. Offline


    1- I'll see what I can do, there's probably a reason it's not set as an output already. ;)
    2- It probably has to do with the way the plugin transfers power. (and if I think about it, it might be why torches aren't allowed)

    I'll play with it a bit.
  29. Offline


    same world
  30. Offline


    @Pand3micc : I have some free time and will be testing the multi-world and see what's up with it. :)
    I'll get back with you soon.

    Edit: I think I figured it out. It doesn't load correctly if the world isn't already loaded. For you pand3micc please add the following line to the plugin.yml in the jar (open with WinRar or 7Zip):
      - XcraftGate
    NeedNotApply likes this.
  31. Offline


    Got this after one of my scheduled server restarts, decided to do another restart to see if it happened again.
    Still did.
    Any idea what causes it? I also get other stuff like "unable to pass player_interact" and stuff now too.

    23.07 15:20:17 [Server] INFO     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    23.07 15:20:17 [Server] INFO     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    23.07 15:20:17 [Server] INFO     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    23.07 15:20:17 [Server] INFO     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    23.07 15:20:17 [Server] INFO     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    23.07 15:20:17 [Server] INFO     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    23.07 15:20:17 [Server] INFO     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    23.07 15:20:17 [Server] INFO     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
    23.07 15:20:17 [Server] INFO     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    23.07 15:20:17 [Server] INFO     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    23.07 15:20:17 [Server] INFO     at Ne0nx3r0.QuantumConnectors.QuantumConnectors.onEnable(QuantumConnectors.java:66)
    23.07 15:20:17 [Server] INFO     at Ne0nx3r0.QuantumConnectors.CircuitManager.<init>(CircuitManager.java:29)
    23.07 15:20:17 [Server] INFO     at Ne0nx3r0.QuantumConnectors.CircuitManager.Load(CircuitManager.java:142)
    23.07 15:20:17 [Server] INFO     at org.bukkit.Location.getBlock(Location.java:72)
    23.07 15:20:17 [Server] INFO java.lang.NullPointerException
    23.07 15:20:17 [Server] SEVERE Error occurred while enabling Quantum Connectors v0.3.4 (Is it up to date?): null

Share This Page