Inactive [MECH] MultiInv V2.4.1 - Per World Inventories [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Pluckerpluck, Feb 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Does the converter work on Linux, in an terminal?
  2. Offline


    ummm it's not july yet.. June 3 was only a 1/2 a month ago
  3. Yea, that's what I thought when I read it first time. But the way he replied just now made me think I must have been wrong... then I saw your post and thought... no, it's definitely still June.

    Not yet, depending how long I decide I need to revise for the latest batch of exams coming up I may have it out by friday. What are you updating from?

    If you tech savvy:
    You can use flobi's converter (assuming it's working, I saw one person with a problem but I saw others that it worked for) to get from pre-2.1 to 2.1. And then you can use some linux power to mass find and replace using the manual method I described earlier.

    but I should have the command line version out soon.

    What worries me most is that you've gone around for the past few days thinking it's July... :p

    I understand why you made the post though, even though your timing was a tad off.

    Edit: I also noted the problem with my gui converter was that I'd messed up somewhere and it didn't append each item but overwrote instead leading to invalid inventories. So thanks for giving people a converter when they needed it and I was unable to make it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  4. Offline


    With the sincerity of his post I was almost convinced for a second that it was July, too but my BDay is in July and I knew it hadn't come yet. LOL
  5. Offline


  6. Offline


    +1; Post title needs to be updated. A lot.

    Great plugin though. Works very well.
  7. Offline

    Psycho Robot

    I think 2.1.0 is still a beta, not a stable release
  8. Offline


    860 works well. I guess the dev just wants to be sure.
  9. Offline


    That should worry me as well :oops:...especially since my family keeps talking about my birthday coming up which is on June 28th, and my supervisor keeps mentioning that the project we're working on is due July 1st.
  10. Offline


    That's awesome. Definitely have to make a note of this one!
  11. If you can somehow upload all the inventories then I can convert it for you if I don't have time to make the non-gui converter.

    OK, I'm changing the topic post now then.
  12. Just to clear things up a bit, i think i've lost track of where this is atm.
    Im currently using 2.1.0, is there a way to (or need for) me to convert the files to 2.2.0?
    Preferably one that has been tried and tested.
  13. Offline


    So correct me if im wrong, but this doesnt work with mc's built in nether?
  14. Tried and tested, no... I'd back up the files, run the converter (if you don't have the latest version) and it should have the option for 2.1 -> 2.2. This does change the files... so definitely back them up first.

    You are correct... and I don't have time to add it till the weekend. I have exams over the next few days that require more attention than my plugin.
    If you're using MultiVerse the only proper fix is you set each portal as a MultiVerse portal to the nether instead... but it won't work the same way.
    AS1LV3RN1NJA likes this.
  15. Offline


    Hmm. Okay, so I have had some issues with players randomly losing their inventorys on restarts and logins and stuff. This should be fixed in 2.2?
  16. Erm, depends on which version you're using now and getting these errors. I don't like the sound of randomly losing inventories. Especially as there's no reason for that to happen.
  17. Offline


    Im using 2.1 right now, and randomly on some restarts like 1-2 people will randomly lose their entire inventory.
  18. Entire inventory? In the world the log into? Other worlds? Every world? I need you to be quite specific to work out why they're losing their inventory. It shouldn't actually matter the way it works, but you restart using the "stop" command rather than just forcing a server exit?

    And does it actually reset to a blank inventory?
  19. Offline


    First I use save-all then stop. It seems it only resets in the world they are in. It clears the inventory completely. Also, if this is relevant. Sometimes when I stop the server, while it is stopping I get spammed with errors saying it cant pass player move to multiverse.
  20. I'm starting to think the error may not be with my plugin, but I can't be sure (I'll explain in a bit). Have you posted the Multiverse problem to the Multiverse thread (assuming you did mean multiverse)? And could I also take a look at the error.

    The reason it's a strange error is this:
    Although I still save the info when a player quits I don't actually load from my plugin when you login (I let it use bukkits default method/minecraft method, as it updates more regularly). So the only way to be "losing" inventories of the world you log out in is either if for some reason the inventory is actually SET to blank before logout (rather than just basic data loss) or another plugin is killing it on login (less likely).

    But depending on the error you get in Multiverse that can start effecting the other plugins you have depending on the error. But unless you change worlds I'm pretty sure I don't run any world loading code in my plugin at all. And that's the only time I'd set a blank inventor. I could be wrong though.

    Edit: One more question: What craftbukkit build are you using?

    Edit 2: I've seen this error only 3 times in the last pages of the Multiverse thread. If I were you I'd make sure Multiverse is up to date and that you're using CB 860 (or CB863 for Multiverse world creation)

    Edit 3: I found a reference by fernferret saying he hadn't been able to find the problem for this error. But suggested updating as at the time the person was on CB 818
  21. Offline


    Hmm. I think the solution to the answer is xAuth. Its supposed to be complatable with multiinv. Basically, I use remote toolkit. When rtoolkit stops the server, it kicks everyone then waits about 5 seconds before it does the stop command. In this window of time, people are able to login and if you dont enter your password intime the server stops with your inventory blank. The xAuth dev said its supposed to give everyones normal inventory when shutting down so this doesnt happen, but I will do more testing to see if that is the actual cause.
  22. There's quite a high chance that my plugin saves the blank inventory before xAuth restores it. But that's why I changed it to not load from my saves on login but to instead use minecrafts saves. So as long minecraft gets the correct inventory when the server stops it should work...

    You could try updating to 2.2 because I change a bit how it worked. But I wouldn't expect it to fix this problem.

    There's a chance my respawn method messes up because I'm not sure if it's called at log in.

    Also, do xAuth change the world you spawn in then teleport you back when you log in. Or is it all done in the same world?

    If my plugin is setting the blank inventory I can try to work with the author of xAuth if need be to let them take control inventories until authentication is completed. But I'd need to be sure that this is the problem first.

    When I have more free time I will investigate myself.
  23. Offline


    My logs are literally FILLED with this stuff:

    2011-06-22 12:02:54 [SEVERE] Could not pass event PLAYER_JOIN to MultiInv
    java.lang.IllegalAccessError: tried to access field from class
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.ServerConfigurationManager.c(
            at net.minecraft.server.NetLoginHandler.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.Packet1Login.a(SourceFile:43)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
            at net.minecraft.server.MinecraftServer.h(
    That, and well, all players share inventories across all maps despite my proper config. Some maps are not listed at all so they should definitely be separate.


    P.S. Also this since forever.
    12:14:41 [WARNING] [MultiInv] Failed to teleport player correctly
  24. Offline


    "If you have the latest craftbukkit, update to latest" :D
  25. <_< lets just say that's because people say they have the latest when they actually don't..... and not because I can't type.

    1) Have you got the latest version of MultiInv
    2) Have you got 860 craftbukkit
    3) That particular error would result in multiInv failing completely and thus you revert back to basic minecraft inventories

    4) Plus that error makes no sense.... because it shouldn't happen. I'd re-download the latest version and try again and tell me if you still get the error.
  26. Offline


    So upload my inventories.dat?
    I have it up at media fire to download <Edit by Moderator: Redacted mediafire url>
    Last edited by a moderator: Dec 15, 2016
    Last edited by a moderator: Dec 15, 2016
  28. Offline


    Ok, so download either the .tar or .zip and after I get what is inside put it in plugins/MultiInv/worlds/, right?
  29. Pretty much, don't copy the "Inventories" folder itself though, you want what's in that folder.
  30. Offline


    K, I'll update later, when there's no one on.
Thread Status:
Not open for further replies.

Share This Page