Inactive [MECH] MultiInv V2.4.1 - Per World Inventories [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Pluckerpluck, Feb 17, 2011.

Thread Status:
Not open for further replies.
  1. Ahh, would explain it (and the lack of MultiHealth plugins). Lets hope Bukkit fixes it.
    Thanks for the quick reply, off to bed now.
  2. Offline


    Other than the health issue (which is bukkits fault) it seems to work great. thanks for the update.
  3. This was a quick edit and so may not work.... but I need sleep. If it doesn't work just download 2.1.0 and log in and out on first run to get the files to create themselves.

    All this does is create the shares files on server start. If you're using 2.1.0 fine then don't get this.
  4. Offline


    Thank you very much, 2.1.0 works great! (except for the health issue)
  5. Offline


    2.1.1 is working great! thanks
  6. Offline


    We're up and running and so far seems to be working well. Great work!
  7. Offline


    Seems to work pretty good here too (2.1.1 on 819 w/ MultiVerse and Blue Telepads) except it's not recognizing the inventories of the previous version (1.5.2). I ran the conversion utility ( which is actually pretty intuitive. It creates an Inventories directory with world directories and player files. Perhaps I'm missing something? It's acting like it's a fresh install making the current inventory active in the current world but loosing everything else. Any ideas?
  8. Offline


    What is Chaos exactly, it sounds interesting.

    So with the 2.2.1 version everything needs to work?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  9. *Shameless self plug*

    Chaos is a vanilla-ish map with no rules (griefing and stealing allowed, just don't use mods / invisible textures). All out PVP. Link to the website is in the description if you want to check it out (goes for everyone :D). Bit busy today but when im on, mention you're from Bukkit.
  10. I have the problem that I have no to test myself. I re-installed my PC and now have nothing...

    If you can give me a copy of your I can work on the converter to ensure that it works.
  11. Offline


  12. Offline


    You got it:

    And I really appreciate it.

    The 1.5.2 works great with the plugins listed on (currently live) and the plugins listed on are what I'm trying to update to (for mc 1.6). The 2.1.1 seems to work fine with those excepting the problem I mentioned about importing from 1.5.2.

    My shares.txt if it helps.
    survivalnormal, survivalnether
  13. Offline


    -03 15:50:47 [WARNING] [MultiInv] Failed to teleport player correctly
    2011-06-03 15:50:47 [INFO] [MultiInv] New player detected: xYph2011
    2011-06-03 15:51:18 [SEVERE] Socket closed
    2011-06-03 15:51:18 [SEVERE]     at
    2011-06-03 15:51:18 [SEVERE]     at
    2011-06-03 15:51:18 [SEVERE]     at
    2011-06-03 15:51:18 [SEVERE]     at
    2011-06-03 15:51:18 [SEVERE]     at
    2011-06-03 15:51:18 [SEVERE]     at
    2011-06-03 15:51:18 [INFO] xYph2011 lost connection: disconnect.endOfStream
    Im a noob @ java, but this error occurs everytime after the multiInv error :/
  14. Offline


    @dep2011: You should give the versions you are using, e.g. I'm using craftbukkit 819 and MultiInv 2.1.1 in my testing (766 & 1.5.2 on the live server).
  15. Offline


    v 2.1.1 and buckkit 819
    Flobi likes this.
  16. Offline


    I ran the conversion jar on a 1.5.2 and then put the 3 directories created into the Worlds directory on the server. On CB819 and using MultiInv2.1.1 and that 1.5.2 imported I get:

    Exception Log (open)

    20:16:49 [SEVERE] Could not pass event PLAYER_TELEPORT to MultiInv
    java.lang.IllegalArgumentException: Invalid inventory size; expected 36
    at org.bukkit.craftbukkit.inventory.CraftInventory.setContents(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.NetServerHandler.teleport(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.ServerConfigurationManager.a(
    at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(
    at com.onarandombox.Rigby.MultiVerse.MVPlayerListener$
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    at net.minecraft.server.MinecraftServer.h(

    Since the exception mentions it: Multiverse 1.7.2 is in use also.

    None of the worlds have their inventories from the conversion process. They all appear blank. However, the blank inventories work correctly when teleporting between worlds. I lose and regain a test item. However the importing of old inventory data is pretty important heh.

    The converter made Antares/ Nether/ and Survival/ - I put these in the Worlds/ directory that the plugin created. I've put Nether = Antares into

    I've just recopied the map directories from a backup and the main world (Antares) has the inventory back but nothing in Survival. Nether correctly keeps the Antares inventory
  17. Offline


    This may help in the bug fixing of the conversion utility. I am pretty sure the following data file which was created after conversion is completely bollocks:

    #Stored Inventory
    #Fri Jun 03 18:06:47 CEST 2011
    It seems it replaces any and all item ids with \! which has its obvious drawbacks the least of which is a complete inventory wipe.

    Hope this helps in the debugging process.
  18. Offline


    Version 2.1.0 is working fine for me with MultiVerse 1.6.5 and CB #820, cept that all worlds but my main world had empty inventories.​
  19. Offline


    Happens randomly to several of my users every day. Think it has something to do with players login before and or after a restart. No errors, just my server restarts once a day at 7am and only players playing around this time have the wiped inventory.
  20. Offline


    I find if I had my users log off in the survival map where items count, when I switched over they had there inv but my other worlds are blank.
  21. Offline


    Other than the very random lose of inventories that seems to have only affected 2 players so far (of about 50) the only problem I'm having is that every player login sends this to the console...

    [WARNING] [MultiInv] Failed to teleport player correctly

    But it's not affecting anyone. Just a console error.
  22. Offline


    Hello, is there any way to combine MultiInv with the Backpack (not up to date atm) plug-in? That would be great to have a bigger inventory and the MultiInv possibility!
  23. Offline


    The format doesn't actually look that complex. It seems to be mainly itemid,quantity,data,damage (or the last two might be reversed). It would be relatively easy to build an inventory editing program for these files. I would write up a quick import tool myself except of all the languages I know, Java isn't one and the source .data file isn't nearly as easy to read. It seems to be some sort of java hash table file. The \! seems to indicate a blank inventory slot.
  24. Offline


    Any update on the conversion process for 1.5.2 inventory data? Seems the converter doesnt transfer it all over for all worlds.
  25. Offline


    I was about to ask if I missed something, I've scanned and don't see an update (makes me feel better that I'm not the only one missing it if it's actually there and I did somehow miss it). I do very much like this plugin, and it's made itself indispensable to the point I can't update my server without the conversion utility working. Though honestly, the 1.6 updates aren't so amazing as to make updating a super-high priority.
  26. Offline


    I think the Author forgot to update the header ;)

    Sorry for my english im german ;)
  27. Offline


    Please update your thread title to contain the latest version, since i'm used to only look at the page to see wether there is an update or not. This cause a few terrible bugs since 818, however only because i literally didn't know there was 2.1.0 until this morning.
  28. Offline


    So is there a working convert tool now for 1.5.2 to 2.1x+?
  29. Offline


    The health bug doesn't seem to be a problem with Bukkit.. There's no bugs listed on leaky to do with it?
Thread Status:
Not open for further replies.

Share This Page