[MECH/FUN] Guns+ v1.8 - Guns, Guns, Guns Galore![SPOUT][1.4.7-R1.0]

Discussion in 'Archived: Plugin Releases' started by atlan1, Jan 31, 2012.

  1. Offline


    oh ok thanks, i can craft the ammo now, but i can't make the sniper guns =o
    im putting the materials like its saying in the yml file
    20, 20, 0, 265, 265, 265, 5, SniperAmmo, 0
    i also tryed replacing the sniperammo with flint but still the sniper wont show up in the
    crafting window :(
  2. Offline


    This is the default recipe:
    (coal stands for sniper ammo)
    Also if you just want the gun, you can take it from the creative mode inventory.
    Yea, as I said, weird issue. I'll look into that later.
    You can't assign effects on ammo yet, but this is indeed a good idea. Open a ticket for this to remember me.
  3. Offline


    Well, right now it's more important that my configs aren't loading... any ideas on that?
  4. Offline


    Atlan what would the code be to add durability to a gun so say a pistol only gets 10 rounds until it's completely broken?
  5. Offline


    I don't believe it's possible to add durability to custom items, I'm afraid :/.
  6. Offline


    Then why'd atlan say it is? O_O I'm confuzzled.
  7. Offline


    Random error every time I try to load the plugin... I have Spout and ApiPlus, but it still dosen't work.
    Anything to do with me being on a mac?
    {EDIT} Read back a few pages and found the same Error, re downloaded spout plugin and now it works fine XD Bit of a fail on my part.
    Show Spoiler

    17:27:28 [SEVERE] Could not load 'plugins/GunsPlus.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoSuchFieldError: MOUSE_RIGHT
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:151)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:213)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:189)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:53)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:166)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:432)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.NoSuchFieldError: MOUSE_RIGHT
    at team.GunsPlus.Enum.KeyType.<init>(KeyType.java:15)
    at team.GunsPlus.GunsPlus.<clinit>(GunsPlus.java:59)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:247)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:140)

    Nice plugin, if you have a fix I would be grateful, Thanks.
  8. Offline


    Alright how do you have it work with Spoutcraft? I have it but now i can't connect to my server or make the plugin work:(
  9. Offline


    It's not complicated. I'm not sure how I could describe it in a way more clear than it already is.
    You download spoutplugin. You put it in your plugins folder.
    You download the Spoutcraft launcher. You run it place of minecraft.exe.
  10. Offline


    I said that I could implement something like that but without the durability bar you can see on tools. Perhaps open a ticket on that to remember us.
  11. Offline


    But how to get the gun, becouse when i try to spawn the id it doesn't work.
  12. Offline


    You can pick the guns in the creative inventory, a lot easier
  13. Now there is a new Error:

    Using latest Spout and Spoutcraft Dev build
    11:27:50 [WARNUNG] Task of 'GunsPlus' generated an exception
    java.lang.ClassCastException: java.lang.Double cannot be cast to java.lang.Integer
            at team.GunsPlus.Util.GunUtils.getTargets(GunUtils.java:105)
            at team.GunsPlus.GunsPlusPlayer.fire(GunsPlusPlayer.java:158)
            at team.GunsPlus.FireBinding$1.run(FireBinding.java:43)
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:126)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:533)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    And now i cant shoot any more.
    First Time shooting, the error above appeared, next schoot, nothing happens

    I found the Prob, its the Heavy Gun, when u fire it, nothing else can fire again!
    Maybe there is a fix?
  14. Offline


    I cant see it :(

    Can u tell in words how to install it? those vids are weird

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 13, 2016
  15. Offline


    Okay also is there a way to make flamethrower that does shoot fire?
  16. Offline


    Try making it use fire charges as a projectile. It doesn't work very well for some reason, last I checked, but it's the best thing I could figure out.
  17. Offline


    Download my pack in the loadouts section and look at how I did the flamethrower.
    I will release a new version today which should fix this.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 13, 2016
  18. Offline


    Hello, here I have a problem I installed everything needed but when I craft the image of the objects is not good it appears in Flint.
    Thank you help me please
  19. Offline


    I downloaded the newest version of gunsplus i have api spoutcraft and spout on the server but the gunsplus mpa is not beeing created :/ plz help
  20. Offline


    I just downloaded the newest version of gunsplus, but when I tried to run it, this error popped up.

    14:07:52 [SEVERE] Could not load 'plugins\GunsPlus (2).jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: ApiPlus
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:207)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:183)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:156)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    14:07:53 [SEVERE] ebean.properties not found

    Please help. Thanks.
  21. Offline


    Thanks for the effort - I am a novice and take a "monkey see, monkey do" approach to loading up the plugins - goes well mostly. Cannot get this one working though. No errors showing up for this plugin when I start the bukkit server script and all looks good - just nothing ..... . All the other plugins work well. On the video I noticed you are using the Spout-dev which runs to about 3 M whereas I am using the spoutplugin jar which is only 942k ? I have subsequently loaded up the spoutcraft.jar plug in as well and am getting erros during the server startup. Assume I am missing something obvious.
    182 recipes
    27 achievements
    11:21:16 [INFO] Starting minecraft server version 1.2.5
    11:21:16 [INFO] Loading properties
    11:21:16 [INFO] Starting Minecraft server on *:25565
    11:21:16 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R4.0-b2222jnks (MC: 1.2. 5) (Implementing API version 1.2.5-R4.0)
    11:21:17 [SEVERE] Could not load 'plugins/Spoutcraft.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:194)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:132)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:213)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:189)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:53 )
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:166)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:432)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
    ... 8 more
    11:21:17 [INFO] [World Portal] Loading World Portal v0.2.4
    11:21:17 [INFO] [Spout] Loading Spout v1212
    11:21:17 [INFO] [SideKick] Loading SideKick v7.5
    11:21:17 [INFO] [ApiPlus] Loading ApiPlus v0.3
    11:21:17 [INFO] [SecureChests] Loading SecureChests v0.6.0
    11:21:17 [INFO] [dynmap] Loading dynmap v0.39-1163
    11:21:17 [INFO] [GunsPlus] Loading GunsPlus v1.4
    11:21:17 [INFO] [Spout] Enabling Spout v1212
    11:21:18 [INFO] Preparing level "world"
    11:21:18 [INFO] Default game type: 0
  22. Offline


    I know I've asked this before but I can't seem to find it again and i'm thinking it may have been moved. Do you know where I could get a list of the effects available. Also with projectile speed is speed calculated in blocks per second? Also does damage apply when the projectile hits or is the projectile just aesthetic?
  23. everything appears as flint for me :'(
  24. Offline


    i dc when i click the items to equip :|
  25. Offline


    Are you using Spoutcraft?
  26. Offline


    i get (Internal exception: java.io.IOException: Received string length is less than zero! Weird string) when i dc
  27. Offline


    Right. Am I not using the newest builds for Spout and API +? (v1212 and 0.3 respectively...) Or did I goof somewhere? Because whenever Bukkit loads Guns+, it can't seem to locate general.yml. Or it found general.yml, but not everything in it since they all -seem to be bloody missing.- As in "WARNING [Guns+] The node 'id-info-suchandsuch' in general.yml is missing or invalid! Defaulting!" kind of missing. It seems to do this for every node in general.yml
    ...least' the server hasn't crashed and burned yet...
    EDIT: Wait, may see a problem already...SpoutCraft isn't loading at all. Hmm.
    EDIT EDIT: Okay, I'm just plain stupid; downloaded the SpoutCraft auto-update and not the launcher. Problem still stands.
  28. Offline


    How Do i add Id's to a gun?:confused:
  29. Offline


    From what I understand about the plugins required, the gun and ammo id's should generate automatically.
    ...you having the same problem I'm having? Is general.yml not loading for you?
  30. Offline


    my general file does load, but how do i get the id's them self?

Share This Page