[MECH/FUN] Guns+ v1.8 - Guns, Guns, Guns Galore![SPOUT][1.4.7-R1.0]

Discussion in 'Archived: Plugin Releases' started by atlan1, Jan 31, 2012.

  1. Offline


    It would seem that whenever I aim up in the air and shoot, I get pushed up into the air, and when flying in creative mode and shooting downward, I get pushed down. This should be the opposite.
  2. Offline


    That would be great. I tried using images I got off google and they didn't work (well they did but look weird). I really like the creepergun.

    Here are the guns I was thinking of: blunderbuss, crossbow, repeating crossbow, hand crossbow, flintlock pistol, flintlock rifle, flintlock rifle with bayonet, lever-action rifle, lever-action rifle with scope, revolver (peacemaker), gunblade (peacemaker with a bowie knife mounted under the blade), riflesword (imagine a sword with rifle barrel bored through the center and a trigger in the hilt).
  3. Offline


    atlan1 - major bug to report, sadly. Permissions ARE NOT working. defaulting to op, and don't work with bPermissions. I have no idea why, console shows nothing.. But it doesn't show.
  4. Offline


    atlan1 : same here with PermissionEx. I've give the HUD permission to my player, but they don't see anything. Only OP does. Sad :(
  5. Offline


    You are using the latest version? Should be fixed in 1.6 however I'll try to reproduce this, perhaps I missed anything.

    TheFluffey , Adkos - It works for me (using PEX), I will try out bPerms later, does anyone else has problems with the permissions?
  6. Offline


    I'm Signing up into bukkit to comment this article.

    NICE JOB! You did a very good job.

    Just a little suggestion. Can you write the Version Name in the Pre-made Gunpacks?

    There are old ones and updated ones. I can't just find the updated ones.

    P.S. Sorry for bad English.
  7. Offline


    Adkos SDK Gun Pack is up to date. You'll have some "missing values error in the console, but don't worry, averything works fine :)
  8. Offline


    Is there a way to find out what the crafting recipes are on the server, without the server admin telling you them?
  9. Offline


    In your grenades pack plugin add smoke bombs like heavy smoke bombs that would be awesome i want people to use that and escpape ^.^ if you make the plugin ofc.
  10. Offline


  11. Offline


    I have no usage - except for op... I think others are getting this problem with PEX too. (Adkos)... I had PEX but got some weird problems with spoutessentials - Now I use bPerms.
  12. Offline


    Just wondering... Does anyone know what causes the "inverted controls" bug when zoomed in? I'm noticing it to be inconsistent. Looking at the yml's I don't see anything to indicate such an option but if I try another gunpack then the bug changes weapons... Still only when zoomed in, inverted controls return after zoom out. Only inverts keyboard movement controls. (WASD, incase anyone is wondering inverted controls = press left, move right. press forward, walks backwards.) Everything else seems awesome. If anymore info would be useful let me know and I'll provide it. Thanks again for everyone's efforts with the plugins. I'm still a little rough with troubleshooting java.
  13. Offline


    1. Just a thought: would it help if the sound files were loaded from a folder on the server's host computer, instead of from dropbox or some other webhost? I don't know, just thinking aloud.
    2. That clears that up, thanks!
    3. Bummer. Oh well.
    4. Ahhh, makes sense. Are there any other stats like this, where you have a default value if none is specified?

    And, a new question/suggestion: I have no idea how damage works in minecraft, but would it be possible to make a body armor plug in? Bulletproof vests, etc? That would be a LOT of fun. :D

    I'm having the same problem, using PEX. Oddly, I had a HUD when I didn't have a permissions node, but when I added it, my HUD went away. Could be a simple error on my part, but I thought I did it right.

    default: false
    prefix: null
    suffix: null
    - permissions.manage
    - permissions.manage.reload
    - permissions.manage.config
    - permissions.manage.backend
    - permissions.manage.users
    - permissions.manage.dump
    - permissions.manage.worlds
    - permissions.manage.worlds.inheritance
    - permissions.manage.users
    - permissions.manage.users.permissions
    - permissions.manage.users.permissions.timed
    - permissions.manage.membership
    - permissions.manage.groups.inheritance
    - permissions.manage.groups
    - permissions.manage.groups.create
    - permissions.manage.groups.remove
    - permissions.manage.groups.permissions
    - permissions.manage.groups.permissions.timed
    - gunpack.hud
    - '*'
    Look at #3 in the first quote of my post; atlan1 explained it to me. I tried removing the potion slowness effect, but that didn't fix it, then you move at crouch/shift speed, and it's still inverted.
  14. Offline


  15. Offline


    New video in the making - Every single gun anyone has uploaded. :)
  16. Offline


    New armor sets are not possible yet (everyone watching spout are chomping at the bit for armor and entities APIs to be finished). Until then it would be nice to be able to change the protection of existing armor. Not sure it should be part of this plugin, and haven't found a plugin that does this (so not sure if it's even possible).
  17. Offline


    Im using CookBook and Recipes dosen't work, any solutions ? I need CookBook for chainmail, I tried putting in the recipe to cookbook, but no luck.
  18. Offline


    Simon13 : I've got the same probleme : using custom materials to craft weapons. The answer is pretty short : "impossible".

    However, and as far as I know, I'm the only one who have done a pack that use custom items to craft weapons. You can download it have a look on how it works. Yes, you can bypass the impossibility, and I'll explain you how :)

    --> custom materials are useless. They have no effects, and are used only to craft omething else.
    --> Ammunitions are useless. They have no effects, and are used only to let the gun shoot.

    Something similar, doesn't it ?
    Yeah, you're right : simply use ammo as materials...
    For exemple, in your "ammo.yml" file, create your "chainmail" and put the image URL.
    Then, in "recipes.yml", create the recipes for your "chainmail", using only vanillia items.

    Then, to craft a weapon using chainmail, just put the ID (or the name) of your chainmail in the recipe of the weapon :)
    As they come from the same plugin, it'll work !

    Have fun, and share your work please !
  19. Offline


    Thanks for the Reply.
    But again another problem, when I try to craft ammo, it works, when I try to craft Weapon it doesn't I did it without cookbook. I don't know whats the problem. I'll check the server log when im at home. I'll edit this post with error log (if there is one) . And i'll show you the config. Again thanks for the reply, appreciate what have you done, keep up the good work.
    *Tip: Add more textures especialy zoom. Like Blured glass, like water around a clear circle would look nice. And add more sounds from MW3 not only Counter-strike. :)
  20. Offline


    In fact, it's not really my work, I've just ported the "SDK's Gun Mod" (= solo) to this plugin (=multi). Sounds and textures are from there :)

    Just show me your "recipes.yml" file, I think that the error is in it.

    Update of my pack :)
    Go to the first page to download it (same URL as before).

    Here's the change log :
    - fix the "missing values" errors
    - no more need to edit your "itemMap.txt" file :)
    - Crafting recipes for Needler and Crystal
    Needler :
    Air - Air - Diamond
    Short Barrel - Diamond - Diamond
    Iron Ingot - Iron Ingot - Iron Ingot

    Crystal (x12)
    Air - Air - Air
    Air - Diamond - Air
    Air - Diamond - Air

    - Adding several Crossbow !
    You just have to change the stick for something in this list to have the others :)
    - Stone
    - Iron Ingot
    - Diamond
    - Obsidian
    Crossbows use arrow, shoots arrow (even if they don't stay in a wall), are slow, can miss the target, can make instant kills.
    The better the crossbow is, the farther it shoots, the stronger it is, more precise, and it have more chance of instakill.

    - Adding Sonic Blaster !
    This weird and precious weapon can create a powerfull sonic wave, that can burst a man into pieces.
    The poor victim, if still alive, will be blow by the wind of such a sound, and will fly away.
    It is usually use by heavy metal guitarists :p

    And here's the ammo for this gun :

    Have fun !

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  21. Offline


    I have a error wen I load the mod:
    02:45:55 [GRAVE] Could not load 'plugins/GunPack.jar' in folder 'plugins':
    org.bukkit.plugin.UnknownDependencyException: Spout
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:166)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:164)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:140)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:52)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:408)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    Can you help me pleas.
  22. Offline


    can i use normal minecraft with it?
  23. Offline


    having trouble with this downloaded adkos pack and i cant craft anything i have spout and spoutcraft
  24. Offline


    Heres my recipes.yml file:

    # Here you can configure your own recipes for guns, ammo and stuff!
    # Look at the examples to see how it works.

    # the type can only be shaped or shapeless
    type: 'shaped'
    # this is the amount of snipers in the output
    amount: 1
    # the ingredients from the right to the left and from the first to the last row in the crafting grid
    ingredients: 265, 0, 265, 0, 261, 0, 265, 0, 265
    critical: 0
    speed: 0
    type: 'shapeless'
    amount: 8
    # the ingredients you have to put in the grid to get ammo
    ingredients: 265, 262
  25. Offline


    You forgot to install Spout on your server! ;)
    'critical' and 'speed' do not belong to the 'recipes.yml', however this should not have effect on the crafting.
    If this is the whole 'recipes.yml' and the ammo is assigned to the gun it should work fine.
  26. Offline


    How do you install it ?
    You just have to extract the files and put them into "GunPack" folder.

    For exemple, if you put them into "GunPack/AdkosGunPack", it'll don't work :)
    Please give me more informations to help you ;)
  27. Offline


    Umm without those two mu gun dosen't shoot. But Nvm I used your new gun pack, and implemented Crossbow it works, crafts, zooms and shots fine. Thanks to you, now I just changed weapon ammo to stone, iron and so on arrows ;) I'm having Race server so I'll just use BanRecipie for baning others to craft crossbows :) I'll tell you if anything goes wrong :) If anything, I'll just use your file to edit everything :) Any thougts where can I get a Crossbow zoom back? Like you used for the shotgun. I need just wood :)
  28. Offline


    I don't really know what you're meaning here... do you speak about the "knockback" value ?
    If so, you can edit it in the "guns.yml" file.

    .... why do you need wood ?
  29. Offline


    it's work thank I have install spout and I'm happy very thanks and good plugin.
    Sorry for my very bad English because I'm french ^^
  30. Offline


    well for this is what i did i extracted the gunpack to my server then i copied each of your files and replaced the orginals in the server i also just tried extracting your files to the server it still wont work. this might help everytime my server starts it say 174 recipes it said this before i got gunpack

    maybe my spout plugin is not right

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016

Share This Page