Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. Offline


    =D yey TNX GeMoschen
  3. Offline


    Why won't Falsebook work? I'm updating to the RB build of craftbukkit, updated to Falsebook 0.92 as well, and get that error.
  4. Offline


    Could I have the link to Falsebook 0.91Alpha please?
  5. Offline


    First post to Bukkit forums, but I think it's finally good that I'm here. I've been giving h3ck to my admins at the MC server I lurk at over the issues I've had with falsebook cart handling over the last couple of months, and they finally directed me here where I can talk more directly with the 'devs.

    Anyways, I read the sketchy docs on the recent update to 0.92a, which was installed at our server (, and the vault I created which worked prior to this update no longer worked as it had. Issues:

    1) Redstone booster rails, though "lit" no longer registered as a booster to the minecart. Easily worked around by pulling and reconnecting redstone power source (eg: torches) to work again.

    2) [collect] signs no longer work as-advertized. Items are still in supply cart upon circuit completion.

    3) Creating a new supply cart now auto-locks the cart to the creator only for use, thereby breaking it for being useable by anyone else, and in a "public" vault, that's a big problem.

    What I need currently:

    - A list of current in-game CLI commands to show me what way to fix useage perms on supply carts.
    - Fixe(s) for the now non-functional [collect] signs to make them work again, or an explanation why current signs won't work with current build, or at least a good reason why they no longer work.
    - Update your freaking Wiki page for falsebook to include new ICs as well as CLI and minecart info(which doesn't exist)

    Thanks in advance. ;2)
  6. Offline


    need a fix for this please - causes mass console spam

    22:40:36 [SEVERE] java.lang.NullPointerException
    22:40:36 [SEVERE] at com.bukkit.gemo.FalseBook.IC.ICs.standard.MC1111.Execute(
    22:40:36 [SEVERE] at com.bukkit.gemo.FalseBook.IC.ExecutionEvents.ICExecutionEvent.Execute(
    22:40:36 [SEVERE] at
    22:40:36 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    22:40:36 [SEVERE] at net.minecraft.server.MinecraftServer.w(
    22:40:36 [SEVERE] at
    22:40:36 [SEVERE] at
  7. Offline


    Hi, love your plugin and ic. Just few questions:

    I have the issue where entire chunk's stone was replaced with air. Someones are suspecting Falsebook, but i've see another place where the gulty was Spout dev 719+ World Edit 5.1.
    I've remplaced spout and WE with the right RB builds dor my #1818 and it seems to be ok.
    But is it possible Falsebook caused this issues?

    Another point, is that the transmitter and receiver [mc1110] et [mc1111] doesn't seems to work anymore.
  8. Offline


    People with Block stone to air update bukkit server to the new 1.1R2, they had a bug in R1 that replaced all block edit events with air or something like that fixed in R2.
  9. Offline


    R3 is out
  10. Offline


    R3 Installed. I hope all will be allright.
    But still having issue with MC1111 & Mc1110.
  11. Offline


    Bridges that are more than 21 long don't work.. :(

    I still can get apples from trees while in protected area.. 1.1 so I don't know if this is Falsebook apple =D or "vanilla apple"

    Testin now

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  12. Offline


    ughh. i hate it how i cant search threads on this forum, even though it gives me option (says it cant be done, or searches the entire forum even though i have "search only this tread" checked.

    Am i doing something wrong now? with the last few versions of this, my lights no longer seem to work

    i have it set up to to flip a switch to make soul sand turn into glowstone, then turn back when the lights are switched. however now all the RS and whateer falls off the glowstone/soulsand which breaks the circuit.

    did something change? am i doing something wrong now? Used to work.

    found this reply

    well that pretty much ruined it. stupid. it doesnt work anymore.
  13. Offline



    I build a Gate, protect the sign with lwc (cprivate), and everyone could use the gate.
    Tested lwc flag redstone on and off.

    Can you fix that GeMoschen

  14. Offline


    Update will be released today! Thanks for the report!

    You must change the value in the config file in plugins/FalseBook/%worldname%/ (maxBridgeLength)

    Download here: Version 0.91alpha

    Have you updated the FalseBookCore.jar too? Seems like you just missed out the new Version of the Core! You MUST replace the old FalseBookCore.jar with the newest version.
    1. Can you please post a picture or similar things? I do not exactly know what you mean :/ Maybe a simple picture with some fancy texts will help :D

    2. Can you post your current syntax on the Collect-Signs?
    Normally it should be like this now:

    _ = normal rail
    [] = Ironore (or what is inside of your config)
    | = Sign with the current lines

    2. [Collect]
    3. all OR ID[:SubID][-ID[:SubId]-ID[:SubId]-ID[:SubId]] (EXAMPLE: stone-dirt-35:2)
    4. same as line 3

    If you have locked the sign with LWC to private, you must also lock the chest to private. If you lock the sign public, the chest must be public. This must be done by one person (same owner of the LWC-Protections).
    This means that the LWC-Protections of both things MUST be the same Type and owner. (Otherwise other people would be able to take item out of locked chests...)

    3. I will add a command for becoming an owner of the storagecarts and also add an option in the properties-file to disable this feature.

    I'm working on all of these things! (Especially the wiki..) :D

    This is because redstone is not covered by this feature FOR NOW. In the next update (coming today) there will be an option to disable redstone for gates/bridges/doors/areas.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  15. Offline


    And Redstone wiring and LWC Potection doen't work together on gate-signs?
    Also not with the new lwc 4.x features? (protectable preasureplates etc...)
  16. Offline


    added permission for lift use?
  17. Offline


    This has nothing to do with LWC directly. But as said above: The option will be added in the next update that will be released today.

    Will also be added, yes!
  18. Offline


    Ok, cause we use them in 'special' places, and don't want to give our players lift build perm
  19. Offline


    Hey Gemoschen :) and everyone else :) can someone help me with permissions? for falsebook 0.92 :D i don't know what permissions i need and also a info for all Commands. thx in advanced:)
  20. Offline


    Well, I was about to make a 'demo YT video of this vault, but now, as it doesn't work, it'd be a little hard. ;2P ;2) I can, however, stick to some more descriptive explanation here.

    But my first point was this all used to work flawlessly for nearly the last 2 months, since I completed it in early December. I suspect the new Bukkit API recode caused some interaction issues, or you put in some new syntax rules that didn't exist before, breaking my signs, as well as the different integration with LWC causing the "auto-lock" of chest carts (our server may have a .config issue here but until I get an admin with me to test this, it'll have to wait).

    That's exactly the construction I have in the vault. (Too bad you can't use other rail types, BTW... ;2P ;2)

    Is "ID" required now, because it wasn't before. I have about 80+ signs using the above syntax, but not the "ID" tag, and you can imagine the headache it would be for me to retype all those signs (no we don't have a sign "edit" plugin, though that may change if I have to retype all this, ugh).

    Here's one (of the most complex) I have as an example:
    1. <blank>
    2. [collect]
    3. 260-282-297-320
    4. 322-349-350-354

    For whatever it's worth, the sign is pointing away from the chest (so you're facing the chest as you read this sign).

    Let me check this now (I'm in-game as I post this)... OK, the chest was unregistered, and the sign (actually, I'm using the one from the above example - a "food" collection) was PRIVATE to my username. I made them both unregistered (with LWC /CREMOVE) and tried again to collect into the chest. No change - still not working. Something else is preventing it; possibly a compounding issue.

    To note, this vault exists within a towny protected area, and the LWC protection I am "preferring" on these chests is using a LWC towny "group" feature (specifically /CPRIVATE t:<Towny Name> - it was a recently added feature), so the chest can be accessed by any resident. True, I am aware of the "switching" feature in towny that can also lock out non-residents to chests, but I wanted to lock them independent of towny protection (which to-date I was able to - doors/chests with these protections in LWC can work outside of the town the resident resides). Not sure if this plays into the issue, but I wanted to make sure this was on the table, since you mentioned the LWC dependency in your previous post.

    Does the pseudo LWC protection you have on the storage cart also have to match the sign and chest? Let's test.

    As I can't get to a CINFO of the storage cart (as it's an entity and CINFO only reports block protections), I can only assume it's set to a CPRIVATE with me as the sole owner (Access Control Set (0)). I'll do the same with the sign and the chest...OK, done.

    I send the cart loaded with items that should collect into the chest...send it along the track...check chest...

    Still not working.

    I also note that the sign is oriented at the "end" of the large chest, as opposed to along one of its sides (it's a large chest).

    This would be great, however, it would be ideal (for me at least) to integrate LWC syntax to this command, so I could use the same syntax for the same protections. Please note the protection I would "prefer" above. If you're integrating LWC protection classes into your FB code, this shouldn't be a problem, but as I'm relatively new to this discussion, I have no idea how you're approaching this.

    Thanks for your reply, GeMoschen. I hope this helps.
  21. Offline


    Thanks for the big reply , at first! :)

    I'll try to answer the things one by one:

    The ID-Tag is NOT needed, and there is no such ID-Tag. It was just an example of how to create the sign. I see that you have done it correctly! So no problem there.

    The sign-orientation should not take effect on the collect/deposit-thing.

    Hmm.. I don't know how the towny-protection works, so this MIGHT by a problem, but I think the problem here is simply the fact that the cart is owned by someone.. We should test it out with the new version again.

    However, I do NOT use the real LWC-System. My protectionsystem of storagecarts is completely selfwritten and has nothing to do with the LWC-System. That's why /cinfo does not work on carts.

    The syntax for locking carts will be "/fbcart lock" and "/fbcart unlock".

    Do you set the carts manually or do you dispense them with the cartdispenser of FalseBook?

    My request is to wait for the next update and then test it again. Maybe this will help out. (it will however reduce the range of possible errors).

    I hope this helps you out a bit.
  22. Offline


    I can't seem to get the glowstone to turn into soulsand :S

  23. Offline


    UPDATE RELEASED: Version 0.92.1alpha


    All Packages:
    • added version-check for the core and the packages (Versions must be equal)

    • fixed MC1111
    • fixed some small bugs
    • fixed "/ch remove <Channel>" not removing the channel
    • added options to disable redstone:
    • added new permissionnode for the use of lifts: falsebook.blocks.lift.use (Note: Players with falsebook.blocks.lift are allowed to build AND use lifts)
    • added commands:
      /fbcart lock : lock a storagecart
      /fbcart unlock :unlock a storagecart
      Permissionnode for both commands: falsebook.cart.lockStorageCart
    • added option to disable autolocking of storagecarts:
    • made locked storagecarts persistent for restarts/reloads

    FalseBook v0.92.1alpha

    falsebook.blocks.lift > creation and use of lifts
    falsebook.blocks.lift.use > use only

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
    DarkFusion likes this.
  24. Offline


    awesome :D you are the Best :D
  25. Offline


    Hi, need falsbook plugin for this bukkit version
    "This server is running Craftbukkit version git-Bukkit-1.0.1-R1-b1597jnks (MC: 1.0.1) (Implementing API version 1.0.1-R1)". I hope someone can help me pls.
  26. Offline


    Use one of the following versions:
    Download 0.90alpha
    Download 0.89alpha

    They should work, but I don't guarantee that they work correctly. PLUS they are missing features. You should really update your bukkitversion.
    R3gualt0r likes this.
  27. Offline


    In properties bridges are max 40 long.. But still when I push the Bridge sign it says bridge not found
  28. Offline


    Can you post a picture please? maybe the sign-angles are not correct or anything else.
    Are you sure that you have edited the correct properties file? It is the one in "plugins/FalseBook/%worldname%/" and NOT in "plugins/FalseBook"
  29. Offline


    2012-01-31_00.43.40.png 2012-01-31_00.43.42.png 2012-01-31_00.40.53.png here

    gate next to it works fine

    Ahaa!! World specific properties!

    How ever With gates the gate is Wide 38 or something and works and the world specific config says max with 20

    Should I destroy the old config files?

    Yey It works.. However :( bridges wont close on lava anymore :(((

    Gates clear lava still =D witch is what I want to do clear lava with bridge or bridge prefearebly with both..


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  30. Offline


    Thanks for this! I'll fix that bug tomorrow, that it closes again.

    And Yes, you should delete the other files, since they are not used anymore.
  31. Offline


    Thanks for the great response, GeMoschen! I'll verify our server is updated with your latest build and I'll test again and come back here with the results.

Share This Page