Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. is there anyway you could do some sort of jenkins for dev builds so us admins that want to keep up with the latest can ?
  3. Offline


    Is it working on LEET version?
  4. Offline


    is this plugin still alive? Long time no new version....
  5. Will this work? I have a popular server and I installed it... It was great this plugin was a blast but than.... I stopped the server than reloaded it than BAM so much errors I can't even finish starting my server... Testing it again
  6. Offline


    Hey, I recently changed my Permissions to PermissionsBukkit and SuperpermsBridge. Now when I try to place [MC0271], it says "You are not allowed to build a DETECTION."
    I have set myself to group with permission node '*': true
    All other plugins permissions I still have, but not FalseBook.
  7. i advise you to setup permissions bukkit properly ;) the * node is for extremely lazy people :p
  8. Offline


    I also added falsebook.*: true for myself
    I have set up it as properly as I can, the * node is just for me, the "Server Owner" group. Wtf is wrong
  9. permissions bukkit doesnt use star nodes. As the node falsebook.* isnt inbuilt into the plugin then it isnt picking it up. Just give yourself the handful of permissions that are part of this plugin and set them to true :)
  10. Offline


    +1 Update this plugin :)
  11. Offline

    Bradley Hilton

  12. Offline


    Actually I also downloaded SuperpermsBridge, so yes it supports * nodes. My * node grants me access to all other plugins.
  13. Get rid of the bridge :p im running 30+ plugins on my server now and 99% of them link in with superperms so i advise you to get rid of superperms bridge and just set it up without all this * nonsense. The sooner you do it the quicker all your problems will be solved :)
  14. Offline


    Is there any chance of an update to 1337 as permissions nodes aren't working with PEX and thats all I can put it down to as had similar issues with other plugins until I updated them.
  15. Offline


    Heres 1 example:
    What do you suggest me to do when Worldguard wiki tells me to do this:

    /region addmember
    • worldguard.region.addmember.own.*
    • worldguard.region.addmember.member.*
    • worldguard.region.addmember.*
    Hmm................ Every option I could use needs to have *
    Ik this is not about FalseBook but.......
  16. Offline


    i have a quastion

    how can i collect more than one items about the [collect] sign?

    thx 4 help
  17. yes but that star node is built into the worldguard plugin..... falsebook doesnt have any star nodes.
  18. Offline


    WTF... It has been like 2 months I use Falsebook Cart for speeding up my trains, but today the 2xBooster is slower than yesterday, and my timers are now with a bad time... I use ID 14 for x2Booster as default and I didn't touch any config! I didn't add any plugin similar than this, so it isnt colliding. The brake block is working! What is happening? I use CB 1337 ...
  19. Offline


    Players say they can't get hidden_switches to work even with permissions ;(
  20. Offline


    Why can't i get these commands to work? not even in console.

    Tough I fould in log a list of failed ic's dunno when/how the list just appears, in the log... Odd..
  21. Offline


    First off, thank you for this excellent plugin! We've been using it now for a few months now, it's a personal favourite of mine and we have had very few problems with it.


    I would love to see an IC iteration of the popular "BUD Switch" or Block Updater Switch if it's even possible given the way these work in exploiting a bug. A BUD Switch will detect a block's state change and send a redstone signal when that's detected. These can be used to detect when plants change growth state, furnaces are stoked and finish their jobs, or even chest or block usage detection. Because of the size of the apparatus, it severely limits it's possible uses, so a single block IC would open so many more possibilities there. A possible configuration I'd like to see if possible:

    BUD Toggle
    Detection Shape (Block, Wall, Pad)
    XYZ:XYZ Offsets

    I would also love to see a focus on integrating CraftBook/Minecart Mania's cart system into this ASAP! There were a few quality minecart plugins created back when Bukkit launched, but all of them have been abandoned and we're stuck with a very poor situation regarding them at the moment.

    Craftbook - Cart System decent - Rest of suite is outdated (Inactive)
    Falsebook - Cart system is outdated - Rest of suite is great
    MinecartMania - Best cart system available, but hugely outdated (Inactive)

    Trying to actually implement carts on a server is tedious and unusable at the moment. WorldEdit zones protect, but also prevent users from placing carts, the lack of cart collectors makes people have to carry carts around on them to use tracks and open chests with carts allow for easy theft. I realize there are workarounds for some of these issues, but a more ideal fix would be the integration of Craftbook/Minecart Mania's more powerful cart systems :)

    With all that said though, thank you for your development time. I've thoroughly enjoyed the plugin!
  22. Offline


    Easy fix for this is to set the region flag to 'vehicle-place: allow' and 'vehicle-break: allow'.

    Is this still being supported? I've been using this on b1317, now about to update to 1337.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  23. Offline


    Get no errors running on CB1317 but for some reason whenever I hook toggle areas to redstone, it works once then i have to reload for it to work again, then reload once more to work again.
  24. Offline


    This doesn't appear to be working on CB 1337. There are no errors in the server log, but it doesn't load any ICs automatically, loading them manually tells you they are now loaded, but they don't appear to respond to anything. None of my dispensers, two way switches, cart blocks etc are doing anything at all, no errors and no functionality. Is this the end?
  25. Offline


    Running CB1317(mac)-Toggle areas only work once(with redstone) then i have to reload the server, is this the issue?
    20:04:35 [INFO] Could not call home.
    20:04:35 [SEVERE] invalid stream header: 00000001
    20:04:35 [SEVERE] at java.i:confused:bjectInputStream.readStreamHeader(
    20:04:35 [SEVERE] at java.i:confused:bjectInputStream.<init>(
    20:04:35 [SEVERE] at com.bukkit.gemo.FalseBook.Block.FalseBookBlockCore.loadArea(
    20:04:35 [SEVERE] at com.bukkit.gemo.FalseBook.Block.FalseBookBlockCore.loadAreas(
    20:04:35 [SEVERE] at
    20:04:35 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    20:04:35 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    20:04:35 [SEVERE] at
    20:04:35 [SEVERE] at
    20:04:35 [INFO] [FalseBook Block] Error while reading plugins/FalseBook/areas/.DS_Store
  26. Offline


    Ok so im sure this is the issue for the falsebook blocks only activating via redstone once then neve working again till reload. CB1337 Falsebook latest.

    18:07:24 [WARNING] Task of 'FalseBookBlock' generated an exception
    at java.util.AbstractList$Itr.checkForComodification(
    at java.util.AbstractList$
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    at net.minecraft.server.MinecraftServer.h(
  27. Offline


    Works perfectly on my server! But could you please create a list of cauldron recipes?
  28. Offline


    How do i add cauldron recipes?? jw cause im retared xD
  29. Offline


    Is it possible to disable the drop of the blocks that are spawn with the P-DOOR ic (MC1210)? Because the admin of my server don't want to allow this ic because player can spawn any type of block and collect it by destroying it.
  30. Offline


    I'm using falsebook chat and added the command so users can join chatroom.
    But now they can't leave, lol. didn't work.
    Whats the command I need to add for their ranks? ty!

    nvm, this worked.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  31. Offline


    Hallo ich nutze die neueste craftbukkit und das aktuelle falsebook.
    Ich habe folgende Probleme.
    Es werden beim Serverstarte 20 Ics als "failed to load" angezeigt
    Leider funktioniert der Befehl "fbic" bei mir nicht
    ob in der Server Konsole direkt oder Ingame mit /fbic
    somit kann ich weder den Status abfagen noch die Ics neu importieren.
    Ansonsten funktioniert fast alles bis auf ein paar kleinigkeiten mit denen
    man leben kann. Da mein Windows basierender Bukkit aber nicht mehr
    mit dem Aufbau der Grafik nachkommt und ich immer wieder Löcher in der
    Landschaft sehe , will ich nun doch mal diese Fehlermeldungen beseitigen.
    Bin für jeden Tip dankbar.


Share This Page