Inactive [MECH/DEV] ItemCraft 1.6.6 - Support for client mods in Bukkit [1060/1000]

Discussion in 'Inactive/Unsupported Plugins' started by asdaarg, May 3, 2011.

  1. Offline




    ItemCraft is a Bukkit mod that allows adding new item and block types, crafting and furnace recipes, and custom tree generators and more. Using a Modloader and SettingsGUI interface it allows subplugins known as ICPlugins to be loaded to support client mods. ICPlugins can be created by translating a client mod using the ICTranslator ICplugin. Using a ModloaderMP interface (ported by krnlyng/liar) it allows porting multiplayer mods to bukkit.

    • Add more Block types
    • Add more Item types
    • Add more Entity types
    • Add more TileEntity types
    • Add more Crafting recipes
    • Add more Smelting recipes
    • Add more Tree generators
    • Ported ModLoader interface
    • Ported ModLoaderMP interface
    • Fake GUIAPI Settings interface
    • Startup file for configuring plugins and making simple blocks and items

    Installation & Usage:
    • Back up your world(s). Just in case.
    • ItemCraft.jar goes in same folder as craftbukkit
    • IC plugins go into ItemCraft/ICPlugins folder under craftbukkit. (folder is autocreated the first time)
    • uncomment (remove #) in front of all plugins you want to use in plugins.ics (autocreated in ItemCraft/ICScript)
    • Make sure you have the recommended version of craftbukkit in the title - since this is a mod of that version in particular.
    • Delete/rename the META-INF folder inside craftbukkit-0.0.1-SNAPSHOT.jar (Use some decent zip program (e.g. 7zip) that can do it.)
    • All players on the server needs to have the client mods installed
    • If you use the 16 bit entity id packet mod (in case you use new entites (only ICMCreatures need it)), All players need (flan's unofficial) ModLoaderMP client mod
    • All players also need the 16 bit entity id packet mod (overwrites a ModLoaderMP's class so make sure ModLoaderMP is installed first) in case you use new entites (only ICMCreatures need it) If decide not to use the packet mod, you can turn it off putting this in your startup file: false setEntityIDPacketMod
    • Sometimes you get block/item ID conflicts, between plugins. You then need to set the conflicting ids in the startup script using setID command: example. They have to be set before the plugin that uses them is loaded. Note also that there is typically a props file on the clientside you have to edit the ids on to be the same as well.
    • To start:
      • Windows:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      • Others:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar:craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      IF You do not understand how to install this follow THIS link! Also Try:

      ItemCraft Forum
      ItemCraft Wiki


      Installation instructions changed since 1.5

      For Minecraft 1.7.3

      Inofficial ItemCraft update by Syrome1.6.6 (#1060)
      ItemCraft 1.6.5 (#1000)
      QwertyPower files (ICSGlass, ICFancyPack addons and more...)
      o4kapuk 16 bit packet mod Does not work without (flan's unofficial) ModLoaderMP client mod.
      ICKSlopes - support for Kaevator SuperSlopes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use Ignore ScotTools or you will have problems breaking various blocks
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.7.3 mod Details regarding use of potted plants IDs and settings
      User ported mods list maintained by icephantom

      For Minecraft 1.6.6

      ItemCraft 1.4.5
      ItemCraft 1.5.1 (for use with planes)

      ItemCraft 1.3.5 (for CB #818)
      ICSGlass - support for ChocolateySyrup's Stained Glass unofficial update for 1.6.6 mod
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.6.6 mod Details regarding use of potted plants Also be sure to read: Release notes Does not work well and not at all with the newest FancyPack update(v6) Wait until client is stable.
      ICKSlopes - support for Kaevator SuperSlopes
      Usage notes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use
      ICMCreatures - Support for DrZhark's Mo's Creatures
      16 bit entity id packet mod
      User ported mods list maintained by Asymetrikon

      Dev tools:
      ICTranslator - How to use

      Source and old versions

      ICScript documentation

      Frequently Asked Questions

      Tutorial on how to make your own blocks also list of block and item IDs in most popular mods.

      Suggestions of mods to port
      Vote here not in this thread anymore (it gets lost in all the other stuff)

      Reporting errors:
      • Read known issues - don't report those.
      • State the version of CB, ItemCraft and ICPlugin(s) you have problems with
      • If your client crashes, start the client from command line so that you get the error report.
      • Make sure the mod(s) works in SSP First before you report any errors here.
      • You are more likely to get a response if you describe the problem in more detail and do some testing yourself first of under what circumstances it occurs
      • Do not ask for uploads of minecraft.jar.
      • Do not pm me.
      • If you have problems installing, you are likely doing something wrong. Make sure you've followed the instructions exactly, read the FAQ and Wiki. If that doesn't work you can always ask in the thread, while I will likely not reply, there are others who can help you with your problem. But at least try to get it working yourself first.

      That said, I want to thank all who have helped users with their problems. In particular special thanks to icephantom and Asymetrikon for their big efforts in this. Also a special thanks to xeronut for being generally helpful.

      Changelog: (open)

      • Inofficial update by Syrome to support CB #1060 and ModloaderMp v1.7.3v4.
      • Added changes by krnlyng/liar to support buildcraft
      • Inofficial updated by Qwertypower to support CB #1000
      • Fixed Generators not working since ModLoaderMP merged.
      • Added option to turn off packet230 being sent to clients: false setPacket230OnLogin
      • @QwertyPower's unofficial update to 1.7.2 and 1.7.3.
      • Fixed issues with ICPlugins not being able to use ModLoader methods obtained through relection.
      • Merge with @krnlyng/liar's translated vesion of SDK's ModLoaderMP
      • Added dummy method RegisterTileEntity to fake modloader.
      • Added dummy methods AddArmor and getUniqueSpriteIndex to fake modloader.
      • ItemCraft commands are now loaded automatically and can be used in init.ic
      • Fixed nonesense message when parsing a string and EOF is found after escape character.
      • Platform independent line breaks of autocreated files
      • added some stuff in the autocreated file
      • Fixed unupdated mod causing problems for other plugins accessing the enum's constants for new block ids 1.6.
      • Removed spam on use command
      • Fixed java method invocation
      • Added javamethod invocation of declared methods
      • Fixed pop removing 2 elements off stack
      • putsetting command, allowing editing settings using new script
      • putvar and getvar commands allowing use of variables in scripts
      • added if command, conditional execution of closures
      • ishidden, isCustomType and getCustomType commands
      • exec command, allowing execution of closures. Acts as function calls.
      • while command, for while-loops, execution of closures.
      • Annotation of non-standard methods allowing correction of semantics during parsing with methods that manually alter type info. (needed for for loops, and various stack commands (such as popall, push, pull,dup, casting, getvar, all that do not have a static type signature) to have any usefulness beyond execution using GUI.
      • added casts
      • Fixed setEntityIDPacketMod demanding a this pointer.
      • Fixed boolean constants missing.
      • Updated to CB #860
      • GUI is now off by default
      • Fixed illegal access of Item constructor and other methods
      • 16 bit Entity Id Packet mod can now be turned off
      • Added file loading functions that use filename rather than file class for Fileman, for use with Janino
      • Fixed intellisense being screwy, showing previous context
      • Fixed castability test of primitive types to primitive types being screwy
      • Fixed selected method in context view not being visible (scrolled down/up to).
      • Fixed array bounds error
      • added intellisense (context box showing sorted list of all applicable methods in context at cursor position, as well as selecting the one closest matching)
      • added tooltips showing documentation both in command box and in the context (list) box
      • added getmaterial method to get Minecraft's materials
      • added documentation to most methods.
      • removed some obsolete methods
      • renamed some methods
      • remove NAME: spam on classloaderlclass, 1,2,3 4.. spam and vs: spam
      • fixed classloaderlclass leaving junk on stack
      • fixed getconstructor (?)
      • fixed right square bracket without left square bracket not resulting in parse error
      • fixed parse to fail due to right bracket not yielding an array type
      • removed autocreate double spam
      • ics extension changed to ic (conflicting with korganizer and iCalendar)
      • moved plugins into plugins.ic (since it now doesn't execute "use" until it parsed the whole file, it doesn't
      • recognize ItemCraft functions in init.ic)
      • added setID
      • added back support for old file format using includeold
      • fixed execution of abstract script calling providing arguments in wrong order
      • ICScript is now completely converted into postfix
      • Completely rewritten script parsing and execution code
      • Math functions should work now
      • Scripts Are not executed until fully parsed
      • ICS now support direct invokation of java functions when no ICS function matches a call
      • ICS now support arrays
      • ICS now support closures (for later support for menus, functions, loops, conditionals)
      • Parser produces Abstract code that runs much faster, than when having to parse each time to execute code.
      • Pre 1.0-style startupfile scripts are no longer supported (for now)
      • Warning of Block loss with prompt to quit CB on any error during parsing
      • Warning of Block loss with prompt to quit CB if startup script file was not found and was autocreated. This way you can have it autocreate it safely without having to worry about loss of blocks during upgrade.
      • Detailed error reports during both parsing with line number and column and during execution.
      • added simple math functions
      • added basic string and character functions
      • fixed methods popping more than one element
      • fixed dup not duplicating
      • added primitive classes
      • added parsing of primitives as primary commands
      • added parsing of strings as primary commands
      • fixed identifier after a string being misparsed
      • fixed popup menus not working in windows
      • added methods to get icplugins and their classloaders
      • added methods to get constructors and invoke them
      • Implemented new functional script language ICScript
      • Implemented GUI
      • inclusion of files (so you can split up startupfile in smaller files)
      • loading plugins on the fly
      • executing any script commands on the fly using GUI
      • exploring variables and functions of objects in GUI
      • invoke any functions, private or public, on any class loaded in IC/ICPlugins/minecraft/CB/any bukkit plugins
      • Built in text editor (was going to be for editing java code)
      • Removal of blocks, entities and items, even on the fly
      • Adding new blocks, entities and items on the fly
      • Specify what entities spawn in what biomes and how frequently.
      • Customizable programmable menus per node type in GUI
      • IC now retrieves version number both for plugins and itself automatically and reports it when plugins are loaded
      • fixed mimic having target object mimic itself.
      • fixed invokation on wrong object when interacting with mimiced block
      • fixed setint setting a string and not an int
      • fixed case sensitivity of block parameters
      • fixed some other bugs related to block parameters
      • no more commas assigning multiple values in block parameters (because I'm lazy)
      • Mobs that are unspawnable don't crash the server anymore
      • Added new startupfile commands: blocks and entites
      • Added new startupfile commands: setbool, setint, setfloat, setdouble, that allows changing the settings of mods that use GUIAPI (nandonalt trees and mo's creatures)
      • fixed various bugs with craft command in startup script
      • removed debug spam on id command
      • fixed comments causing "unknown commands" in startup file
      • cleaned up unnecessary stuff from error report
      • fixed skip skipping over the next line too
      • Implemented modloader removespawn (could that have anything to do with the watermob problem?)
      • fixed unknown command spam on empty lines
      • fixed some bugs with craft command in startup file manager.
      • Fixed kicked when horse throws you off because of accessing protected field
      • Fixed problems adding recipes, tile entites, entites using API.
      • added items command for debug purposes
      • added a copy of spawncreatures to the mod, no idea if that will solve the issue with sharks crashing server.
      • Mimic feature of block allows block to mimic other blocks, fully or in some respect (useful to customize blocks beyond the fixed values from startup file)
      • back to start from craftbukkit folder; its no longer a plugin
      • IC plugins go into ICPlugin folder now in craftbukkit folder. These are to avoid problems caused by plugins being reloaded by CB
      • usedefaults on by default
      • fix item 0 is not valid item spam
      • implemented Modloader getUniqueEntityId,RegisterEntityID,setPrivateValue
      • implemented various SettingsGUI widgets facades, and SettingFloat, SettingsMulti
      • script pauses when error occurs to avoid startup with wrong settings
      • Items are also registered as dummy, to avoid error spam by other plugins
      • Modloader world generator interface for normal type worlds implemented
      • Barebones fake GUIAPI interface that loads default settings (might add ability to modify options through startup later)
      • Added fix for blocks not having dummy material in ICFancyPack that inherit the Block class directly
      • Dummy id changed to 255
      • Added support for Entities in API
      • Added support for adding mobs to biome spawnlist in API
      • Added support for adding tilentities in API
      • Added fake modloader for to interface with translated mod plugins
      • Added more detailed output when plugin loading fails.
      • Backward incompatible update to 766
      • Added ability to set data on input items in crafting recipe
      • Added ability to comment in startup file with #
      • Added more error handling.
      • Fixed unable to craft out of nonblocks
      • Added more error handling
      • Partial support for GUIs
      • Mod for custom tree generation
      • Custom Tree generation API
      • Custom Tree generation startup file instructions:tree,treebiome and biometreedensity
      • Added mod of org.bukkit.Material to accomodate new block types, should reduce at least some errors other plugins have.
      • Fixed Item id being offset by 256
      • Fixed startup script created Blocks not being added to item list
      • Added more error handling
      • Fixed ItemCraft not starting because of spaces in the path on windows machines
      • Fixed regexp error on windows when starting as plugin
      • More error handling added
      • Fixed freeze when adding new block properties using startup script
      • Now doubles as plugin, so you can start it as a plugin rather than a mod
      • Startup file autocreation
      • loud startup file instruction- prints out more info at startup
      • a whole lot more error handling
      • fixed bug not being able to load any other plugin that KSlopes.jar (what am I thinking)
      • Most if not all simple constant Block properties now definable from the startup file.
      • Better error handling
      • More complete Block API
      • Syntax correction
      • Initial Release
      • Made compatible with IC 1.0
      • Syntax correction
      • More information on startup
      • Fixed slopes and corners dropped having wrong data.
      • Initial Release
      • Introduced options to change settings and IDs
      • Disabled new bookshelves
      • Updated for 1.7.3
      • Fixed another NPE on startup
      • Fixed NPE on startup
      • Updated to unofficial version of 1.6.6
      • changed class path for flower, cactus and reed
      • Fixed not able to place in potted plants
      • Fixed blockcycler interaction
      • Added potted plants
      • Initial Release
      • Updated to 1.7.3
      • Fixed static construction of objects problem
      • Fixed no tree generation
      • updated to 1.6.6
      • fixed clicking on bananacake blocks, fruit leaves
      • fixed using fertilizing
      • fixed activating banana cake
      • Initial Release
      • Updated to 1.6.6
      • Made everything public and even added a public ()V constructor in water mob class (no idea if that will solve it though)
      • Says its loaded on startup when its loaded
      • Initial Release
      16 Bit Entity ID Packet Mod
      • Supports both 16 bit and 8 bit servers
      • Initial Release
      • Fixed conflict with glass bug
      • Initial Release
      • Fixed no output on windows machines.
      • More informative about files to translate not being found.
      • Made it tolerate there being no file separator at the end of retroSource.
      • Removed some spam.
      • Added checks that make sure you have all the necessary maps specified, when you translate.
      • Initial Release
      • Update to 1.7.3
      • Initial Release

      Donate (Not necessary but appreciated)
  2. Offline


    I don't really understand where i take the ICPlugin folder, it says that it will appear when i'm going to launch the server but, in the instructions, it says to put it in the folder before to start the server. And when I try to start the server with the Start.bat, the server window appears but disappears after.

    Can you help me ?
  3. Offline


    So you mean it works when you add the planes mod on the client? :S
  4. Offline


    And now its working I had to install flans plane mod to the client.

    This Is for client Only
    1. Download & Install Risugami's ModLoader
    2. Download & Install SDK's ModLoaderMp
    3. Download & Install GaryCXJk's Turbo Model Thingy
    4. (Optional)Download & Install Risugami's AudioMod
    5. Download Planes v14 from here
    6. Add the contents of the "jar files" folder to the minecraft.jar
    7. Add the contents of the "resource files" to the resources folder
    8. Drag planes.txt and into the .minecraft folder
    9. Delete META-INF folder, if you didn't already
    10. Play
    And step 11. add the 16 bit entity id packet mod

    and you DO NOT have to install flans planes to the server.

    Yes sir I can have a test on some other mods aswell and see what they got in common.

    Same thing when I install only Industrial craft.

    It's like the server does not detect any mods and then you get the packet id 230 error.
    When the server detects a mod but not nesicerly a mod that is installed to the server it let you connect without the error.
    asdaarg likes this.
  5. Offline


    Can someone help me?
  6. Offline


    you don't remove the "meta-inf" folder in bukkit.jar
  7. Offline


    I don't works because when I do that, it says invalid or corrupt file.

    What do I do to make it work, I really have no idea.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  8. Offline


    I can confirm this. I installed Planes Mod and now im able to connect to my Testserver without getting the packet id error.. But i guess installing Planes to make it work cant be the solution. :p
    asdaarg likes this.
  9. Going by the way the ModloaderMP stand-alone version works, if you install the planes mod serverside, you HAVE to have it clientside to be able to connect - maybe its the same now ? I've not had time to set up a test server yet, I'll look into it when I can.
  10. Offline


    Haha well any ModLoaderMP compatible mod should work but still it should work without any mods :p

    put pause on a new line in your start.bat
    java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    Then you can see the error instead of it disapearing in an instant.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  11. Offline


    Just installed SDKs Mods after the instructions given in the "ModLoaderMp for bukkit" Thread. But on the Server i cant craft anything. Or do we have todo sth else?
  12. Offline


    Does the server load the sdk mods you have installed and were did you install them?
    Bukkit.jar or ItemCraft.jar ?
  13. On the Modloader version they had the same problem of the plane crafting not working - in the file both serside and clientside, they had to change the ID of the workbench from 255 to 254 to get it to work.
  14. Offline


    I tried it and it says:
    C:\Users\Alexis\Desktop\RPG Valkyria - Copie>java -Xmx1024M -Xms1024M -cp ItemCr
    aft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    java.lang.NoSuchMethodError: net.minecraft.server.Block.l()Ljava/lang/String;
    at net.minecraft.server.ItemBlock.a(
    at net.minecraft.server.Item.j(
    at net.minecraft.server.StatisticList.a(SourceFile:141)
    at net.minecraft.server.StatisticList.b(SourceFile:78)
    at net.minecraft.server.Block.<clinit>(
    at net.minecraft.server.StatisticList.a(SourceFile:124)
    at net.minecraft.server.StatisticList.<clinit>(SourceFile:59)
    at net.minecraft.server.MinecraftServer.main(
    at org.bukkit.craftbukkit.Main.main(
    C:\Users\Alexis\Desktop\RPG Valkyria - Copie>pause
    Appuyez sur une touche pour continuer...

    Someone know what to do?
  15. Offline


    I did it after the INstructions. Copy class files to craftbukkit.jar in net/minecraft/server.
    Place props in Servermaindirectory.

    And the SDKs props file doesnt have a ID for Workbench. :p
    Ah i see Planes has an extra Workbench so it has nothing todo with SDKs Guns.

    My Server Startup looks like this. Dont know why ModLoaderMP is loaded 6 times?
    2011-07-03 21:33:06 [INFO] Starting minecraft server version Beta 1.6.6
    2011-07-03 21:33:06 [INFO] Loading properties
    2011-07-03 21:33:06 [INFO] Starting Minecraft server on *:25565
    2011-07-03 21:33:06 [INFO] This server is running Craftbukkit version null (MC: 1.6.6)
    2011-07-03 21:33:06 [INFO] [Permissions] (Phoenix) was Initialized.
    2011-07-03 21:33:07 [FINE] ModLoader Server Beta 1.6.6v4 Initializing...
    2011-07-03 21:33:07 [INFO] ModLoader Server Beta 1.6.6v4 Initializing...
    2011-07-03 21:33:07 [INFO] ModLoader Server Beta 1.6.6v4 Initializing...
    2011-07-03 21:33:07 [FINER] Adding mods from G:\test\ItemCraft.jar
    2011-07-03 21:33:07 [FINER] Zip found.
    2011-07-03 21:33:07 [INFO] Done.
    2011-07-03 21:33:07 [INFO] ItemCraft 1.5.1
    2011-07-03 21:33:07 [INFO] Preparing level "world"
    2011-07-03 21:33:07 [INFO] Preparing start region for level 0 (Seed: -137793307111938676)
    2011-07-03 21:33:07 [INFO] ModLoaderMP Beta 1.6.6v4 Initialized
    2011-07-03 21:33:07 [FINE] ModLoaderMP Beta 1.6.6v4 Initialized
    2011-07-03 21:33:07 [INFO] ModLoaderMP Beta 1.6.6v4 Initialized
    2011-07-03 21:33:07 [INFO] [Permissions] version [2.7.2] (Phoenix)  loaded
    2011-07-03 21:33:07 [INFO] Whitelist: Trying to load whitelist and settings...
    2011-07-03 21:33:07 [INFO] done.
    2011-07-03 21:33:07 [INFO] Whitelist version 2.7 is enabled!
    2011-07-03 21:33:08 [INFO] Bukkit version format changed. Version not checked.
    2011-07-03 21:33:08 [INFO] Plugin Essentials Version 2.2.16 geladen, erstellt von Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans and Xeology, ├╝bersetzt von snowleo
    2011-07-03 21:33:08 [INFO] Plugin EssentialsSpawn Version 2.2.16 geladen, erstellt von Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans and Xeology, ├╝bersetzt von snowleo
    2011-07-03 21:33:08 [INFO] Done (0,091s)! For help, type "help" or "?"
    2011-07-03 21:33:43 [INFO] Whitelist: Player Asymetrikon is trying to join...
    2011-07-03 21:33:43 [INFO] allow!
    2011-07-03 21:33:43 [INFO] Asymetrikon [/] logged in with entity id 40 at ([world] 258.131126932429, 64.0, -473.6093946374408)
    2011-07-03 21:33:43 [INFO] Asymetrikon joined with mod_GlasGalore v0.1, mod_Planes 1.6.6v14, mod_SdkFlasher 1.6.6v5, mod_SdkFps 1.6.6v5, mod_SdkGrapplingHook 1.6.6v5, mod_SdkGuns 1.6.6v5, mod_SdkUtility 1.6.6v5
    2011-07-03 21:33:43 [FINE] Asymetrikon joined with mod_GlasGalore v0.1, mod_Planes 1.6.6v14, mod_SdkFlasher 1.6.6v5, mod_SdkFps 1.6.6v5, mod_SdkGrapplingHook 1.6.6v5, mod_SdkGuns 1.6.6v5, mod_SdkUtility 1.6.6v5
    2011-07-03 21:33:43 [INFO] Asymetrikon joined with mod_GlasGalore v0.1, mod_Planes 1.6.6v14, mod_SdkFlasher 1.6.6v5, mod_SdkFps 1.6.6v5, mod_SdkGrapplingHook 1.6.6v5, mod_SdkGuns 1.6.6v5, mod_SdkUtility 1.6.6v5
    Ah i just saw you have to add them to ItemCraft when you go after the Serverlog. Ill try this.
  16. Offline

    Kyle Stilkey

    I can't connect to my server, it's due to ModLoaderMP, when I install it I get a black screen when joining my server, without it I can join just fine.

    Do I need to uninstall the original ModLoader?
  17. Offline


    Ok it worked. You have to place the class files of the ported Mods into Itemcraft.jar in net/minecraft/server.
    I crafted two items one from planes and one from guns and it worked.

    Edit: I fear this will confuse alot of Peolpe. Because now we have two Ways of installing mods. With jars and by altering ItemCraft jar.
  18. Offline


    Same thing with all the new furnaces and stuff in industrial craft you can craft them but you cant use them. :/
  19. Offline


    Yep, I guess ModLoaderMP never was meant to be used alone so this sort of thing didn't happen. We'll have to figure out how to circumvent it. Btw can you place the planes?
  20. Offline


    Ye I can place them they are there and all but you cant see them and you cant get into them
  21. Offline


    Cant test this as the GUI of the Plane Crafting Bench wont open. I can place it but i cant use it.
    The normal Recipes work just fine.
  22. Offline


    we need a stable version for 1.6.6, but we don't need ModLoaderMP.
  23. Offline


    Well I'm of to bed cya!
  24. Offline


    >_<.. when can we get a stable version of itemcraft for 935 ? only itemcraft..
  25. Offline


    Can you please stop spamming the Thread with your Questions?
    Seriously the new Version came out just a few hours ago.
    What about thanking asdaarg for all the work he already did?
    Im really starting to get pissed at people like you. All you can do is demand but not one single Thank you.
  26. Offline


    The job Asdaarg do is really awesome, his mod is one of the best because it's a REAL plugin, we can have new items etc.. but the last update broke my server and i can't rollback in #860 because paintings bug (spam on the floor) make my server lag and my players are really impatient .. sorry asdaarg for spamming. Take your time for making something really awesome, and sorry Asymetrikon too, your job for Baby animals were really awesome too.
  27. Offline


    Can someone help me, I post my question before but nobody answered.
  28. Offline


    SDKs Guns seems to work. I crafted a Desert Eagle and shot a Pig. :p

    One advise: Never install a new Version on your Live Server. Make a local Testserver on your Computer and test it first. Thats what i do to avoid nasty surprises.
  29. Offline


    Okay okay, thank's for tips.
  30. Offline


    Is it working on 953 ? If no, will it be updated ?
  31. Offline


    I've been running IC v1.4.x with Bukkit 860 just fine; but when I move to Bukkit anything beyond 910 (and with any version of IC), none of my other plugins would load. This is the server output:

    16 achievements
    20:17:48 [INFO] Starting minecraft server version Beta 1.6.6
    20:17:48 [INFO] Loading properties
    20:17:48 [INFO] Starting Minecraft server on *:25565
    20:17:48 [INFO] This server is running Craftbukkit version null (MC: 1.6.6)
    20:17:49 [INFO] DataSourcePool [MinecartManiaCore] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    20:17:49 [INFO] SubClassFactory parent ClassLoader []
    20:17:49 [INFO] Entities enhanced[0] subclassed[2]
    20:17:50 [INFO] ControllerBlock: 1.18 by Hell_Fire
    20:17:50 [INFO] ControllerBlock: Using IRON_BLOCK (42) as ControllerBlock, loaded 0 disallowed types from config
    20:17:50 [INFO] [Permissions] (Yeti) was initialized.
    20:17:50 [INFO] [Permissions] version [3.1.6] (Yeti) loaded
    20:17:50 [INFO] class com.asdaarg.bukkit.itemcraft.ICS
    20:17:50 [INFO] ItemCraft 1.3.6
    20:17:50 [INFO] class com.asdaarg.bukkit.itemcraft.ItemCraft
    20:17:50 [INFO] ItemCraft: ICKSlopes 0.1 Loaded.
    20:17:50 [INFO] ItemCraft: ICFancyPack 0.2.5 Loaded.
    20:17:50 [INFO] ItemCraft: ICMCreatures 0.1.2 Loaded.
    20:17:50 [INFO] ItemCraft: ICNTrees 0.1.3 Loaded.
    20:17:50 [INFO] ItemCraft: ICSGlass 0.1.1 Loaded.
    20:17:50 [INFO] Preparing level "bworld"
    20:17:50 [INFO] Preparing start region for level 0
    20:17:51 [INFO] Preparing spawn area: 73%
    20:17:51 [INFO] Preparing start region for level 1
    20:17:52 [INFO] Preparing spawn area: 73%
    20:17:53 [INFO] SubClassFactory parent ClassLoader []
    20:17:53 [INFO] Entities enhanced[0] subclassed[2]
    20:17:53 [INFO] SubClassFactory parent ClassLoader []
    20:17:53 [INFO] Entities enhanced[0] subclassed[2]
    20:17:53 [INFO] ControllerBlock: 1.18 by Hell_Fire
    20:17:53 [INFO] ControllerBlock: Using IRON_BLOCK (42) as ControllerBlock, loaded 0 disallowed types from config
    20:17:53 [INFO] [Permissions] (Yeti) was initialized.
    20:17:53 [INFO] Done (0.312s)! For help, type "help" or "?"

    My normal server output runs longer than this, showing all of my other plugins being enabled. Has anyone seen this problem? Any lead is appreciated.

Share This Page