Inactive [MECH/DEV] ItemCraft 1.6.6 - Support for client mods in Bukkit [1060/1000]

Discussion in 'Inactive/Unsupported Plugins' started by asdaarg, May 3, 2011.

  1. Offline




    ItemCraft is a Bukkit mod that allows adding new item and block types, crafting and furnace recipes, and custom tree generators and more. Using a Modloader and SettingsGUI interface it allows subplugins known as ICPlugins to be loaded to support client mods. ICPlugins can be created by translating a client mod using the ICTranslator ICplugin. Using a ModloaderMP interface (ported by krnlyng/liar) it allows porting multiplayer mods to bukkit.

    • Add more Block types
    • Add more Item types
    • Add more Entity types
    • Add more TileEntity types
    • Add more Crafting recipes
    • Add more Smelting recipes
    • Add more Tree generators
    • Ported ModLoader interface
    • Ported ModLoaderMP interface
    • Fake GUIAPI Settings interface
    • Startup file for configuring plugins and making simple blocks and items

    Installation & Usage:
    • Back up your world(s). Just in case.
    • ItemCraft.jar goes in same folder as craftbukkit
    • IC plugins go into ItemCraft/ICPlugins folder under craftbukkit. (folder is autocreated the first time)
    • uncomment (remove #) in front of all plugins you want to use in plugins.ics (autocreated in ItemCraft/ICScript)
    • Make sure you have the recommended version of craftbukkit in the title - since this is a mod of that version in particular.
    • Delete/rename the META-INF folder inside craftbukkit-0.0.1-SNAPSHOT.jar (Use some decent zip program (e.g. 7zip) that can do it.)
    • All players on the server needs to have the client mods installed
    • If you use the 16 bit entity id packet mod (in case you use new entites (only ICMCreatures need it)), All players need (flan's unofficial) ModLoaderMP client mod
    • All players also need the 16 bit entity id packet mod (overwrites a ModLoaderMP's class so make sure ModLoaderMP is installed first) in case you use new entites (only ICMCreatures need it) If decide not to use the packet mod, you can turn it off putting this in your startup file: false setEntityIDPacketMod
    • Sometimes you get block/item ID conflicts, between plugins. You then need to set the conflicting ids in the startup script using setID command: example. They have to be set before the plugin that uses them is loaded. Note also that there is typically a props file on the clientside you have to edit the ids on to be the same as well.
    • To start:
      • Windows:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      • Others:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar:craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      IF You do not understand how to install this follow THIS link! Also Try:

      ItemCraft Forum
      ItemCraft Wiki


      Installation instructions changed since 1.5

      For Minecraft 1.7.3

      Inofficial ItemCraft update by Syrome1.6.6 (#1060)
      ItemCraft 1.6.5 (#1000)
      QwertyPower files (ICSGlass, ICFancyPack addons and more...)
      o4kapuk 16 bit packet mod Does not work without (flan's unofficial) ModLoaderMP client mod.
      ICKSlopes - support for Kaevator SuperSlopes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use Ignore ScotTools or you will have problems breaking various blocks
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.7.3 mod Details regarding use of potted plants IDs and settings
      User ported mods list maintained by icephantom

      For Minecraft 1.6.6

      ItemCraft 1.4.5
      ItemCraft 1.5.1 (for use with planes)

      ItemCraft 1.3.5 (for CB #818)
      ICSGlass - support for ChocolateySyrup's Stained Glass unofficial update for 1.6.6 mod
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.6.6 mod Details regarding use of potted plants Also be sure to read: Release notes Does not work well and not at all with the newest FancyPack update(v6) Wait until client is stable.
      ICKSlopes - support for Kaevator SuperSlopes
      Usage notes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use
      ICMCreatures - Support for DrZhark's Mo's Creatures
      16 bit entity id packet mod
      User ported mods list maintained by Asymetrikon

      Dev tools:
      ICTranslator - How to use

      Source and old versions

      ICScript documentation

      Frequently Asked Questions

      Tutorial on how to make your own blocks also list of block and item IDs in most popular mods.

      Suggestions of mods to port
      Vote here not in this thread anymore (it gets lost in all the other stuff)

      Reporting errors:
      • Read known issues - don't report those.
      • State the version of CB, ItemCraft and ICPlugin(s) you have problems with
      • If your client crashes, start the client from command line so that you get the error report.
      • Make sure the mod(s) works in SSP First before you report any errors here.
      • You are more likely to get a response if you describe the problem in more detail and do some testing yourself first of under what circumstances it occurs
      • Do not ask for uploads of minecraft.jar.
      • Do not pm me.
      • If you have problems installing, you are likely doing something wrong. Make sure you've followed the instructions exactly, read the FAQ and Wiki. If that doesn't work you can always ask in the thread, while I will likely not reply, there are others who can help you with your problem. But at least try to get it working yourself first.

      That said, I want to thank all who have helped users with their problems. In particular special thanks to icephantom and Asymetrikon for their big efforts in this. Also a special thanks to xeronut for being generally helpful.

      Changelog: (open)

      • Inofficial update by Syrome to support CB #1060 and ModloaderMp v1.7.3v4.
      • Added changes by krnlyng/liar to support buildcraft
      • Inofficial updated by Qwertypower to support CB #1000
      • Fixed Generators not working since ModLoaderMP merged.
      • Added option to turn off packet230 being sent to clients: false setPacket230OnLogin
      • @QwertyPower's unofficial update to 1.7.2 and 1.7.3.
      • Fixed issues with ICPlugins not being able to use ModLoader methods obtained through relection.
      • Merge with @krnlyng/liar's translated vesion of SDK's ModLoaderMP
      • Added dummy method RegisterTileEntity to fake modloader.
      • Added dummy methods AddArmor and getUniqueSpriteIndex to fake modloader.
      • ItemCraft commands are now loaded automatically and can be used in init.ic
      • Fixed nonesense message when parsing a string and EOF is found after escape character.
      • Platform independent line breaks of autocreated files
      • added some stuff in the autocreated file
      • Fixed unupdated mod causing problems for other plugins accessing the enum's constants for new block ids 1.6.
      • Removed spam on use command
      • Fixed java method invocation
      • Added javamethod invocation of declared methods
      • Fixed pop removing 2 elements off stack
      • putsetting command, allowing editing settings using new script
      • putvar and getvar commands allowing use of variables in scripts
      • added if command, conditional execution of closures
      • ishidden, isCustomType and getCustomType commands
      • exec command, allowing execution of closures. Acts as function calls.
      • while command, for while-loops, execution of closures.
      • Annotation of non-standard methods allowing correction of semantics during parsing with methods that manually alter type info. (needed for for loops, and various stack commands (such as popall, push, pull,dup, casting, getvar, all that do not have a static type signature) to have any usefulness beyond execution using GUI.
      • added casts
      • Fixed setEntityIDPacketMod demanding a this pointer.
      • Fixed boolean constants missing.
      • Updated to CB #860
      • GUI is now off by default
      • Fixed illegal access of Item constructor and other methods
      • 16 bit Entity Id Packet mod can now be turned off
      • Added file loading functions that use filename rather than file class for Fileman, for use with Janino
      • Fixed intellisense being screwy, showing previous context
      • Fixed castability test of primitive types to primitive types being screwy
      • Fixed selected method in context view not being visible (scrolled down/up to).
      • Fixed array bounds error
      • added intellisense (context box showing sorted list of all applicable methods in context at cursor position, as well as selecting the one closest matching)
      • added tooltips showing documentation both in command box and in the context (list) box
      • added getmaterial method to get Minecraft's materials
      • added documentation to most methods.
      • removed some obsolete methods
      • renamed some methods
      • remove NAME: spam on classloaderlclass, 1,2,3 4.. spam and vs: spam
      • fixed classloaderlclass leaving junk on stack
      • fixed getconstructor (?)
      • fixed right square bracket without left square bracket not resulting in parse error
      • fixed parse to fail due to right bracket not yielding an array type
      • removed autocreate double spam
      • ics extension changed to ic (conflicting with korganizer and iCalendar)
      • moved plugins into plugins.ic (since it now doesn't execute "use" until it parsed the whole file, it doesn't
      • recognize ItemCraft functions in init.ic)
      • added setID
      • added back support for old file format using includeold
      • fixed execution of abstract script calling providing arguments in wrong order
      • ICScript is now completely converted into postfix
      • Completely rewritten script parsing and execution code
      • Math functions should work now
      • Scripts Are not executed until fully parsed
      • ICS now support direct invokation of java functions when no ICS function matches a call
      • ICS now support arrays
      • ICS now support closures (for later support for menus, functions, loops, conditionals)
      • Parser produces Abstract code that runs much faster, than when having to parse each time to execute code.
      • Pre 1.0-style startupfile scripts are no longer supported (for now)
      • Warning of Block loss with prompt to quit CB on any error during parsing
      • Warning of Block loss with prompt to quit CB if startup script file was not found and was autocreated. This way you can have it autocreate it safely without having to worry about loss of blocks during upgrade.
      • Detailed error reports during both parsing with line number and column and during execution.
      • added simple math functions
      • added basic string and character functions
      • fixed methods popping more than one element
      • fixed dup not duplicating
      • added primitive classes
      • added parsing of primitives as primary commands
      • added parsing of strings as primary commands
      • fixed identifier after a string being misparsed
      • fixed popup menus not working in windows
      • added methods to get icplugins and their classloaders
      • added methods to get constructors and invoke them
      • Implemented new functional script language ICScript
      • Implemented GUI
      • inclusion of files (so you can split up startupfile in smaller files)
      • loading plugins on the fly
      • executing any script commands on the fly using GUI
      • exploring variables and functions of objects in GUI
      • invoke any functions, private or public, on any class loaded in IC/ICPlugins/minecraft/CB/any bukkit plugins
      • Built in text editor (was going to be for editing java code)
      • Removal of blocks, entities and items, even on the fly
      • Adding new blocks, entities and items on the fly
      • Specify what entities spawn in what biomes and how frequently.
      • Customizable programmable menus per node type in GUI
      • IC now retrieves version number both for plugins and itself automatically and reports it when plugins are loaded
      • fixed mimic having target object mimic itself.
      • fixed invokation on wrong object when interacting with mimiced block
      • fixed setint setting a string and not an int
      • fixed case sensitivity of block parameters
      • fixed some other bugs related to block parameters
      • no more commas assigning multiple values in block parameters (because I'm lazy)
      • Mobs that are unspawnable don't crash the server anymore
      • Added new startupfile commands: blocks and entites
      • Added new startupfile commands: setbool, setint, setfloat, setdouble, that allows changing the settings of mods that use GUIAPI (nandonalt trees and mo's creatures)
      • fixed various bugs with craft command in startup script
      • removed debug spam on id command
      • fixed comments causing "unknown commands" in startup file
      • cleaned up unnecessary stuff from error report
      • fixed skip skipping over the next line too
      • Implemented modloader removespawn (could that have anything to do with the watermob problem?)
      • fixed unknown command spam on empty lines
      • fixed some bugs with craft command in startup file manager.
      • Fixed kicked when horse throws you off because of accessing protected field
      • Fixed problems adding recipes, tile entites, entites using API.
      • added items command for debug purposes
      • added a copy of spawncreatures to the mod, no idea if that will solve the issue with sharks crashing server.
      • Mimic feature of block allows block to mimic other blocks, fully or in some respect (useful to customize blocks beyond the fixed values from startup file)
      • back to start from craftbukkit folder; its no longer a plugin
      • IC plugins go into ICPlugin folder now in craftbukkit folder. These are to avoid problems caused by plugins being reloaded by CB
      • usedefaults on by default
      • fix item 0 is not valid item spam
      • implemented Modloader getUniqueEntityId,RegisterEntityID,setPrivateValue
      • implemented various SettingsGUI widgets facades, and SettingFloat, SettingsMulti
      • script pauses when error occurs to avoid startup with wrong settings
      • Items are also registered as dummy, to avoid error spam by other plugins
      • Modloader world generator interface for normal type worlds implemented
      • Barebones fake GUIAPI interface that loads default settings (might add ability to modify options through startup later)
      • Added fix for blocks not having dummy material in ICFancyPack that inherit the Block class directly
      • Dummy id changed to 255
      • Added support for Entities in API
      • Added support for adding mobs to biome spawnlist in API
      • Added support for adding tilentities in API
      • Added fake modloader for to interface with translated mod plugins
      • Added more detailed output when plugin loading fails.
      • Backward incompatible update to 766
      • Added ability to set data on input items in crafting recipe
      • Added ability to comment in startup file with #
      • Added more error handling.
      • Fixed unable to craft out of nonblocks
      • Added more error handling
      • Partial support for GUIs
      • Mod for custom tree generation
      • Custom Tree generation API
      • Custom Tree generation startup file instructions:tree,treebiome and biometreedensity
      • Added mod of org.bukkit.Material to accomodate new block types, should reduce at least some errors other plugins have.
      • Fixed Item id being offset by 256
      • Fixed startup script created Blocks not being added to item list
      • Added more error handling
      • Fixed ItemCraft not starting because of spaces in the path on windows machines
      • Fixed regexp error on windows when starting as plugin
      • More error handling added
      • Fixed freeze when adding new block properties using startup script
      • Now doubles as plugin, so you can start it as a plugin rather than a mod
      • Startup file autocreation
      • loud startup file instruction- prints out more info at startup
      • a whole lot more error handling
      • fixed bug not being able to load any other plugin that KSlopes.jar (what am I thinking)
      • Most if not all simple constant Block properties now definable from the startup file.
      • Better error handling
      • More complete Block API
      • Syntax correction
      • Initial Release
      • Made compatible with IC 1.0
      • Syntax correction
      • More information on startup
      • Fixed slopes and corners dropped having wrong data.
      • Initial Release
      • Introduced options to change settings and IDs
      • Disabled new bookshelves
      • Updated for 1.7.3
      • Fixed another NPE on startup
      • Fixed NPE on startup
      • Updated to unofficial version of 1.6.6
      • changed class path for flower, cactus and reed
      • Fixed not able to place in potted plants
      • Fixed blockcycler interaction
      • Added potted plants
      • Initial Release
      • Updated to 1.7.3
      • Fixed static construction of objects problem
      • Fixed no tree generation
      • updated to 1.6.6
      • fixed clicking on bananacake blocks, fruit leaves
      • fixed using fertilizing
      • fixed activating banana cake
      • Initial Release
      • Updated to 1.6.6
      • Made everything public and even added a public ()V constructor in water mob class (no idea if that will solve it though)
      • Says its loaded on startup when its loaded
      • Initial Release
      16 Bit Entity ID Packet Mod
      • Supports both 16 bit and 8 bit servers
      • Initial Release
      • Fixed conflict with glass bug
      • Initial Release
      • Fixed no output on windows machines.
      • More informative about files to translate not being found.
      • Made it tolerate there being no file separator at the end of retroSource.
      • Removed some spam.
      • Added checks that make sure you have all the necessary maps specified, when you translate.
      • Initial Release
      • Update to 1.7.3
      • Initial Release

      Donate (Not necessary but appreciated)
  2. Offline


    Actually now whenever the server runs that error happens.
  3. Offline


    Do you have the needed mods installed? Sorry if I misread it, but it sounded like you only have the 16 bit ID pack installed.
  4. Offline


    Yes I have all the mods needed installed.
  5. Offline


    It can't find the files in specified folder.
  6. Offline


    I see the word 'dolphin' in your report, from your server. In the main post is something stated about watermobs, if the crash the server.

    asdaarg says in his main post:
    For some people watermobs crash the server. The solution for now is to move those classes into the craftbukkit jar in the same sub folder.

    Maybe this is a solution, other than that, I wouldn't know. Everything works fine in singleplayer?

    Yeah, but the point is, the specified folder contains the needed files. but the plugin does not seem to find them. I checked and double checked, but the files are there, happily existing in the right folder.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  7. Offline


    Yes everything works fine in singleplayer now.
  8. Offline


    I see it!
    You have ICMcreatures 0.1.1, you need 0.1.2 for 1.6.6. Download the latest version.
  9. Offline


    :confused: Looks like java is getting the better of me.
    I'm working on this mod :
    I've done the translation and have the .java files
    BlockColoredSand, BlockStainedGlass, EntityColoredSand, ItemColoredSand, mod_coloredsand, RenderColoredSand, & TmimMod

    I thought mod_coloredsand would be the main class but inside I found this line:
    class mod_coloredsand extends TmimMod

    and inside this line exists:
    public abstract class TmimMod extends BaseMod

    now I'm assuming is the base

    I made the plugin.yml and added "import com.asdaarg.bukkit.itemcraft.ItemCraft;" to
    but am unsure what I'm doing after that point.

    I think these lines at the bottom are the one I put inside "public void ItemCraftInit(MinecraftServer ms) { }"
        private int Pield_100040_terrainIndex;
        private int Pield_100042_myterrainIndex;
        private boolean Pield_100043_bound;
        private static HashMap Pield_100045_map = new HashMap();
        private static File Pield_100041_file;
        private static BufferedWriter Pield_100046_configWriter;
        protected String Pield_100044_modName;
                File file = Minecraft.U_unc_6240_b/*getMinecraftDir*/();
                file = new File(file, "config");
                Pield_100041_file = new File(file, "tmim.conf");
                Pield_100046_configWriter = new BufferedWriter(new FileWriter(Pield_100041_file, true));
            catch(Exception exception) { }
    Oh, what is everyone else using to recompile?
  10. Offline


    I don't understand why i have no java files in the java folder. This is what i have

    PS: i give you an extern link because the message in the console is HUGE!!

    Please give me your entire itemcraft folder i don't succeed having java files

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  11. Offline


    Well nao everything works!
  12. Offline


    I am happy because I succeeded in helping you XD

    Well, to be honest, I think he is confusing it with the java files which are extracted from your minecraft.jar, instead of the actual translated files.

    I've misread, probably. I am very curious on how he managed to actually translate something.

    What I think is a bit strange, it always says "\ not found.".
    Why does it have that backslash?
  13. Offline


    I cant help you wiht your Problem, but i translated MicroCubes. So maybe someone who knows how todo the last Steps can have a try at it.
    Some files didnt get translated, but they werent native files so i dont know what todo with them. I added them in the folder nottranslated.

    When soneone else wants to have stomething translated, he can ask me. I dont know how to do the whole process. But im happy to help as far as i can. :)
  14. Offline


    Hm, what should I add :
    public void ItemCraftInit(MinecraftServer ms) {

    Maybe I should just give someone the folder with the translated mod so someone can finish it :p
  15. Offline


    Here is the setup I used:
    it is configured to work from root c:

    The steps I used:
    Take an unmodded minecraft.jar , add wanted mod and supporting mods.
    [in my case install mod loader then better stained glass]
    If you can play single player and the mod works it is done right.

    put the modded minecraft.jar into "C:\Mod_Port_Server\ICtranslate"
    extract only the mod to be translated into "C:\Mod_Port_Server\ICtranslate\mod"
    [in my case only]

    Run translateMCP.bat , your java folder should have files now

    Run START SERVER.bat in "C:\Mod_Port_Server"
    when its done stop the server and goto "C:\Mod_Port_Server\ICtranslate\translatedmod"

    I can't help further because that's where I'm stopped
  16. Offline


    Translated PlanesMod too.
    There was only one file that didnt get translated. Its ip.class. I looked it up should be ShapedRecipes.
    But when i try the singletranslate command i get a error. I copied asdaarsgs command and just changed the needed things.

    "java.lang.String" class [ "" ] "c:\\planesnew\\" translate
    2011-06-20 22:11:59 [INFO] "java.lang.String" class [ "" ] "c:\\planesnew\\" translate <-- Argument #1 type mismatch != java.lang.String for translate <String[]> <File> @ Line 1 Col 77
    Planes Translated(ip.class in nottranslated):

    Just saw that i still have the Translation of PlasticCraft i tried to port.
    As far as i can see all Files translated.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  17. Offline


    it wants a File not a string. Type "file" before translate and it should work.

    Note: It does not translate files with $ in them, these are nested classes, and jad doesn't handle them. I'm not sure how to go about with this. Maybe try various decompilers.

    Edit: Apparently jode decompiles them. Looks like that's our way out of this.

    Edit: Apparently jad supports inner classes too, with some exceptions. So I guess I can leave it as it is (it ignores all files containing $).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  18. Offline


    Hmm with this:
    "java.lang.String" class [ "" ] "c:\\planesnew\\" file translate
    I get this:
    2011-06-20 23:12:58 [INFO] "java.lang.String" class [ "" ] "c:\\planesnew\\" file translate <-- Argument #0 type mismatch [Ljava.lang.String; != [Ljava.lang.Class; for translate <String[]> <File> @ Line 1 Col 82
    Have newest Versions of everything btw.
  19. Offline


    So this can be used for a bukkit server? Im just a little confused on that
  20. Offline


    Why does the Fancystone+waterbucket=mossycobblestone not work? :(
  21. Offline


    Asdaarg, how do you compile the java files? o_o
  22. Offline


    You need an IDE to compile them into a jar file. I use eclipse or you can use netbeans. To understand it more you might want to look at the craftbukkit how to make a plugin tutorial.

    Also, tried to translate Millenaire at my first go at this...think it gave me about 38 lines that didn't translate over. Maybe not the best mod to try and go for first with so little java knowledge.
  23. Offline


    Yay just found out how to reference Itemcraft and Bukkit with NetBeansProjects. :D

    Heres a Tutorial (note this is only for NetBeans):
    1. Right Click on your Project.
    2. Click Properties
    3. Choose Category "Libraries"
    4. Add Itemcraft.jar and Bukkit.jar with the "Add jar/folder" Button
    5. Done :)

    I feel a bit stupid now cause its so easy. :p

    Edit: Managed to compile a small Testmod i made, after getting rid of some Errors. Looked some things up that got translated wrong. Tomorrow ill try to find out how to pack the whole thing properly into a .jar. And then hopefully ill port the first Real Mod. :)

    Edit2: One Question i have though.

    import com.asdaarg.bukkit.itemcraft.ItemCraft;

    gives me a unused import warning(yellow) in NetBeans. But it compiles without errors. Is this correct?

    Edit3: For all who are interested heres the Code without Errors from my Testmod.

    package net.minecraft.server;
    import com.asdaarg.bukkit.itemcraft.ItemCraft;
    public class mod_GhostCraft extends BaseMod
        public void ItemCraftInit(MinecraftServer ms)
            ModLoader.AddName(Pield_100131_ghostwood, "Ghost Wood");
            Pield_100131_ghostwood.textureId/*blockIndexInTexture*/ = ModLoader.addOverride("/terrain.png", "/ghostcraft/ghostwood.png");
        public String Version()
            return "v0.1";
        public static Block Pield_100131_ghostwood;
            Pield_100131_ghostwood = (new BlockGhostWood(248, 0)).c/*setHardness*/(3F).b/*setResistance*/(2000F).a/*setStepSound*/(Block.i/*soundMetalFootstep*/).a/*setBlockName*/("ghostwood");

    package net.minecraft.server;
     public class BlockGhostWood extends Block
        protected BlockGhostWood(int i, int j)
            super(i, j, Material.WOOD/*wood*/);
        public boolean a/*isOpaqueCube*/()
            return false;
        public int func_234_g/*getRenderBlockPass*/()
            return 1;
  24. Offline


    The test worked well enough, looking at what was done though....I concluded I wouldn't be able to replicate all of that so I am now using the test server as my server. So far things are working swell. :)

    Thanks for the help!
  25. Offline

    Michael Murphy

    Having an issue here with ModLoader.RegisterEntityID(). What am I doing wrong? I decompiled mod_mocreatures.class with DJ to peak at what it does, but it just says net/minecraft/server/<entityclassname>
    and this is not syntax for java, so I assume it's a decompiling/translation issue. Here's a pretty picture that's probably worth 1000 words of explanation. It's saying it can't find the EntityAirship, yet it's clearly there. It exports, but it says with compile errors, so I figured it wouldn't load. I will try it for the lulz anyways.
    edit: Should've expanded my referenced libs - they're both there. - The wonderful people in #risu explained that i needed to pass EntityAirship.class ( which I didn't realize [for that matter know existed] would point to the class)[​IMG]
  26. Offline


  27. Offline


    Haven't ventured into your thread for a while, how are mo creatures doing? Still the same as pre 1.6? :)
  28. Offline


    EDIT: EDIT: Been working on porting Mystic's Ore since you posted the instructions. Managed to resolve my previous two issues. Server started up, logged in successfully with Mystic's Ores running along with Mo Creatures, though encountered another error that I'll attempt to resolve. Will update laters.
  29. Offline

    Michael Murphy

    Alright, I wanted to make sure my code was alright first. I was looking for where the Vehicles are popped into existence and it looks like the Item calls that code ( For boats ItemBoat ) And it all seems to be there. However when I right click with it, it does not appear, but the item disappears, so here's the code to it. Let me know what I'm doing wrong, I've commented out the parts I didn't think I would need, however there's a few I wasn't sure about. - EntityAirship - ItemAirship - mod_Airship
    I can use the regular mod for this, and I don't have to use the one that was used for translation, correct?
    Maybe it has something to do with calling
    ModLoader.RegisterEntityID(EntityAirship.class, "Airship", ModLoader.getUniqueEntityId());
    and not having it line up with the correct ID on the client side. If anyone has an idea what I should do, please let me know. The server isn't kicking me, nor erroring, and the client is not crashing.
  30. Offline


    Question about the Fancy pack. I installed it and it works but not really. I cannot make chimneys and when I make chairs and walls and such they don't place with their backs to me like they should. Any ideas? Nevermind I am just dumb. I didn't realize how they placed until just now. Disregard this post entirely.
  31. Offline

    Michael Murphy

    Did you read the OP post about how the newest one is not working correctly, and that you should use the previous version on the server side? You'll find that any vertically stacked items will crash your client, with the newest ( or atleast I did)

Share This Page