[MECH] CraftBook - Redstone bridges, gates, minecarts, ICs, more [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 27, 2011.

  1. Offline


    CraftBook adds a number of original gameplay elements to Minecraft from switchable bridges to elevators to gates (including flood gates)! It also has redstone support, allowing you to wire up pumpkins and use integrated circuits!

    Some cool stuff people made last year:

    • Mechanisms
      • Bridges
      • Doors *not yet ported*
      • Gates
      • Elevators
      • Cauldrons
      • Light switches
      • Readable bookshelves
      • Toggle areas (advanced toggle doors and bridges)
      • Hidden switches
      • Custom block drops
      • Apple tree drops
      • Bookshelf drops
      • MORE!
    • Redstone
      • Integrated circuits
      • Programmable logic chips
      • Redstone pumpkins
      • Redstone netherstone
      • Ammeter
      • MORE!
    • Minecart features
      • Booster blocks
      • Brake blocks
      • Reverse blocks
      • Ejector blocks
      • Chest-storage minecart transfer blocks
      • Station blocks
      • Sort blocks
      • Message announcer block
      • Minecart dispensers
      • Change minecart behavior
      • MORE!

    CraftBook is being developed again, although by someone else. Get the latest downloads here: http://dev.bukkit.org/server-mods/craftbook/

    [​IMG] (CraftBook is open source!)
    kazeen, dragon8510, Jaein and 45 others like this.
  2. Offline


    and yes... "You do not have permissions to do that!". it's really annoying when u don't have permission to craftbook... maybe they should fix it...
  3. Offline


    it is fixed...
  4. Offline


    when did they fix this? i still get it. u'r using alpha2 right? Because my players still get it.

    The lower rank players that does not have access to craftbook get that error in the chat box!
  5. Offline


    I fixed it by adding craftbook.mech.cauldron permission to everyone.
  6. Offline


    it was fixed in a night build.
  7. Offline


    is it possible that you can add a “state change triggered ic”. So it sends out a short peak, if the state change?
    Something like this, where “i” is the input and “o” th output:
    t  0  1  2  3  4
    i  0  1  1  1  0
    o  0  1  0  0  0
    You could add following options: Trigger on rising-edge or falling-edge (or both) and a “peak” length. In my example the trigger was only rising-edge and the peak length = “t”.

    If you have no time to add this IC I could implement this and create a pull request. But at least I want to know, if this IC will be added sometimes.

  8. Offline


    why do the bridges and gates doesn't work anymore??
  9. Offline


    and where do i get the "night build"
  10. Offline


    So do minecart dispensers work?
  11. Offline


    They're due for alpha 3 I believe.
  12. Offline


    how can i give my players access to all the mc's? like "craftbook.ic.mc.*"?
  13. Offline


    So guys I need ur help!
    Running bukkit server ver 677, installed in root directory WorldEditor 4.3, and installed the latest version of CraftBook in plugins directory.
    So when I first run the server, in plugins directory within 4 .jar files of CraftBook appeared 4 directories with same names.
    Then I logged in game and tried to build a BRIDGE, but it doesn't worked :O
    So what I've done wrong?

    or the reason is that Bukkit ver. 677 is too new for all these plugins?
  14. Offline


    When players right-click anywhere, they have a "You don't have permission tu use this." message on their chat. How do I remove that ?
    I tried to set the "craftbook.ic.safe.*" and "craftbook.ic.restricted.*" permissions for all my players, but it does not change anything.
    The only way to get rid of this was to set the "craftbook.*" permission on for everybody. But isn't it too much ?

    - craftbukkit #677
    - permissions 2.7
    - worldedit 4.3
    - craftbookcommon 3.0-alpha2
    - craftbookmechanisms 3.0-alpha2

    All with default configuration file (my plugins folder content here).

    Attached Files:

  15. Offline


    Sorry for the lack of updates and news lately. I have been busy. On top of that I have my Minecraft server to update and add stuff to too, plus needing to actually play it sometime.

    However, I do have free time from time to time, and you can track that here:
    https://www.google.com/calendar/b/0/[email protected]

    Generally releases will rarely ever be made outside slots indicated on that calender (because I don't work on them usually outside those times) and I will try to keep you updated.

    Remember that all my plugins are open source and you are encouraged to help out if possible.
  16. Offline


    WHY ISNT DUMBLEDORE RESSURECTING! Omg its soo annoying :p
  17. Offline


    - craftbook.mech.* should help, perhaps -craftbook.mech.cauldron
  18. Offline


    i tested this on my server and it turned out to be a conflict with worldedit+craftbook.... replace craftbook with falsebook for now and see if it works =/..
    still testing whether that actually works though xP
  19. Offline


    FOUND BUG: you can get infinite itens using brigde...
  20. Offline


    I didn't get the gates and the minecart stations working with Craftbook (maybe an issue with Worldedit ?)... I've installed Falsebook to try.
  21. Offline


    Hey what is about new Bukkit 1.5 ?
  22. Offline


    sorry to say, but it didn't work. I had a 5 clock pulse on the input. (front of the sign), but it didn't work :(
  23. Offline


    On my server it worked. Does the “Sensor created”-message appear? And do you use the second alpha?

  24. Offline


    Try it with a simple pushbutton to check if you made the IC & daysensor correct.
    Enter my server during European evening hours, I'll show it to you.
    (make sure you use 1.4, I'm not updating as long 1.5 is full with bugs)
  25. Offline


    Not a bug, clearly stated in the readme that this can happen, depending on how the bridges are configured.

    I'm currently using craftbook and worldedit, gates are working.

    Haven't messed with minecarts though.
  26. Offline


    Gates are broken in 1.5_01, hey ?
  27. Offline


    i think that it need to get updated for 1.5
  28. Offline


    Hey! Could you implement a "MC1510", this would be very awesome :D

    Thanks! Jopi
  29. Offline


    hello i was hoping some one could tell me what i'm doing wrong with the perlstone here is what i tried:
    second line [MC5000] then i just get the unknown ic detected
    second line [Code block] no message about it being created
    second line [MC5032] then i just get the unknown ic detected
    i know that atm craftbook wont work proporly before it gets updated for 1.5
    tried this in 1.4 tho
    so any there have a clue why it did'nt work?
  30. Offline


    @Ghostetr: Here you have all implemented ICs, and no MC5XXX at the moment. So you have to wait.

  31. Offline


    It does kind of work in 1.5 . Bridges and elevators always worked fine in 1.5 (or 1.5_01) but for me gates didn't. Those are the 3 most common things used on my server, so I was trying to work out how to get gates to work, and I got it !
    Right clicking on the gate is now broken, so if you use a lever and redstone torch it will work fine.
    Is my very nice diagram. The -- is redstone wire, the / is a lever , the i is a redstone torch and the | is a sign with [gate] on the second line. It works for me, but it doesn't always work, it will randomally glitch out with fences not going the whole way down and stuff, but about 1 in 2 times it works fine.

Share This Page