[MECH] CraftBook - Redstone bridges, gates, minecarts, ICs, more [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 27, 2011.

  1. Offline


    CraftBook adds a number of original gameplay elements to Minecraft from switchable bridges to elevators to gates (including flood gates)! It also has redstone support, allowing you to wire up pumpkins and use integrated circuits!

    Some cool stuff people made last year:

    • Mechanisms
      • Bridges
      • Doors *not yet ported*
      • Gates
      • Elevators
      • Cauldrons
      • Light switches
      • Readable bookshelves
      • Toggle areas (advanced toggle doors and bridges)
      • Hidden switches
      • Custom block drops
      • Apple tree drops
      • Bookshelf drops
      • MORE!
    • Redstone
      • Integrated circuits
      • Programmable logic chips
      • Redstone pumpkins
      • Redstone netherstone
      • Ammeter
      • MORE!
    • Minecart features
      • Booster blocks
      • Brake blocks
      • Reverse blocks
      • Ejector blocks
      • Chest-storage minecart transfer blocks
      • Station blocks
      • Sort blocks
      • Message announcer block
      • Minecart dispensers
      • Change minecart behavior
      • MORE!

    CraftBook is being developed again, although by someone else. Get the latest downloads here: http://dev.bukkit.org/server-mods/craftbook/

    [​IMG] (CraftBook is open source!)
    kazeen, dragon8510, Jaein and 45 others like this.
  2. Offline


    thanks!! that helped!!
  3. Offline


    okay i dont really understand how to set up permissions for craftbook...how do i set the permission for example for the usage of elevators?...can someone please post an example line...pls!
  4. Offline


    The base permission node is craftbook.mech.[mechanismname]. So for elevators/lifts, it's craftbook.mech.lift. Cauldrons would be craftbook.mech.cauldron.

    I had this same problem on an old version of CraftBook. If memory serves, you have to remove the blocks on either side of the block the sign is on. This way, the sign won't think that it has to build a bridge under it and will build one above it. Also, make sure the [Bridge] text is facing away from the bridge.

    Here's a picture to illustrate what I mean:


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  5. Offline


    When i use the laste version of this plugin, and try to set a block it get a error! "You have not permission to do this" but the block are put down fine.

    Btw.. Dit it work with bukkit 670??
  6. Offline


    pls bug fix
  7. It works with 670 fine, and to get rid of that error read the Change Log as was stated. You have to add craftbook.mech.* to your permissions. This will stop your "You do not have permission to do this" error.

    Hope this helped.
  8. Offline


    Are there any permission nodes??
  9. Offline


    This. I'd like to see more specific info regarding the CraftBook permissions. The craftbook.mech.* node doesn't work; non-admin players on my server can't use mechanisms other than cauldrons. Listing them out (craftbook.mech.lift, etc.) gives the same result. IC permissions do the same thing. I've tried the permission nodes listed in the changelog, and none of it works. We are running Bukkit 617, current CraftBook, WG and WE.
  10. Offline


    I used craftbook.mech.* to get rid of that issue with the error message, but right clicking interferes with mcMMO. fix please?
    Trottimus likes this.
  11. Offline


    I was looking for those too. There should be something made about on his Wiki.
  12. Offline


    The wiki will be updated soon. Once all of the permission nodes are confirmed working and also:

    craftbook.mech.elevator -Build a lift
    craftbook.mech.elevator.use -use a lift

    That should be correct I'll double check when I get home.
  13. Offline


    thanks that was bugging the hell out of me yesterday on my server. +1
  14. Offline


    After some toying around with permissions, I finally got them working. Since there is little to no proper documentation and the support in the #craftbook IRC is shoddy at best (my experience only; yours may vary, in defense of some folks over there), I'll post the permission nodes here that are working for me (craftbukkit 670, current WG, WE and CB):

    craftbook.mech.lift (I have both of these because I'm not sure which one is the correct one. I think it's .elevator.)
    Jiggster and Lolmen like this.
  15. Offline


    It's elevator but there's also a .use permission :)
  16. Offline


    Is this compatible with EssentialsGroupManager? (GroupManager)

    craftbook.mech.* is not working for me.
  17. Offline


    When mod it is included, drop dropping out after death it is not visible. How it to correct?
  18. Offline


    @Xemnas33 Thanks for the clarification. My lifts seem to be working for non-admins without the .use permission.

    @seriosbrad Don't use the craftbook.mech.* node. List them out instead, like I have in my previous post.
  19. Offline


    I'm sure you're getting spammed with people complaining about this error, but just in case this isn't the case. Whenever someone without the permission node -'*' or without operator status places a block it says the do not have permission to place it. However, the block stays put. Anyways, great plugin and again, my apologies if you are getting spammed with this error.
  20. Offline


    If you join the CraftBook IRC chat, you can get a fixed version that doesn't spam you with the permission Node error
  21. Offline


    Yep, I tried that too I'm afraid

    Confirmed, working!

    Edit: If anyone installed EssentialsGroupManager, remove your old GroupManager directory. Essentials will rename itself to GroupManager and any plugins requiring Permissions/GroupManager should work again. They don't know to look under the EssentialsGroupManager directory.
  22. Offline


    Why did you add sender (MC1111) and didnt add reciever (MC0111)?
  23. Offline


    The download link is broken for me. Mirror please?
  24. Offline


    The message "you don't have permission to use this" when an average user (not an OP) right clicks something or places a block is caused by a conflict between Worldedit and Craftbook. I dont know why but I am absolutely sure that's the problem. I deleted all craftbook files from my server and the message is now gone and when i run my test server with ONLY Worldedit and Crafbook the error "you don't have permission to use this pops up. And that only happens when you have both running on one server.

    EDIT: Actually if you like/need craftbook you can just delete the CraftbookMechanisms Jar file and the CraftbookMechanisms folder from your plugins folder and the problem will go away. Thats probably the best solution.
  25. Offline


    same here.
  26. Offline


  27. Offline


    i dont exactly understand how to instale and set it up with permissions could anyone help. Thank.
  28. Offline


    Because the 0111 is a self-triggered IC. They haven't been added yet however the MC1110 and MC1111 work fine.

    It is down to a bug with craftbook. As said above it was fixed though.
  29. Offline


    hey, i found a problem with craftbook 3.0 alpha 2, its causing the "You dont have permission to do this" problem for permissions, just throwing it out there...
  30. Offline


    same issue here, it was fixed. read above on this page.
  31. Offline


    Hey, i was updateing the new version now it comes when a "member" try to destroy a sign
    [SHOP]oi, you dont have the permission.
    I use Bettershop, but i have the right permissions, all the time it was work, now with the new craftbook version it comes.
    And when the member destroy the sign after the message the sign comes back.
    Only admins can destroy the signs.

Share This Page