Inactive [MECH] CommandSigns v0.9 - Issue commands using signs [953]

Discussion in 'Inactive/Unsupported Plugins' started by Fluff, May 5, 2011.

  1. Offline


    CommandSigns v0.9

    Tired of having to type out the same commands again and again? Want to allow your players to use commands only at certain places? Help is at hand!

    Feature Summary
    • Allows chat commands and chat messages to be send on right-clicking a sign.
    • Allows commands to be run on signs that players wouldn't be able to use through chat.
    • Sign usage can be limited to specific players or groups.
    • Supports 'variables' for player name and x,y,z position.
    • Won't allow users to gain access to forbidden commands without permission (secure).
    • Add a cost to use a sign, or a reward for clicking the sign!
    • Limit the number of times a sign can be used.
    • Enable and disable signs without destroying them.
    • Permissions-friendly
    • Developer API available
    User's Guide

    About The Developers

    Want to ensure your bug or suggestion isn't lost in the thread? Post it on our issue tracker.

    Command Summary (open)

    • /commandsign enable - Enables the next command sign you right-click on.
    • /commandsign enable <x> <y> <z> - Enables the command sign at x,y,z in the current world.
    • /commandsign enable <x> <y> <z> [w:]<world> - Enables the command sign in world <world> at x,y,z.
    • /commandsign enable [a:]<alias> - Enables the command sign at the alias.
    • /commandsign enable <uses> - Enables the next command sign you right-click on with a number of uses.
    • /commandsign enable <uses> <x> <y> <z> - Enables the command sign at x,y,z in the current world with a number of uses.
    • /commandsign enable <uses> <x> <y> <z> [w:]<world> - Enables the command sign in world <world> at x,y,z with a number of uses.
    • /commandsign enable <uses> [a:]<alias> - Enables the command sign at the alias with a number of uses.
    • /commandsign disable - Disables the next command sign you right-click on.
    • /commandsign disable <x> <y> <z> - Disables the command sign at x,y,z in the current world.
    • /commandsign disable <x> <y> <z> [w:]<world> - Disables the command sign at x,y,z in world <world>.
    • /commandsign disable [a:]<alias> - Disables the command sign at the alias.
    • /commandsign alias - Right-click on a block to get the alias of its location.
    • /commandsign alias <x> <y> <z> - Get the alias of the location x,y,z in the current world.
    • /commandsign alias <x> <y> <z> w:<world> - Get the alias of the location x,y,z in world <world>.
    • /commandsign alias [a:]<name> - Right-click on a block to set the alias of its location.
    • /commandsign alias <x> <y> <z> [a:]<name> - Set the alias of the location x,y,z in the current world.
    • /commandsign alias <x> <y> <z> w:<world> [a:]<name> - Set the alias of the location x,y,z in world <world>.
    • /commandsign alias remove - Right-click on a block to remove the alias of its location.
    • /commandsign alias remove [a:]<name> - Removes the alias.
    • /commandsign alias remove <x> <y> <z> - Remove the alias at location x,y,z in the current world.
    • /commandsign alias remove <x> <y> <z> w:<world> - Remove the alias at location x,y,z in world <world>.
    • /commandsign alias [a:]<name> [a:]<newname> - Set the alias of the location at <name> to <newname>.
    • /commandsign config - Lists all the configuration nodes.
    • /commandsign config <node> - Lists the configuration node.
    • /commandsign config <node> <value> - Sets the configuration node to the value.
    • /commandsign exec [a:]<alias> - Executes the command sign at the location pointed to by the alias.
    • /commandsign exec <x> <y> <z> - Executes the command sign at location x,y,z in the current world.
    • /commandsign exec <x> <y> <z> [w:]<world> - Executes the command sign at location x,y,z in world <world>.
    Syntax Summary (open)

    • [command] - use on the first line of a sign to define a command sign.
    • **[title] - use on the first line in place of [command] to customise the title of the sign
    • /command - runs a command as the player using the sign
    • /*command - runs a command as the fictional user &CommandSigns
    • /@command - elevates the player's permissions (using the permissions assigned to &CommandSigns) if necessary to run the command
    • @player/group - commands following (up to the next @) are limited to that player/group.
    • \message - prints the message to chat
    • \\message - prints the message to the player
    • <NAME> / <X> / <Y> / <Z> / <I> - replaced with the using players name/x/y/z-coord/current held item id on running.
    • $;<cost1>[;<costN>] where cost is <item id>,<item number> or <item id>:<item data>,<item number> - adds a cost to the sign
    • $$ - break evaluation of a command sign
    Permission Nodes (open)

    • commandSigns.use - Use a command sign.
    • commandSigns.create - Create, enable, or disable a command sign.
    • commandSigns.super - Create, enable, or disable a command sign using /*command, /@command, @player/group, or $.
    • commandSigns.super.cost - Create, enable, or disable a command sign using $.
    • commandSigns.super.elevated - Create, enable, or disable a command sign using /@command.
    • commandSigns.super.fakeuser - Create, enable, or disable a command sign using /*command.
    • commandSigns.super.restricted - Create, enable, or disable a command sign using @player/group.
    • commandSigns.default.<default group name> - A flag stating that the group is the default group.
    • commandSigns.config - Allows a user to manage the configuration.
    • commandSigns.alias - Allows a user to manage aliases.
    • commandSigns.exec - Allows a user to remotely trigger command signs.
    Reporting a Problem (open)
    The following bits of information are helpful to include when reporting a problem:
    1. Bukkit and plugin version.
    2. Excerpt from server log of the failed command usage, preferably with the debug configuration option set to true.
    3. Complete command sign text.
    4. Command sign configuration file.
    5. Name of plugin that the failed command comes from, preferably with a link to the plugin's forum thread.

    Recommended Plugins
    • With Annotate, you can have CommandSigns on practically any block with an almost unlimited amount of room for commands! They can even activate when pressing a button or a pressure plate!
    • With ScrollingMenuSign, your signs can look even nicer while allowing your users to scroll through a menu of commands!

    Download Latest Version
    MD5: 7f4076eea7198f2c0f17cde3f62f7c1f
    Download 0.8.1i - RB 803 and previous
    MD5: 72a60e16bfd775b3d15a03aca70e86e0


    To Everyone Asking For Redstone Support (open)

    Yes, I also think redstone support would be very cool. Unfortunately, there are some major limitations on what you can do with a redstone-controlled sign. You can read about those limitations in this post, and you can read a rationale about why those limitations exist in this post. Given those two limitations, I don't think redstone support is currently a useful feature to add, especially given what Annotate can do for you. (If you disagree, please post on the issue tracker on how you would use redstone support.) In the (not too distant) future, redstone support may will be added in a separate plugin due to the different nature of redstone command signs.

    Change Log
    version 0.9 - See Post
    • If PEX permissions work, this plugin supports it.
    • Economy redone; added Essentials Economy.
    • Localization support added.
    • Added new command: /commandsign exec
    • Events properly unregistered when plugin is disabled.
    version 0.8.13
    • Default groups should work for real.
    Older Entries (open)

    version 0.8.12
    • Added handling for default groups.
    • Added support for command aliases.
    • Added /commandsign config.
    version 0.8.11
    • Fixed @ directive.
    • Fixed '/commandsign disable' bug.
    • Added aliases.
    version 0.8.10
    • Fixed /@ permissions error.
    • Added exception handling for removing permissions from users.
    version 0.8.9
    • Added PEX and Permissions 3.0 support.
    • Added new placeholders: <N> and <I>
    • Fixed bug with regular / commands.
    • Added new directives: $$ and \\
    • Added additional debug messages.
    version 0.8.8
    • Fixed /* and /@ working without permissions support.
    • Fixed Permissions creating new users with the wrong casing.
    version 0.8.7
    • Fixed command sign creation permissions.
    • Added debug configuration option.
    version 0.8.6
    • Added Permissions checks to developer API.
    • Fixed enabling bug with /* and /@.
    • Updated to work with GroupManager and fake Permission plugins.
    version 0.8.5 - See Post
    • Fixed multi-world Permissions bug.
    • Changed @ group directive
    version 0.8.4
    • Removed support for Permissions 3.x
    • Updated to 818
    version 0.8.3
    • Fixed API bug
    version 0.8.2
    • Updated for Permissions 3.x
    version 0.8.1
    • Fixed GroupManager integration
    version 0.8
    • Added /@ to temporarily elevate a user's permissions.
    • Added developer API.
    version 0.7.1
    • Fixed item data bug - for real, this time.
    version 0.7 - See Post
    • Removed SignReadMore support.
    • Added Annotate support.
    • Added more granular permissions for advanced sign creation.
    • Removed a debug message that looked like an error.
    version 0.6.2
    • Fixed enable bug on sign creation.
    • Fixed item data bug.
    version 0.6.1
    • Fixed berating of users who can't create command signs but were just innocently putting up a sign.
    version 0.6
    • Added SignReadMore support.
    version 0.5.1
    • Can no longer place blocks directly on enabled command signs.
    • Fixed @ directive.
    • Changed fake user network code.
    version 0.5 - See Post
    • Added /commandsign commands.
    • Added finite-use signs.
    version 0.4.10
    • Fixed BOSEconomy support
    version 0.4.9
    • Supports BOSEconomy
    version 0.4.8
    • Trimming commands in hopes it fixes some problems.
    version 0.4.7 - See Post
    • Added cost signs.
    version 0.4.6
    • Hackish solution to 'items not showing up in inventory' bug.
    version 0.4.5 - See Post
    • Updated support for GroupManager.
    • Added configuration option to change the display name of the fake user.
    • Added configuration option to allow command parser to understand // commands.
    version 0.4.4
    • Fixed numerous bugs when not using Permissions.
    • Beginnings of an API for other plugin devs.
    version 0.4.3
    • Added configuration file.
    • Fixed chat command bugs.
    • Rearranged code for simpler maintenance.
    version 0.4.2 - See Post
    • BREAKING CHANGE - The fake user is now named &CommandSigns.
    version 0.4.1
    • Fixed for 740
    version 0.4
    • Bukkit team trying to break everything again
    version 0.35
    • Fixed conflict when using <NAME> in commands overriding permissions.
    version 0.3
    • Added NAME, X, Y and Z variables
    • Added permission filter
    • Allowed creation of signs that call commands user would not usually have access to
    • Allowed customisation of [command] to other text.
    version 0.15
    • Bugfix ("Insufficient Permissions" annoyance bug)
    version 0.1
    • Plugin Released
    Dimochka, c_dric, Flipp and 5 others like this.
  2. Offline


    With that sign, you shouldn't need any permissions. It should just say 'test message' from the fake user.
  3. Offline


    You mean it should say 'test message' from the user that clicked it :p

    And yeah, I just realised the message command wouldn't need the fake user permissions and came back to edit it... Oh well

    As long as the user has 'commandSigns.use' it should work, unless message signs don't even need permissions?
  4. Offline


    Oh yeah, that's how it works. Yeah, as long as the user has commandSigns.use, it should work.
  5. Offline


    First, thank you Fluff for making and maintaining these plugins, they really improve the immersion factor for our tiny server.

    Second, my problem is that CommandSigns always generates an error whenever a command sign is left clicked. After much troubleshooting I have yet to get the plugin to work. Since it looks like most people are getting CommandSigns to work I assume something is wrong with my setup, but I have no idea what I've done wrong. In looking over this thread it seems that this type of error came up due to multiworld problems, and I am running with the MultiVerse plugin.

    In short: This is no big deal but any insights or observations from anyone here would be much appreciated.

    CraftBukkit version: 803
    CommandSigns version: 0.8.8 (but I have tried 0.8.1c with the same results)
    Log Excerpt (open)
    2011-06-08 15:11:07 [SEVERE] Could not pass event PLAYER_INTERACT to CommandSigns
    java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V
        at com.edwardhand.commandsigns.CommandSigns.runCommandString(
        at com.edwardhand.commandsigns.CommandSignPlayerListener.runCommand(
        at com.edwardhand.commandsigns.CommandSignPlayerListener.onPlayerInteract(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(
        at net.minecraft.server.ItemInWorldManager.interact(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet15Place.a(SourceFile:57)
        at net.minecraft.server.NetworkManager.a(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(

    This error is generated with all of the following signs (but [command] does turn green)
    Command sign #1 text:
    /*time day
    Command sign #2 text:
    /@time day
    Command sign #3 text:
    /time day
    Config File (open)
        fakeUserDisplayName: CommandSigns
        writeDebugMessages: true
        useOldGroupDirective: false
        useOldCommandSignsUser: false
        ignoreSpacesAtEndOfLine: false
        allowRunOnCommands: false

    Names of plugins that might be involved:
    • Permissions version: 2.7.4 (was also running with 2.7.3 during a previous attempt)
    • CommandBook(slimmed down to just the core and /time functionallity)
    • MultiVerse for multiple worlds.
    • Annotations (which works flawlessly, thanks!)
    • ScrollingMenuSign (which will execute the command /time day when CommandSigns is removed)
    Also, here is my permissions file for the default world 'Nexus' where i placed the signs:
    Permissions (open)
            system: default
            default: true
                build: false
            default: false
                build: true
                - Default
            default: false
                build: true
                - '*'
                    group: Admins
                    group: Admins
                    group: Admins
                    group: Admins
                    group: Admins
                    group: Admins
  6. Offline


    Based on the error you posted, I'm pretty sure this is your problem. I may have forgotten to compile 0.8.1c against 803 instead of 818, though I thought I tested it. I'll push a new 803-compatible version out for you tomorrow.
  7. Offline


    I granted Default users commandSigns.use, created a user called &CommandSigns and made them an op and admin user. It still doesn't work. Hell, with debug on a regular user clicking the sign gets no messages at all in the log. :(
  8. Offline


    This is one of those things that is possible to program, but it's not really setup to do. As an alternative, you could setup the sign to grant the reward and then warp them somewhere else. You could also setup a command sign at the beginning of a maze that puts the player in a new group, and then check for that group on the reward sign at the end; if the player is in the maze group, reward the player and remove the player from the maze group.
    That's surprising. I'll check and possibly add some more debug messages to help track this down.
  9. Offline


    Ah, that makes sense. I really should get up to speed with RB 818 anyway.

    I'll try the 803 compatible plugin when you get it up, but I'm totally fine with upgrading too.

  10. Am seeing these now:

    "10:32:34 [INFO] ! CommandSigns Error: Couldn't find the permissions file!"

    I realize it's related to the earlier reported issue, just odd they suddenly appeared today and not before, haven't changed a sign ><
  11. Offline


    Is there a way to have the sign send a message just to the player activating it?

    I can use HeroChat to send a pm from &commandsigns, but then the chat displays the name "&commandsigns" and changing the display name in the config doesn't appear to change this since it's only within commandsigns.

    Also, using a command sign with /* generates an [INFO] ! CommandSigns Error: Couldn't find the permissions file!

    It still works though.
  12. Offline


    There will be in today's release. The problem with using HeroChat's PMs is that they are sent using the player's real name, not their display name. /msg out of some plugins will appear to come from the display name.
  13. Offline


    Using the /*msg command (from essentials) with a command sign results in this, and no output in-game:

    17:22:06 [INFO] ! CommandSigns Error: Couldn't find the permissions file!
    17:22:06 [SEVERE] javax.script.ScriptException: Wrapped java.lang.NullPointerException (<Unknown source>#150) in <Unknown s
    17:22:06 [SEVERE]       at com.sun.script.javascript.RhinoScriptEngine.invoke(
    17:22:06 [SEVERE]       at com.sun.script.javascript.RhinoScriptEngine.invokeFunction(
    17:22:06 [SEVERE]       at nickguletskii200.SpyerAdmin.CustomHandling.playerMsg(Unknown Source)
    17:22:06 [SEVERE]       at nickguletskii200.SpyerAdmin.SpyerAdmin.onCommand(Unknown Source)
    17:22:06 [SEVERE]       at com.earth2me.essentials.Essentials.onCommandEssentials(
    17:22:06 [SEVERE]       at com.earth2me.essentials.Essentials.onCommand(
    17:22:06 [SEVERE]       at org.bukkit.command.PluginCommand.execute(
    17:22:06 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(
    17:22:06 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    17:22:06 [SEVERE]       at com.edwardhand.commandsigns.CommandSigns.runCommandString(
    17:22:06 [SEVERE]       at com.edwardhand.commandsigns.CommandSignPlayerListener.runCommand(
    17:22:06 [SEVERE]       at com.edwardhand.commandsigns.CommandSignPlayerListener.onPlayerInteract(
    17:22:06 [SEVERE]       at$9.execute(
    17:22:06 [SEVERE]       at org.bukkit.plugin.RegisteredListener.callEvent(
    17:22:06 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.callEvent(
    17:22:06 [SEVERE]       at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(
    17:22:06 [SEVERE]       at net.minecraft.server.ItemInWorldManager.interact(
    17:22:06 [SEVERE]       at net.minecraft.server.NetServerHandler.a(
    17:22:06 [SEVERE]       at net.minecraft.server.Packet15Place.a(SourceFile:57)
    17:22:06 [SEVERE]       at net.minecraft.server.NetworkManager.b(
    17:22:06 [SEVERE]       at net.minecraft.server.NetServerHandler.a(
    17:22:06 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    17:22:06 [SEVERE]       at net.minecraft.server.MinecraftServer.h(
    17:22:06 [SEVERE]       at
    17:22:06 [SEVERE]       at
    Not knowing java this tells me nothing. I see a bunch of plugin names in there though, namely SpyerAdmin and Essentials, no idea what spyer has to do with this though.

    The command works when used in the chat.
  14. Offline


    [INFO] ! CommandSigns Error: Couldn't find the permissions file!
    Permissions 3.x
  15. Offline


    Per his reply to me on this exact same subject, Permissions 3.x is not supported by this plugin, only 2.x. Support for Permissions 3.x will be part of a later release.
  16. Offline


    Arrrggg..... [pig]
    Please Permission 3.x support ;)
  17. Offline


    0.8.9 and 0.8.1d released.

    In theory, 0.8.1d should continue to work with RB 803. I can't test because I don't have a backup of my 1.5 client.

    All sorts of goodies in this one. Permissions 3.0 and PEX should be supported. I completely reworked how CommandSigns (and all my other plugins) supports permissions, so be prepared for the possibility of funkiness here. In addition, I found a bug with regular / commands not working. That should be fixed. Lots of debug messages were added in hopes of tracking down any remaining bugs.

    New stuff! A couple of new placeholders: <N> is a shorter version of <NAME>, and <I> returns the numeric item id of the item held by the player. In addition, there are two new directives for use on CommandSigns. \\ will send a message only to the triggering player. $$ will break execution of a command sign; you won't have to use an unfulfillable cost any more.

    I didn't test this one rigorously, just a few pokes at it to make sure it generally worked. As always, let me know what I broke. v1.0 won't be this Friday. There's a big piece that I was trying to finish in time for this release, but it'll have to wait for the next one. In addition, the developer API isn't complete. Once both of those are finished, it'll be released as 1.0.
  18. Offline


    Hey, I just dropped 0.8.1d into my 803 server and everything worked straight away. I'll continue testing of course, but I just wanted to let you know how it went. There is so much that this plugin lets us do. I'm so excited!

    It's great that you are willing to support the older version of Bukkit in the first place. Now I can take my time upgrading. Good luck on your push for version 1.0 and thanks for using your kick ass developer powers to bring more awesome to Minecraft!
  19. Offline


    In other news, I just had a freaking amazing idea. If you'll recall the last time I had one of these, it lead to Annotate. I'm super excited about this one; I just have to make sure it's possible with all the permission plugins. Tune up your imaginations and be ready for 0.9 and the accompanying sister plugin; I can't even count all the possibilities that this will open up.
  20. Offline


    Yep, I'm afraid there is some funkiness... testing this with CommandSigns 0.8.9 and Permissions 2.7.4.

    Created a sign:

    /@time set day
    It enables it OK, but right-clicking gives me "You don't have permission to set the time." (this is from General). This worked in 0.8.8.

    Relevant extracts from Permissions/world.yml:

         - general.time.set
            default: false
                prefix: ''
                suffix: ''
                build: true
            - Default
            - commandSigns.*
            group: Moderator
            permissions: []
            group: CS
    And another minor regression, though I think the old behaviour might have been undocumented. This sign:
    made me say "hello" when right-clicking before, but now does nothing - I need to put \hello on the sign. Same applies when I send the command via the runCommandString() API call.

    Also seems to be a problem with Permissions 3.1.5b and CommandSigns 0.8.9. Same sign as above:

    /@time set day
    gives the same permissions error. But I've verified permissions for &CommandSigns:

    >pr &CommandSigns w:world has general.time.set
    09:35:26 [INFO] [Permissions] User/Group has that permission.
    /* commands seem to work fine, by the way. The above using /*time set day worked.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  21. Offline


    @Fluff use MCNostalgia from It can downgrade to every client version and isn't the hardest to use.
  22. Offline


    Aye, I knew about that behavior, but I wasn't sure it was necessarily good or bad. In this version I took it out to reduce the chance of user error confusion. If this is important behavior for someone, I can add a legacy option to revert back to it.

    I'll take a look at the other reported issues. I'm pretty sure they are command parser errors instead of permission errors due to it working with /*.

    EDIT: Found and fixed the problem. It'll be in the next release.
  23. Aah I think that is my issue also, will look forward to next version, was trying to use Annotate as well.
  24. Offline


    0.8.10 and 0.8.1e released.

    The /@ processing is fixed. Also, /@ should be more robust in removing permissions from users. Before, if an exception was thrown in the plugin that actually has the command, the permissions would not be removed. Now they at least have a chance to be removed, and if they can't be removed there should be a message in the server log.
  25. Offline


    Hi Fluff,

    I had a problem earlier with 0.8.8 (with Permissions 2.7.4 - craftbukkit 819) that the @g:default didn't recognize new players that were part of group 'default' by default but didn't have an entry in the world.yml file yet. For players who already have an entry in the permission file, it worked fine.

    Now i just tried the new update 0.8.10 and it looks like the @g:groupname option is completely ignored.

    This is the commandsigns for that button :

    @g:default /*checkpoint remove <NAME>
    @g:default /*user -setgroup u:<NAME> s:ffa
    @ /@warp ffa
    As a member of the 'admins' group, i was set in group 'ffa' after using that command.

    Also, a command that used to work fine for all players/groups, '/killstats', now returns a warning about the player missing permissions.
  26. Offline


    If the admins group (or any other group) inherits from the default group, that should happen. The @ directive should obey group inheritance. Let me know if this is not the case so I can hit my test signs again.

    Also, you don't need the second @g:default statement. Everything after the first @ directive will continue to use it until the next @ directive.

    I'll look into /<command> again. It shouldn't be messing with permissions at all.
  27. Offline


    Hello, I had a problem, I haven't understood as to add a command for example I write on the table

    /aircraft pilot

    And to me writes that such command isn't present. Write please that it is necessary to register to add such command/aircraft pilot or /aircraft turn left/
    (Write please just as it is necessary to write in a chat)
    Thankful in advance.
  28. Offline


    Here are the relevant parts of my permissions file.
    VIP/builders and above are setup not to inherit the groups below.

            system: default
            default: false
                prefix: '&6'
                suffix: ''
                build: true
                rank: 0
            - goldies
            - '*'
            default: false
                prefix: '&6'
                suffix: ''
                build: true
                rank: 0
            - sg0
            default: false
                prefix: '&a'
                suffix: ''
                build: true
                rank: 0
            - vip
            default: false
                prefix: '&a'
                suffix: ''
                build: true
                rank: 0
            inheritance: null
            default: false
                prefix: '&b'
                suffix: ''
                build: true
                rank: 0
            inheritance: null
            default: false
                prefix: '&7'
                suffix: ''
                build: true
                rank: 0
            inheritance: null
            default: true
                prefix: '&f'
                suffix: ''
                build: true
                rank: 0
            inheritance: null
    The commandsign executed :

    @g:default /*checkpoint remove <NAME>
    @g:default /*user -setgroup u:<NAME> s:ffa
    @ /@warp ffa
    The debug info i get

    07:24:36 [INFO] [Permissions] Reload of World Zero completed.
    07:24:36 [INFO] . CommandSigns Debug: Adding permissions to c_dric
    07:24:36 [INFO] . CommandSigns Debug: Adding permission essentials.* to c_dric
    07:24:36 [INFO] . CommandSigns Debug: Adding permission g:sg0 to c_dric
    07:24:36 [INFO] . CommandSigns Debug: Adding permission jobs.* to c_dric
    07:24:36 [INFO] . CommandSigns Debug: Adding permission * to c_dric
    07:24:36 [INFO] . CommandSigns Debug: Fake player is op; opping c_dric
    07:24:36 [INFO] . CommandSigns Debug: Removing permissions from c_dric
    07:24:36 [INFO] . CommandSigns Debug: Removing permissions from c_dric
    07:24:36 [INFO] . CommandSigns Debug: Removing permissions from c_dric
    07:24:36 [INFO] . CommandSigns Debug: Removing permissions from c_dric
    07:24:36 [INFO] . CommandSigns Debug: Removing op from c_dric
    It seems to be doing a lot of things i don't understand.
    The plugins involved in that sign are MyWarp, MinrCheckpoint & PermissionsPlus to setgroup 'ffa'.
  29. Permissions now work somewhat better, great stuff!

    Yet still an issue, am using annotate:

    /*time night

    That's in the file. However, currently ANY user can use this sign, thus not requiring group Teacher. The iConomy currency is taken correctly.
  30. Offline


    0.8.11 and 0.8.1f released.

    The @ directive is fixed. In addition, a bug with disabling command signs is fixed.

    A new feature: aliases. An alias is basically a friendly name for a specific location in a world. I don't have time right now to fully explain how to use them, but they're in there. I'll post with more information if I have time later, or I might just wait for 0.8.12, which is going to add an additional command.
  31. Offline


    Updated to 0.8.11 & cb860 (with Permissions 2.4.7)

    My simple /killstats buttons are still refusing to work, even though everyone can use /killstats.
    It worked fine up to 0.8.8.

    The signs with @g: seems to work now. But users with no entry in the worldname file, members of 'default' by default, still can't use a command after a @g:default.

    Debug as op/admin. Seems to work, it didn't change my group as i was 'admins'

    Debug as default with no entry in worldname.yml
    Didn't detect me as g:default so no group change.

    Debug as default with entry in worldname.yml.
    It worked now, my group was switched.


Share This Page