[MECH] Archers v1.0 - Advanced Archery [1.5R0.1]

Discussion in 'Archived: Plugin Releases' started by 1337, Apr 27, 2011.

  1. Offline


    Archers (Reborn) - Made by [1337]
    I - Introduction
    Archers, makes archery way more powerful and fun! It has a big list of special arrows who can be enabled/disabled easily with Permissions.
    Here is a quick list of its possibilities:
    • Powerful Arrows Light things up with Fire and Lighting arrows, Blow things up with TNT arrows, morph monsters, and the mighty Nuke arrow
    • Fun Arrows generate new trees, make mobs fly up and teleport
    II - Download
    III - Installation and configuration
    • Check the Permission nodes below:
      • Code:
        archers.bow.(arrow name) - Needed to fire the bow
    IV - Usage
    It is really easy. If you type /arrow a list with available arrows will pop up, if you need more information. Just type /arrow (arrow name), and you can see what ammo it uses, and what you too enable it. Also if you dont have permission for a arrow it shows up red, if you do have permission it shows up green

    V - Final note
    Suggestions, Questions or bug reports: Post them in this Thread!
    You can also post, what you want to be updated first. That would also really help me :)
  2. Offline


    There IS a new permissions update, thats all I know. its 3.0 now, and says some plugins will be incompatible until fixed, so I stayed on 2.whatever ;)

    Then again I didn't update to 803 yet...
  3. Offline


    This may be it.. I have permissions 3.
  4. Offline


    Thats probably it then. Do you want my older permissions.jar to test/use?
  5. Offline


    If you wouldn't mind posting that, that would be lovely!
  6. Offline


    Ok then i blame permissions :D ill update after i have done my homework :D
  7. Offline


    Any idea about my suggestion?
  8. Offline


    Would cause a lot of lag when used, looping through the map and finding items

    Anyone got a link to the new permissions? there not on the permissions thread afaik?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  9. Offline


  10. Offline


    Ok thanks,fixing now

    Ok fixed it :D will add new download link in the morning though. here is the changelog to keep you busy though:
    Fixed permissions
    Fixed steal arrow - as mentioned in this git hub issue : https://github.com/X1337X/Archers/issues/1

    Also future bug report should be made as a issue on git hub if possible :D thanks

    http://bit.ly/Archerstwopointtwo - 2.2 with permissions and steal arrow fix,now im of to bed night :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  11. Offline


    Would it be possible to tweak the plugin to give certain arrows redstone compatibility?
    So when the player hits a certain block it redstone activates the block like a button or plate?
    Would be fun for shooting competitions on our server :)

    have fun & enjoy ur day

    EDIT: At least also great: certain arrows can interact with buttons/plates :)
  12. Offline


    I could turn the block it lands on into a pressure plate or a on redstone wire?
  13. Offline


    Sadly, Im still getting the same error. :(

    I really don't know what's going on with this anymore..
  14. Offline


    hmm ok give me a sec i thought just rebuilding against permissions would fix :/
  15. Offline


    :'(No permission 3.0+ support?
  16. Offline


    Hey everytime i try to set this up (diff versions of premmissions, etc) i get a different error and either the plugin doesnt work fully, or i can do /arrow but the /arrow (name) fails; also, if i try to shoot arrows i lose them and they don't appear. Can you send me your permissions folder and your archer folder? this is the only thing i could think of... i really want to use this plugin. Thanks
  17. Offline


    I'm getting this error when running the mod...
    01:02:53 [SEVERE] Error occurred while enabling Archers v2.2 (Is it up to date?)
    : com.nijikokun.bukkit.Permissions.Permissions cannot be cast to com.nijiko.perm
    java.lang.ClassCastException: com.nijikokun.bukkit.Permissions.Permissions canno
    t be cast to com.nijiko.permissions.PermissionHandler
            at TechGuard.x1337x.Archers.Archers.setupPermissions(Archers.java:52)
            at TechGuard.x1337x.Archers.Archers.onEnable(Archers.java:33)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:134)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:112)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    When I fire arrows I hear the sound, but no arrows fire... but the ammo disappears.
    I also get this error.

    2011-06-01 01:07:33 [SEVERE] Could not pass event PLAYER_INTERACT to Archers
        at TechGuard.x1337x.Archers.pListener.onPlayerInteract(pListener.java:75)
        at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:299)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
        at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:209)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:556)
        at net.minecraft.server.Packet15Place.a(SourceFile:57)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    *Edit* using Craftbukkit 818 & Archers 2.2
    guess it doesn't work with the latest craftbukkit :(
  18. Offline


    What's up with that? Download link and title say 2.1, but eveybody talks about 2.2?
    Please try to keep the OP up-to-date?
  19. Offline


    Where is the changelog ?


  20. Offline


    I've been getting this exact same error. I've tested against 818 and 803, where it has previously worked for me; no luck. I've also tried it with Permissions 2.7.4 and 3.1. Errors all around.

    D'oh, while typing this up, I suddenly realized what's wrong. The download only gives you the .jar file, while the plugin ALSO requires a config.yml and arrows.ammo file! Does anyone have a copy of these files they would be willing to share?

    EDIT: Found these on page 11 of the thread.

    EDIT2: Nevermind, even adding the config files didn't help. Same error with finding permissions.
  21. Offline



    Is this plugin still being developed? Would be a shame to lose such a good plugin...
    Still hoping for the crafting permission thing, but by the looks of it there are more pressing issues to deal with. Is 2.3 on the horizon!?
    Many thanks, hoping you find the time and energy...

  22. Offline


    DAMN alerts, sorry i havnt been active,my alerts died again. The craftpermissions is easy now, as i will be using @Afforess 's bukkitcontrib

    You need permissions....
    Not yet, will update soon sorry for any problems caused by this
    Should auto make the files on enable if they are not there

    Whats the error you get?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  23. Offline


    The error that Soryo and I have had blocked the creation of the config files. I tried removing permissions; it created the config files and then turned off because of no permissions, as was expected. When trying with *any* version of permissions, the error returns. I've tried removing all other plugins, so it's not a conflict issue.
  24. Offline


    is archers no longer compatible with essentials? it used to work fine with essentials (uses groupmanager for permissions i think) could you add essentials support?
  25. Offline


    Hmm I will see what I can do with permissions
  26. Offline


    Well, I tried rebuilding the plugin using Permissions 2.7.4 and CB818 as the imports; seems to work for now. Not sure if it's as simple as that, or if this is only a quick hack-together that could be bad in the long-run.

    Just in case anyone else is getting that error, try this (at your own risk): http://dl.dropbox.com/u/11098231/Archers.jar
  27. Offline


    Found the cause of the permissions error, fixing now, should have 2.3 out today, which will contain that fix. 2.4 will have crafting permissions :D

    Ok i have it fixed, but i am going to delay the release, cause i am going to add crafting permissions and custom speed and damage, just so people are ready the permission for crafting will be archers.craft :D
    for now just use the custom build posted above, it works and has no bad code in it(i checked) so i fully suport that build and will help with any error :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  28. Offline


    Well... Actually, although it's no longer erroring on startup, it's not working at all. Firstly, this is a bit ridiculous in the console (is this new?). Also, it's going back to the error where on shooting, your arrows are decremented, but you never actually shoot. Where I'm testing, I have the wildcard permissions.

    Gonna play around with it a bit, but I really have no idea what I'm doing with Java. The link above will stay the same; I'll post a new one if I find something that works.
  29. Offline


    I am having the same problem as the above poster; I get the "[INFO] arrow shot name = Ice [INFO] They MATCH :D :D" in the console, but no arrow is actually fired.
  30. Offline


    Sorry about the debug will fix asap
  31. Offline


    so will it work with essentials now too? *hopeful face*
    edit: NVM, i cant read. using the custom above fixes it

    I do have a request though.....
    I was wondering if you could make it so that when a player does /arrow it only lists the arrows they have permissions for

    any luck yet?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016

Share This Page