Items become bugged and un-usable for crafting

Discussion in 'Bukkit Help' started by DrHolbr, Feb 2, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Okay i have been fighting with this problem for around a month now to no avail. It seems that items in my players inventory will be become "bugged" at random times. A bugged item will give no results when someone tries to craft with it. My main question is does anyone have any idea what plugin(s) might cause this?

    1. What OS are you using (Brand and version - Ex. Windows XP SP3)?
    Windows server 2008
    2. What architecture is the OS you are running (x64 or x86)?
    3. What version and architecture is your java install? (Type: java -version in command prompt.)
    java version "1.6.0_29"
    Java(TM) SE Runtime Environment (build 20.4-b02, mixed mode)
    4. Are you running any wrappers? nope
    5. What Build of CraftBukkit are you running? This server is running CraftBukkit version git-Bukkit-1.1-R3-b1846jnks (MC: 1.1) (Implementing API version 1.1-R3)
    6. What command are you using to run your CraftBukkit server?
    Title Minecraft started - looping
    Echo OFF
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" "C:\Program Files (x86)\Java\jre6\bin\java.exe" -Xms512M -Xmx1280M -jar mineshafter-server.jar craftbukkit.jar
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="86" "C:\Program Files (x86)\Java\jre6\bin\java.exe" -Xms512m -Xmx1024M -jar mineshafter-server.jar craftbukkit.jar
    goto start
    7. What plugins are you running?
    Plugins: MinecraftViewer, AppleTree, GroupManager, WorldEdit, Pail, SLAMP, AutoShutdown, PorteCoulissante, SignLift, Plastik GameMode Changer, WorldGuard, PailPlus, iConomy, Register, BookWorm, Permissions, HawkEye, CraftBukkitUpToDate, NoFarm, ServerLogSaver, ChestShop, SimpleSpleef, AutoAnnouncer, Essentials, Burning Creative Suite, SimpleRegionMarket, ShowCaseStandalone, Citizens, Jobs, EssentialsSpawn, EssentialsGeoIP, dynmap, Dynmap-WorldGuard, EssentialsChat, Dynmap-Essentials
    8. What error are you getting (post your server.log file)? NONE
    9. What have you tried already? I have been trying to isolate the problem plugin for a month now, but its difficult to troubleshoot b\c i don't know how to cause an item to bug (it seems random), and the bugged items still remain in the game. i have tried all the tricks in the book, updated all plugins, removed discontinued plugins (XAuth was a suspect for awhile but not it) etc
    10. Have you tried any of the things below?
    Does not occur on vanilla with a new world
    Does not occur on craftbukkit with no plugins and new world
    For me to test this plugin by plugin would require a new world and a lot of server white listing time, i would like to avoid that by any means possible. any ideas or help would be greatly appreciated.
  2. Offline


    try updating everything (plugins and craftbukkit)
Thread Status:
Not open for further replies.

Share This Page