Iridium Server Manager - |GUI|Creator|Toolkit|Port Forwarder|

Discussion in 'Bukkit Tools' started by ImminentFate, Jul 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    oh and spartanaw I am only human, and time differences and other commitments means I can't spend all my time on here. But I am very much active on these forums
  2. Offline


    I've just tried this 'Bukkit Auto Installer' and I have a few suggestions:

    1. Make your starter batch files dynamic
    2. Maybe even make a application like I did that holds all the essentials in one place
    3. Maybe make your own icon for this project instead of using the regular CraftBukkit logo
  3. Offline


    I don't have much programming knowledge, so these things are harder for me. I have made a dynamic batch generator, but want to refine it before implementing it. Also, I've been busy with school, so this has had to take a back seat to that. As for the app that holds everything in one place, I don't think I need that yet, until I add more features to the installer.
    Since its just an installer for bukkit, I don't believe it needs its own icon. I like the lava bucket, its a clean image.
  4. Offline


    im sorry if i sounded pushy! I was just really excited.
  5. Offline


    mac version?
  6. Offline


    I know i've said this a lot, but I will make one soon. I don't have a mac to test it on, so it makes it harder.
  7. Offline


    In most cases, you will need a macintosh to make cocoa-based applications. If you don't have a mac, you might want to re-write that last comment
  8. Offline


    I have a few ways of getting around that issue ;)
    And no, I don't mean pirating macintosh.
    However, I would need some beta (alpha?) testers to make sure that it works before i release it to everyone
  9. Offline


    Oh, I think I have an idea on that plan. (BTW: if i had a mac, i would help you.)
  10. Offline


  11. Offline


    I always download this one but now it says Error Unable to access jarfile .. what next!????
  12. Offline


    run the installer again until it works. It's not my fault, its the programming language and timeouts and stuff
  13. Offline


    OK here comes a Huge Noob Question I can't seem to figure out how to give ppl Permission like HomeSpawnPlus and WheresmyBones and deathchest, I have Vault and worldedit and command book, and your most up to date server, I'v read a lot fo things just very unsure how or were to give the players there rights.
  14. Offline


    Hey Imminent the next time you're online if you have time do you want to try TeamViewing with me to try and solve my CMD closes so quickly? (I've installed the new version)
  15. Offline


    If ImminientFate can't use TeamViewer, I'm pretty good with that too. If he can't help, I will
  16. Offline


    sure. Although, that may not be necessary. Try using the newest installer, and if that won't work, PM me and we can set up a suitable time
  17. Offline


    I had that problem too. I had too copy the code from the top of the get craftbukkit page into one of the starters

    Now I have a problem with the window that is supposed to open when command prompt finishes. It doesn't want to open.

    Hey!! I discovered a solution for the cmd closing so quickly!! You just have to go into the starters code and add "PAUSE" on the very last line, and it will stop cmd from automatically closing allowing you to read the error!!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  18. Offline


    I added that in the newer release
  19. Offline


    Hiya thar. So me and a buddy are setting up a server for a group of friends, and so I've been asked to do it, considering I'm the only one thats used Bukkit before. Unfortunately that was quite a while back, and seeing this, I iz happeh. So I attempted to use it, but got to the bat file issue I remember from last time. "Unable to access Jarfile C:\Users\Sam\Documents\CraftBukkit\craftbukkit.jar"

    Now I remember I figured this out last time, but no matter what I do I can't get it working.
    Any tips?
  20. Offline


    After i auto-install Bukkit i attempt to open the CraftBukkit shortcut it puts on my desktop. The CMD window opens like normal but it says: Unable to access jarfile C:Users\Owner\desktop\craftbukkit\craftbukkit.jar
    Press any key to continue....
    *i tried to make the new craftbukkit.jar file in the craftbukkit folder and it still wont work!*
  21. Offline


    I'm getting a Connection Lost End of Stream error when I try to get into Minecraft on my server. The server loads up fine, and just did a bunch of CommandBook loading I've never seen before. Hamachi server is up and running fine, and I was on my server an hour ago. Is this just an update or did I break something again?
  22. Offline


    Just run the installer again, sometimes it fails to download, because of slow internet connections and timeouts.

    something probably broke. Are you using localhost to connect?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  23. Offline


    I'm using hamachi as my little setup. I have a localhost that won't connect/ times out, and a connection using the hamachi IP that gives me the error.
  24. Offline


    Hey, I have a question. If the installer does not download certain files, can I manually download and add them myself? Including the plugins, i.e. Pail?
  25. Offline


    yes that will work. However, make sure the craftbukkit jar gets renamed to craftbukkit.jar if it already isnt. You can try running the installer again, I think that a slow internet connection sometimes makes it fail (time out), but doing it again can fix it.
  26. Offline


    Ok. So today I wanted to start a server, and Bukkit seemed like the only option. I looked around, and found their download. I follow THEIR wiki, and try nearly 10 times. No crap happens. I Google, and find this. I do the install, and i find the error "Unable to access jar file (route to the jar)" so i close the window and try to open it again. I get "Java is not recognized as an internal or external command, operable program, or batch file" What is wrong, and why does Bukkit use Java, Java sucks. (Yes i have tried re installing the program, happens the same every time)
  27. Offline


    Alright, thanks. I'll try and see if it'll work. :)

    Bukkit uses Java because Minecraft uses Java. As for being unable to access the bukkit jar, try installing it manually, that worked for me ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  28. Offline


    try upgrading to java 7, AFTER uninstalling your old version. Bukkit uses Java because minecraft uses java.
  29. Offline


    Soooo... I got it working, but it doesn't bring up the Pail GUI, and I don't see anything about Pail in the folder. Are some of the things not supposed to show in the folder at all, like Pail and Commandbook, and WorldEdit, and the chat manager?
  30. Offline


    they should show up. You will need to download those plugins manually, and just place them in the plugins folder. I will see if I can do anything about fixing the timeout of the downloads.
    PS How long does it take for the installer to download the files? (approximately)
Thread Status:
Not open for further replies.

Share This Page